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Before You Begin

The JADE Schema Inspector Utility User’s Guide is intended as the main source of information when you inspect
JADE database objects in production systems.

Who Should Read this Guide
The main audience of the JADE Schema Inspector Utility User’s Guide is expected to be system administrators.

Related Documentation
Other documents that are referred to in this guide, or that may be helpful, are listed in the following table, with an
indication of the JADE operation or tasks to which they relate.

Title Related to…

JADE Database Administration Guide Administering a JADE database

JADE Development Environment Administration Guide Administering the JADE development environment

JADE Development Environment User’s Guide Using the JADE development environment to
development JADE applications

JADE Initialization File Reference Maintaining JADE initialization file parameter
values

JADE Installation and Configuration Guide Installing and configuring JADE

JADE Report Writer User’s Guide Using the JADE Report Writer to develop and run
reports

JADE Runtime Application Guide Administering JADE deployed runtime applications

JADE Web Application Guide Implementing, monitoring, and configuring Web
applications

Conventions
The JADE Schema Inspector Utility User’s Guide uses consistent typographic conventions throughout.

Convention Description

Arrow bullet ( ) Step-by-step procedures. You can complete procedural instructions by using either
the mouse or the keyboard.

Bold Items that must be typed exactly as shown. For example, if instructed to type foreach,
type all the bold characters exactly as they are printed.

File, class, primitive type, method, and property names, menu commands, and dialog
controls are also shown in bold type, as well as literal values stored, tested for, and
sent by JADE instructions.
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Convention Description

Italic Parameter values or placeholders for information that must be provided; for example,
if instructed to enter class-name, type the actual name of the class instead of the word
or words shown in italic type.

Italic type also signals a new term. An explanation accompanies the italicized type.

Document titles and status and error messages are also shown in italic type.

Blue text Enables you to click anywhere on the cross-reference text (the cursor symbol changes
from an open hand to a hand with the index finger extended) to take you straight to
that topic. For example, click on the "Using the Schema Inspector Form"
cross-reference to display that topic.

Bracket symbols ( [ ] ) Indicate optional items.

Vertical bar ( | ) Separates alternative items.

Monospaced font Syntax, code examples, and error and status message text.

ALL CAPITALS Directory names, commands, and acronyms.

Small font Keyboard shortcut keys.

Key combinations and key sequences appear as follows.

Convention Description

Key1+Key2 Press and hold down the first key and then press the second key. For example, "press
Shift+F2" means to press and hold down the Shift key and press the F2 key. Then
release both keys.

Key1,Key2 Press and release the first key, then press and release the second key. For example,
"press Alt+F,X" means to hold down the Alt key, press the F key, and then release both
keys before pressing and releasing the X key.
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Chapter 1     Inspecting a Deployed Database

This document covers the following topics.

Overview

Using the Schema Inspector Dialog

Using the Schema Inspector Form

Overview
The Schema Inspector is supplied with JADE, to enable you to inspect database objects in your production JADE
systems.

The Schema Inspector icon is installed in your JADE program folder when you install JADE.

A security filter method enables you to define security to specify users who can inspect class instances in a
deployed (run time) database. For details, see "Deployed JADE Database Inspection Security", in Chapter 3 of the
JADE Object Manager Guide.

Note At run time, instances cannot be inspected if either of (or both) the _jadeapp and _jadedef database files
has been marked offline and the security filter method has not been reimplemented or it does not return true. This
ensures that any user of the Schema Inspector in a deployed application can inspect only those classes to which
access has been specifically permitted by the application software developer.

The following is an example of the command line required to run the Schema Inspector.

jade.exe path=s:\jade\system ini=c:\jade\system\jade.ini schema=JadeMonitorSchema
app=JadeSchemaInspector

To execute the deployed Schema Inspector

1. Click the Schema Inspector icon in the JADE program folder, to run the standalone Schema Inspector
application.

The Schema Inspector sign-on form is then displayed. The user id of your workstation is displayed in the
User Id text box, by default.

As your password is hidden for security reasons, each character is represented by an asterisk (*) character.

The user id and password are case-sensitive.

2. Specify your user id and optionally your password in the appropriate text boxes, and then click the OK button
to sign on to the Schema Inspector.
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The Schema Inspector dialog, shown in the following image, is then displayed.

3. In the Select Schema to inspect combo box, select the schema whose instances you want to inspect. The
classes list box is then populated with all classes in the selected schema.

4. In this list box, select the classes whose instances you want to inspect.

Tip As the classes list box is a multiple-selection list box, you can use the Shift or Ctrl key to select a group
or range of classes.

5. When you have selected the required classes, click the OK button. Alternatively, double-click an entry to
view instances of that class. If security is not set, the Schema Inspector is then displayed. Alternatively, click
the Cancel button to abandon your selections.

6. If security is set for a selected class and you do not have sufficient security, a message box is displayed,
informing you that you do not have sufficient security to inspect instances of the specified class.

Schema Inspector Utility
User's Guide
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Perform one of the following actions.

Select another class to which you may have inspection access rights.

Select the Logoff command from the File menu to display the Schema Inspector sign-on form and
specify a user id and password that permit access to the classes whose instances you want to inspect.

Select the Exit command from the File menu, to close the Schema Inspector.

When any security filter requirements have been satisfied, the Schema Inspector form is then displayed. For
details about inspecting class instances, see "Using the Schema Inspector Form", later in this document.

Using the Schema Inspector Dialog
The Schema Inspector dialog menu bar contains the following menus.

File

Edit

View

Help

Using the File Menu
Use the File menu in the Schema Inspector dialog to:

Exit from the inspector. (You can also exit from the Schema Inspector dialog by clicking the close icon at the
top right corner of the window or by selecting the Close command from the Control-Menu.)

Log off from the Schema Inspector when access to class instances is restricted and you want to specify
another user id and optionally the password.

To exit from the Schema Inspector dialog

Select the Exit command on the File menu. Alternatively, click the Cancel button.

The Schema Inspector dialog is then closed.

To log off from the Schema Inspector dialog

Select the Logoff command on the File menu.

The Schema Inspector sign-on form is then displayed, to enable you to change the user id and optionally the
password if access to instances of a class is restricted.

Using the Edit Menu
To locate a class in the schema hierarchy

1. Perform one of the following actions.

Select the Find command from the Edit menu.

Press F4.

The Find dialog is then displayed.

Schema Inspector Utility
User's Guide

Chapter 1    Inspecting a Deployed Database 8



SchemaInspector - 2020.0.02

2. In the Class to search for: combo box, select the class that you want to locate for subsequent inspection.

3. Click the OK button. Alternatively, click the Cancel button.

Your selected class is then highlighted in the class hierarchy list box of the Schema Inspector dialog.

Using the View Menu
Although a schema inherits all classes and their associated properties, methods, and constants from its
superschemas, these inherited classes are not displayed by default in the Schema Inspector dialog of the
subschema. Instead, for the sake of clarity, only classes local to the schema are displayed, as well as any
superschema classes to which subclasses, methods, or constants have been added.

To display superschema classes in the schema hierarchy

1. Select the Superschemas command from the View menu.

The View Superschemas dialog is then displayed. The current schema is displayed in the Show classes
and methods defined in: combo box, by default.

2. Select the superschema whose classes you want to display in your Schema Inspector.

3. When you have selected the appropriate superschema, click the OK button.

The classes list box of the Schema Inspector dialog is then populated with all of the classes in the specified
superschema. (Classes defined in a superschema are displayed in red and those defined in the current schema
are displayed in black.)

Using the Help Menu
Use the commands in the Schema Inspector dialog Help menu to access the standard Common User Access
(CUA) help options. These commands are described in the following subsections.

Index Command
Use the Schema Inspector dialog Help menu Index command to open the Schema Inspector online help. The
JADE Schema Inspector Utility User’s Guide is then opened, providing access to the topics available in online
help.

To access the online help, perform one of the following actions

Select the Index command from the Help menu

Press F1

The JADE online help is then displayed; for example, the SchemaInspector.pdf) document is displayed in Adobe
Reader.

Use the functions available in JADE online help to find the required topics. For details, see "JADE HTML5 Online
Help" or "JADE Product Information Library in Portable Document Format", in Chapter 2 of the JADE Development
Environment User’s Guide.

About Command
Use the Schema Inspector dialog Help menu About command to access information about the Schema Inspector.

Schema Inspector Utility
User's Guide
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To access the Schema Inspector information

Select the About command from the Help menu.

The About box is then displayed, providing information about the JADE release, copyright and licence information,
database path, operating system of the workstation, and the file version (that is, ANSI or Unicode). This dialog is
for display purposes only.

Using the Schema Inspector Form
The Schema Collection Inspector form, shown in the following image, is displayed when you have selected a
class or classes from the deployment Schema Inspector dialog with the appropriate security.

The Schema Inspector title bar specifies the number of instances of the selected class.

The list box in the middle pane contains an entry for each instance of the selected class or classes. In addition, if
the class is a collection class, a list box at the upper center displays the properties of the collection. Clicking on a:

Property name displays the property value.

Collection entry displays the collection entry details.

If the collection class has any properties, both list boxes are automatically made visible. If the collection class does
not have any properties, only the collection entries list box display is initially made visible.

When both the collection properties and collection entries list boxes are visible, a resize bar is displayed between
them. To change the size of each of the list boxes, drag this resize bar vertically.

Schema Inspector Utility
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Note When a collection is displayed on the left of the JADE Inspector form, clicking on another collection entry
preserves the vertical scroll position of the text box that displays the property values on the right, if that position
exists.

To toggle the display of collection instance properties

Select the Show Collection Properties command in the Options menu.

This command is not visible if the collection is an internal JADE collection (for example, one that used to
display all instances of a class).

To examine each object

Select an object in the left-hand (object) list.

To inspect a specific object (drill-down)

Double-click on an object in the Object List in the middle pane of the Schema Inspector form.

The specified object and any properties defined for that object are then displayed in a new Schema Collection
Inspector form.

Clicking the Use Same Window command in the Options menu toggles whether the menu item is checked (that is,
whether the same form is used). Toggling the value of this command writes the true or false value to the
UseSameWindow parameter in the [JadeInspector] section of the JADE initialization file.

When the Use Same Window command is checked, each double-click of an object in an Inspector form re-uses
the same form to display the selected object, replacing the previously displayed object. A pane at the left of the
form contains a hierarchical list box displaying all of the objects that have previously been inspected. The
hierarchy indicates the history of how the objects were inspected. The entries display the value of the name
property if it exists in the object, followed by the class name and the JADE object identifier (oid). Clicking on an
entry in the hierarchical history list displays the selected object again.

The Schema Collection Inspector form displays the type, name, and dynamic attribute names and values of
JadeDynamicObject instances. If a dynamic property is a reference, double-clicking the property name opens an
inspector for that reference. In addition, dynamic property names are displayed in dark blue text.

To view the values for the current property in the object

Click the required property.

Schema Inspector Utility
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The values for the selected property are then displayed in the pane at the left of the form when the same form is
re-used, as shown in the following image.

Notes If the current property is a reference or a collection and the same form is not being re-used, you can
double-click on it to open a new Inspector form for that property. This enables you to "drill-down" through your
references and collections.

The History menu is displayed only when two or more objects are displayed in the hierarchy list box on the
History sheet.

To inspect an object, click on an object listed in the lower part of the Object List in the center pane, to display
details of that object in the pane at the right of the form.

You can inspect the edition, volatility, and time an object was updated or created, by clicking edition, volatility,
lastUpdateTranId, or creationTime, displayed beneath ***Object*** in the Object List in the center pane, to
display that value in the pane on the right of the Inspector Form.

The Schema Inspector form menu bar contains the following menus.

File

Options

History

Help

Using the File Menu
Use the File menu in the Schema Inspector form to exit from the deployment inspector. (You can also exit from the
Inspector form by clicking the close icon at the top right corner of the form or by selecting the Exit command from
the Control-Menu.)

Schema Inspector Utility
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To close all open non-modal Inspector forms

Select the Close All command on the File menu.

Note This command is displayed only when the Schema Inspector form was not shown modally.

All open Schema Inspector forms are then closed.

To open a new Inspector form for the currently displayed object

Select the NewWindow command on the File menu.

A new Inspector form for the currently displayed object is then displayed (regardless of the setting of the Use
Same Window command). This enables you to display an object in a separate Schema Inspector form that can be
retained regardless of the objects that are inspected in the original form or forms.

To exit from the Inspector forms

Select the Exit command on the File menu.

The Schema Inspector form is then closed.

Using the Options Menu
Note If more than one user uses the same JADE initialization file on the client, they will share the same values
for parameters in the [JadeInspector] section.

To replace the saved position and size with the default position and size

Select the Clear Saved Position/Size command from the Options menu if you want to use the default
position and size for Inspector forms.

When the next Inspector form is opened, the default position and size will be used.

To save the current position and size of the form

Select the Save Position/Size command from the Options menu if you want to save the current position and
size of the form.

This information, which is used to position and size any subsequent Inspector forms that are displayed, is stored in
the WindowPos parameter in the [JadeInspector] section of the JADE initialization file.

To re-use the same form to display the selected object (applies to version 2016.0.01 and higher)

Select the Use Same Window command from the Options menu.

By default, the same Inspector form is not used (that is, this command in unchecked, or unselected), so that each
double-click of an object in an Inspector form opens a new Inspector form.

When the Use Same Window command is checked, each double-click of an object in an Inspector form re-uses
the same form to display the selected object, replacing the previously displayed object. A pane at the left of the
form contains a hierarchical list box displaying all of the objects that have previously been inspected. The
hierarchy indicates the history of how the objects were inspected. The entries display the value of the name
property if it exists in the object, followed by the class name and the JADE object identifier (oid). Clicking on an
entry in the hierarchical history list at the right of the form displays the selected object again.

Schema Inspector Utility
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The value of this setting (that is, true or false) is information is stored in the UseSameWindow parameter in the
[JadeInspector] section of the JADE initialization file.

To specify the font used to display text in the Inspector form

Select the Font command from the Options menu if you want to change the default font from Tahoma,
regular, 8.25 points.

The common Font dialog is then displayed, to enable you to make your font selections. When you have selected
your required font options, focus is then returned to the Inspector form.

To toggle the display of the collection properties list box

Select the Show Collection Properties command from the Options menu.

The collection properties list box is then displayed or removed from the form and the check mark on the menu item
displayed or removed.

Using the History Menu
The History menu displays up to the last 25 objects inspected in the Schema Inspector form, in the reverse order
that they were double-clicked.

To redisplay an object instance

Click an entry in the history list.

The History menu displays a check mark at the left of the object currently displayed in the Schema Inspector form
(if it is in the menu item list).

Press the Alt+↑ (up arrow) or Alt+↓ (down arrow) accelerator keys to step to the previous or next entry in the history
list, respectively, in the order in which they were originally displayed.

Note The History menu list is not affected by clicking an item in the history list or by clicking an item in the
hierarchy history list box at the left of the form.

The History menu is displayed only when two or more objects are displayed in the hierarchy list box on
theHistorysheet.

Schema Inspector Utility
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Applies to Version: 2016.0.01 and higher

Using the Help Menu
Use the commands in the Schema Inspector form Help menu to access the standard Common User Access (CUA)
help options. These commands are listed in the following subsections.

Command Description

Index Opens the Schema Inspector online help, with all topics available in the online help file
displayed down the left side of the help window in Adobe Reader.

About Accesses information about the release of the JADE Schema Inspector. (For details, see
"About Command" under "Help", earlier in this document.)

For details about using JADE online help, see "JADE HTML5 Online Help" or "JADE Product Information Library in
Portable Document Format", in Chapter 2 of the JADE Development Environment User’s Guide.
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