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Before You Begin

The JADE Monitor User’s Guide is intended as the main source of information when you are monitoring and
examining your JADE environment.

Who Should Read this Guide
The main audience for the JADE Monitor User’s Guide is expected to be system administrators and application
developers.

What’s Included in this Guide
The JADE Monitor User’s Guide has two chapters.

Chapter 1 Covers initiating and setting up the JADE Monitor, including running the JADE Monitor as a
background process

Chapter 2 Covers using the JADE Monitor for system instrumentation and diagnosis

Related Documentation
Other documents that are referred to in this guide, or that may be helpful, are listed in the following table, with an
indication of the JADE operation or tasks to which they relate.

Title Related to…

JADE Database Administration Guide Administering a JADE database

JADE Development Environment User’s
Guide

Using the JADE development environment to development
JADE applications

JADE Initialization File Reference Maintaining JADE initialization file parameter values

JADE Installation and Configuration Guide Installing and configuring JADE

JADE Object Manager Guide JADE Object Manager administration, including sign-on
security, implementing system instrumentation and diagnosis
methods, and node sampling

JADE Report Writer User’s Guide Using the JADE Report Writer to develop reports for your JADE
applications

JADE Runtime Application Guide Administering JADE deployed runtime applications

JADE Thin Client Guide Administering JADE thin client environments

JADE Web Application Guide Implementing, monitoring, and configuring Web applications
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Conventions
The JADE Monitor User’s Guide uses consistent typographic conventions throughout.

Convention Description

Arrow bullet ( ) Step-by-step procedures. You can complete procedural instructions by using either
the mouse or the keyboard.

Bold Items that must be typed exactly as shown. For example, if instructed to type foreach,
type all the bold characters exactly as they are printed.

File, class, primitive type, method, and property names, menu commands, and dialog
controls are also shown in bold type, as well as literal values stored, tested for, and
sent by JADE instructions.

Italic Parameter values or placeholders for information that must be provided; for example,
if instructed to enter class-name, type the actual name of the class instead of the
word or words shown in italic type.

Italic type also signals a new term. An explanation accompanies the italicized type.

Document titles and status and error messages are also shown in italic type.

Blue text Enables you to click anywhere on the cross-reference text (the cursor symbol
changes from an open hand to a hand with the index finger extended) to take you
straight to that topic. For example, click on the "Forcing Off a User from JADE"
cross-reference to display that topic.

Bracket symbols ( [ ] ) Indicate optional items.

Vertical bar ( | ) Separates alternative items.

Monospaced font Syntax, code examples, and error and status message text.

ALL CAPITALS Directory names, commands, and acronyms.

Small font Keyboard shortcut keys.

Key combinations and key sequences appear as follows.

Convention Description

Key1+Key2 Press and hold down the first key and then press the second key. For example, "press
Shift+F2" means to press and hold down the Shift key and press the F2 key. Then
release both keys.

Key1,Key2 Press and release the first key, then press and release the second key. For example,
"press Alt+F,X" means to hold down the Alt key, press the F key, and then release both
keys before pressing and releasing the X key.

Monitor User's Guide
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Chapter 1     Initiating and Setting Up the JADE
Monitor

This chapter covers the following topics.

Overview

Log File Location

Initiating the JADE Monitor

Running the JADE Monitor as a Background Process

Accessing the JADE Monitor

Calling the JADE Monitor from a Web Service Consumer

Structure of the JADE Monitor Window

Using the Navigator Pane

Monitor Activities

Setting Up the JADE Monitor

Overview
The JADE Monitor provides systems analysis and diagnostic tools that enable you to:

Enable and disable the capture of data

Log captured data to file for subsequent replay in another JADE Monitor session

Extract class number cross-reference for subsequent replay in another JADE Monitor session

Capture ad hoc data to a Comma-Separated Values (CSV) file

Specify a periodic sampling interval

Specify which performance data items are to be periodically sampled

Perform ad hoc sampling of performance data items as a group

Sort displayed data

Print displayed data as it is currently displayed to the user

Load and replay historical data

Search for a specific user (for example, so that you can sign him or her off the application)

Dynamically turn specific statistics gathering off and on

Quickly navigate to any displayed information; for example, a specific user

Obtain a range of information, including:

Node statistics counters and analysis

Behavior analysis figures (for example, the most-contended locks)
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Lock conflict analysis

Interactive method instrumentation

Information about the viewed data via an in-built knowledge base of information, or add your own
information (for example, notes or tips) to the in-built knowledge base

This functionality enables you to monitor how well your system is running, to easily identify aspects that have the
most impact on performance, and to quickly identify the likely cause of a problem in an emergency situation.

The diagnostic information is available in a number of levels of detail, ranging from a general overview down to
detailed component analysis.

Note In this chapter, the unqualified term Monitor refers to a JADE client session running the JADE Monitor
application or to a browser accessing monitor functionality via Web services.

For details about running the JADE Web Application Monitor, see Chapter 2, "Monitoring Your Web Sessions", in
the JADE Web Application Guide. For details about the Application Programming Interface (API) framework whose
methods can be incorporated into JADE applications to examine a JADE system, nodes, or processes, see
Chapter 4, "JADE System Instrumentation and Diagnosis", of the JADE Object Manager Guide. For details about
security, see "JADE Monitor Security", in Chapter 2 of the JADE Object Manager Guide.

Log File Location
When the JADE Monitor starts up, the JADE initialization file on the presentation client is read. If entries are
absent, the appropriate directory parameter values are derived and the parameter values are created in the JADE
initialization file on the presentation client. For example, the log directory on the presentation client is established
as follows.

1. If the LogDirectory parameter, which was obsolete from JADE 6.3, is located in the [JadeMonitor] section of
the JADE initialization file, it is replaced by the DefaultLogDirectory parameter and its value is used.

2. If the DefaultLogDirectory parameter is located in the [JadeMonitor] section, its value is used.

3. If the LogDirectory parameter is located in the [JadeLog] section of the JADE initialization file, it is written to
the DefaultLogDirectory parameter in the [JadeMonitor] section and its value is used.

4. If none of the previous steps in this instruction are performed, the home-directory/logs value is written to the
DefaultLogDirectory parameter in the [JadeMonitor] section and its value is used.

If you specify a relative directory name, the directory is assumed to be relative to the JADE HOME directory.
For example, if your installation directory is Jade\bin (that is, your JADE HOME directory is Jade) and you
specify DefaultLogDirectory=MonitorLogs, the full directory path is Jade\MonitorLogs.

If you are running on a presentation client in JADE thin client mode and you want to log sampling files on the
application server, you must set this up when the JADE Monitor is running, by using step of the Monitor Setup
activity (see step 4 of the instruction documented under "Setting Up the JADE Monitor", later in this chapter) or by
loading a directives file (see "Loading Directives", in Chapter 2).

Initiating the JADE Monitor
The freestanding Jade Monitor program icon or the Monitor command from the Browser File menu enables you to
monitor, examine, and analyze your JADE systems, nodes, and processes.

The JADE Monitor is installed in your database directory as part of the JADE installation process. The default
multiuser installation sets up the JADE MultiUser \ JADE Monitor shortcut for the JADE Monitor.

Monitor User's Guide
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The following table lists examples of the properties required to run the JADE Monitor, installed in your database
directory.

Property Example

Command line d:\jade\bin\jade.exe path=s:\jade\system ini=s:\jade\system\jade.ini app=JadeMonitor
schema=JadeMonitorSchema

Working directory d:\jade\bin

Running the JADE Monitor as a Background Process
The read-only JADE Monitor background application, which you can set up to start automatically when a node
starts, gathers and records information that can be replayed and assessed later (for example, to forward to JADE
Support for problem analysis and resolution if your JADE licence includes support).

You can start the JADE Monitor background application by:

Using the predefined application (that is, ServerApplication<application-number>=JadeMonitorSchema,
JadeMonitorBackground) in the [JadeServer] section of the JADE initialization file on the server node to
start the background application when the server node starts up

Selecting the Start Monitor Background Application command from the File menu in the GUI JADE Monitor

From the command line; for example:

jade.exe path=s:\jade\system schema=JadeMonitorSchema app=JadeMonitorBackground
ini=s:\jade\system\supportdirectives.ini

The JADE initialization file specifies the directives file to run against (for example, if you want to run multiple
JADE Monitor background applications with different directives files concurrently, you could have a separate
JADE initialization file for each directives file).

Notes You can run multiple JADE Monitor background applications concurrently; for example, to record different
sets of data for your JADE system.

The JADE Monitor background application does nothing if a directives file containing the statistics to be recorded
has not yet been saved to the path and file specified in the DirectivesFile parameter in the
[JadeMonitorBackground] section of the JADE initialization file (that is, if the directives file is empty, it does not
exist, or it is not specified, the background monitor application is launched but does nothing). For details, see the
JADE Initialization File Reference.

Accessing the JADE Monitor
To access the JADE Monitor, perform one of the following actions

Click the Monitor toolbar button in the JADE development environment.

Select the Monitor command from the JADE development environment Browser File menu.

Select the Jade Monitor program icon from your JADE program folder, to run the standalone JADE Monitor
application.

Running the JADE Monitor application from the command line, as shown in the following example.

jade.exe path=s:\jade\system ini=s:\jade\system\jade.ini
schema=JadeMonitorSchema app=JadeMonitor

Monitor User's Guide
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The JADE Monitor sign-on dialog is then displayed. When security is set for your JADE development environment,
you can sign on to the JADE Monitor only if you have the appropriate access permission. When you click the OK
button and you have access permission, the JADE Monitor Summary view is then displayed.

If you want to display another view (for example, the Users view) when the monitor is initialized, specify the valid
view name in the DefaultPane parameter in the [JadeMonitor] section of the JADE initialization file on the client
node.

For details about:

Setting up the JADE Monitor, see "Setting Up the JADE Monitor", later in this chapter.

Using the JADE Monitor, see Chapter 2, "Using the JADE Monitor for System Instrumentation and
Diagnosis".

Using system instrumentation and diagnosis methods in your JADE applications to examine your JADE
system, nodes, or processes, see Chapter 4, "JADE System Instrumentation and Diagnosis", of the JADE
Object Manager Guide.

In an SDS environment, the secondary database server has a node stub that represents the primary server
node. This node stub does not have the full functionality of a normal client; in particular, some statistical
functions cannot be carried out on the node stub (for example, getting a node’s cache statistics).

Any attempt to do so raises exception 1265 (Environmental operation out of scope for process). You can use
the value returned by the Node class nodeRole method to distinguish the node stub from standard client
nodes. For the node stub, the returned value is the Node class Role_Replay constant (as opposed to the
Role_Standard constant).

The context-related help information (knowledge base) that is displayed at the lower-right of the window of
each view and selected component, see "Maintaining Knowledge Base Information", in Chapter 2.

Calling the JADE Monitor from a Web Service Consumer
You can invoke a subset of the JADE Monitor functionality from a Web service consumer by using the
JadeMonitorV2WS application provided by JADE in the JadeMonitorSchema schema.

Before you run the JadeMonitorV2WS application provided in the JadeMonitorSchema, you will probably want to
override the default application parameters; for example, the connection name and the port number.

The JadeWebConfigurator application that is also provided in the JadeMonitorSchema enables you to create
and maintain a configuration file for the JadeMonitorV2WS application. For details, see Chapter 3, "Configuring
Web Applications", in the JADE Web Application Guide.

The following example is the command line to run the JadeMonitorV2WS application.

jade.exe path=s:\jade\system schema=JadeMonitorSchema app=JadeMonitorV2WS
ini=s:\jade\system\jade.ini

Alternatively, you can create a shortcut to run this application from the JADE installation directory in which the
JADE executables were installed (which defaults to the bin directory).

The JADE Web Application Monitor is then displayed. For details, see Chapter 2, "Monitoring Your Web
Sessions", in the JADE Web Application Guide.

A default WSDL, JadeMonitorV2WS.wsdl, is provided in the wsdl folder in the JADE release medium.

This Web service exposes a subset of the JADE Monitor functionality; that is, items that are not practical to expose
are not included in the Web service. The excluded items include exposing mechanisms to select specific classes
or methods from a schema to profile, as too much traffic would have to be sent to describe the full schema content.

Monitor User's Guide
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The Application Programming Interface (API) framework provides methods that you can incorporate into JADE
applications to construct a custom Web service exposure in your JADE environment to consolidate or extend
features provided by the JadeMonitorV2WS application. (For details, see Chapter 4, "JADE System
Instrumentation and Diagnosis", of the JADE Object Manager Guide.)

The JADE Monitor Web service consumer uses client-side XSLT to convert the Web service response message
into table data that is displayed to the user. For more details, see the SOAP Web Services white paper on the
JADE Web site at https://www.jadeworld.com/jade-platform/developer-centre/documentation/white-papers.

Structure of the JADE Monitor Window
The JADE Monitor window consists of the:

Navigator pane at the left

Activity view in which general information or detailed metrics are displayed at the upper right

Overview pane (that is, knowledge base articles) at the lower right

Monitor User's Guide
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An example of the JADE Monitor window is shown in the following image.

Details of the last time a sample of the displayed activity was taken are displayed at the upper-right of the window.

The Navigator pane is structured in a top-to-bottom hierarchy, to enable you to drill down through metrics and
statistics when analyzing your system; for example:

1. Host performance

2. System statistics

Monitor User's Guide
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3. Node statistics

4. Process statistics

Note It is recommended that when investigating application performance, only one of the JADE Profiler,
JADE Monitor, or method profiling is used at any one time, as the results reported when any of these are
combined is undefined.

5. Method analysis

6. Persistent object activity (for example, the most-accessed classes or objects)

Caution The recording of class access frequency statistics can have an impact on performance. You can
register or de-register a process from class access frequency sampling, to reduce any overhead caused by
maintaining counters for a large number of classes.

7. Cache performance, which provides the Details check box to toggle the display of a summary of cache
performance and cache performance details for each type of cache

8. Database statistics

Selecting an activity group or activity in the Navigator pane displays metrics in the activity view for that activity or
group. The Overview pane is then updated to display general information about the selected activity or group and
the activity view to display general activities or metrics for the selection.

Tip As you click on a metric displayed in a table of statistics, the Overview pane is refreshed to display
information specific to that statistic.

When you move to another sheet (for example, Notifications), the sizes of the columns on the table for the
previous sheet are discarded. If you return to the original sheet, any saved columns are discarded and the tables
are automatically resized. As any column sizes that you have set manually will be lost, you must manually set
them again, if required.

For more details about using the JADE Monitor to drill down from general information to fine component analysis,
see "Using the Navigator Pane" and "Monitoring Activities", in the following subsections.

Using the Navigator Pane
To enable you to monitor how well your systems are running and to easily identify aspects that have the most
impact on performance, the hierarchical Navigator pane enables you to drill down from a general overview
through to fine component analysis (for example, in an emergency situation where you have the need to quickly
identify the likely cause of the problem or to identify major bottlenecks if your application is performing poorly).

The analysis and diagnostic information to which you can navigate is listed in the following section, "Monitor
Activities".

The Navigator pane also enables you to access network traffic statistics, which you can use in conjunction with
shared memory use; for example, to identify the impact of queuing for locks on heavily contended objects and to
analyze node statistics output.

The graphical nature of the JADE Monitor enables you to:

Observe trends

Correlate different types of statistics

Profile methods or processes and to display the profile results

Monitor User's Guide

Chapter 1    Initiating and Setting Up the JADE Monitor 13



JadeMonitor - 2020.0.02

Note It is recommended that when investigating application performance, only one of the JADE Profiler,
JADE Monitor, or method profiling is used at any one time, as the results reported when any of these are
combined is undefined.

JADE Monitor method profiling displays the:

Number of times an invoked method is called

Total CPU and elapsed time spent in the method (including nested calls)

Total CPU and elapsed time spent in the method (excluding nested calls)

You can specify profiling for all internal and external methods, selected methods only, or selected methods
and the methods called by them.

Node sampling enables you to analyze the maximum and minimum time spent in each method and a more-
detailed analysis of method execution (for example, how much time is spent locking, fetching, or updating objects,
initiating notification events, and so on.)

Lock conflict analysis and resolution enables you to detect when a contended lock is causing lengthy queuing,
analyzing whether the process with the lock should be informed, and the ability to resolve the situation, if required.

Statistics analysis analyzes the statistics that are gathered and produces meaningful analysis from it; for example,
you could use the JADE Monitor background application to check for alarm situations and to take the appropriate
action (for example, issuing SNMP traps). The statistics that you can analyze include:

Mutex contentions

Database cache statistics

RPC number of trips

Other RPC statistics

Other database statistics

Monitor Activities
Selecting an activity group or activity in the Navigator pane displays metrics in the activity view for that activity or
group. The Overview pane is then updated to display general information about the selected activity or group and
the activity view to display general activities or metrics for the selection.

The Overview pane (that is, knowledge base information about the current activity) is displayed by default at the
lower right of the JADE Monitor window. You can toggle the display of knowledge base information about the
currently displayed activity, by clicking the Hide button at the upper right of the Overview pane or selecting the
Overview command from the Options menu.

The analysis and diagnostic information to which you can navigate is as follows.

General

Monitor Setup

Load Historical Samples

Licence Information

Class Number Allocation

Summary

Monitor User's Guide
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Users

Notifications

Host Performance

System Statistics

Node Statistics

Process Information

Setup Process Statistics

Local Request Statistics

Remote Request Statistics

Call Stack Summary

Timers

Method Cache Statistics

Method Analysis

Selective Analysis

Transient Object Activity

Transient File Summary

Transient File Analysis

Persistent Object Activity

Class Access Setup

Class Access Analysis

Class Access Registered

Most Accessed Objects

Cache Performance

Locks

Queued Locks

Mutex Contentions

Lock Analysis

Summary by Class

Detail for Selected Class

Summary by Oid

Details for Selected Oid

Lock Chronology

Lock Contentions

Monitor User's Guide

Chapter 1    Initiating and Setting Up the JADE Monitor 15



JadeMonitor - 2020.0.02

Database Statistics

DbFile Analysis

RPC Activity Summary

Node Sampling

Capture

Analysis

Web Performance

Setting Up the JADE Monitor
When you first access a JADE Monitor, set it up to meet your own requirements. Alternatively, you can maintain
user preferences for the current JADE Monitor work session.

To set up the JADE Monitor or maintain your user preferences

1. Expand the General activity group in the Navigator pane at the left of the JADE Monitor window and then
select the Monitor Setup activity. (Alternatively, you can click the down-arrow icon at the upper-right of the
Navigator pane, to expand all collapsed activity groups and then select the Monitor Setup activity.)

The Monitor Setup view of the General activity group is then displayed at the right of the window.

2. If you want to activate the timer, check the Activate Timer check box. Alternatively, click the clock icon at the
right of the status line. The cross symbol is then removed from the clock icon, indicating that the timer is
active.

Note When the timer is active, activities that are selected for sampling are displayed in a red font in the
Navigator pane.

3. If you want to change the frequency of sampling, enter the number of seconds in the Frequency text box (for
example, if you want sampling to occur at 45 seconds intervals rather than the default 30 seconds interval).

The maximum time interval is 32,400 seconds, or nine hours.

The number of seconds that you specify in this text box is displayed in parentheses after the Timer Interval
command in the Options menu.

4. If you want to change the path and directory to which sampling files are logged, enter the value in the Log
Output Path text box. (For details of the type and location of this file, see the discussion in the knowledge
base article at the lower right of the window.) Alternatively, click the Browse button and select the path and
directory in the common Browse For Folder dialog that is then displayed.

For details about the default log file location, see "Log File Location", earlier in this chapter.

5. In the Periodically Sampled Items list, check the check box at the left of each item that you want sampled
periodically.

Alternatively, if you want to select all items or clear all selected items from periodic samples, right-click in this
list (or press Shift+F10) and select the respective Select All or Clear All command from the popup menu that
is then displayed. (For details, see "Selecting All Items or Clearing the Selection of All Items in a List", later in
this chapter.)

Monitor User's Guide
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6. In the Samples Logged to File list, check the check box at the left of each item whose samples you want
logged to the file specified in the Log Output Path text box. (For details about toggling the logging of
sampled activities to a file, see "Logging a Sample to a File", in Chapter 2.)

Alternatively, if you want to select all items or clear all selected items from samples, right-click in this list (or
press Shift+F10) and select the respective Select All or Clear All command from the popup menu that is then
displayed. (For details, see "Selecting All Items or Clearing the Selection of All Items in a List", later in this
chapter.)

You can set up a JADE Monitor session to periodically sample specified performance metrics, with the option
of writing any or all of the sampled metrics to a file (to a log file for future playback in another JADE Monitor
session or to a CSV file for use in an external program). For details, see "Logging a Sample to a File" or
"Starting or Stopping the Capture of Data to a CSV File", in Chapter 2.

7. In the File System Access table, click the row of the File System column whose file system you want to
change and then select the Server value in the drop-down list if you want to change the file system from the
default Client value or the Client value if you want to change the System file system back to the client.

As the log output path applies only to the client system, there is no drop-down list in the Log Output Path row
in the File System column.

8. Click the Update button, to save your preferences.

Note If you have changed any of the controls in the Monitor Setup view and you click Refresh at the upper
right of the window (or you press F5) before you click the Update button, your changes are abandoned.

Monitor User's Guide
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The following image shows an example of the Monitor Setup view in the General activity group.

If you want to save your user preferences to a directives file so that you can use the same preferences for
subsequent JADE Monitor work sessions, select the Save Directives or Save Directives As command from the
File menu. For details, see "Saving Directives" or "Saving the Directives File as another Name", in Chapter 2.

Monitor User's Guide
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Chapter 2     Using the JADE Monitor for System
Instrumentation and Diagnosis

This chapter covers the following topics.

Using JADE Monitor Menus

Performing File Menu Command Actions

Performing Options Menu Command Actions

Performing Selections Menu Command Actions

Performing Help Menu Command Actions

Performing Maintenance Menu Command Actions

Performing Popup Menu Command Actions

Maintaining Knowledge Base Information

Using JADE Monitor Menus
The menus (and the commands in menus) that are displayed at any time depend on the activity or element from
which you access the menu. For example, the Maintenance menu and its functions are visible only in the
Knowledge Base Help Editor view of the JadeMonitorV2HelpEditor application.

For details about the structure of the JADE Monitor window, see "Structure of the JADE Monitor Window", in
Chapter 1.

Notes Menu commands that are not available for selection are disabled.

There are faster ways of accessing some frequently used functions; for example, by clicking a button or using
shortcut keys.

Right-click or press Shift+F10 on a component, activity, activity group, or pane to quickly display a popup (context)
menu that provides choices for that item. (See "Popup Menus", later in this chapter.)

The JADE Monitor provides the menus listed in the following table.

Menu Provides commands that enable you to…

File Perform file-related tasks and to exit or log off from the JADE Monitor

Options Specify options for the JADE Monitor

Selections Switch views

Help Obtain information about the JADE Monitor

Maintenance Extract and load a knowledge base text file

Popup Access commands applicable to the selected element

For details, see the following subsections.
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Performing File Menu Command Actions
The File menu provides the commands listed in the following table.

Command For details, see…

Load Directives File Loading Directives

Save Directives File Saving Directives

Save Directives File As Saving the Directives File as another Name

Extract Class Cross Reference Extracting a Class Number Cross-Reference

Start Monitor Background Application Running the JADE Monitor as a Background Process, in Chapter 1

Historical Mode – Load Log File Loading Files in Historical Mode

Revert to Normal Mode Reverting to Normal Mode

Print Printing the Contents of an Activity View

Log Off Logging Off from the JADE Monitor

Release Log File Releasing a Log File

Exit Exiting from the JADE Monitor

Maintaining Directives
The text-based directives file stores sampling set-up parameters and is read when the JADE Monitor or JADE
Monitor background application initiates, to determine:

The samples (if any) that are to be taken at a specified frequency

The samples (if any) that are to be written to log files

The target periodic sampling frequency

If the periodic sampling timer is active

The JADE Monitor creates or updates the directives file when you save the current monitor preferences to the
local directives file specified in the DirectivesFile parameter in the [JadeMonitor] section of the JADE initialization
file or to a specified directives file. For details about the default location to which sampling files are logged when
running the JADE Monitor in thin client mode, see "Log File Location", in Chapter 1.

The following is an example of the directives file.

JadeMonitorDirectivesFile:20081225
sampleInterval:30000
sampleIntervalActive:false
MonFS_LogFileOutDir:C:/jadeTest/logs/monitor/
MonFS_HistoryFileIn:Client
MonFS_HistoryXRefFileIn:Client
MonFS_LogFileOut:Client
MonFS_NodeSamplingLogFileIn:AppServer
MonFS_NodeSamplingLogFileOut:Client
MonFS_AdHocCSVFileOut:Server

You can therefore provide a directives file to another user (who is potentially using a different JADE system), to
capture specified metrics and most likely to log the results to file.
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A Graphical User Interface (GUI) Monitor session can collect any sampling data that you require. You do not have
to save a directives file unless you want to use a specific set of sampling directives at a later date. For details
about setting up sampling, see "Setting Up the JADE Monitor", in Chapter 1.

However, a JADE Monitor background application must have a directives file specified in the DirectivesFile
parameter in the [JadeMonitorBackground] section of the JADE initialization file to instruct the background
process which samples to collect (that is, if the directives file is empty, it does not exist, or it is not specified, the
background monitor application is launched and then does nothing). See also "Running the JADE Monitor as a
Background Process", in Chapter 1.

Loading Directives
You can load an existing directives file into the JADE Monitor by referencing that file in the DirectivesFile
parameter in the [JadeMonitor] in the JADE initialization file or by using a menu command.

To load an existing directives file into your current JADE Monitor work session

1. Select the Load Directives File command from the File menu. The common Load File dialog is then
displayed.

2. Select the directives file that you want to load, and then click the Open button.

3. Click the OK button on the Load Complete message box that is then displayed.

The JADE Monitor window is then updated (for example, activities that are selected for sampling are displayed in
a red font in the Navigator pane and user options in that directives file are displayed in the Monitor Setup view.

Saving Directives
When the directives file is saved, the current state of the JADE Monitor sampling setup is saved to the local
directives file specified in the DirectivesFile parameter in the [JadeMonitor] of the JADE initialization file.

To save the current sampling setup to the default directives file

Select the Save Directives File command from the File menu.

The Info message box is then displayed, stating that the directives file has been written to the directives file name
(which defaults to Directives.txt) and location (which defaults to the JADE installation directory) specified by the
DirectivesFile parameter in the [JadeMonitor] of the JADE initialization file. Click the OK button to return focus to
your current JADE Monitor view.

Saving the Directives File as another Name
You can save the current state of the JADE Monitor sampling setup to a name and location other than the local
directives file specified in the DirectivesFile parameter in the [JadeMonitor] of the JADE initialization file. For
example, if you want to run multiple JADE Monitor background applications with different directives files
concurrently, you can save different sampling setups to different names and locations and then have a separate
JADE initialization file to run against for each directives file.

To save the current sampling setup to a name and location of your choice

1. Select the Save Directives File As command from the File menu.

The common Save Current Directives As dialog is then displayed.

2. In the File Name text box, specify the prefix that you require for the directives text file.
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3. In the Save In combo box, specify or select the location to which the directives file is saved.

4. Click the Save button.

The Info message box is then displayed, stating that the setup values have been written to the specified directives
file name (which defaults to Directives.txt) and location.

Click the OK button to return focus to your current JADE Monitor view.

Extracting a Class Number Cross-Reference
You can extract a class number cross-reference for subsequent replay in another JADE Monitor work session (for
example, so that JADE Support can replay files that you provide them to analyze a problem and associate class
names with class numbers in other files that you provide them for investigation).

To extract the class number cross-reference to a name and location of your choice

1. Select the Extract Class Cross Reference command from the File menu. The common Extract Class Cross
Reference dialog is then displayed.

2. In the File Name text box (which default to classCrossReference.txt), specify the file name that you require
for the class cross-reference file if you want a text file with a file prefix other than the default value.

3. In the Save In combo box (which defaults to the JADE installation directory), specify or select the location to
which the class number cross-reference text file is saved.

4. Click the Save button.

The Info message box is then displayed, stating that the class number cross-reference values have been written to
the specified file name and location. Click the OK button to return focus to your current JADE Monitor view.

Loading a Log File in Historical Mode
In historical mode, you can load a log file of previously captured data into the JADE Monitor. The source of the
data can be from your own JADE system or from another JADE system. For details about logging a sampled
activity to file for subsequent loading as historical data in another JADE Monitor session, see "Logging a Sample
to a File", later in this chapter.

Historical mode also enables you to load an extracted class number cross-reference. For details, see "Extracting a
Class Number Cross-Reference", in the previous section.

To load a log file into your JADE Monitor work session in historical mode

1. Select the Historical Mode – Load Log File command from the File menu.

All current periodic sampling then ceases and the Load Historical Samples view of the General activity
group is displayed.

2. In the Log Input File text box, enter the path and the name of the log file that you want to load or click the
Browse button and select the file in the common Load Samples from Log File dialog that is then displayed.

3. If you also want to load a class numbers cross-reference file, in the Class Cross Reference File text box,
enter the path and the name of the cross-reference text file that you want to load or click the Browse button
and select the file in the common Load Class Cross Reference File dialog that is then displayed.

4. A large sampling log file can take a long time to load.
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You can therefore filter the sample types that you want to load, by unchecking the check boxes in the Select
Sample Types to Load list at the left of the Load Historical Samples view of each sample type that you do
not want to load.

5. If you want to keep existing historical samples, uncheck the Clear Existing Historical Samples check box in
the Additional Load Options group box.

6. If you want to load historical data that was sampled within a specific time range, enter the start and end times
(in twenty-four hour clock format) in the Time Filter text boxes in the Additional Load Options group box.

7. Click the Load Samples button. The load process is then started and the progress is displayed in the
Additional Load Options group box.

8. When the load process is complete, click the OK button on the Load Complete message box that is then
displayed.

The activities for which valid data has been loaded are then highlighted in red in the Navigator pane.

9. To display the time or times at which an activity was sampled, click on an activity highlighted in red in the
Navigator pane. The timestamp of each sample is then displayed in the Sample Timeline list box at the
lower right of the window.

The check boxes in each row of the Sample Timeline list box are bookmarks that enable you to check
samples of interest, go the another sample type, and then return to the previous sample and see the
persisted bookmarks.

10. To view details of a sampled activity, click on a sampled timestamp. Details about that activity are then
displayed in the corresponding view; for example, the Most Accessed Classes view of the Persistent Object
Activity group.

For more details, see the Overview pane (that is, knowledge base articles) at the lower right of the JADE Monitor
window.

Reverting to Normal Mode
When you have loaded a log file of sampled data in historical mode, the Revert to Normal Mode command is
then enabled in the File menu.

To revert to normal JADE Monitor work session mode

Select the Revert to Normal Mode command from the File menu.

Periodic sampling then resumes and highlighting of loaded valid sampling data is removed from those activities in
the Navigator pane.

Printing the Contents of an Activity View
You can print the contents of an activity view; for example, the table of Most Accessed Classes.

To print the current activity view

1. Select the Print command from the File menu. Alternatively, press Ctrl+P.

The common Print Monitor Table dialog is then displayed, to enable you to specify your print options; for
example, the printer name and the number of copies.

2. Make the selections that you require.

3. Click the OK button. Alternatively, click the Cancel button to abandon your selections.
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The print preview of your current view is then displayed on your monitor. For details about previewing print output,
see "Previewing Print Output", in Volume 2 of the JADE Encyclopaedia of Classes.

Logging Off from the JADE Monitor
The Log Off command in the File menu enables you to exit from your JADE Monitor work session, in preparation
for starting a new work session.

When you log off from the JADE Monitor:

Any current sampling ceases.

All locks are released.

All objects are cleared from memory.

To log off from the JADE Monitor

Select the Logoff command from the File menu.

The JADE Monitor sign-on dialog is then displayed again, to enable you to sign on as the same user or a different
user. For example, if you want to run a new copy of the JADE Monitor as this requires a different sign-on user code
to enable files to be kept separate but still allow for all logging undertaken by a specific user to be logged to one
file each day, regardless of how many times that user starts and stops the JADE Monitor.

Releasing a Log File
You can release a jommon.log file that has been created in your current work session without having to exit from
the JADE Monitor; for example, if you want to start the file from scratch to attach it to another application or to
rename it.

To release a log file

Select the Release Log File command from the File menu. (This command is disabled if the log file has not
yet been opened.)

The Info message box is then displayed, stating that the current log file has been released and renamed. Click the
OK button to return focus to your current JADE Monitor view.

The current log file (named jommon_CCYYMMDD_user-id.log) is then released, it is renamed jommon_
CCYYMMDD_user-id_released_HHMMSS.log, and a new empty log file is created for any additional logging in
the current work session.

Exiting from the JADE Monitor
Select the Exit command from the File menu to terminate the JADE Monitor.

To exit from the JADE Monitor, perform one of the following actions

Select the Exit command from the File menu.

Click the close icon at the top right corner of the window or select the Close command from the Control-
Menu.

Press Alt+F4.
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When you exit from the JADE Monitor:

Your current window settings are saved

The JADE Monitor is closed

All locks and the log file are released

All objects are cleared from memory

Note Any current runtime JADE application is not terminated when you exit from a JADE development work
session.

Performing Options Menu Command Actions
The Options menu provides the commands listed in the following table, which enable you to specify your JADE
Monitor options.

Command For details, see…

Font Bigger Increasing the Font Size

Font Smaller Decreasing the Font Size

Activate Timer (nnn) Activating the Timer for the Specified Period

Timer Based Sampling Setup Setting Up Timer-Based Sampling

Highlight Timer Sampled Items Toggling the Highlighting of Activities Sampled by the Timer

Navigator Click Causes Refresh Clicking in the Navigator Pane to Refresh the Current View

Find Locating an Element in the Current View

Overview Toggling the Display of Knowledge Base Information

Refresh Refreshing the Current View

Refresh All Refreshing All Views

Clear Table Sort Settings Clearing Table Sort Settings

Increasing the Font Size
To increase the size of the displayed font, perform one of the following actions

Select the Font Bigger command from the Options menu.

Press Ctrl+1.

The font size is then doubled (that is, increased by a factor of 100 percent).

You can repeat this action once more if you want the displayed font to be 200 percent larger than the default font
(that is, this command is disabled when you have selected it twice in succession).

Note The UIFontSize parameter in the [JadeMonitor] section of the JADE initialization file specifies the size in
points of the font used to display information in the JADE Monitor program. The value can be 10 (the default), 11,
or 12.
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Decreasing the Font Size
To decrease the increased size of the displayed font, perform one of the following actions

Select the Font Smaller command from the Options menu.

This command is disabled when the text in the JADE Monitor is the default font size.

Press Ctrl+0.

The font size is then halved (that is, decreased by a factor of 100 percent).

You can repeat this action once more if you want the displayed font to be 200 percent smaller than the maximum
increased font size and returned to the default font size (that is, this command is disabled when you have selected
it twice in succession).

Note The UIFontSize parameter in the [JadeMonitor] section of the JADE initialization file specifies the size in
points of the font used to display information in the JADE Monitor program. The value can be 10 (the default), 11,
or 12.

Activating the Timer for the Specified Period
To activate the sampling of activities at a specified period, perform one of the following actions

Select the Activate Timer (nnn) command from the Options menu.

The value in parentheses is the number of seconds at which sampling occurs and which is specified on the
Monitor Setup view of the General activity group.

Press Ctrl+F8.

The timer is then activated, the cross symbol is removed from the clock icon at the right of the status bar, activities
that are selected for sampling are displayed in a red font in the Navigator pane and the Options menu displays the
Stop Timer command.

Alternatively, if the timer is activated, select the Stop Timer command to deactivate the timer. The timer is then
deactivated and the Options menu displays the Activate Timer command.

For details about changing the frequency of sampling (for example, from the default sampling interval of 30
seconds), see "Setting Up the JADE Monitor", in Chapter 1.

Setting Up Timer-Based Sampling
To set up timer-based sampling

Select the Timer Based Sampling Setup command from the Options menu.

The Monitor Setup view of the General activity group is then displayed. For details about setting up timer-based
sampling, see "Setting Up the JADE Monitor", in Chapter 1.

Toggling the Highlighting of Activities Sampled by the Timer
In normal mode, activities sampled by the timer are highlighted in a red font in the Navigator pane by default, to
provide a visual indication of the items selected for sampling.
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The Highlight Timer Sampled Items command from the Options menu enables you to toggle the display of
highlighted activities. For details about setting up timer-based sampling, see "Setting Up the JADE Monitor", in
Chapter 1.

To hide or display the highlighting of activities sampled by the timer

Select the Highlight Timer Sampled Items command from the Options menu.

A check mark is displayed to the left of the command in the Options menu when activities sampled by the timer are
highlighted.

Clicking in the Navigator Pane to Refresh the Current View
By default, the most-recently taken sample is displayed in an activity view. The Navigator Click Causes Refresh
command from the Options menu enables you specify that you want a new sample taken and the resulting data
displayed in the corresponding view when you click on an activity in the Navigator pane.

By default, data from the most-recent sample is displayed; that is, clicking the Navigator pane does not cause a
new sample to be taken and the sampled data displayed.

To activate the taking of a new sample and the display of that data when an activity is clicked

Select the Navigator Click Causes Refresh command from the Options menu.

A check mark is displayed to the left of the command in the Options menu when an activity clicked in the Navigator
pane causes the sampling of that activity and the display of the sampled data.

To view various statistics without causing an intermediate sample to be taken, uncheck the Navigator Click
Causes Refresh command to remove the check mark displayed to the left of the command.

Locating an Element in the Current View
You can locate an element in the current view; for example, the id of a user in the Users view that you want to sign
off from the JADE Monitor or a statistical attribute in Cache Performance view.

To locate an element in the current view

1. Select the Find command from the Options menu. Alternatively, press F3 or click the Find button at the upper
right of the current view.

The search bar is then displayed with a blue background at the bottom of the view, as shown in the following
image.

2. In the Find text box, enter the value that you want to locate in the current view.

3. If you want the exact match by case (where uppercase or lowercase is significant), check the Match Case
check box. A search is then performed for text with the same capitalization as the text in the Find text box. By
default, searching is case-insensitive; that is, this check box is unchecked.

4. Click the Next button to perform a search of the values in the current view. If no match is found, phrase not
found is displayed in red at the right of the search bar. If the specified phrase is located, the first instance of
the phrase in that view is then selected.
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5. Click the Next button if you want to locate the next instance of the specified phrase in the view (or keep
pressing the Enter key).

Alternatively, click the Previous button if you want to locate the previous instance of that phrase.

6. To hide the search bar, repeat step 1 of this instruction (that is, to toggle the display of the search bar).

Toggling the Display of Knowledge Base Information
The Overview pane, which is displayed by default at the lower right of the JADE Monitor window, provides you
with knowledge base information about the current view.

To toggle the display of the Overview pane, perform one of the following actions

Click the Overview button at the upper right of the activity view.

Click the Hide button at the upper right of the Overview pane.

Select the Overview command from the Options menu.

Press F4.

For details about loading an updated knowledge base file provided by JADE Support into your JADE system, see
"Maintaining Knowledge Base Information", later in this chapter.

Refreshing the Current View
You can add an activity component to or remove an activity component from a periodic sample group by:

Right-clicking or pressing F10 on an activity or activity group in the Navigator pane and then selecting the
Add to Periodic Sampling Group command from the popup menu that is displayed

Selecting the appropriate activity in the Periodically Sampled Items list on the Monitor Setup view,
accessed from the General activity group in the Navigator pane

If the activity of the current view has been selected for periodic sampling, it is refreshed as the timer fires. If the
activity of the current view has not been set up for periodic sampling, view is not refreshed when the timer
activates.

If the currently displayed activity is not selected for periodic sampling by the JADE Monitor timer function, the
Refresh button is enabled so that you can click it if you want to take a new sample of the activity. The Refresh
button is disabled if the activity is selected in the Periodically Sampled Items list.

If the Users or Setup Process Statistics view is the current view and the Navigator Click Causes Refresh
command is checked, the Refresh button is highlighted with a red font when an add or delete notification has
been received for a node or process, to indicate that view changes are pending and the view will not be refreshed
until the next timer event is fired, you click the Refresh button, or you press F5.

To take a new sample of the current activity and display the sampled data

Click the Refresh button.

Alternatively, press F5.

A new sample of that activity is then taken, the current activity view is refreshed with new details, and the date and
time at which the sample was taken and the number of seconds since the last sample was taken of that activity is
displayed at the upper right of the view.
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For details about clicking an activity in the Navigator pane to take a new sample and display the sampled data,
see "Clicking the Navigator Pane to Refresh the Current View", earlier in this chapter.

Refreshing All Views
If the displayed activity is not selected for periodic sampling by the JADE Monitor timer function, the Refresh All
button is enabled so that you can click it if you want to take a new sample of all activities.

Before you can select the Refresh All command, you must have selected entities for sampling in the Monitor
Setup view of the General activity group and pressed the Update button.

To take a new sample of all activities and update the displayed the sampled data on all views

Select the Refresh All command from the Options menu. Alternatively, press Ctrl+F5.

Any item that has been selected for periodic sampling (that is, on the Monitor Setup view, in a loaded directives
file, or by right-clicking the activity in the Navigator view and then selecting the Add to Periodic Sampling Group
command from the popup menu that is displayed) is refreshed when you select the Refresh All command.

Clearing Table Sort Settings
You can sort the columns of data in the tables of sampled activities, except for transient file analysis and call stack
analysis. When a table is sorted, changing the sort column (clicking the column header row) retains the sort
direction of the previously selected column.

To sort a column of sampled data in ascending order

Click in the heading of the column whose data you want to sort.

The table is then refreshed, with the values in the selected column listed in ascending order (that is, with the
lowest number or character closest to the start of the alphabet in that column at the top of the table and the highest
number or last alphabetic character at the bottom). In addition, the ( icon is displayed at the left of the column
heading caption.

To sort a column of sampled data in descending order when it is sorted in ascending order

Click in the heading of the column that is currently sorted in ascending order.

The table is then refreshed, with the values in the selected column listed in descending order (that is, with the
highest number or character closest to the end of the alphabet in that column at the top of the table and the lowest
number or first alphabetic character at the bottom). In addition, the ( icon is displayed at the left of the column
heading caption.

To clear the sorting of a table column, perform one of the following actions

Select the Clear Table Sort Settings command from the Options menu.

Press F6.

The sorting of a column in the table in the currently displayed activity is then cleared, with the data listed in the
order that it was sampled.
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Performing Selections Menu Command Actions
The Selections menu provides the commands listed in the following table, which enable you to select one of the
following activity views.

Command For details, see…

Locks Displaying the Locks View

Notifications Displaying the Notifications View

Queued Locks Displaying the Queued Locks View

Statistics Displaying the Statistics View

Users Displaying the Users View

Licence Info Displaying the Licence Information View

Displaying the Locks View
Select the Locks command from the Selections menu to display the Locks view if it is not the current view. For
details about the Locks view, see the Overview pane (that is, knowledge base information) at the lower right of the
JADE Monitor window.

To display the Locks view, perform one of the following actions

Select the Locks command from the Selections menu.

Click the Locks activity group in the Navigator pane.

The Locks view is then displayed, loaded with the latest lock information.

Displaying the Notifications View
Select the Notifications command from the Selections menu to display the Notifications view if it is not the current
view. For details about the Notifications view, see the Overview pane (that is, knowledge base information) at the
lower right of the JADE Monitor window.

To display the Notifications view, perform one of the following actions

Select the Notifications command from the Selections menu.

Click the Notifications activity in the Navigator pane.

The Notifications view is then displayed, loaded with data from the most-recent sample of notifications.

Displaying the Queued Locks View
Select the Queued Locks command from the Selections menu to display the Queued Locks view if it is not the
current view. For details about the Queued Locks view, see the Overview pane (that is, knowledge base
information) at the lower right of the JADE Monitor window.

To display the Queued Locks view, perform one of the following actions

Select the Queued Locks command from the Selections menu.

Click the Locks activity group in the Navigator pane if it has not been expanded to display its activities and
then select the Queued Locks activity.
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The Queue Locks view is then displayed, loaded with data from the most-recent sample of queued locks.

Displaying the Statistics View
Select the Statistics command from the Selections menu to display the System Statistics view if it is not the
current view. For details about the System Statistics view, see the Overview pane (that is, knowledge base
information) at the lower right of the JADE Monitor window.

To display the Statistics view, perform one of the following actions

Select the Statistics command from the Selections menu.

Click the System Statistics activity in the Navigator pane.

The System Statistics view is then displayed, loaded with data from the most-recent sample of system statistics.

Displaying the Users View
Select the Users command from the Selections menu to display the Users view if it is not the current view. For
details about the Users view, see the Overview pane (that is, knowledge base information) at the lower right of the
JADE Monitor window.

To display the Users view, perform one of the following actions

Select the Users command from the Selections menu.

Click the Users activity in the Navigator pane.

The Users view is then displayed, loaded with data from the most-recent sample of users.

Displaying the Licence Information View
Select the Licence Info command from the Selections menu to display the Licence Information view if it is not the
current view. For details about the Licence Information view, see the Overview pane (that is, knowledge base
information) at the lower right of the JADE Monitor window.

To display the Licence Information view

Select the Licence Info command from the Selections menu.

Click the Licence Info activity in the Navigator pane.

The Licence Information view is then displayed, loaded with data from the most-recent sample of licences.

Performing Help Menu Command Actions
The Help menu provides the commands listed in the following table, which enable you to access the standard
Common User Access (CUA) help options.

Command For details, see…

Index Accessing the JADE Monitor User’s Guide

About Accessing JADE Monitor Release Information
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Accessing the JADE Monitor User’s Guide
The Help menu Index command enables you to open online help. The JADE Monitor User’s Guide is then
opened, providing access to the topics available in online help.

To access the online help, perform one of the following actions

Select the Index command from the Help menu

Press F1

The JADE online help is then displayed; for example, the JadeMonitor.pdf) document is displayed in Adobe
Reader.

Use the functions available in JADE online help to find the required topics. For details, see "JADE HTML5 Online
Help" or "JADE Product Information Library in Portable Document Format", in Chapter 2 of the JADE Development
Environment User’s Guide.

Accessing JADE Monitor Release Information
The Help menu About command enables you to access information about the JADE Monitor.

To access the JADE Monitor information

Select the About command from the Help menu

The JADE Monitor About box is then displayed, providing information that includes the database that is being
monitored, the company to whom JADE is licensed, the server node operating system, and the JADE release
version. This dialog is for display purposes only.

Performing Popup Menu Command Actions
Use popup (context) menus to quickly display the choices for your currently selected item.

To access a popupmenu, perform one of the following actions

Right-click on the required item.

Press Shift+F10 from a list box or table.

Popup menus, depending on the areas from which you access them (for example, the Navigator pane or from a
specific view), can display the commands listed in the following table.

Command For details, see…

Add Item Adding an Item to or Removing it from a List

Add to / Remove from Periodic Sampling
Group

Adding an Activity to or Removing it from a Periodic Sampling
Group

Add Selected Class Adding a Selected Class to a List

Add Selected Class Including Subclasses Adding a Selected Class and its Subclasses to a List

Call Stack Summary Displaying the Call Stack Summary of a Selected User

Copy Copying Selected Data to the Clipboard

Copy Cell to Clipboard Copying a Cell to the Clipboard
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Command For details, see…

Copy Row to Clipboard Copying a Row to the Clipboard

CSV Capture – Column Selection Capturing Columns to a CSV File

Delta Values Capturing a Column as Delta Values to a CSV File

Rate Values Capturing a Column as Rate Values to a CSV File

Raw Values Capturing a Column as Raw Values to a CSV File

CSV Capture – Row Selection Capturing Rows to a CSV File

Add Selected Rows Adding Selected Rows to a CSV Capture Group

Clear All Clearing All Rows from a CSV Capture Group or List

Remove Selected Rows Removing Selected Rows from a CSV Capture Group

CSV Capture – Start Starting or Stopping the Capture of Data to a CSV File

Deregister Process Deregistering a Process

Dump All Nodes Dumping All Nodes

Dump Selected Node Dumping a Selected Node

Enable / Disable Save Lock Call Stack Enabling or Disabling the Saving of the Lock Call Stack

Expand / Collapse Section Expanding or Collapsing a Table Section

Find Locating a Phrase in a Knowledge Base Article

Force Off User Forcing Off a User from JADE

Force Off Node Forcing Off a Node from JADE

Interrupt User Interrupting Users

Log Sample to File Logging a Sample to a File

Method Cache Statistics Displaying Process Method Cache Statistics

Page Setup Setting up Print Options

Print Printing Knowledge Base Articles

Register / Deregister for Process Stats
(Local)

Registering or Deregistering for Local Process Statistics

Register / Deregister for Process Stats
(Remote)

Registering or Deregistering for Remote Process Statistics

Select All / Clear All Selecting All Items or Clearing the Selection of All Items in a List

Show Lock Call Stack Displaying the Lock Call Stack

Show Timers Displaying Timer Details for a Selected Process

Shutdown Selected Monitor Process Shutting Down a Specific JADE Monitor Process

Transient Database File Analysis Displaying a Transient Database File Analysis

Transient Database File Summary Displaying a Transient Database File Summary

View Lock Details for Selected Class / Oid Displaying Lock Details for a Selected Class or Oid

View Process on Users View Displaying Process Ids on the Users View
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Adding an Activity to or Removing it from a Periodic Sampling Group
To add an activity to the periodic sampling group

1. In the Navigator pane, right-click on the activity that you want to add to the group of activities that is
periodically sampled.

Use the Ctrl or Shift key to select a group or range of activities, respectively.

2. Select the Add to Periodic Sampling Group command from the popup menu that is then displayed. This
command is disabled if the activity is already included in the periodic sampling group or if the periodic
sampling does not apply to that activity (for example, the Capture activity in the Node Sampling activity
group).

The selected activity is then added to the periodic sampling group and highlighted in red in the Navigator pane.

To remove an activity from the periodic sampling group

1. In the Navigator pane, right-click on the activity that you want to remove from the group of activities that is
periodically sampled.

Use the Ctrl or Shift key to select a group or range of activities, respectively.

2. Select the Remove from Periodic Sampling Group command from the popup menu that is then displayed.

This command is disabled if the activity is not included in the periodic sampling group or if the periodic
sampling does not apply to that activity (for example, the Monitor Setup activity in the General activity group).

The selected activity is then removed from the periodic sampling group, the check mark or check marks are then
removed from the activity or activities in the Periodically Sampled Items list on the Monitor Setup view of the
General activity group, and the red highlighting is removed in the Navigator pane.

Adding an Item to or Removing it from a List
To add an item to a list of selected items

1. Right-click on an item in a list of items that are available for selection (for example, the Attributes Available
for Extract list box at the left of the Analysis view of the Node Sampling activity group). Use the Ctrl or Shift
key to select a group or range of items, respectively.

2. Select the Add Item command from the popup menu that is then displayed. Alternatively, double-click on the
item.

The selected item is then moved to the list of selected items at the right of the view (for example, the Selected
Classes list box on the Capture view of the Node Sampling activity group).

To remove an item from a list of selected items

1. Right-click on an item in a list of selected items (for example, the Selected Classes list box on the Capture
view of the Node Sampling activity group). Use the Ctrl or Shift key to select a group or range of items,
respectively.

2. Select the Remove Item command from the popup menu that is then displayed. Alternatively, double-click
on the item.

The selected item is then moved to the list of items available for selection at the left of the view (for example, the
Attributes Available for Extract list box at the left of the Analysis view of the Node Sampling activity group).
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Adding a Selected Class and its Subclasses to a List
To add a class and all of its subclasses to a list of selected classes

1. Right-click on the class in a list of classes that are available for selection (for example, the ModelEntity
superclass in the Classes list box at the left of the Capture view of the Node Sampling activity group). Use
the Ctrl or Shift key to select a group or range of classes, respectively.

2. Select the Add Selected Class (include subclasses) command from the popup menu that is then displayed.
This command is available only when the selected class is a superclass.

The selected class and all of its subclasses are then moved to the list of selected classes at the right of the view
(for example, the Selected Classes list box on the Capture view of the Node Sampling activity group).

For details about removing a selected class from a list, see "Adding an Item to or Removing it from a List", earlier
in this chapter.

Adding a Selected Class to a List
To add a class to a list of selected classes

1. Right-click on the class in a list of classes that are available for selection (for example, the Classes list box at
the left of the Capture view of the Node Sampling activity group). Use the Ctrl or Shift key to select a group or
range of classes, respectively.

2. Select the Add Selected Class command from the popup menu that is then displayed. Alternatively, double-
click on the class.

The selected class is then moved to the list of selected classes at the right of the view (for example, the Selected
Classes list box on the Capture view of the Node Sampling activity group).

For details about removing a selected class from a list, see "Adding an Item to or Removing it from a List", earlier
in this chapter.

Copying a Cell to the Clipboard
To copy a table cell of sampled data to the clipboard

1. Right-click on the cell whose table data you want to copy to the clipboard.

2. Select the Copy Cell to Clipboard command from the popup menu that is then displayed.

The sampled data in that cell is then copied to the clipboard, to enable you to paste it into another application.

Copying a Row to the Clipboard
To copy a table row of sampled data to the clipboard

1. Right-click on the row whose table data you want to copy to the clipboard. Use the Ctrl or Shift key to select a
group or range of rows, respectively. Alternatively, press Ctrl+A to select all rows.

2. Select the Copy Row to Clipboard command from the popup menu that is then displayed.

Alternatively, press Ctrl+C to copy the selected rows.

The row of sampled data is then copied to the clipboard, to enable you to paste it into another application.
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Capturing Columns to a CSV File
You can select whether sampled statistical data displayed in some views (for example, activity and cache statistics
for the database displayed on the Database Statistics view) is written to a Comma-Separated Values (CSV) file
as one of the following values. For details, see the following subsections.

Raw data (the default of total values since the JADE database was opened)

Delta values since the previous sample

Computed rate-per-second values

You can then use an external program such as Excel to manipulate the captured data.

Sample data values of the selected type are recorded to a CSV file in the default JADE Monitor log directory in the
following format.

jommon_capture-date_user-id_activity-name.csv

The following is an example of a CSV file of system statistics.

jommon_20140713_Wilbur_SystemStats.csv

For details about the default log file location, see "Log File Location", in Chapter 1.

To stop the capturing of sampled data when the timer is active or when the view is refreshed, right-click on a table
row and then select the CSV Capture - Stop command.

Data capture is controlled on a sheet-by-sheet basis.

You can turn off the CSV capture of data for a specific activity while leaving it enabled for another. (For details, see
"Starting or Stopping the Capture of Data to a CSV File", later in this chapter.)

The status line indicates the current capture status (that is, DISABLED or ENABLED).

For some views (for example, the Node Statistics view and the Database Statistics view) you must first select
the row or rows whose columns you want to capture. For details, see "Adding Selected Rows to a CSV Capture
Group" under "Capturing Rows to a CSV File", later in this chapter.

Capturing a Column as Delta Values to a CSV File

To capture a column of selected statistical data samples to a CSV file as delta values

1. Right-click on a row in the table that has Value, Delta, and Rate columns (for example, the System
Statistics view).

2. Position the mouse over the CSV Capture – Column Selection command and then select the Delta Values
command from the submenu that is displayed.

3. Right-click again on a table row and then select the CSV Capture - Start command. (The command then
changes to the CSV Capture - Stop command.)

Capturing a Column as Rate Values to a CSV File

To capture a column of selected statistical data samples to a CSV file as rate values

1. Right-click on a row in the table that has Value, Delta, and Rate columns (for example, the Node Statistics
view).
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2. Position the mouse over the CSV Capture – Column Selection command and then select the Rate Values
command from the submenu that is displayed.

3. Right-click again on a table row and then select the CSV Capture - Start command. (The command then
changes to the CSV Capture - Stop command.)

Capturing a Column as Raw Values to a CSV File

To capture a column of selected statistical data samples to a CSV file as raw values

1. Right-click on a row in the table that has Value, Delta, and Rate columns (for example, the Database
Statistics view).

2. Position the mouse over the CSV Capture – Column Selection command and then select the Raw Values
command from the submenu that is displayed.

3. Right-click again on a table row and then select the CSV Capture - Start command. (The command then
changes to the CSV Capture - Stop command.)

Capturing Rows to a CSV File
You can select the row or rows on a table of sampled data to capture to a CSV file. You can then use an external
program such as Excel to manipulate the captured data.

By default, raw data of statistical samples is captured, unless you select the capture or delta or rates values. In
addition, you can remove selected rows form the CSV capture group or you can clear all selected roes from the
capture group.

Rows of data marked to be part of the CSV capture group are highlighted in the view table with a light-green
background. The status line indicates the current capture status (that is, DISABLED or ENABLED).

Notes Data capture is controlled on a sheet-by-sheet basis. You can turn off the capture of data for a specific
activity while leaving it enabled for another. (For details, see "Starting or Stopping the Capture of Data to a CSV
File", later in this chapter.)

The column selection menu items dictate which columns are saved for the rows that have been marked for
capture. (For details about the capturing of columns of raw, delta, and rate values of statistical data samples, see
"Capturing Columns to a CSV File", earlier in this chapter.)

Sample data values of the selected type are recorded to a CSV file in the default JADE Monitor log directory in the
following format.

jommon_capture-date_user-id_Objectactivity-name.csv

The following is an example of a CSV file of node statistics for analysis.

jommon_20140713_Wilbur_ObjectNodeStatsAnalysis.csv

For details about the default log file location, see "Log File Location", in Chapter 1.

To stop the capturing of sampled data when the timer is active or when the view is refreshed, right-click on a table
row and then select the CSV Capture - Stop command.

For details, see the following subsections.
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Adding Selected Rows to a CSV Capture Group

To add a row or rows to a CSV capture group for the current view

1. Right-click on a row in the table that you want to add to the capture group.

2. Position the mouse over the CSV Capture – Row Selection command and then select the Add Selected
Rows command from the submenu that is displayed.

Use the Ctrl or Shift key to select a group or range of rows, respectively.

3. Right-click again on a table row and then select the CSV Capture - Start command. (The command then
changes to the CSV Capture - Stop command.)

The values in all columns of the selected row or rows are then recorded to a CSV file when the view is refreshed
or the active timer fires. For details about the format and location of this file, see "Capturing Rows to a CSV File",
earlier in this chapter.

For details about removing selected rows from the capture group, see "Clearing All Rows from a CSV Capture
Group or List" and "Removing Selected Rows from a CSV Capture Group", in the following sections.

Clearing All Rows from a CSV Capture Group or List

To clear all selected rows from a CSV capture group or list for the current view

1. Right-click on a row in the table whose selected rows or list box whose items you want to remove from the
respective capture group or list.

2. Position the mouse over the CSV Capture – Row Selection command and then select the Clear All
command from the submenu that is displayed. This command is disabled if no rows or list items are currently
selected.

The selection highlighting is then removed from all rows and the capture status is removed from the status line.
For details about adding rows to the capture group, see "Adding Selected Rows to a CSV Capture Group", in the
previous section.

Removing Selected Rows from a CSV Capture Group

To remove a row or rows from a CSV capture group for the current view

1. Right-click on a row in the table that you want to remove from the capture group.

Use the Ctrl or Shift key to select a group or range of rows, respectively.

2. Position the mouse over the CSV Capture – Row Selection command and then select the Remove
Selected Rows command from the submenu that is displayed. This command is disabled if no rows are
currently selected.

The selection highlighting is then removed from each row selected for removal from the capture group. For details
about adding rows to the capture group, see "Adding Selected Rows to a CSV Capture Group", in the previous
section.

Copying Selected Data to the Clipboard
To copy text selected in the Overview pane to the clipboard

1. In the Overview pane at the lower right of the JADE Monitor window, select the text that you want to copy to
the clipboard.
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2. Right-click in the selection and then select the Copy command from the popup menu that is displayed.

The selected text is then copied to the clipboard, to enable you to paste it into another application (for example,
Notepad).

For details about toggling the display of the knowledge base information, see "Toggling the Display of Knowledge
Base Information", earlier in this chapter.

Deregistering a Process
You can deregister all local or remote processes for a node that were registered by selecting the Register for
Process Stats (Local) or Register for Process Stats (Remote) popup menu command in the table on the Setup
Process Statistics view instead of deregistering them individually.

The Process Statistics Local or Process Statistics Remote views enable you to identify a process that is
causing a problem (for example, using excessive CPU or getting all of the objects).

You can deregister the recording of local or remote process statistics directly from the applicable view instead of
deregistering them individually in the Setup Process Statistics view. For example, if you narrow down excessive
CPU consumption of a local process to a specific application server, you can then select a number of processes in
that node and go through them one at a time, ruling out those that are not causing the problem.

To deregister a process

1. Right-click on the process section row whose registered local or remote process statistics you want to
deregister in the table on the Process Statistics Local or Process Statistics Remote view.

2. Select the Deregister Process command from the popup menu that is then displayed.

Tip If the view displays a lot of process statistics in the table, you can hide the display of statistics in each node if
you do not want to have to scroll down to each node. For details, see "Expanding or Collapsing a Table Section",
in the following section.

The Y value (that is, yes) is then removed from the respective L column (local process statistics) or the R column
(remote process statistics) of users in the selected node on the Setup Process Statistics view.

Displaying a Transient Database File Analysis
To display the analysis of a transient database file, perform one of the following actions

Select the Transient File Analysis activity in the Transient Object Activity group in the Navigator pane.

Right-click on the a specific user or node in the table on the Users view or the process in the Transient File
Summary view and then select the Transient Database File Analysis command from the popup menu that
is displayed.

The Transient File Analysis view of the Transient Object Activity group is then displayed, providing an analysis of
the transient database file of each user or process selected.

Note To analyze the transient database file, the target process is temporarily activated or interrupted. After the
file has been analyzed, the process resumes from the point at which it was activated or interrupted.
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Displaying a Transient Database File Summary
To display a transient database file summary, perform one of the following actions

Select the Transient File Summary activity in the Transient Object Activity group in the Navigator pane.

Right-click on the user in the table on the Users view (or a specific node, if you want to summarize transient
database file details of all user processes in the node) and then select the Transient Database File
Summary command from the popup menu that is displayed.

The Transient File Analysis view of the Transient Object Activity group is then displayed.

Note To summarize the transient database file, the target process is temporarily activated or interrupted. After
the file has been summarized, the process resumes from the point at which it was activated or interrupted.

Displaying Lock Details for a Selected Class or Oid
To display lock details for a selected class or oid

1. Right-click on the class or oid in the table on the Summary by Class, Summary by Oid, or Detail for
Selected Class view in the Lock Analysis activity group.

2. Select the View Lock Details for Selected Class or View Lock Details for Selected Oid command from the
popup menu that is then displayed.

Note These commands are enabled only when lock data has been monitored.

The Detail for Selected Class or Detail for Selected Oid view of the Lock Analysis activity group is then
displayed.

Displaying Process Ids in the Users View
To display process ids of a class or oid on the Users view

1. Right-click on the class or oid in the table on the Summary by Class, Detail for Selected Class, Summary
by Oid, or Detail for Selected Oid view in the Lock Analysis activity group.

2. Select the View Process Ids on Users View command from the popup menu that is then displayed.

Note This command is enabled only when lock data has been monitored.

The Users view is then displayed highlighting the user who had acquired the selected lock; for example, to
enable you to force off or interrupt the user. (For details, see "Forcing Off a User from JADE" or "Interrupting
Users", earlier in this chapter.)

Displaying the Call Stack Summary of a Selected User
To display the call stack summary of a selected user, perform one of the following actions

Select the Call Stack Summary activity in the Process Information activity group in the Navigator pane.

Right-click on the user in the table on the Users view and then select the Call Stack Summary command
from the popup menu that is displayed.

The Call Stack Summary view of the Process Information activity group is then displayed.
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Displaying Timer Details for a Selected Process
To display timer details for a selected process, perform one of the following actions

Select the Timers activity in the Process Information activity group in the Navigator pane.

Right-click on the process in the table on the Users view or the Setup Process Statistics view in the
Process Information activity group and then select the Show Timers command from the popup menu that is
displayed.

The Timers view of the Process Information activity group is then displayed.

Displaying Process Method Cache Statistics
To display method cache statistics for a selected process or for all processes in a node

1. Select the Users activity in the in the Navigator pane. The Users view is then displayed.

2. Right-click on the node in the first row of the table, or on a process in the node.

3. Select the Method Cache Statistics command from the popup menu that is displayed.

The Method Cache Statistics table is then displayed in the Process Information view.
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If the method cache is overrun (for example, you have set it to a low limit such as 64K in the [JadeInterpreter]
section of the JADE initialization file), an additional Overrun percentage bracket over cache limit table is
displayed under the cache statistics for each process, as shown in the following image.

Applies to Version: 2018.0.01 and higher

Dumping a Selected Node
To invoke a non-fatal process dump of a specific node

1. In the Users view, right-click on the node for which you require a process dump. Alternatively, use the Ctrl or
Shift key to select a group or range of nodes, respectively.

2. Select the Dump Selected Node command from the popup menu that is displayed. This command is
disabled if no node is currently selected in the Users view.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to initiate an
operating system process dump for the selected node or nodes. (Alternatively, click the Cancel button to abandon
the process dump.)
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Dumping All Nodes
To invoke a near-simultaneous process dump of all nodes and the server node itself

1. In the Users view, right-click on a node.

2. Select the Dump All Nodes command from the popup menu that is displayed. This command is disabled if
no node is currently selected in the Users view.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to initiate an
operating system process dump for all nodes. (Alternatively, click the Cancel button to abandon the process
dump.)

Enabling or Disabling the Saving of the Lock Call Stack
You can enable or disable the saving of the lock call stack of a process, by selecting the Enable Save Lock Call
Stack or Disable Save Lock Call Stack popup menu command in the table on the Users view.

To enable or disable the saving of the lock call stack of a process

1. On the Users view, right-click on the process whose saving of the lock call stack you want to enable or
disable.

2. To enable the saving of a disabled lock call stack, select the Enable Save Lock Call Stack command from
the popup menu that is then displayed.

Conversely, if you want to disable the saving of a lock call stack, select the Disable Save Lock Call Stack
command from the popup menu.

3. Repeat steps 1 and 2 of this instruction for each process whose saving of the lock call stack you want to
enable or disable.

When the saving of a lock call stack of a process is enabled, the Show Lock Call Stack command from the popup
menu in the Locks view enables you to display the call stack of a currently locked object of a process at the time it
was locked. Any process can retrieve this information while the lock is held; for example, you can use it to help
find and resolve locking problems during application development.

Applies to Version: 2016.0.01 and higher

Expanding or Collapsing a Table Section
Some tables are made up of data displayed in sections, with each section highlighted with a blue background; for
example, persistent, transient, and remote transient cache details sections on the Cache Performance view.

Some sections can also contain groups of data; for example, individual nodes within cache performance detail
sections. These groups, which are also highlighted with a blue background, can also be toggled to display or hide
the data within a group; for example, if you want to view cache performance statistics for a specific node for a
specific type of cache, you could collapse the other node groups and cache type sections.

To collapse a section or group of data in a table, perform one of the following actions

Double-click anywhere in that section or group.

Right-click in the section or group and then select the Collapse Section command from the popup menu that
is displayed.

The section or group is then collapsed so that the rows of data in it are hidden and only the blue section or group
row is displayed. The command in the popup menu then changes to the Expand Section command.
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To expand a collapsed section or group in a table, perform one of the following actions

Double-click anywhere in that section or group.

Right-click in the section or group whose rows of data are hidden and then select the Expand Section
command from the popup menu that is displayed.

The section or group is then expanded so that the rows of data in it are displayed. The command in the popup
menu changes to the Collapse Section command.

Forcing Off a User from JADE
To force a user from a specific node

1. In the Users view, right-click on the user who you want to force off a specific node. Alternatively, use the Ctrl
or Shift key to select a group or range of users, respectively.

2. Select the Force Off User command from the popup menu that is displayed. This command is disabled if no
user is currently selected in the Users view.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to force the
selected user or users from the node. (Alternatively, click the Cancel button to abandon the forcing off action and
allow that user to continue using the JADE environment.)

You cannot force yourself off when you are the monitoring node itself (that is, this action has no effect if you select
the Force Off User command when your own user id is the monitoring node).

Note When you force off a user, the Application class finalize method is not executed.

Forcing Off a Node from JADE
To force a node from JADE

1. In the Users view, right-click on the node that you want to force off JADE. Alternatively, use the Ctrl or Shift
key to select a group or range of nodes, respectively.

2. Select the Force Off Node command from the popup menu that is displayed. This command is disabled if no
node is currently selected in the Users view.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to force off the
node and all users signed on to that node. (Alternatively, click the Cancel button to abandon the forcing off action
and allow the user or users to continue monitoring.)

Interrupting Users
To interrupt one or more users

1. In the Users view, right-click on the user who you want to conditionally interrupt on a specific node.
Alternatively, use the Ctrl or Shift key to select a group or range of users, respectively.

2. Select the Interrupt User command from the popup menu that is displayed. This command is disabled if no
user is currently selected in the Users view.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to interrupt the
selected user or users on the node. (Alternatively, click the Cancel button to abandon the interrupt action and
allow the user or users to continue uninterrupted.)

Monitor User's Guide

Chapter 2    Using the JADE Monitor for System Instrumentation and Diagnosis 44



JadeMonitor - 2020.0.02

You can use this command to interrupt a database operation. This action cancels (that is, performs a user abort
action of) an in-progress file certify, file compact, file reindex, file freespace evaluate, file usage analysis, make file
partitioned, and move instances database operations, and in-progress reorganizations.

Locating a Phrase in a Knowledge Base Article
To locate a phrase in a knowledge base article

1. In the Overview pane, right-click on text in the Overview or Discussion section.

2. Select the Find command from the popup menu that is displayed. This command is disabled if the caret is not
positioned on text on the Overview pane.

The Find dialog is then displayed.

3. In the Find what text box, specify the text that you want to locate in the knowledge base article.

4. If you want to search backwards through the contents of the Overview pane from the current caret position up
to the beginning of the article, select the Up option button in the Search group box.

By default, searching is performed from the current caret position to the end of the article; that is, the Down
option button is selected.

5. If you want the exact match by case (where uppercase or lowercase is significant), check the Match case
check box. A search is then performed for text with the same capitalization as the text in the Find what text
box.

By default, searching is case-insensitive; that is, this check box is unchecked.

6. If you want the search restricted to the full word specified in the Find what text box (for example, Request will
not find extractRequestStatistics), check the Whole words only check box.

A search is then performed for full words that match your specified search criteria. As this check box is not
checked by default, the search will match on part of a word.

7. To find the next occurrence of the specified text, click the Find Next button.

If JADE finds the text string that matches your specified options, the located text is then highlighted and focus
is returned to the Overview pane. If JADE cannot find the text string that matches your specified options, a
message box informs you that the search text was not found and waits for you to click the OK button in the
message box before returning focus to the Overview pane.

8. When you do not want to locate any more text in the knowledge base article, click the Cancel button. Focus
then returns to the Overview pane.

Logging a Sample to a File
You can toggle the logging of sampled data to a file for subsequent replay in another JADE Monitor work session
to allow for the viewing of historical sampling information. For details, see "Loading Files in Historical Mode",
earlier in this chapter.

In a JADE thin client environment, monitor logging is performed to directories that are accessible to the
presentation client.

For details about specifying that an activity is output to a log file when periodically sampled or when you click the
Refresh button, see setting up your JADE Monitor preferences, see "Setting Up the JADE Monitor", in Chapter 1.

In normal mode, activities that are selected for periodic sampling are displayed in the Navigator pane in a red font.
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To log the data of a sampled activity to a file

1. In the Navigator pane, right-click on the activity whose sampled data you want to log for historical purposes.

Alternatively, check the check box at the left of the activity in the Samples Logged to File list on the Monitor
Setup view of the General activity group. (For details, see "Setting Up the JADE Monitor", in Chapter 1.)

2. Select the Log Sample to File command from the popup menu that is then displayed.

A check mark is then displayed at the left of the command in the popup menu and the check box of that activity in
the Samples Logged to File list on the Monitor Setup view is checked.

Sampled activities are output to a log file in the default JADE Monitor log directory in the following format.

jommon_capture-date_user-id.log

The following is an example of a log file of a sampled activity.

jommon_20140716_Wilbur.log

For details about the default log file location, see "Log File Location", in Chapter 1.

Note The monitor log is primarily designed to be a machine-readable log. The timestamp on each line is
generated using the literalFormat method of the TimeStamp primitive type.

To stop the logging of a sampled activity to a file

Right-click on the activity in the Navigator pane and then select the Log Sample to File command from the
popup menu that is displayed.

Alternatively, uncheck the check box at the left of the activity in the Samples Logged to File list on the
Monitor Setup view of the General activity group.

The check mark is then removed from the left of the command in the popup menu and the check box of that activity
in the Samples Logged to File list on the Monitor Setup view is unchecked.

Printing Knowledge Base Articles
To print the knowledge base article for the current activity

1. In the Overview pane, right-click on text in the Overview or Discussion section.

2. Select the Print command from the popup menu that is displayed. This command is disabled if the caret is
not positioned on text on the Overview pane.

The common Print dialog is then displayed, to enable you to specify the printer name, the print range, the
number of copies, and whether you also want to output the article to a file (if you select Adobe PDF in the
Name combo box).

3. Click the OK button.

The knowledge base article is then output to the selected printer. For example, to your default printer or if you
checked the Print to File check box and selected a value such as Adobe PDF or Microsoft XPS Document
Writer in the Name text box, the common Save the file as dialog is then displayed, to enable you to select the
name and location of the print output file.
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Registering or Deregistering for Local Process Statistics
You can register or deregister the recording of local process statistics for a specific node user. (For details about
deregistering all local processes for a node, see "Deregistering a Process", earlier in this chapter.)

To register or deregister a user for local process statistics on a specific node

1. On the Setup Process Statistics view, right-click on the row of the user whose local process statistics for
that node you want to register or deregister.

2. If a Y value (that is, yes) is displayed in the L column for that user (indicating that the user is registered for
local process statistics), select the Deregister for Process Stats (Local) command from the popup menu
that is then displayed.

The Y value is then removed from the L column for that user.

Conversely, if the user is not yet registered for local process statistics on that node, select the Register for
Process Stats (Local) command from the popup menu. A Y value is then displayed in the L column for that
user.

3. Repeat steps 1 and 2 of this instruction for each user whose local process statistics you want to register or
deregister.

Tip If the view displays a lot of nodes and users in the table, you can hide the display of statistics in each node if
you do not want to have to scroll down to each node. For details, see "Expanding or Collapsing a Table Section",
earlier in this chapter.

Registering or Deregistering for Remote Process Statistics
You can register or deregister the recording of remote process statistics for a specific node user. (For details about
deregistering all remote processes for a node, see "Deregistering a Process", earlier in this chapter.)

To register or deregister a user for remote process statistics on a specific node

1. On the Setup Process Statistics view, right-click on the row of the user whose remote process statistics for
that node you want to register or deregister.

2. If a Y value (that is, yes) is displayed in the R column for that user (indicating that the user is registered for
remote process statistics), select the Deregister for Process Stats (Remote) command from the popup
menu that is then displayed. The Y value is then removed from the R column for that user. Conversely, if the
user is not yet registered for remote process statistics on that node, select the Register for Process Stats
(Remote) command from the popup menu. A Y value (that is, yes) is then displayed in the R column for that
user.

3. Repeat steps 1 and 2 of this instruction for each user whose remote process statistics you want to register or
deregister.

Tip If the view displays a lot of nodes and users in the table, you can hide the display of statistics in each node if
you do not want to have to scroll down to each node. For details, see "Expanding or Collapsing a Table Section",
earlier in this chapter.
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Selecting All Items or Clearing the Selection of All Items in a List
If you want to select most of the items in a list, you can select all items and then individually remove those you do
not want included from the selection (for example, in the Periodically Sampled Items list on the Monitor Setup
view). Conversely, if a majority of items in a list is selected and you want to include a few only, you can clear all
items from selection and then individually select only those you want to include.

To select all items in a list

Right-click in the list and then select the Select All command from the popup menu that is then displayed.

All items are then selected; for example, a check mark is displayed in all enabled (valid) check boxes in the
Samples Logged to File list on the Monitor Setup view. For details about setting up the JADE Monitor, see
"Setting Up the JADE Monitor", in Chapter 1.

To clear the selection of all items in a list

Right-click in the list and then select the Clear All command from the popup menu that is then displayed.

All items are then removed from selection; for example, no check marks are displayed in any check boxes in the
Select Sample Types to Load list on the Load Historical Samples view.

Setting up Print Options
To set up options when printing the knowledge base article for the current activity

1. In the Overview pane, right-click on text in the Overview or Discussion section.

2. Select the Page Setup command from the popup menu that is displayed. This command is disabled if the
caret is not positioned on text on the Overview pane.

The common Print Setup dialog is then displayed, to enable you to specify your printer options. Any values that
you specify in this dialog are retained for subsequent print requests. For details about using the Print Setup dialog,
see "Setting Up Your Printer", in Chapter 3 of the JADE Development Environment User’s Guide.

Shutting Down a Specific JADE Monitor Process
To shut down a specific JADE Monitor process for a user on a node

1. In the Users view, right-click on the row that has JadeMonitor/JadeMonitorSchema in the Application
column of the node in which you want to shut down the JADE Monitor.

Use the Ctrl or Shift key to select a group or range of JADE Monitor users, respectively.

2. Select the Shutdown Selected Monitor Process command from the popup menu that is displayed. This
command is disabled if the selected row is not running the JADE Monitor.

A message box is then displayed, prompting you to click the OK button to confirm that you do want to shut down
the selected JADE Monitor process for that user or users on the node. (Alternatively, click the Cancel button to
abandon the shut down action and allow the user or users to continue interrupted.)

Starting or Stopping the Capture of Data to a CSV File
Data captured to a CSV file for manipulation by an external program such as Excel is controlled on a sheet-by-
sheet basis. You can turn off the capture of data for a specific activity while leaving it enabled for another. For
details about selecting the data for capture to a CSV file, see "Capturing Columns to a CSV File" and "Capturing
Rows to a CSV File", earlier in this chapter.
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To start the capture of data to a CSV file when the view is refreshed or the active timer fires

1. In the table of data for the current activity, select the row whose data you want captured to file for subsequent
manipulation by an external program.

2. Right-click on a table row and then select the CSV Capture - Start command. (A message box is displayed if
you have not yet selected the item or items whose data you want captured.)

All sampled data values that were recorded since the previous sample are then recorded to a CSV file when the
view is refreshed or the active timer fires and the command changes to the CSV Capture - Stop command.

To stop the capture of data to a CSV file when the view is refreshed or the active timer fires

Right-click on the row of a table whose selected data is captured to a CSV file when the view is refreshed or
the active timer fires and then select the CSV Capture - Stop command.

The capture of sampled data for selected items in that activity then stops and the command changes to the CSV
Capture – Start command.

Maintaining Knowledge Base Information
When JADE provides a new text file of knowledge base articles, you can run the JADE Monitor help editor to load
the new file into your JADE database.

The following example is the command line to run the JADE Monitor help editor application.

jade.exe path=s:\jade\system ini=s:\jade\system\jade.ini schema=JadeMonitorSchema
app=JadeMonitorV2HelpEditor

Alternatively, you can create a shortcut to run this application from the JADE installation directory in which the
JADE executables were installed (which defaults to the bin directory).
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The JADE Monitor window is then opened in the Knowledge Base Help Editor view, shown in the following image.

Loading a new knowledge base articles file overwrites the existing knowledge base; it is not amended to it. For
details about toggling the display of the knowledge base articles, see "Toggling the Display of Knowledge Base
Information", earlier in this chapter.

Maintenance Menu
When you run the JADE Monitor help editor, the Maintenance menu is displayed in the JADE Monitor window.
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The Maintenance menu provides the commands listed in the following table, which enable you to extract an
existing knowledge base articles file and to load a new file of knowledge base articles provided by JADE Support.

Command For details, see …

Extract Articles Extracting an Existing Knowledge Base Information File

Load Articles Loading a New Knowledge Base Information File

Extracting an Existing Knowledge Base Information File
You can extract your existing knowledge base articles file; for example, when JADE Support provides a new file
and you want to retain the existing text file.

To extract the knowledge base articles file

1. Select the Extract Articles command from the Maintenance menu.

The common Select Monitor KnowledgeBase Backup File dialog is then displayed, to enable you to specify
your text file backup options.

2. In the Look in text box, enter the absolute path to which to extract the existing knowledge base articles text
file or use standard facilities to browse to the location you require for the backed up information file.

3. In the File name text box, specify the file prefix that you require.

Tip As a new knowledge base articles file overwrites an existing file of the same name in the target path,
you may want to name the file to distinguish it from a new file (for example, by calling it
KnowledgeBase31032009.txt).

4. Click the Open button.

5. If you specified a new file name or a difference absolute path, a message box is displayed stating that the file
does not exist in the selected directory and prompting you to click the Yes button if you want to create the file.

Alternatively, click the No button to abandon the backing up of the existing knowledge base file.

The Extract Complete message box is then displayed, stating that the knowledge base articles have been
extracted to the specified location and file. Click the OK button to return focus to the JADE Monitor Knowledge
Base Help Editor.

Loading a New Knowledge Base Information File
You can load a new text file of knowledge base articles supplied by JADE Support.

To load a new knowledge base information file

1. Select the Load Articles command from the Maintenance menu.

The common Load Monitor KnowledgeBase From Backup File dialog is then displayed, to enable you to
specify your load options.

2. In the Look in text box, enter the absolute path in which the new text file of knowledge base articles is
located.

3. Select the text file of knowledge base articles that you want to load in the folder and file list in the middle of
the dialog or specify the file name in the File name text box.

4. Click the Open button.
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A message box is then displayed, warning you that the load action will delete any existing knowledge base
articles in your JADE database and prompting you to click the Yes button if you want to continue with the text
file load process. (Alternatively, click the No button if you want to return to the to the JADE Monitor
Knowledge Base Help Editor; for example, to extract the existing knowledge base information to another
location or file name before initiating the knowledge base articles load process again.)

The Load Complete message box is then displayed, stating that the knowledge base articles have been loaded
into your JADE database from the specified location and file.

Click the OK button to return focus to the JADE Monitor Knowledge Base Help Editor.
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