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Before You Begin

The JADE Remote Node Access Utility User’s Guide is intended as the main source of information when you start
or administer JADE on a server node.

Who Should Read this Guide

The main audience for the JADE Remote Node Access Ultility User’'s Guide is expected to be system

administrators.

Related Documentation

Other documents that are referred to in this guide, or that may be helpful, are listed in the following table, with an
indication of the JADE operation or tasks to which they relate.

Title

Related to...

JADE Development Environment Administration Guide Administering the JADE development environment

JADE Synchronized Database Service (SDS) Administering JADE Synchronized Database

Administration Guide Services (SDS), including Relational Population
Services (RPS)

JADE Object Manager Guide JADE Object Manager administration, including
security

JADE Installation and Configuration Guide Installing and configuring JADE

JADE Initialization File Reference Maintaining JADE initialization file parameter
values

Conventions

The JADE Remote Node Access Utility User’s Guide uses consistent typographic conventions throughout.

Convention

Description

Arrow bullet (3))

Bold

Italic

Step-by-step procedures. You can complete procedural instructions by using either the
mouse or the keyboard.

Items that must be typed exactly as shown. For example, if instructed to type foreach,
type all the bold characters exactly as they are printed.

File, class, primitive type, method, and property names, menu commands, and dialog
controls are also shown in bold type, as well as literal values stored, tested for, and
sent by JADE instructions.

Parameter values or placeholders for information that must be provided; for example, if
instructed to enter class-name, type the actual name of the class instead of the word or
words shown in italic type.

Italic type also signals a new term. An explanation accompanies the italicized type.

Document titles and status and error messages are also shown in italic type.
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Convention

Description

Blue text

Bracket symbols ([])
Vertical bar (| )
Monospaced font
ALL CAPITALS
SMALL CAPITALS

Enables you to click anywhere on the cross-reference text (the cursor symbol changes
from an open hand to a hand with the index finger extended) to take you straight to that
topic. For example, click on the "JADE Server Node and Multithreading”
cross-reference to display that topic.

Indicate optional items.

Separates alternative items.

Syntax, code examples, and error and status message text.
Directory names, commands, and acronyms.

Keyboard keys.

Key combinations and key sequences appear as follows.

Convention Description

KEY1+KEY2 Press and hold down the first key and then press the second key. For example, "press
Shift+F2" means to press and hold down the Shift key and press the F2 key. Then
release both keys.

KEY1,KEY2 Press and release the first key, then press and release the second key. For example,

"press Alt+F X" means to hold down the Alt key, press the F key, and then release both
keys before pressing and releasing the X key.
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Chapter 1 Using the JADE Remote Node
Access Utility

This document covers the following topics.
®  Overview
o JADE Server Node and Multithreading
= |nstalling and Running the JADE Remote Node Access Utility
m  Executing the JADE Remote Node Access Utility
m  Administering the JADE Remote Node Access Utility
o Clearing the JADE Server Node Window Display
o Disabling Users from Signing On
o Minimizing or Restoring the JADE Server Node Window
o Synchronizing Non-GUI Server Application Cached Details
o Starting a Service
o Stopping a Service
o Displaying Server Configuration Details
o Displaying Current Client Connections
o Exiting from the JADE Remote Node Access Utility
m  Specifying Your JADE Remote Node Access Utility Options
o Running the Server Node as a Service
®  Obtaining Online Help for the JADE Remote Node Access Utility
o Accessing the Online Help Contents

o Displaying JADE Remote Node Access Version Information

Overview

The JADE Remote Node Access utility (jadrap) is a user interface that enables you to start or administer JADE on
a server node. You can use this utility to:

m  Access a JADE database on the server node in multiuser mode
m  Disable users from signing on

= View server configuration information

m  View the currently connected clients

L Run the server node as a service
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The menu options that enable the JADE Remote Node Access utility to run as a service are disabled if you
do not have the necessary privileges to install or remove an application as a service. Installing, controlling,
and removing a service can be performed only if you have sufficient (that is, administrative) operating system
privileges.

m  Synchronize cached values when you have modified non-GUI server application details in the JADE
initialization file

In a multiuser environment, the JADE Remote Node Access utility can be accessed only from the server node. A
client node can therefore not use a specific JADE database until that database has been accessed on the server
node, by using the JADE Remote Node Access utility. (The JADE Remote Node Access utility has no meaning in
single user mode, as the client and server nodes are the same node.)

Each JADE database in multiuser mode must have its own JADE Remote Node Access utility, regardless of the
server workstation on which itis running; thatis, one server workstation may have one or more JADE Remote
Node Access utilities.

Client nodes in a multiuser JADE environment can connect to the server node by using the TCP/IP
communications protocol.

JADE Server Node and Multithreading

Server node threads perform server node request processing. (Each application running in JADE is executed on
its own thread and each thread effectively runs as a standalone Windows program.)

JADE provides flexibility in configuring a multiuser JADE application environment by enabling you to specify the:
= Minimum and maximum number of server node, short, and long threads

This provides an application administrator with full control of how much resource the server node can use and
when new resource is activated.

When a non-GUI application thread fails to respond within 45 seconds, JADE attempts to interrupt the processing
of that thread, waits for another 10 seconds, and then terminates the thread. See also "Note about Shutting Down
a Database Server Node", in the following subsection.

Note Active users are calculated from the total of all JADE application instances on all JADE client nodes plus
one additional system user for each JADE client node. For example, running one JADE development client node
counts as two active users; thatis, one for the JADE development application and one for the system user.
Similarly, a client node running a deployed JADE application counts as two active users. If both these JADE client
nodes run at the same time, you use a total of four active users. However, when running the same deployed JADE
application from within another JADE application (for example, the development environment), you use two users
for JADE application instances plus one system user, totaling three.

JADE'’s flexible approach to distributed processing provides scalable applications that maximize the utilization of
the available hardware resources. A scalable system enables you to minimize potential bottlenecks, both physical
and logical.

Two or more processes can communicate independently with the server node, as there is one logical connection
for each node process.

Notes The maximum number of server methods that can execute concurrently is limited to the number of long
threads available on the server node.

If an exception handler is armed in the executing node and an exception is raised, itis handled in the executing
node. If no exception handler is armed in the executing node, the exception is reported back to the invoking node
for exception handling.
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Note about Shutting Down a Database Server Node

When you shut down a database server node (that is, jadrap or jadserv) and there are database transactions still
in progress, these incomplete transactions must be aborted.

You can determine whether transactions are in progress by using the JADE Monitor.

The server control program waits up to 45 seconds for each server thread to terminate. However, a server thread
may be processing a lengthy operation such as returning deleted object space to the freespace index, which may
take longer than 45 seconds to complete in some situations.

If the server control program finalizes the database while a user updating operation is still in progress, itis not safe
to continue and a fatal exception is raised, resulting in the abrupt termination of the database server. Subsequent
restart recovery will undo the incomplete transaction.

When this scenario is detected, the following messages are recorded in the jommsg.log file.

PDB:clearing active user: [3] <user3> during finalise

PDB:user: [3] <user3> has active thread in database engine

PDB:*** unexpected sign off while database operation still active for [3] user3
PDB:*** thread state not known, database server must terminate to force restart
recovery

PDB:*** Terminating process nNow .......

In the simple case when the database is finalized and users have been left signed on with incomplete
transactions but they do not have pending update operations in progress, the following messages are recorded in
the jommsg.log file.

PDB: clearing active user: [6] <user6> during finalise
PDB: [6] <user6> unexpected sign off while in transaction state
PDB: [6] <user6> aborting overflowed transaction 1293682...

In this situation, if the transaction abortis allowed to complete, the database will be closed normally.

Physical Bottlenecks

Physical bottlenecks occur when hardware resources are exhausted in a workstation due to work overload.
Physical bottlenecks are common on a centralized system in which a specific workstation handles a
disproportionate amount of the total system workload.

JADE enables you to build scalable systems, by allowing the distribution of the workload among client and server
workstations in a flexible manner. Client and server workstations host heterogeneous nodes that can potentially
perform any of the system’s tasks.

In JADE, clients can execute not only presentation code and application logic, but also a large part of the data
management functions that otherwise have to be carried out by the server node.

Transaction processing in JADE is divided into client node transaction tasks and server node transaction tasks.
The server node transaction tasks are thus reduced to those thatitis strictly necessary for the server node to
perform; for example, concurrency control and transaction recovery.

Most of the index processing and update consolidation for objects takes place in the client node that originated
the transaction.
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Logical Bottlenecks

Logical bottlenecks occur when there is frequent contention for logical global resources because of the nature of
the system. Logical bottlenecks can occur both in a centralized and in a decentralized system. The system design
characteristics can help to reduce it, depending on the amount of flexibility provided by the development tools that
are used.

The flexible JADE data model allows the definition of relatively small indexes and collection. Working with smaller
and independent units of data reduces the potential for logical bottlenecks.

When logical bottlenecks are avoided, more work can be done in parallel by more nodes in the system and the
net effect is that the system can handle larger volumes of transactions.

When a new client node is added to a JADE network, the node brings with it its computational power, which
reduces the requirements of the central server for each client node. This condition increases the number of client
nodes, each performing a significant amount of work that can participate in a JADE network.

Installing and Running the JADE Remote Node Access
Utility

The JADE Remote Node Access utility is installed in the directory in which your JADE binary files are located (for
example, c:\jade\bin) as part of the JADE installation process. (For details about running the server node as a
service, see "Running the Server Node as a Service", later in this document.)

You can install multiple copies of JADE on a server, each one having its own database and associated JADE
Remote Node Access utility and JADE initialization file.

Note Ensure thatthe correct path is specified in the command line for each JADE Remote Node Access utility
that you install; for example:

jadrap path=c:\jade\system ini=c:\jade\system\jade.ini

You can also run the JADE Remote Node Access utility as a non-GUI executable, as shown in the following
example.

jadserv path=c:\jade\system ini=c:\jade\system\jade.ini start
The jadserv executable command has the following argument values.

jadserv path=database-path
ini=JADE-initialization-file-path
service=name-of-service
[name=initializaton-file-named-section]
[quiet]
install|uninstall |remove|start|startsync|stop|stopsync|run

The optional quiet argument suppresses message boxes relating to the action being performed.

Each invocation of jadserv.exe can specify one only of the install, uninstall, remove, start, startsync, stop,
stopsync, or run action arguments for the service.

The run argument, specified in the registry command line, runs the service started by the Microsoft service
manager.

If the jadserv command line does not contain the service=name-of-service argument, the service defaults to the
value of the NodeName parameter in the [JadeServer] section of the JADE initialization file. If that is not present,
the name of the service defaults to JadeServerNode.
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For details about installing and configuring JADE in a multiuser environment, see "Installing Your JADE Software"
and "JADE Configurations", in Chapter 1 of the JADE Installation and Configuration Guide and for details about
the parameters in the JADE initialization file that affect the operation of the JADE server, see "JADE Object
Manager Server Section [JadeServer]", in the JADE Initialization File Reference.

Executing the JADE Remote Node Access Utility

»

You can execute the JADE Remote Node Access utility to initiate a JADE database only from the server
workstation.

To execute the JADE Remote Node Access utility, perform one of the following actions

m  Click the JADE Remote Node Access icon in your JADE program folder for the appropriate JADE database.
(As a JADE server workstation can have many databases, the server can have many JADE program folders.)

®m  In Explorer or File Manager, access the directory in which your JADE binary files are located (for example,
c:\jade\bin) and then double-click on the jadrap program file.

The JADE server node window, shown in the following image, is then displayed.

pr

& Jade C\ade\system Tcplp(60046021,61001) | = | =] 8 |

File Options Help

JADE"

Users on client nodes can now access the JADE database.

Tip The title bar of the JADE server node window displays the node name, the path of the JADE database on
the server node, and the configured transport protocol, to enable you to differentiate between the JADE databases
on the server workstation.

Use the menu bar to access the JADE Remote Node Access utility commands.
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Administering the JADE Remote Node Access Utility

Use the File menu in the JADE server node window to perform one of the administrative actions listed in the

following table.

Command

Description

For details, see...

Clear Display

Disable User SignOn

Use System Tray Icon

Synch Server Apps

Start Service

Stop Service

Show Configuration
Show Connections

Exit

Clears contents from the JADE server
node window

Stops users signing on to JADE in a
multiuser environment

Automatically minimizes the JADE
Remote Node Access utility as an
icon in the system tray after start up or
toggles the minimizing or restoring of
the utility

Synchronizes the non-GUI server
application details in caches

Starts the JADE Remote Node Access
utility as a service

Stops running the JADE Remote
Node Access utility as a service

Displays server configuration details
Displays current client connections

Exits from the JADE server, and
closes the JADE database

Clearing the JADE Server Node Window
Display

Disabling Users from Signing On

Minimizing or Restoring the JADE Server
Node Window

Synchronizing Non-GUI Server Application
Cached Details

Starting a Service

Stopping a Service

Displaying Server Configuration Details
Displaying Current Client Connections

Exiting from the JADE Remote Node Access
Utility

Clearing the JADE Server Node Window Display

»

The Clear Display command from the File menu enables you to clear the contents from the JADE server node

window, if required.

To clear the window contents

= [fyou no longer want the contents displayed in the JADE server node window, select the Clear Display
command from the File menu.

The window contents are then removed from the JADE server node window.

Disabling Users from Signing On

»

The Disable User SignOn command from the File menu enables you to disable users from signing on to the JADE
database; for example, when you want to back up the database on the server node.

To disable users from signing on

m  [fyou do not wantany more users to sign on to the JADE database, select the Disable User SignOn
command from the File menu.
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»

A check mark is then displayed to the left of the command in the File menu, indicating that user sign on is currently
disabled. Any user who then tries to sign on to the JADE database is unable to do so and an exception is raised
on the remote node at which the sign on was attempted.

To allow users to sign on to the JADE database
m  Select the Disable User SignOn command from the File menu.

The check mark is then removed from the left of the menu command and remote users can then sign on the
database again.

Minimizing or Restoring the JADE Server Node Window

»

»

»

By default, the JADE server node window is automatically minimized and an icon is placed in the system tray
when the JADE Remote Node Access utility starts up.

The Use System Tray Icon command from the File menu enables you to toggle the minimizing or restoring of the
JADE server node window to or from the system tray icon. When the window can be automatically minimized and
a system tray icon displayed in the Taskbar (the default value), a check mark is displayed to the left of the
command in the File menu and an icon is placed in the system tray in the Taskbar at the lower right of the screen
when the utility starts up.

The icon is removed from the system tray when the JADE Remote Node Access utility closes down or the use of
the system tray icon is disabled.

To toggle the use of the system tray icon
= (Click the Use System Tray Icon from the File menu.

When the use of the system tray icon is activated, a check mark is displayed to the left of the command in the File
menu and an icon is placed in the system tray at the lower right of the screen when the utility starts up.

When you disable the use of the system tray icon for the utility, no check mark is displayed at the left of the
command in the File menu, no icon is located in the system tray, and the window is not automatically minimized
when the application starts up.

In addition, the UseSystemTraylcon parameter in the [JadeServer] section of the JADE initialization file is
updated to maintain the current value for future work sessions when you exit from the utility. For details, see the
"UseSystemTraylcon" parameter under "JADE Object Manager Server Section [JadeServer]", in the JADE
Initialization File Reference.

When you move the mouse over the icon, bubble help is displayed that contains the information displayed in the
title bar of the JADE server node window; that is, the node name, the path of the JADE database on the server
node, and the configured transport protocol. This information, which enables you to differentiate between the
JADE databases on the server workstation, is truncated to 63 characters in the bubble help, if applicable.

To restore the JADE server node window
m | eft-click on the JADE Remote Node Access utility icon in the system tray at the right of the Taskbar.

The JADE server node window is then restored (that is, maximized).

To minimize the window again when the use of the system tray icon is enabled
m  |eft-click on the JADE Remote Node Access utility icon in the system tray again.

The JADE server node window is then minimized; that is, left-clicking on JADE Remote Node Access utility icon in
the system tray toggles the minimizing and restoring of the JADE server node window.
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»

To access the JADE Remote Node Access utility system tray icon menu

m  Right-click on the JADE Remote Node Access utility icon in the system tray at the right of the Taskbar.
The system tray icon menu for the utility is then displayed.

The JADE Remote Node Access utility icon menu provides the following commands.

®  Minimize / Restore

The Minimize or Restore command, determined by the current status of the JADE server node window,
toggles the minimizing or restoring of the JADE server node window.

= Disable User SignOn

The Disable User SignOn command stops users signing on to JADE in a multiuser environment. For details,
see "Disabling Users from Signing On", earlier in this document.

m  Use System Tray Icon

The Use System Tray Icon command enables or disables the automatic minimizing of the JADE server
node window when the application starts up and placement of the JADE Remote Node Access utility icon in
the system tray.

Tip Select this command from the icon menu if you want to disable the use of the system tray icon and
automatic minimizing of the JADE server node window. The icon is then removed from the system tray.
(When use of the system tray icon is disabled, you can enable it at any time by selecting the Use System
Tray lcon command in the File menu of the JADE server node window.)

The UseSystemTraylcon parameter in the [Jade] section of the JADE initialization file enables you to
configure whether the interrupticon is positioned in the system tray.

= Sync Server Apps

The Sync Server Apps command synchronizes the non-GUI server application details in caches. For
details, see "Synchronizing Non-GUI Server Application Cached Details", later in this document.

= Exit

The Exit command exits from the JADE server and closes the JADE database. For details, see "Exiting from
the JADE Remote Node Access Utility", later in this document.

Synchronizing Non-GUI Server Application Cached Details

If you add or remove a ServerApplication<application-number> parameter in the [JadeAppServer] or
[JadeServer] section of your JADE initialization file or you change any variable values after the server has started,
select the Synch Server Apps command from the JADE Remote Node Access utility File menu.

JADE then reads all ServerApplication<application-number> parameters in the JADE initialization file and
caches the changed values. Use this command if you have changed the time at which a non-GUI server
application is started or you have specified a new non-GUI server application to start at a specific time, for
example.

Starting a Service

Use the Start Service command from the File menu to start running the JADE server node as a service.
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»

To start running the server node as a service

1. Ensure thatthe Run Server as Service check box in the Service Configuration dialog is checked. (For
details, see "Running the Server Node as a Service", later in this document.)

2. Selectthe Start Service command from the JADE server node window File menu.

This command is disabled if the server node is not configured to run as a service or itis currently running as
a service.

A message dialog then informs you that the service has successfully started.

Notes As services are supported only by Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows
Server 2012, and Windows Server 2008, this command is enabled only if you are running JADE under a Windows
operating system that supports services (and the server node is currently configured as a service).

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of the registry
must be modified but standard Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows Server
2012, and Windows Server 2008 users do not have the necessary privileges to do this. The menu options that
enable the JADE Remote Node Access utility to run as a service are disabled if you do not have the necessary
privileges to install or remove an application as a service. Installing, controlling, and removing a service can be
performed only if you have sufficient operating system privileges.

To run the database server with administrative privileges, right-click on the JADE Database Server program
shortcutin your JADE 2018 Installation folder on the Windows Start menu, select the More command, and then
select the Run as administrator command from the submenu. Alternatively, to run the database server with
administrative privileges for this and every work session, right-click on the JADE Database Server item in
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\<installation-folder-name>\JADE MultiUser, and
then select the Run as administrator command from the popup (context) menu.

Stopping a Service

»

Use the Stop Service command from the File menu to stop running the JADE server node as a service.

To stop running the server node as a service
m  Selectthe Stop Service command from the JADE server node window File menu.
This command is disabled if the server node is not currently running as a service.

The JADE Remote Node Access service is then stopped.

Notes As services are supported only by a Windows operating system that supports services this command is
enabled only if you are running JADE under a Windows operating system that supports services (and the server
node is currently running as a service).

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of the registry
must be modified but standard Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows Server
2012, and Windows Server 2008 users do not have the necessary privileges to do this. The menu options that
enable the JADE Remote Node Access utility to run as a service are disabled if you do not have the necessary
privileges to install or remove an application as a service. Installing, controlling, and removing a service can be
performed only if you have sufficient operating system privileges.

Displaying Server Configuration Details

Use the Show Configuration command from the File menu to display details about the server node configuration.
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» Todisplay server configuration details
m  Selectthe Show Configuration command from the JADE server node window File menu.

Server node information that you have configured in the NetworkSpecification<specification-number>
parameters in your [JadeServer] section of the JADE initialization file is then displayed in the JADE server node
window; for example, the TCP/IP communications protocol, listener port, and interface of each network
specification, as well as the configured values of the TransportidlePollinterval, MinShortThreads,
MinLongThreads, MaxShortThreads, and MaxLongThreads parameters in the [JadeServer] section of the JADE
initialization file.

You can clear this displayed server configuration details by selecting the Clear Display command in the File
menu. For details, see "Clearing the JADE Server Node Window Display".

Displaying Current Client Connections

Use the Show Connections command from the File menu to display information about the current client
connections.

» Todisplay client connection details
m  Select the Show Connections command from the JADE server node window File menu.

The current client connections, if any, are then displayed in the JADE server node window, as well as the number
of active short and long server threads.

You can clear this displayed current client connections information by selecting the Clear Display command in
the File menu. For details, see "Clearing the JADE Server Node Window Display".

Exiting from the JADE Remote Node Access Utility

Use the Exit command from the File menu to exit from the JADE Remote Node Access utility and close the JADE
database.

» To exit from the JADE Remote Node Access utility
®  Select the Exit command from the File menu.
The JADE server node window and the JADE database are then closed.

If any client nodes are accessing the server node at the time that you select the Exit command, the Termination
message box advises you that client nodes are still connected, and asks you to confirm that you want to exit from
the server node. When you click the Yes button to confirm that you want to exit, any connected clients are
immediately disconnected, and the server node is then closed down. If the system tray icon was in use (the
default), the icon is removed from the system tray when the JADE Remote Node Access utility closes down.

Note Ifthe server node is shut down because of a user signing off as an operating system user and that user
does not confirm that the JADE Remote Node Access utility is to be closed when JADE users are still connected to
the server, the sign off from the operating system is aborted.

If you have changed your configuration to run the server node from a server to a service, the service is started after
the server has disconnected from the database.

The JADE Remote Node Access utility has an optional style TERMINATION message box, which is controlled by
using the TerminationMsgbox parameter with a value of TryAgain in the [JadeServer] section of the JADE
initialization file. If you do not specify this value or the parameter has a <default> value, the message box displays
Yes and No buttons only.
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When the TerminationMsgbox parameter has a value of TryAgain, the message box displays the following
buttons.

= Cancel
Closes the message box.
= Try Again

Rechecks to see if there are any active nodes. If there are no active nodes, jadrap terminates. If there are
active nodes, the message box is redisplayed.

= Continue

Shuts down jadrap, even if active nodes are attached.

Specifying Your JADE Remote Node Access Utility
Options

Use the Options menu in the JADE server node window to run the server node as a service.

Note Installing, controlling, and removing a service can be performed only if you have sufficient (that is,
administrative) operating system privileges.

The Options menu command is listed in the following table.

Command For details, see... Description

Service Running the Server Node as a Service Displays the Service Configuration dialog

For details, see the following subsection.

Running the Server Node as a Service

Use the Service command from the Options menu to configure your server node as a service.

Notes As services are supported only by Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows
Server 2012, and Windows Server 2008, this command is disabled if you do not have Windows permission to
change the service configuration.

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of the registry
must be modified but standard Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows Server
2012, and Windows Server 2008 users do not have the necessary privileges to do this. The menu options that
enable the JADE Remote Node Access utility to run as a service are disabled if you do not have the necessary
privileges to install or remove an application as a service. Installing, controlling, and removing a service can be
performed only if you have sufficient operating system privileges.

When you run the JADE Remote Node Access utility as a service, the service is started automatically when the
server workstation is started up, to enable client nodes to access that JADE database. (When the utility is run as a
server node, it must be started from the JADE Remote Node Access shortcut or the JADE Remote Node
Access icon in your JADE program folder on the server node to initialize the JADE database before client nodes
can use that database.)
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»

You can use the Windows 10, Windows 8, Windows 7, Windows Server 2016, Windows Server 2012, or Windows
Server 2008 Control Panel Services window to specify that the service is started manually or the Start Service
command from the JADE server node window File menu. (For details, see "Starting a Service", earlier in this
document.)

When a service is to be started manually, client nodes cannot access the database until the service is started,
even if the server workstation is started up.

To configure your server node as a service
1. Selectthe Service command from the Options menu.

The Service Configuration dialog, shown in the following image, is then displayed.

Service Configuration @I&J

[T Bun Server az Service

| ak. | Cancel Help

2. Check the Run Server as Service check box if you want the server node to be run as a service.
By default, a server node is not run as a service; that s, this check box is unchecked.
3. Click the OK button. Alternatively, click the Cancel button to abandon your selection.

The service is then installed and registered in the Windows 10, Windows 8, Windows 7, Windows Server
2016, Windows Server 2012, or Windows Server 2008 registry, the service with the name of the server node
(for example, DevSvrNode_12) is created in automatic start-up mode, and the RunAsService parameter in
the [JadeServer] section of your JADE initialization file is set to true.

4. Selectthe Exit command from the File menu to close the JADE server node window and the JADE database.
The JADE service is then started.

When the JADE Remote Node Access utility is run as a service, that service is connected to the database. To
access the utility as a server node for administrative purposes only, double-click the JADE Remote Node Access
shortcut or click the JADE Remote Node Access icon in your JADE program folder on the server node when the
service is running. (In administration mode, you cannot connect to the database, as that connection is currently
used by the service.)

Note Any changes that you make in administration mode update your JADE initialization file but do not update
the service until that service is closed and then restarted. (To close a service, select the service from the Windows
Control Panel Services utility window and then click the Stop button.)

Resetting a Service to a Server Node

If you no longer want to run the server node as a service, you must reset the JADE Remote Node Access utility in
the administration mode.
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¥ To configure your service as a server node

1. Double-click the JADE Remote Node Access shortcut or click the JADE Remote Node Access icon in
your JADE program folder on the server node when the service is running. The JADE server node window is
then displayed.

2. Selectthe Service command from the Options menu. The Service Configuration dialog is then displayed.
3.  Uncheck the Run Server as Service check box, to specify that the server node is to run as a server.
4. Click the OK button. Alternatively, click the Cancel button to abandon your selection.

When you uncheck the Run as Service check box when the JADE server node is still running as a service, a
message box is displayed, advising you that you cannot uncheck this option when the service is running and
that you must first stop the service. In addition, the service state (for example, running, stopped, and so on) is
continuously updated to reflect service state changes made externally; for example, by using the Task
Manager.

The service is then stopped and deregistered from the Windows 10, Windows 8, Windows 7, Windows
Server 2016, Windows Server 2012, or Windows Server 2008 registry. The RunAsService parameter in the
[JadeServer] section of the JADE initialization file is set to false.

5. Selectthe Exit command from the File menu to close the JADE server node window and the JADE database.

6. Restartthe server node by double-clicking the JADE Remote Node Access shortcut or clicking the JADE
Remote Node Access icon in your JADE program folder on the server node, to initialize the JADE database
before client nodes can use that JADE database.

Obtaining Online Help for the JADE Remote Node Access
Utility

Use the Help menu in the JADE server node window to perform one of the actions listed in the following table.

Command For details, see... Description

Index Accessing the Online Help Contents Opens the online help in Adobe Reader

About JadRap Displaying JADE Remote Node Access Displays version information for the JADE
Version Information Remote Node Access utility

Accessing the Online Help Contents

»

Use the Index command from the JADE Remote Node Access utility Help menu to access the JADE Remote Node
Access Utility User's Guide, which provides access to the topics available in online help.

To access the online help, perform one of the following actions

m  Select the Index command from the Help menu.

= Press F1 when the focus is on the JADE server node window.

The JADE online help is then displayed; for example, the JadRap.pdf) document is displayed in Adobe Reader.

Use the functions available in JADE online help to find the required topics. For details, see "JADE HTML5 Online
Help" or "JADE Product Information Library in Portable Document Format", in Chapter 2 of the JADE Development
Environment User’s Guide.
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Displaying JADE Remote Node Access Version Information

Use the About JadRap command from the Help menu to display version (and copyright) information for the JADE
Remote Node Access utility.

» Todisplay version information
m  Selectthe About JadRap command from the Help menu.

The version and copyright information for the JADE Remote Node Access utility are then displayed. When you
have viewed the version information, click the OK button to close the dialog and return focus to the JADE server
node window.
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