Jade Software Corporation Limited cannot accept any financial or other responsibilities that may be the result of your use of this information or software material, including direct, indirect, special or consequential damages, or loss of profits. There are no warranties extended or granted by this document or software material.

You should be very careful to ensure that the use of this software material and/or information complies with the laws, rules, and regulations of the jurisdictions with respect to which it is used. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Jade Software Corporation Limited.

The information contained herein is subject to change without notice. Revisions may be issued to advise of such changes and/or additions.

Copyright © 2018 Jade Software Corporation Limited.

All rights reserved.

JADE is a trademark of Jade Software Corporation Limited. All trade names referenced are the service mark, trademark, or registered trademark of the respective manufacturer.

For details about other licensing agreements for third-party products, you must read the JADE ReadMe.txt file.
Contents

Before You Begin ........................................................................................................... xi
  Who Should Read this Guide ................................................................. xi
  What You Need to Know ................................................................... xi
  What's Included in this Guide .............................................................. xi
  Conventions ......................................................................................... xii
  Related Documentation ................................................................... xii

Chapter 1  JADE Report Writer Concepts ..................................................................... 14
  Overview ................................................................................................. 14
  Summary of Terms Used in this Guide .............................................. 15
  JADE Report Writer Configuration .................................................. 17
  JADE Report Writer Designer .............................................................. 17
    Query Processor ............................................................................... 18
    Report Generator ........................................................................ 18
  Report Templates ............................................................................... 18
  Reporting Views ............................................................................... 18
  Collections .......................................................................................... 19
  Profiles .................................................................................................... 20
  Report Folders ...................................................................................... 20
  Customizing Reports ........................................................................ 20
  Sorting Data ......................................................................................... 20
  Summarizing Data ............................................................................. 21
  Filtering Data ....................................................................................... 21
    Object Parameters ........................................................................... 22
  Report Security .................................................................................... 22
  Exception Handling ............................................................................ 23
  Concurrency Strategy ........................................................................ 23
  Deploying Reports .............................................................................. 24
  Defining Report Field Formats ......................................................... 24
  Dynamically Configuring Reports at Run Time ................................. 25
  Interfacing to Reports at Run Time from Thin Clients ..................... 25
    Handling Reports at Run Time in JADE Thin Client Mode ............... 25
    Handling Reports at Run Time in HTML Thin Client Mode ............. 25

Chapter 2  Getting Started ......................................................................................... 26
  Prerequisites .......................................................................................... 26
  Loading the JADE Report Writer Schema .......................................... 26
  Invoking a JADE Report Writer Application ....................................... 26
    Invoking a JADE Report Writer Application from a User Application .................................................. 27
    Invoking a JADE Report Writer Application from JADE .......................... 28
  Using the Window Menu and Help Menu ........................................... 29
    Using the Window Menu ................................................................ 29
    Cascade Command ........................................................................ 29
    Tile Horizontal Command ............................................................... 29
    Tile Vertical Command ................................................................ 29
  Using the Help Menu ........................................................................... 30
    Using the Online User's Guide ........................................................ 30
    PDF Online Help ........................................................................... 31
    Closing the User's Guide Window .................................................... 31
    Displaying JADE Report Writer Application Version Information .................. 32

Chapter 3  Configuring the JADE Report Writer ......................................................... 33
  Defining Your Reporting Views ........................................................... 34
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a New Reporting View</td>
</tr>
<tr>
<td>Reporting on Transient Classes</td>
</tr>
<tr>
<td>Copying a Reporting View</td>
</tr>
<tr>
<td>Opening a Reporting View</td>
</tr>
<tr>
<td>Selecting the Schema, Types, and Features for Your Reporting View</td>
</tr>
<tr>
<td>Selecting the Types for Your View</td>
</tr>
<tr>
<td>Selecting the Features for Your View</td>
</tr>
<tr>
<td>Removing Types and Features</td>
</tr>
<tr>
<td>Development Changes Can Affect Your View</td>
</tr>
<tr>
<td>Deleting a Reporting View</td>
</tr>
<tr>
<td>Closing a Reporting View</td>
</tr>
<tr>
<td>Unloading a Reporting View Definition</td>
</tr>
<tr>
<td>Loading a Reporting View Definition</td>
</tr>
<tr>
<td>Unloading All Report Writer Data to a Single File</td>
</tr>
<tr>
<td>Unloading All Report Data from the Configuration Application</td>
</tr>
<tr>
<td>Unloading All Report Data using the Non-GUI Client Application</td>
</tr>
<tr>
<td>Loading All Report Writer Data from One File</td>
</tr>
<tr>
<td>Loading All Report Data from the Configuration Application</td>
</tr>
<tr>
<td>Loading All Report Data from the Batch JADE Load Utility</td>
</tr>
<tr>
<td>Removing Undefined View Items</td>
</tr>
<tr>
<td>Highlighting Changed Items</td>
</tr>
<tr>
<td>Viewing Bubble Help</td>
</tr>
<tr>
<td>Validating a Reporting View Definition</td>
</tr>
<tr>
<td>Building a Default Reporting View Definition</td>
</tr>
<tr>
<td>Checking Your Reporting View Usage</td>
</tr>
<tr>
<td>Building Your JADE Root Collection Paths</td>
</tr>
<tr>
<td>Building Your Collection Path</td>
</tr>
<tr>
<td>Selecting Your Collection Path</td>
</tr>
<tr>
<td>Selecting Script Methods</td>
</tr>
<tr>
<td>Creating Root Collection Joins</td>
</tr>
<tr>
<td>Selecting the Collections to Join</td>
</tr>
<tr>
<td>Selecting the Fields to Join</td>
</tr>
<tr>
<td>Creating Selection Criteria for Your Join</td>
</tr>
<tr>
<td>Obtaining Database Statistics</td>
</tr>
<tr>
<td>Using the JADE Report Configuration Menus</td>
</tr>
<tr>
<td>View Menu</td>
</tr>
<tr>
<td>Folders Menu</td>
</tr>
<tr>
<td>Maintain Command</td>
</tr>
<tr>
<td>Accessing the Folder Maintenance Window</td>
</tr>
<tr>
<td>Listing Folder Contents</td>
</tr>
<tr>
<td>Creating a New Folder</td>
</tr>
<tr>
<td>Using the Folder Edit Commands</td>
</tr>
<tr>
<td>Closing the Folder Maintenance Window</td>
</tr>
<tr>
<td>Unload Command</td>
</tr>
<tr>
<td>Load Command</td>
</tr>
<tr>
<td>System Formats Menu</td>
</tr>
<tr>
<td>Maintain Command</td>
</tr>
<tr>
<td>Number Sheet</td>
</tr>
<tr>
<td>Currency Sheet</td>
</tr>
<tr>
<td>Date Sheet</td>
</tr>
<tr>
<td>Time Sheet</td>
</tr>
<tr>
<td>TimeStamp Sheet</td>
</tr>
<tr>
<td>Boolean Sheet</td>
</tr>
<tr>
<td>Unload Command</td>
</tr>
<tr>
<td>Load Command</td>
</tr>
<tr>
<td>Users Menu</td>
</tr>
<tr>
<td>Preferences Command</td>
</tr>
<tr>
<td>Unload Command</td>
</tr>
<tr>
<td>Load Command</td>
</tr>
<tr>
<td>Configuration Menu</td>
</tr>
<tr>
<td>System Formats Command</td>
</tr>
</tbody>
</table>
Chapter 4  Designing JADE Reports

Overview ................................................................................................................................................................................. 110
Opening a New or Existing Report Design ...................................................................................................................... 111
Starting a Report from Scratch ........................................................................................................................................ 111
Opening an Existing Report ............................................................................................................................................... 114
Starting a Template ......................................................................................................................................................... 117
Opening a Template ......................................................................................................................................................... 117
Using the Sections of a Report ........................................................................................................................................ 120
Report Section Descriptions ........................................................................................................................................... 121
Report Header Section ....................................................................................................................................................... 121
Page Header Section ......................................................................................................................................................... 121
Detail Section ..................................................................................................................................................................... 121
Page Footer Section .......................................................................................................................................................... 122
Report Footer Section ....................................................................................................................................................... 122
Group Sections .................................................................................................................................................................... 123
Group Header and Footer .................................................................................................................................................. 123
Creating and Manipulating Extra Frames ....................................................................................................................... 123
Changing the Section Properties ................................................................................................................................... 125
Designing a Report ............................................................................................................................................................ 125
Report Design Overview .................................................................................................................................................. 126
Using Administrative Functions ........................................................................................................................................ 126
Setting User Preferences ................................................................................................................................................ 127
Setting Report Properties ............................................................................................................................................... 131
Using the Details Sheet ...................................................................................................................................................... 131
Using the Font Sheet .......................................................................................................................................................... 134
Using the Output Sheet ..................................................................................................................................................... 136
Using the Default Sheet .................................................................................................................................................... 140
Using the Page Sheet ......................................................................................................................................................... 141
Using the Preview Sheet .................................................................................................................................................... 143
Using the Parameters Sheet ............................................................................................................................................... 144
Setting Report Formats ....................................................................................................................................................... 146
Using the Number Sheet .................................................................................................................................................... 147
Using the Currency Sheet .................................................................................................................................................. 148
Using the Date Sheet .......................................................................................................................................................... 150
Using the Time Sheet ........................................................................................................................................................ 153
Using the TimeStamp Sheet ............................................................................................................................................ 154
Using the Boolean Sheet ................................................................................................................................................... 158
Setting the Section Properties ......................................................................................................................................... 159
Changing the Section Properties on the Popup Menu .................................................................................................... 160
Changing the Section Properties using the Properties Command ............................................................................. 162
Changing the Section Properties using a Format Script ................................................................................................ 165
Creating or Maintaining Profiles ....................................................................................................................................... 166
Using the Profile Sheet ...................................................................................................................................................... 166
Using the Sort Order Sheet .................................................................................................................................................. 168
Contents

Using the Selection Criteria Sheet .................................................. 171
Using the Group Sheet .................................................................. 179
Using the Detail Functions ................................................................. 179
Report Detail Overview ................................................................. 180
Inserting Report Fields .................................................................. 181
Inserting a Literal ......................................................................... 185
Inserting a Picture .......................................................................... 186
Inserting a Line .............................................................................. 187
Specifying Line Properties .............................................................. 189
Inserting a Box .............................................................................. 191
Specifying Box Properties .............................................................. 194
Inserting a Special Field ............................................................... 196
Inserting a Database Field ............................................................. 197
Linking and Unlinking Headers ...................................................... 198
Using the Catalog of Available Fields Dialog .............................. 199
Using the System Sheet ................................................................. 201
Using the Param Sheet .................................................................. 201
Inserting a Parameter in Your Layout ........................................... 202
Creating a Parameter .................................................................... 203
Updating a Parameter .................................................................... 204
Deleting a Parameter ..................................................................... 205
Using the Script Sheet ................................................................... 205
Creating a Script ........................................................................... 206
Updating a Script .......................................................................... 212
Deleting a Script ........................................................................... 212
Using the Summary Sheet ............................................................... 212
Creating a Summary Field ............................................................ 213
Updating a Summary Field ........................................................... 217
Deleting a Summary Field ............................................................. 217
Using the Variables Sheet ............................................................... 217
Creating Report Variables ............................................................. 219
Updating Report Variables ............................................................ 219
Deleting Report Variables .............................................................. 220
Using the Methods Sheet ............................................................... 220
Creating a Method Field ............................................................... 222
Updating a Method Field .............................................................. 223
Deleting a Method Field ............................................................... 224
Displaying Field Usage ................................................................. 224
Setting Field Properties ................................................................ 226
Properties Command ..................................................................... 227
Using the Common Sheet ............................................................... 229
Using the Layout Sheet ................................................................. 230
Using the Number Sheet ............................................................... 232
Using the Font Sheet ..................................................................... 233
Using the Date Sheet ..................................................................... 235
Using the Time Sheet ..................................................................... 237
Using the Picture Sheet using a Format Script ............................. 239
Setting Field Properties using a Format Script ............................. 239
Visible Command .......................................................................... 240
Border Command ......................................................................... 241
Alignment Command ...................................................................... 242
Delete Command ........................................................................... 242
Using the Layout Commands .......................................................... 242
Move Field(s) to the Left Button ..................................................... 244
Move Field(s) to the Right Button .................................................. 244
Move Field(s) Up Button ................................................................ 244
Move Field(s) Down Button .......................................................... 244
Make Field(s) Thinner Button ......................................................... 245
Make Field(s) Wider Button ........................................................... 245
Make Field(s) Shallower Button ..................................................... 245
Make Field(s) Deeper Button .......................................................... 245
Center Vertically Command .................................................. 245
Center Horizontally Command ........................................... 245
Top Command ........................................................................ 245
Bottom Command .................................................................. 246
Left Command ........................................................................ 246
Right Command ....................................................................... 246
Same Width Command ............................................................ 246
Same Height Command ............................................................ 247
Same Height and Width Command ........................................... 247
Space Evenly Down Command .............................................. 247
Space Evenly Across Command ............................................. 248
Spread Down Container Command ......................................... 248
Spread Across Container Command ......................................... 248
Vertically Adjacent Command ................................................ 248
Horizontally Adjacent Command ........................................... 249
Using Guidelines ................................................................... 249
Using the Quick Launch Tools ................................................ 251
Creating Groups .................................................................... 251
Creating a New Group ............................................................ 252
Updating an Existing Group .................................................... 255
Using Groups Example ............................................................ 257
Creating Templates ................................................................ 258
Using the JADE Report Writer Designer Menus ......................... 260
File Menu .............................................................................. 261
New Report Command ............................................................ 262
New Template Command ........................................................ 262
Open Report Command ........................................................... 262
Open Template Command ....................................................... 262
Close and Save Command ....................................................... 263
Abandon Changes Command .................................................. 263
Save Command ....................................................................... 263
Rename/Reposition Command .................................................. 263
Save As Copy Command .......................................................... 265
Delete Report Command .......................................................... 266
Delete Template Command ...................................................... 267
Print Command ...................................................................... 269
Refresh Preview Command ...................................................... 269
Print Setup Command ............................................................. 269
Extract Data Command ............................................................ 270
Unload Definition Command .................................................... 271
Selecting Reports and Templates to Unload ............................... 273
Specifying Reports and Templates to be Deleted ........................ 275
Load Definition Command ....................................................... 276
Selecting Template and Report Definitions to Load .................... 277
User Preferences Command ...................................................... 278
Exit Command ....................................................................... 278
Edit Menu .............................................................................. 278
Undo Command ...................................................................... 279
Redo Command ..................................................................... 279
Cut Command ........................................................................ 280
Copy Command ..................................................................... 280
Paste Command ..................................................................... 280
Select All Command ................................................................ 280
Delete Command .................................................................... 281
Script Command ..................................................................... 281
Summary Command ................................................................ 281
Parameter Command ................................................................ 282
Link Header Command ............................................................. 282
Unlink Header Command ........................................................ 282
Section Command .................................................................. 282
Group Command ................................................................... 282
Chapter 5  Printing and Extracting JADE Reports ........................................... 307

Overview ......................................................................................... 307
Previewing Print Output .................................................................. 307
Searching Your Report Preview .................................................... 309
Printing Your Report ...................................................................... 310
Using the Print Setup Command .................................................... 311
## Appendix C  Script Fields

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>377</td>
</tr>
<tr>
<td>Report Fields</td>
<td>378</td>
</tr>
<tr>
<td>Parameter Fields</td>
<td>378</td>
</tr>
<tr>
<td>Script Fields</td>
<td>379</td>
</tr>
<tr>
<td>Summary Fields</td>
<td>380</td>
</tr>
<tr>
<td>Method Fields</td>
<td>380</td>
</tr>
<tr>
<td>Database Fields</td>
<td>381</td>
</tr>
<tr>
<td>Report Variables</td>
<td>381</td>
</tr>
<tr>
<td>Special Fields</td>
<td>382</td>
</tr>
<tr>
<td>Format Properties</td>
<td>382</td>
</tr>
<tr>
<td>\enspace Section Format Scripts</td>
<td>383</td>
</tr>
<tr>
<td>\enspace Field Format Scripts</td>
<td>383</td>
</tr>
<tr>
<td>Format Constants</td>
<td>386</td>
</tr>
</tbody>
</table>
Before You Begin

The JADE Report Writer User’s Guide is intended as the main source of information when you are using the JADE Report Writer to develop and run reports.

Who Should Read this Guide

The main audience for the JADE Report Writer User’s Guide is expected to be developers of JADE reports and runtime users of deployed JADE applications.

What You Need to Know

To use the JADE Report Writer Configuration application, you should be familiar with:

- Concepts of JADE systems
- The JADE database

To use the JADE Report Writer Designer application, you should be familiar with designing and building database reports.

While familiarity with the JADE product would be beneficial when using the JADE Report Writer Designer application, this guide has been produced with end-users in mind, who may not be familiar with JADE and who also may not have any computing experience beyond that of being an end-user of business applications.

To use the most basic level of the scripting language within the JADE Report Writer Designer application requires only an elementary understanding of arithmetic or accounting formulae, and the vast majority of reporting requirements can be satisfied with this level of expertise. However, to use all of the scripting features requires JADE programming skills or familiarity with a similar object-oriented language.

What’s Included in this Guide

The JADE Report Writer User’s Guide has six chapters and three appendixes.

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Provides an overview of JADE Report Writer concepts and terminology</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 2</td>
<td>Provides instructions for signing on and off and using the JADE Report Writer</td>
</tr>
<tr>
<td>Chapter 3</td>
<td>Provides instructions for configuring the JADE Report Writer</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>Provides instructions for designing your JADE reports</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Provides instructions for previewing, printing, and extracting data from JADE reports</td>
</tr>
<tr>
<td>Chapter 6</td>
<td>Provides instructions for running the JADE Report Writer, including setting security and dealing with exceptions</td>
</tr>
<tr>
<td>Appendix A</td>
<td>Provides a detailed description of creating scripts in the JADE Report Writer Designer</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Provides a detailed description of using script commands in the JADE Report Writer Designer</td>
</tr>
<tr>
<td>Appendix C</td>
<td>Provides a detailed description of using script fields in the JADE Report Writer Designer</td>
</tr>
</tbody>
</table>
Conventions


<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow bullet (&gt;)</td>
<td>Step-by-step procedures. You can complete procedural instructions by using either the mouse or the keyboard.</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Items that must be typed exactly as shown. For example, if instructed to type report, type all the bold characters exactly as they are printed.</td>
</tr>
<tr>
<td></td>
<td>File, class, primitive type, and property names, menu commands, and screen controls are also shown in bold type, as well as literal values stored, tested for, and sent by JADE instructions.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Parameter values or placeholders for information that must be provided; for example, if instructed to enter class-name, type the actual name of the class instead of the word or words shown in italic type.</td>
</tr>
<tr>
<td></td>
<td>Italic type also signals a new term. An explanation accompanies the italicized type.</td>
</tr>
<tr>
<td></td>
<td>Document titles and status and error messages are also shown in italic type.</td>
</tr>
<tr>
<td><strong>Blue text</strong></td>
<td>Enables you to click anywhere on the cross-reference text (the cursor symbol changes from an open hand to a hand with the index finger extended) to take you straight to that topic. For example, click on the &quot;Using the Window Menu and Help Menu&quot; cross-reference to display that topic.</td>
</tr>
<tr>
<td><strong>Bracket symbols</strong> [ ]</td>
<td>Indicate optional items.</td>
</tr>
<tr>
<td><strong>Vertical bar</strong>)</td>
<td>Separates alternative items.</td>
</tr>
<tr>
<td><strong>Monospaced font</strong></td>
<td>Syntax, code examples, and error and status message text.</td>
</tr>
<tr>
<td><strong>ALL CAPITALS</strong></td>
<td>Directory names, commands, and acronyms.</td>
</tr>
<tr>
<td><strong>SMALL CAPITALS</strong></td>
<td>Keyboard keys.</td>
</tr>
</tbody>
</table>

Key combinations and key sequences appear as follows.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KEY1+KEY2</td>
<td>Press and hold down the first key while pressing the second key. For example, &quot;press Shift+F2&quot; means to press and hold down the Shift key and press the F2 key. Then release both keys.</td>
</tr>
<tr>
<td>KEY1,KEY2</td>
<td>Press and release the first key, and then press and release the second key. For example, &quot;press Alt+F,X&quot; means to hold down the Ait key, press the F key, and then release both keys before pressing and releasing the X key.</td>
</tr>
</tbody>
</table>

Related Documentation

Other documents that are referred to in this document, or that may be helpful, are listed in the following table, with an indication of the JADE operation or tasks to which they relate.

<table>
<thead>
<tr>
<th>Title</th>
<th>Related to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>JADE Database Administration Guide</td>
<td>Administering JADE databases</td>
</tr>
<tr>
<td>Title</td>
<td>Related to…</td>
</tr>
<tr>
<td>--------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>JADE Developer’s Reference</td>
<td>Developing or maintaining JADE applications</td>
</tr>
<tr>
<td>JADE Development Environment Administration Guide</td>
<td>Administering JADE development environments</td>
</tr>
<tr>
<td>JADE Development Environment User’s Guide</td>
<td>Using the JADE development environment</td>
</tr>
<tr>
<td>JADE Encyclopaedia of Classes</td>
<td>System classes (Volumes 1 and 2), Window classes (Volume 3)</td>
</tr>
<tr>
<td>JADE Encyclopaedia of Primitive Types</td>
<td>Primitive types and global constants</td>
</tr>
<tr>
<td>JADE Installation and Configuration Guide</td>
<td>Installing and configuring JADE</td>
</tr>
<tr>
<td>JADE Initialization File Reference</td>
<td>Maintaining JADE initialization file parameter values</td>
</tr>
<tr>
<td>JADE Synchronized Database Service (SDS) Administration Guide</td>
<td>Administering JADE Synchronized Database Services (SDS), including Relational Population Services (RPS)</td>
</tr>
<tr>
<td>JADE Object Manager Guide</td>
<td>JADE Object Manager administration</td>
</tr>
<tr>
<td>JADE Thin Client Guide</td>
<td>Administering JADE thin client environments</td>
</tr>
<tr>
<td>JADE Web Application Guide</td>
<td>Implementing, monitoring, and configuring Web applications</td>
</tr>
</tbody>
</table>
Chapter 1  JADE Report Writer Concepts

This chapter contains an overview of the components of the JADE Report Writer and covers the following topics.

- Overview
- Summary of Terms Used in this Guide
- JADE Report Writer Configuration
- JADE Report Writer Designer
- Report Templates
- Reporting Views
- Collections
- Profiles
- Report Folders
- Customizing Reports
- Report Security
- Exception Handling
- Concurrency Strategy
- Deploying Reports
- Defining Report Field Formats
- Dynamically Configuring Reports at Run Time
- Interfacing to Reports at Run Time from Thin Clients

Overview

The JADE Report Writer is a generic report writer that enables you to configure and design reports for all schemas in your JADE database. These reports can be tailored by a JADE developer or by a user of a deployed JADE runtime application.

The JadeReportWriterSchema system is implemented as a subschema of RootSchema so that you can use it to write reports for any schema in your JADE database. You can integrate these reports with any JADE application so that they appear as extensions of that application.

From the JADE development environment, the JadeReportWriterSchema schema provides the following applications that enable you to configure and design your reports.

- The ReportWriterConfiguration application enables you to set up a schema view containing the classes and their properties and methods that can be reported on.
- The ReportWriterDesigner application enables you or your report designers to design the reports based on that view.
In addition, developers of JADE applications can use the methods defined in the `JadeReportWriterManager`, `JadeReportWriterReport`, and `JadeReportWriterSecurity` classes (inherited from the `Object` class) to dynamically override report details at run time. For details, see Chapter 1 of the *JADE Encyclopaedia of Classes, Volume 1*.

The following image shows the schema hierarchy.

```
RootSchema
      |     |
UserSchema1 | JadeReportWriterSchema | UserSchema2
```

The following image shows the structure of the JADE Report Writer schema.

```
Report Writer Configuration ----> Query Processor ----> Report output
    | rules | query | query results |
    | rules | query |
Report Writer Designer ----> Report Generator
    | report | collection |
```

### Summary of Terms Used in this Guide

The following table lists the terms used in this guide, with a brief definition of each.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>A control that gives a True/False or Yes/No option. Used in groups to display multiple choices from which you can select one or more options. Check boxes in a group can be checked or unchecked independently of each other, in contrast to option buttons where only one option button in a group can be set at a time.</td>
</tr>
<tr>
<td>Collection</td>
<td>A basic structure containing the classes and features (properties and methods) reported on in the view.</td>
</tr>
<tr>
<td>Combo Box</td>
<td>A control that gives you the choice of typing in the text box portion or selecting an item from the list portion of the control. It combines the user entry capabilities of the text box and list box.</td>
</tr>
<tr>
<td>Control</td>
<td>A specialized child window that resides on top of a form (for example, a window or dialog) or another control (for example, a group box). It is a general term for the user interface items such as buttons, list boxes, text boxes, check boxes, and so on.</td>
</tr>
<tr>
<td>Dialog</td>
<td>A window that provides a user interface that differs from a basic window in that it provides a two-way communication between you and the application through the use of control buttons such as <em>OK, Open, Cancel, Delete, Exit</em>, and so on.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Detail section</td>
<td>One or more frames that form the main body of the report. Although it is not always necessary to actually print the detail section, you must define it.</td>
</tr>
<tr>
<td>Feature</td>
<td>A property or method included in a report collection.</td>
</tr>
<tr>
<td>Frame</td>
<td>One or more fields that are grouped together for reporting purposes.</td>
</tr>
<tr>
<td>Group box</td>
<td>A control that provides a way of grouping controls in a container. It can be a container for groups of controls.</td>
</tr>
<tr>
<td>Group footer</td>
<td>One or more frames that are printed when the value of a variable changes and all details frames have been printed for the old value.</td>
</tr>
<tr>
<td>Group header</td>
<td>One or more frames that are printed when the value of a variable changes and prior to printing any detail frames for the new value.</td>
</tr>
<tr>
<td>Instruction</td>
<td>Forms the body of your script, and defines the actions to be carried out as a sequence of actions. It specifies one corresponding action. Instructions are executed sequentially, one after the other, and not simultaneously.</td>
</tr>
<tr>
<td>List box</td>
<td>A control that displays a list of items from which you can select one or more items.</td>
</tr>
<tr>
<td>Option button</td>
<td>A control that displays an option that can be turned on or off. Only one of a group of option buttons can be turned on. Usually used as part of a group to display multiple options from which you can select only one.</td>
</tr>
<tr>
<td>Page footer</td>
<td>One or more frames that are printed at the bottom of every page.</td>
</tr>
<tr>
<td>Page header</td>
<td>One or more frames that are printed at the top of every page.</td>
</tr>
<tr>
<td>Profile</td>
<td>Defines a sort sequence, filtering criteria, and grouping fields so that one report layout can be used for several different styles of report output.</td>
</tr>
<tr>
<td>Report field</td>
<td>A literal value, property value, picture, special field (for example, date, time, or page number), parameter value, total field, calculated value, line, or box that is displayed on a report.</td>
</tr>
<tr>
<td>Report folder</td>
<td>A means of classifying and arranging report definitions.</td>
</tr>
<tr>
<td>Report footer</td>
<td>One or more frames that are printed at the end of the report.</td>
</tr>
<tr>
<td>Report header</td>
<td>One or more frames that are printed at the start of the report.</td>
</tr>
<tr>
<td>Report layout</td>
<td>The definition of a single report.</td>
</tr>
<tr>
<td>Report script</td>
<td>Defined for use as formulae in the report to calculate values to be printed, to set property values.</td>
</tr>
<tr>
<td>Report template</td>
<td>A section that enables standard headers and footers to be defined once and used across all reports.</td>
</tr>
<tr>
<td>Sheet</td>
<td>A feature of a dialog that allows several different sets of controls to be overlaid on the one window. Usually accessed by clicking on a corresponding sheet tab.</td>
</tr>
<tr>
<td>Text box</td>
<td>A control that displays information entered by you or information assigned to the control by code at run time. Text boxes are used for entering original data such as names and addresses, in contrast to list boxes in which you select an entry from a list that is provided by the application.</td>
</tr>
<tr>
<td>Type</td>
<td>A JADE class included in a report collection.</td>
</tr>
<tr>
<td>View</td>
<td>Defines what parts of the JADE database are available for reporting, how data is accessed, and provides meaningful names for classes and properties.</td>
</tr>
</tbody>
</table>
### JADE Report Writer Concepts

#### Term Definition

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window</td>
<td>A screen interface, usually the whole screen or part of the screen, on which application information is shown and through which you can navigate to other parts of the application or to other applications. A complex window may be divided into several panes. A window with which you can communicate with the application is called a dialog (see the entry earlier in this table).</td>
</tr>
</tbody>
</table>

---

**JADE Report Writer Configuration**

The JADE Report Writer Configuration application creates views of the JADE database. (For more details, see *Reporting Views*, later in this chapter.)

The JADE Report Writer Configuration application enables a JADE developer or system administrator to configure the JADE Report Writer for use with a specific JADE application. You can redefine the default system formats at a system level and tailor them for each report.

The JADE Report Writer Configuration application enables you to:

- Define database views that can contain a subset of classes and their properties and methods
- Define meaningful names, or aliases, to be used instead of JADE class and property names
- Join two collections for reporting on related classes within each collection
- Extract and reload reporting view definitions
- Define standard formats that will be applied to all reports defined for the application
- Define and maintain folders in which report and template definitions can be saved
- List, move, or delete reports and template definitions

For details, see Chapter 3, *Configuring the JADE Report Writer*.

---

**JADE Report Writer Designer**

The JADE Report Writer Designer application enables a JADE developer or the user of a deployed JADE application to define the layout and content of a report. Based on the content of a report, the JADE Report Writer generates a query that retrieves the required data from the JADE database, prints or previews the report, or outputs it to a file.

A report is based on a database view that you have already created by using the JADE Report Writer Configuration application.

For details about using the JADE Report Writer Designer application, see Chapter 4, *Designing JADE Reports*.

The engines of the JADE Report Writer Designer application are the Query Processor and the Report Generator. These work behind the application and are not visible to the end user. They are described in the following subsections.
Chapter 1  JADE Report Writer Concepts

Query Processor

The Query Processor produces a collection of objects based on query criteria, which specify:

- Properties from one or more classes to be included in the query
- The order in which objects appear in the result set
- Filtering criteria to exclude unwanted objects
- Rules for joining unrelated classes

Report Generator

The Report Generator produces report output from the report definition. Reports can be generated by a JADE developer using the ReportWriterDesigner application or run by a user of a deployed application. Although a report is output to the printer by default, you can preview it or you can extract it to a file in one of the following formats.

- ASCII or Unicode text (.txt)
- Delimiter-Separated Values (.csv)
- Rich Text Format (.rtf)
- HyperText Markup Language (.htm)
- Extensible Markup Language (.xml)

For details, see Chapter 5, "Printing and Extracting JADE Reports".

Report Templates

Report templates enable you to create a standard look for your reports by providing re-usable components that can include standard formats and parameters as well as frames.

Most often, you would use templates to create standard headers and footers. You can choose to print template headers and footers instead of or in addition to the report headers and footers that are provided automatically. The JADE Report Writer Designer application enables you to hide a field or a section of a report (for example, page headers or report detail) so that it is not printed.

You can attach one or more templates to a report. When the report is generated, any frames defined in the template are printed for the report. For details, see Chapter 4, "Designing JADE Reports".

Reporting Views

Reports designed in the JADE Report Writer Designer application are based on a view of the database. This view is a selective description of what is contained in the database. It includes selected classes (and selected features of those classes) from the JADE database. A view also restricts the information that is visible to JADE developers or users who design reports.

A view makes visible selected types (JADE classes) and features (JADE properties and methods) for reporting. You can use a view as the basis for a number of reports.

A view is defined by using the JADE Report Writer Configuration application.
You can define one or many views for a JADE database (for example, Payroll, Accounts Receivable, Accounts Payable, and so on). You can include classes from several schemas in a single view but you can associate only one reporting view with each report definition. For details, see Chapter 3, "Configuring the JADE Report Writer".

The features of a report view are listed in the following table.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A unique name for each reporting view.</td>
</tr>
<tr>
<td>Text</td>
<td>A description of the reporting view.</td>
</tr>
<tr>
<td>Schemas</td>
<td>The user schemas whose types (classes) and features (properties and methods) can be included in the report.</td>
</tr>
<tr>
<td>Types</td>
<td>The types (classes) that are part of the reporting view. Each type can have a subset of features (properties and methods) that are made available in a reporting view. For a method to be included, it must return a primitive type, and any parameters passed to the method must also be primitive types. You can give the types and features meaningful names, termed aliases, that are used in the JADE Report Writer Designer application.</td>
</tr>
<tr>
<td>Collections</td>
<td>The JADE collections that are available for reporting (for example, ProductType.instances, Root.firstInstance.allCustomers, and app.myCompany.allProducts). A Report Writer collection can be the amalgamation of several JADE collections.</td>
</tr>
<tr>
<td>Joins</td>
<td>You can join two JADE root collections for reporting purposes. You can graphically select the join keys (for example, similar classes such as names) within the two joined collections. You can also specify selection criteria for a join to take place and the relationship between the join keys.</td>
</tr>
</tbody>
</table>

Collections

A report created in the JADE Report Writer Designer application must include at least one root collection or a view join between root collections defined in the configuration phase for the view on which the report is based. A report can return data only on objects that can be accessed through its root collection (or collections) or view join (or joins).

A JADE collection is a basic structure used to contain multiple references to similar objects. To access the contents of a root collection, the JADE Report Writer uses a root collection path. A collection path is constructed by selecting the features of objects that reference collections (such as a reference property Company.firstInstance.allClients, by which a Company object references its collection of Client objects) or by specifying all instances of a class.

When you have defined the features and types for a reporting view, you then specify the root collections to be used for reporting by defining their root collection paths. The collections available for your reports are limited to those collections and objects (types) that have been included in the reporting view.

In most cases, a report requires only one collection, as all required data is accessible by traversing object references (for example, Employee::myBranch.description or Company::allCustomers.name). In other cases, you may have to join two unrelated member classes to produce the data required for a report. A special case is one where a report requires a ‘self-join’, in which case a collection can be selected more than once with an alias being assigned to each usage of the collection.

Before you build the root collection path to the JADE root collection, you must set up the types (classes) and features (properties and methods returning data to report) of the objects that can be accessed from the root collection. You can then report on all data that can be navigated to from this collection.
As the building of the root collection path completes the JADE Report Writer configuration, the report is then ready to be designed. For details, see Chapter 3, "Configuring the JADE Report Writer".

**Profiles**

A report can have a number of *profiles* associated with it. Each profile can modify the report by having different:

- Sort orders
- Selection criteria
- Grouping fields

This enables you to use one report layout for several different styles of report output. When the report is run, the user selects the profile that is required.

New reports are created with a default profile. New profiles can then be created and defined. The default profile is used when no profile is explicitly set.

For details, see "Customizing Reports", later in this chapter, and Chapter 4, "Designing JADE Reports".

**Report Folders**

Report folders classify and arrange report definitions.

You can arrange report folders in a hierarchy to make it easy for users to find a specific report definition.

All users can access unsecured report folders but a JADE developer can secure a report folder by implementing security rules in a subclass of the `JadeReportWriterSecurity` class. For details, see "Setting Security for Your JADE Reports", in Chapter 6.

**Customizing Reports**

You can modify the report formats and data output to meet specific requirements by:

- Sorting Data
- Summarizing Data
- Filtering Data
- Working with Report Scripts
- Grouping Objects

**Note**  Summary fields and scripts are not available in report templates.

For details, see Chapter 4, "Designing JADE Reports".

**Sorting Data**

You can sort collection data in a profile in ascending or descending order of the values of a database or script field or fields. Only database fields (that is, properties and methods) and scripts that do not, directly or indirectly, reference summary fields are available for sorting.
The sort sequence determines the order in which records are displayed in the report. If groups are defined in the report, the output is in sort order within group order. The group fields are automatically treated as sort fields and do not need to be specified as such.

**Summarizing Data**

You can summarize data or scripts in a report collection by using one of the following functions.

- Sum
- Average
- Non-zero average
- Count
- Distinct Count
- Non-null Count
- Maximum
- Minimum

A summary field cannot summarize a script if that script references summary fields.

A summary field can be used for a running total or as a summary of a group of query results. A summary field used as a running total accumulates throughout a report. A summary is usually printed once at the end of a series of detail lines. A running total may be printed for each line, showing the accumulating total.

A summary field has a reset feature, which indicates the range of query result objects to summarize (for example, the sum of sale amount reset on the change of branch or a running total of the sale amount reset on the change of sales item). Valid values for the reset feature are:

- Never
- Change of database field value
- Change of group
- Whenever the summary field is printed (for example, when printing totals for a page)

**Filtering Data**

You can apply selection criteria to database fields to filter data in the collection (for example, retail sales with a price greater than $10,000).

The selection operator for each database field can be one of the following.

- Null
- Equal to
- Greater than
- Greater than or equal to
- Less than
- Less than or equal to
Chapter 1  JADE Report Writer Concepts

- One of
- Between
- Starts with (string fields)
- Ends with (string fields)
- Is like (string fields)
- Is kind of (object reference)
- Is (object reference)
- Is empty (object reference)

You can use a **not** operator to logically negate any of your selection criteria.

### Object Parameters

Report parameters can be defined as object parameters as well as primitive types. They can be defined as being of any class for which there is a type definition in the reporting view.

Object parameters are intended for use primarily in profile selection but can be used in the report body and also in scripts. When they are used in the body of a report or in scripts, the value returned by the **Object** class `jadeReportWriterDisplay` method is displayed (so that the value of the parameter can be reported as a string).

Two methods are available to enable setting object parameters in the JADE Report Writer Designer application for previewing and running reports: `jadeReportWriterParamObjects` and `jadeReportWriterDisplay`. These methods are called by the JADE Report Writer Designer application when requesting parameter values. They must be reimplemented in the schema (or schemas) from which the JADE Report Writer is run, so that combo boxes on the Report Properties dialog **Parameters** sheet and the report extract and print dialog can be populated with object entries for parameters.

In addition, the **Application** class `jadeReportWriterTimeDetails` method records timings of each JADE Report Writer report (for example, if you want to log timing details for performance or billing purposes) and the **Application** class `jadeReportWriterParamLiteral` method returns the required literal (for example, "<All>").

For details about the `jadeReportWriterParamLiteral` method that enables you to print a different value when the ignore flag is set for a primitive type of object parameter, see "Using the Parameters Sheet", in Chapter 4, and for details about the **Object** class `jadeReportWriterTimeDetails`, `jadeReportWriterParamObjects`, and `jadeReportWriterParamLiteral` methods, see Chapter 1 of the **JADE Encyclopaedia of Classes**.

### Report Scripts

A script field is the value returned by executing a JADE Report Writer script when the report is run.

You can define scripts for use as formulae in the report to calculate values to be printed, to set property values or to filter query results (for example, to determine whether a field or frame should be printed).

Scripts can also be used in profile selection criteria and as sort and group fields. However, since JADE Report Writer scripts are always evaluated after the query results are retrieved, it is more efficient to use JADE methods in the profile where possible.

For details about scripts, see Appendix A, "Using JADE Report Writer Scripts".
Grouping Objects

Grouping objects is similar to sorting them, but header and footer sections of a report are available with grouping. For example, a report could group retail sales for each client in alphabetical order and add header and footer information, such as the client name and a sales total.

Group fields are relevant only for reports that have group sections defined for them. Groups can be created in a report before profiles are set up. At first, these group sections apply only to the default profile. When any new profiles are created, each profile inherits the existing groups. You can then change groups for each profile without affecting other profiles, but the groups are always part of a profile.

Group fields affect the order in which objects are returned by the query processor (sort fields within group fields). Once any profiles are created, a group section is printed when the value of a detail item changes. Data is grouped based on the values of database fields.

Your reports can have one or more group header and footer sections.

Report Security

When you define a new view of the database or you modify an existing view, you can make the view secure to restrict access to the required objects.

By default, JADE Report Writer applications are not secured; that is, any user who knows the application and schema names could set up a shortcut and sign on to the application. If you want to restrict access to these applications, it is your responsibility to implement the appropriate security checking in your user schemas by subclassing the JadeReportWriterSecurity class and reimplementing each of the methods that provide the types of restrictions that you require.

You can implement security to restrict access in:

- JADE Report Writer applications by JADE developers
- Reports at run time by users of deployed JADE applications

For details, see "Setting Security for Your JADE Reports", in Chapter 6.

Exception Handling

Any exception or error condition arising from a JADE Report Writer application or running a report stops the current action and initiates an exception entry and dump to a Report Writer application log. You can access these logs to determine the cause of the exception and the best means of dealing with it.

By default, no user dialogs are shown from an exception within the Report Writer application. A log file is written with the exception details. A JADE initialization file parameter enables an exception to be passed back to an application exception handler after the exception details are logged.

For details, see "Handling Exceptions in JADE Reports" and "JADE Report Writer Application Logs", in Chapter 7. See also the PassBackException and QueryReadFailureOptionOff parameters under "JADE Report Writer Section [JadeReportWriter]", in the JADE Initialization File Reference.

Concurrency Strategy

The JADE Report Writer concurrency strategy defines the strategy that is to be used to isolate the report results during report output from the effects of concurrently updating transactions.
A default concurrency strategy is defined for a view. New reports based on this view are created with this value as their concurrency option. You can modify the strategy to be used during the report design process or programmatically. For details about setting a concurrency strategy for a report, see "Using the Options Sheet" under "Query Options Command", in Chapter 4, and "Dynamically Configuring JADE Reports at Run Time", in Chapter 6.

The default concurrency strategy is **None**, which performs no explicit locks. Automatic cache coherency may be used to ensure objects in the persistent cache are kept up to date. Other concurrency strategies are available if collections or objects used in the report are volatile.

### Deploying Reports

Reports that you design using the JADE Report Writer Designer application can be run from another deployed JADE application.

This installation of JADE must still include the **JadeReportWriterSchema** schema component.

The batch JADE Load utility (**jadloadb**) provides optional parameters that enable you to load report configuration or definition files extracted from the JADE Report Writer into an existing schema.

You can also load files extracted from the JADE Report Writer into a user-defined schema as part of a multiple schema file load, by specifying the appropriate files extracted from the JADE Report Writer in a multiple schema file.

For details about specifying JADE Report Writer files extracted from the JADE development environment in a multiple schema file, see "Multiple Schema File Syntax", in Chapter 10 of the **JADE Development Environment User's Guide**. For details about using the batch JADE Schema Load (**jadloadb**) executable, the **JadeSchemaLoader** application in **jadclient**, **jade**, or the **Application** class **startApplicationWithParameter** method to load JADE Report Writer files into a deployed runtime-only application, see "Loading a Schema and Forms in Batch Mode" in the **JADE Schema Load Utility User's Guide**.

Loading a report view over an existing view using the **jadloadb** batch Schema Load utility replaces view items that are unused or are not in the loaded report view file.

### Defining Report Field Formats

Field formats determine the appearance of data output to your report fields.

Your reports can use the default JADE Report Writer system format for report fields, you can change the default system formats to meet your requirements, or each user can change the report formats for individual reports and for each report field.

You can use the default system formats that are set with your installed version of the JADE Report Writer. These formats apply to all reports.

You can modify the system default values by using the JADE Report Writer Configuration application. These default values apply to all subsequent reports. You can do this to apply standard formats that apply throughout your organization.

In the JADE Report Writer Designer application, you can modify the default field formats for each individual report.

Finally, you can modify the default display format for each individual field in a report, by selecting that field and then applying your changes.
Dynamically Configuring Reports at Run Time

You can use the JadeReportWriterReport class methods to dynamically configure the report at run time. For example, you can use these methods to get report parameters, specify the printer, or set page options at report run time.

For details, see "Dynamically Configuring JADE Reports at Run Time", in Chapter 6.

Interfacing to Reports at Run Time from Thin Clients

Reports can be run from client workstations operating in thin client mode.

Handling Reports at Run Time in JADE Thin Client Mode

If your application is running in JADE thin client mode, printing is performed on the presentation client using a printer attached to the presentation client workstation.

When the presentation client requests a print preview, the pages of the printed report do not have to be transferred to and from the application server. (This optimizes the performance of the print preview process when running in JADE thin client mode over a slow network.)

However, if your application calls the Printer class setReport method to indicate that user logic subsequently stores or manipulates the report output, each page of output is transferred to the application server.

Handling Reports at Run Time in HTML Thin Client Mode

You cannot configure and design reports from a Web browser by using the JADE Report Writer Configuration and JADE Report Writer Designer applications.

However, you can run or view reports from a Web application.
Chapter 2  Getting Started

This chapter covers the following topics.

- Prerequisites
- Loading the JADE Report Writer Schema
- Invoking a JADE Report Writer Application
- Using the Window Menu and Help Menu

Prerequisites

Before you can run the JADE Report Writer Configuration and JADE Report Writer Designer applications, you require:

1. JADE development environment release 6.2, or higher
2. User schemas on which to base your reports

Note  The JADE Report Writer Configuration and JADE Report Writer Designer applications are not available from a Web browser.

To run reports designed using the JADE Report Writer application, you require a JADE release 6.2 or higher run time or deployment installation or upgrade. In addition, set up any security that you require for:

- JADE Report Writer Configuration and JADE Report Writer Designer applications
- Folders, reports, or views at run time

For details, see "Setting Security for Your JADE Reports", in Chapter 6.

Loading the JADE Report Writer Schema

To load the JadeReportWriterSchema into JADE 6.2 or higher

1. Install or upgrade the JADE release, if required.
2. Load your existing user schemas into the JADE development environment or define the JADE schema or schemas whose reports you want to define.

Invoking a JADE Report Writer Application

Invoking a JADE Report Writer application is described in the following topics.

- Invoking a JADE Report Writer Application from a User Application
- Invoking a JADE Report Writer Application from JADE
Invoking a JADE Report Writer Application from a User Application

The JADE Report Writer Configuration and Designer applications should be integrated into the user system. The JADE Report Writer Designer application print, extract data, and preview options are not enabled unless the report designer is run from the user system.

For initial evaluation of the JADE Report Writer, you can do this from JadeScript methods, as shown in the following examples.

```jade
startConfiguration();
vars
  rwManager : JadeReportWriterManager;
begin
  create rwManager transient;
  rwManager.startReportWriterConfiguration("a user name", null);
  epilog
    delete rwManager;
end;
startDesigner();
vars
  rwManager : JadeReportWriterManager;
begin
  create rwManager transient;
  rwManager.startReportWriterDesigner("a user name", null);
  epilog
    delete rwManager;
end;
```

For full integration into the user system, use the same JadeReportWriterManager methods but with the first method parameter being the name of the currently signed-on user and the second method parameter being the subclass of JadeReportWriterSecurity in the user schema.

**Note** It is recommended that you run your JADE Report Writer applications as separate applications from the one in which you are working and on the same schema level as the schema on which you are reporting. Attempting to run your JADE Report Writer reports in the same session as your working application causes locking issues that can result in impaired performance.


The JADE Report Writer keeps a reference to the security object reference set when the setSecurityObject method of the JadeReportWriterManager class is called. The security object is used whenever the JADE Report Writer needs to check security access to something. This reference is held in the internal equivalent of the user app object, so needs to be valid for the life of the application.

Instead of deleting it after calling the report writer startReportWriterConfiguration or startReportWriterDesigner methods, it would be best to create it once and hold a reference in the user app object or equivalent, and reuse this instance so it stays valid. It can be deleted at the end of the application.

For details, see "Dynamically Configuring JADE Reports at Run Time" under "Run Time Considerations", in Chapter 6. For full details, see the JADE Encyclopaedia of Classes.

For details about configuring or designing reports, see Chapter 3 or Chapter 4, respectively.
Depending on your security class access, you could have read-only or full access to your JADE Report Writer application. If you are limited to read-only access, the title bar will display [Read-only] along with the usual information. With read-only access, you cannot save or apply any changes to a report layout or reporting view.

## Invoking a JADE Report Writer Application from JADE

Invoking a JADE Report Writer application from within the JADE development environment enables you to view the application, configure views, and design and load reports, but does not enable you to preview or run reports.

To preview or run reports, invoke your JADE Report Writer application from your own application and your own schema. For details, see "Invoking a JADE Report Writer Application from a User Application", earlier in this section.

### To invoke a JADE Report Writer application from JADE

1. From the Schema Browser, select the `JadeReportWriterSchema` schema.
2. Perform one of the following actions.
   - Select the **Run** command from the Application menu in the Application Browser when the appropriate application is set as the current application (by double-clicking on that application, if it was not currently set).
   - Click the **Run Application** toolbar button.
   - Select the shortcut from your desktop, if applicable.

   The Run Application dialog is then displayed.
3. In the **Application Name** field, select the JADE Report Writer application that you want to run (that is, `ReportWriterConfiguration` or `ReportWriterDesigner`).

   **Note** This is not recommended for running the JADE Report Writer Designer application, since you cannot preview or print a report from within the `JadeReportWriterSchema` schema.
4. Click the **OK** button.

   The System Logon dialog for the selected application, shown in the following image, is then displayed.

   ![System Logon dialog](image)

   5. Specify another user id in the **Usercode** text box, if required.
6. Click the **Logon** button. Alternatively, click the **Shut Down** button to exit from the JADE Report Writer application.
Using the Window Menu and Help Menu

The Window menu and Help menu, common to both the JADE Report Writer Configuration window and the JADE Report Designer window, are described in the following subsections.

- Using the Window Menu
- Using the Help Menu

Using the Window Menu

The Window menu provides standard facilities that enable you to arrange open windows in the JADE Report Writer Configuration and JADE Report Writer Designer applications by tiling or cascading them. The Window menu also displays a list of the currently enabled windows.

The Window menu commands are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Arranges open windows in an overlapping pattern</td>
</tr>
<tr>
<td>Tile Horizontal</td>
<td>Resizes and arranges windows horizontally without overlap</td>
</tr>
<tr>
<td>Tile Vertical</td>
<td>Resizes and arranges windows vertically without overlap</td>
</tr>
</tbody>
</table>

For details, see the following subsections.

Cascade Command

Use the **Cascade** command from the Window menu to arrange open windows in an overlapping pattern so that the title bar of each window remains visible.

This is the default JADE Report Writer window option.

» To arrange open windows in a cascade

- Select the **Cascade** command from the Window menu.

  All open windows are then overlapped so that the title bar of each window is visible.

Tile Horizontal Command

Use the **Tile Horizontal** command from the Window menu to resize and arrange windows without overlap so that all windows are visible and each window is wider than it is long.

» To tile open windows horizontally

- Select the **Tile Horizontal** command from the Window menu.

  All open windows are then sized so that they are arranged horizontally.

Tile Vertical Command

Use the **Tile Vertical** command from the Window menu to resize and arrange windows without overlap so that all windows are visible and each window is longer than it is wide.
To tile open windows vertically

- Select the Tile Vertical command from the Window menu.

All open windows are then sized so that they are arranged vertically.

Using the Help Menu

Use the commands in the Help menu to access the online Report Writer User’s Guide for help and to display current version information for the JADE Report Writer Configuration or JADE Report Writer Designer application.


The Help menu commands are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>For details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Displays JADE Report Writer version information</td>
<td>Displaying JADE Report Writer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Application Version Information</td>
</tr>
</tbody>
</table>

Using the Online User’s Guide

JADE provides the JADE product information library, the JADE white papers, and the JADE Erewhon Demonstration System Reference in HyperText Markup Language 5 format (HTML5) in addition to Portable Document Format (PDF).

To access the online JADE Report Writer User’s Guide

- Select the User’s Guide command from the Help menu.

By default, context-sensitive help from the JADE Report Writer is obtained from .htm topics in the HTML5 Web format of the product information. For details, see the UseJadeWebHelp parameter and the JadeHelpBaseUrl parameter in the [JadeHelp] section of the JADE initialization file.

Access the HTML5 online help in your browser at:

www.jadeworld.com/docs/jade-2016/Default.htm

The JADE HTML5 online help enables you to:

- Access a specific topic in the Web format of the JADE product information library from the JADE development environment, by pressing F1 from the entity whose information you want to view.

- Return to a summary of and access the documents in the JADE product information library at any time, by clicking the dark gray jade text (which acts as the Home function), in the upper left of your browser above the Contents pane.

- Click an image thumbnail on a Web page, to display the full-sized image.

Conversely, to collapse an expanded image (for example, to reduce scrolling), click on the image again to restore the thumbnail format.

- Print a Web page with the image expanded to the full size, by clicking the Print icon at the upper left of the topic pane.
Tip When you have printed a topic that contains an image, the image is not minimized to a thumbnail until you refresh the display (by pressing F5, for example) or you navigate to another topic and then back to the topic that you printed.

For details about formulating search expressions in the JADE HTML5 help and printing a topic, see the Search and Print Tips topic, which is the second entity in the Contents pane at the left of your browser.

PDF Online Help

If you want to use context-sensitive help to specific sections in the ReportWriter.pdf file (for example, if you have slow or restricted Web access or if you want to print a range of pages or all of a document), set the value of the UseJadeWebHelp parameter to false.

When you select the User’s Guide command from the Help menu, the Adobe Reader then opens the JADE Report Writer User’s Guide and displays the title page of the document on your monitor. Adobe Reader provides standard navigation features. For example, you can perform the following actions.

- Use the Page Up or Page Down key (or the scroll bar) to browse the document.
- Select a topic from the expanded document contents at the left of your monitor.
- To display pages side-by-side, right-click anywhere on a page of the document and then select the Continuous - Facing command from the popup menu that is then displayed. (To return to the original page display, right-click again, and then select the Single Page command from the popup menu.) This popup menu provides other navigation commands such as the Previous Page and the Find command.
- Click the magnifying glass icon in the vertical toolbar at the left of your monitor (or depending on your workstation settings, the horizontal toolbar at the top of your monitor) and then click the page that is currently displayed, to zoom in (enlarge) the display of that page.
- Select the Print command from the File menu, which displays the standard Print dialog that enables you to specify your print requirements (for example, that you want to print the current page or a range of pages).
- When the cursor symbol changes from an open hand to a hand with the index finger extended, click on the topic to which the finger is pointing (for example, a reference to another part of the document, enclosed in double quotation marks, or a topic displayed in the document contents displayed at the left of your monitor or at the front of the document itself). The selected topic is then displayed.
- Use the Find command from the Edit menu to search for any word, partial word, or combination of words in the document.

For more details about using a Portable Document Format (PDF) file, select the Complete Acrobat Reader Help command from the Adobe Reader Help menu. The Adobe Reader Help document that is then displayed provides extensive assistance in using Acrobat PDF files. For details about using Adobe Reader to view JADE documents, refer to "JADE Product Information Library in Portable Document Format" under "JADE Online Help", in Chapter 2 of the JADE Development Environment User’s Guide.

Closing the User’s Guide Window

To close the Adobe Reader window, perform one of the following actions

- Select the Exit command from the File menu.
- Click the close icon at the top right corner of the window or select the Close command from the Control-Menu (that is, the icon at the top left corner of the window).
- Press Alt+F4.
Displaying JADE Report Writer Application Version Information

Use the JADE Report Writer application Help menu About command to access information about your JADE Report Writer application.

- To display version information for your current JADE Report Writer application
  - Select the About command from the Help menu.

The About box is then displayed, providing information about the JADE release, copyright and licence information, database path, operating system of the workstation, and the file version (that is, ANSI or Unicode), and so on. This dialog is for display purposes only.

To close the About box, click the Close button at the top right corner of the window.
Chapter 3  Configuring the JADE Report Writer

This chapter covers the following topics.

- Defining Your Reporting Views
  - Creating a New Reporting View
  - Opening a Reporting View
  - Selecting the Schema, Types, and Features for Your Reporting View
  - Deleting a Reporting View
  - Closing a Reporting View
  - Unloading a Reporting View Definition
  - Loading a Reporting View Definition
  - Validating a Reporting View Definition
  - Building a Default Reporting View Definition
  - Unloading All Report Writer Data to a Single File
  - Loading All Report Writer Data from One File
  - Checking Your Reporting View Usage

- Building Your JADE Root Collection Paths
  - Building Your Collection Path
  - Selecting Your Collection Path

- Selecting Script Methods

- Creating Root Collection Joins
  - Selecting the Collections to Join
  - Creating Selection Criteria for Your Join
  - Selecting the Fields to Join

- Obtaining Database Statistics

- Using the JADE Report Configuration Menus
  - View Menu
  - Folders Menu
  - System Formats Menu
  - Users Menu
  - Configuration Menu
  - Type Menu
Chapter 3  Configuring the JADE Report Writer

- Edit Menu
- Window Menu
- Help Menu

Defining Your Reporting Views

Specify reporting views of your database by using the JADE Report Configuration application.

Use reporting views to define the classes, features, and collections on which your future report designs are based. You can give class and property names meaningful aliases within your reporting view definitions.

The following subsections provide details about creating, maintaining, and building your reporting views.

- Creating a New Reporting View
- Copying a Reporting View
- Opening a Reporting View
- Selecting the Schema, Types, and Features for Your Reporting View
- Deleting a Reporting View
- Closing a Reporting View
- Unloading a Reporting View Definition
- Loading a Reporting View Definition
- Unloading All Report Writer Data to a Single File
- Loading All Report Writer Data from One File
- Removing Undefined View Items
- Highlighting Changed Items
- Validating a Reporting View Definition
- Building a Default Reporting View Definition
- Checking Your Reporting View Usage

For details about the JADE Report Writer Designer application, see Chapter 4.

Creating a New Reporting View

Use the New command from the View menu to create a new reporting view.
To create a new reporting view

1. Select the **New** command from the View menu.

   The New Reporting View dialog, shown in the following image, is displayed.

   ![New Reporting View dialog](image)

   - **Name**
   - **Include Transient Classes**
   - **Selected Top-Level Schema**
   - **Selected Lowest-Level Schema**
   - **Default Report Concurrency Option**
   - **Copy existing view**

2. Specify the name of your reporting view in the **Name** text box (for example, *ErewhonView*). The maximum length for the name is 30 characters.

3. If you want to include transient classes in your view, check the **Include Transient Classes** check box.

   By default, the **Include Transient Classes** check box is unchecked.

   **Note** The transient classes option enables you to build complex queries by combining data into a composite transient class and then using the JADE Report Writer to report on the transient data. For more details, see "Reporting on Transient Classes", later in this chapter.

4. Click the **Top Level Schema** sheet tab or click once in the **Selected Top-Level Schema** text box.
The Top Level Schema sheet, shown in the following image, is then displayed, to enable you to specify the highest-level schema in the schema hierarchy from which data is to be reported.

Select a schema from the Available Schemas list box and then click the Details sheet tab. The selected schema is then displayed in the Selected Top Level Schema text box.

5. Click once in the Selected Lowest-Level Schema text box. The Lowest Level Schema sheet, shown in the following image, is then displayed, to enable you to specify the lowest-level schema in the schema hierarchy from which data is to be reported.

Select a schema from the Available Schemas list box. The lowest-level schema must be the same as or a subschema of the highest-level schema. Click the Details sheet tab. The selected schema is then displayed in the Selected Lowest-Level Schema text box.

6. Select a default concurrency strategy option for reports based on your reporting view from the Default
Report Concurrency Option drop-down list box. The default setting for new views is None. For details about setting a concurrency strategy for reports, see "Using the Options Sheet" under "Query Options Command", in Chapter 4.

7. Click the Description tab. The Description sheet is then displayed.

   In the Description text box, enter an optional description of your reporting view.

8. Click the OK button. Alternatively, click the Cancel button to abandon your selections.

The reporting view that is then created becomes the active view in the JADE Report Configuration window. You can now define the reporting view by selecting types and features for reporting.

**Reporting on Transient Classes**

All objects and properties required for reporting are normally stored as instances of persistent classes retained in the JADE database between application sessions. The Include Transient Classes check box on the New Reporting View dialog enables you to configure reporting views that include transient classes. By default, this option is not selected and reporting views can be based only on persistent objects.

In a complex system, it may be necessary to perform additional processing on persistent objects to derive more information such as gathering and combining data from several collections and performing further calculations on that data. The results of processing applied to several collections are contained in transient objects, which require fewer resources than persistent objects because they are not permanently stored in the database.

Use the Include Transient Classes check box for pre-designed reports that are run as part of a system where specific transient classes are created to represent data gathered from complex composite sources.

**Copying a Reporting View**

Use the New command from the View menu to create a copy of an existing reporting view.
To copy an existing reporting view

1. Select the **New** command from the View menu.

   The New Reporting View dialog, shown in the following image, is displayed.

2. Specify the name of your reporting view in the **Name** text box (for example, **ErewhonView**). The maximum length for the name is 30 characters.

3. Check the **Copy existing view** check box and select the view you want to copy from the combo box.

4. Click the **Description** tab. The **Description** sheet is then displayed.

   In the **Description** text box, enter an optional description of your reporting view.

5. Click the **OK** button. Alternatively, click the **Cancel** button to abandon your selections.

   The reporting view that is then created becomes the active view in the JADE Report Configuration window. You can now define the reporting view by selecting types and features for reporting.

Opening a Reporting View

Use the **Open** command from the View menu to open an existing reporting view.
To open an existing reporting view

1. Select the **Open** command from the View menu.
   
   The Open View dialog, shown in the following image, is then displayed.

   ![Open View Dialog](image)

2. In the **Views** list box, select the view that you want to open.

3. To view the details of the currently selected view in the Reporting View dialog, click the **Details** button. The description and top-level schema for the view are then displayed.

   Use the Reporting View dialog to change your reporting view details; for example, when renaming your reporting view. For details, see "Creating a New Reporting View", earlier in this chapter.

4. Click the **Open** button.

   A progress dialog is displayed while the view is opening. You can click the **Cancel** button on the progress dialog to abandon the open process at any time.

   The reporting view that is opened becomes the active view in the JADE Report Configuration window.
Selecting the Schema, Types, and Features for Your Reporting View

Use the Types & Features sheet of the JADE Report Configuration window, shown in the following image, to select the types and features for your reporting view.

Use the panes on the left of the sheet to make your selections and the panes on the right of the sheet to display the types and features that you have selected.

**Note**  You can define a root collection path only through the types and features that are already selected for a view, and only those types and features selected for a view are reported on through a root collection.

The top-level schema and lowest-level schema that you specified for this view are displayed under the Schemas caption.

The list box in the Classes and Interfaces pane of the Types & Features sheet displays all classes defined for the lowest-level schema up to the highest-level schema for selection. For details about selecting the top-level and lowest-level schemas, see "Creating a New Reporting View" or "Opening a Reporting View", earlier in this chapter. You must first open a view or create a new one. For details, see "Opening a Reporting View" or "Creating a New Reporting View", earlier in chapter.
The following subtopics describe the use of the **Types & Features** sheet.

- **Selecting the Types for Your View**
- **Selecting the Features for Your View**
- **Removing Types and Features**
- **Development Changes Can Affect Your View**

**Note** You can create a default reporting view that contains *all* of the types and features of a selected schema. For details, see "Building a Default Reporting View Definition", later in this chapter.

In some cases, this could provide a quicker method of creating a reporting view by including all of the types and features in the view and then simply removing the types and features that are not required.

**Selecting the Types for Your View**

**Note** In JADE, classes represent groupings of similar objects together with the data they contain (properties) and the actions that they can perform (methods). Types represent the superclass of classes, interfaces, and primitive types (special types used to store values of a specific kind). Types therefore represent all of the classes that your reporting view can access.

The class hierarchy of your selected schema is shown in the **Classes and Interfaces** pane in the top left of the **Types & Features** sheet, as shown in the following image.

To select a class to include in the Selected Types pane, perform one of the following actions

- Click the class that you want to include and then click the right pointing arrow.
- Double-click the class that you want to include.
- Click and drag the class across to the Selected Types pane at the top right of the sheet.
- Click the class, right-click within the pane, and then select the **Select** command from the popup menu that is displayed.
The selected class is then included in the Selected Types pane and is disabled in the **Classes and Interfaces** pane.

**To select a group of classes to include in the Selected Types pane**

1. To select a group of consecutive classes in the **Classes and Interfaces** pane, click the first class in the group, hold down the Shift key, and then click the last class in the group.

   To select a group of non-consecutive classes in the **Classes and Interfaces** pane, click the first class of the group, hold down the Ctrl key, and then click each subsequent class that you want to include in the view.

2. Perform one of the following actions.
   - Click the right-pointing arrow.
   - Drag the types across to the Selected Types pane at the top right of the sheet.
   - Right-click and then select the **Select** command on the popup menu that is displayed.

The selected classes are then included in the Selected Types pane and are disabled in the **Classes and Interfaces** pane. The following image shows the **Selected Types** pane after selecting the **SaleItem** class and its two subclasses.

The default value in the **Alias** column is the class name. However, you can change the alias to a more meaningful description, if required.

**To change the alias for a selected type in the Selected Types pane**

1. Click the **Alias** cell or select the **Rename** command from the Edit menu.

   An entry box is displayed around the **Alias** cell, as shown in the following image.

2. Type your new alias over the displayed alias; for example, **Retail Sale Item**.

3. Press the Enter key or the Tab key, or click outside the current pane to complete the alias change.

The alias of the selected type is then changed. Invalid characters in the alias (for example, punctuation marks that are not allowed in report scripts) are automatically removed.
Selecting the Features for Your View

**Note** In JADE, a feature is something that describes an object or some operation that an object performs. Features are the properties and methods associated with a type or class.

When you have selected the types for your view, you can then select the features (that is, the properties and methods) for each type.

- **To display all of the features for a type, perform one of the following actions**
  - Click a type in the *Selected Types* pane.
  - If you want to display methods that have primitive parameters for that type (methods that have no parameters are always shown), check the box in the *Show Methods* column of the *Select Types* table.

<table>
<thead>
<tr>
<th>Alias</th>
<th>Type</th>
<th>Show Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>RetailSaleItem</td>
<td>RetailSaleItem</td>
<td></td>
</tr>
<tr>
<td>SaleItem</td>
<td>SaleItem</td>
<td></td>
</tr>
<tr>
<td>TenderSaleItem</td>
<td>TenderSaleItem</td>
<td></td>
</tr>
</tbody>
</table>

**Note** Only methods that return a primitive value can be used as Method fields in the Report Writer Designer.

- Select the type in the *Types* list box in the lower left pane.

The features (properties and methods) of the selected type are then displayed in the Features pane, as shown in the following image.

You can then select the features that you require for your reporting view from the features list. Your selected features are displayed in the Selected Features pane at the lower right of the window.
To Perform

Chapter 3  Configuring the JADE Report Writer

Notes  All public and read-only properties are shown in alphabetical name order, followed by methods in alphabetical name order. Only those methods that can be reported on are shown; that is, methods that are public or read-only, non-abstract, and have a return type.

The type of a feature (corresponding to its Data Type listed in the table in the Selected Features pane) is indicated by a graphical icon displayed to the left of the feature. These icons are used throughout the JADE Report Writer applications. For details, see "Using the Catalog of Available Fields Dialog", in Chapter 4.

To select a feature to include in the Selected Features pane, perform one of the following actions

- Click the feature that you want to include and then click the right pointing arrow.
- Double-click the feature that you want to include.
- Click and drag the feature across to the Selected Features pane in the upper right of the sheet.
- Click the feature, right-click within the pane and then select the Select command on the popup menu that is displayed.

The selected feature is then included in the Selected Features pane.

You can select all of the features from a type.

To select a group of features to include in the Selected Features pane

1. To select a group of consecutive features in the Features pane, click the first feature in the group, hold down the Shift key, and then click the last feature in the group.

   To select a group of non-consecutive features in the Features pane, click the first feature of the group, hold down the Ctrl key, and then click each subsequent feature that you want to include in the view.

2. Perform one of the following actions.
   - Click the right pointing arrow.
   - Drag the features across to the Selected Features pane at the lower left of the sheet.
   - Right-click and then select the Select command on the popup menu that is displayed.

The selected features are then included in the Selected Features pane.

To select all the features for a selected type or class, perform one of the following actions

- Click the down arrow in the Selected Types pane at the upper right of the sheet.

- Right-click within the pane and then select the Select ALL Features command in the displayed popup menu.

All of the features for the selected type are then listed in the Selected Features pane, including the features inherited from the superclass.
The following image shows the Selected Features pane after selecting all of the features from the SaleItem class.

The default value in the Alias column is the feature name. However, you can change an alias to a more meaningful name, if required.

To change the alias for a selected feature in the Selected Features pane

1. Click the Alias cell or select the Rename command from the Edit menu.

   An entry box is then displayed around the Alias cell, as shown in the following image.

   ![Alias Entry Box]

2. Type your new alias over the displayed alias.

3. Press the Enter key or the Tab key, or click outside the current pane, to complete the alias change.

The alias of the selected feature is then changed to your new value. Invalid characters in the alias (for example, punctuation marks that are not allowed in report scripts) are automatically removed. You can change the length of a feature in your view if, for example, you know that the length is usually less than the length specified in the database.

To change the feature or path for a selected alias in the Selected Features pane

1. Double-click the Feature/Path cell to be changed.

   An entry box is displayed around the Feature/Path cell, as shown in the following image.

   ![Feature/Path Entry Box]

2. Type your new feature or path name over the displayed feature.

3. Press the Enter key or the Tab key, or click outside the current pane, to complete the feature or path change.

   If the new feature or path name is valid and its type is the same as the old feature or path, the name is changed.
Chapter 3 Configuring the JADE Report Writer

To change the length of a selected property feature in the Selected Features pane

1. Click the **Length** cell (for data types that are integer, string, decimal, or binary values).

   An entry box is then displayed around the **Length** cell, as shown in the following image.

<table>
<thead>
<tr>
<th>Alias</th>
<th>Feature/Path</th>
<th>Data Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>codeNumber</td>
<td>codeNumber</td>
<td>Integer</td>
<td>9</td>
</tr>
<tr>
<td>codePrefix</td>
<td>codePrefix</td>
<td>String</td>
<td>4</td>
</tr>
</tbody>
</table>

2. Type your new length over the displayed length (the maximum value is **9999**).

3. Click outside the current pane to complete the change.

   The length of the selected feature is then changed.

Removing Types and Features

Removing types and features from your view is similar to selecting types and features.

To remove a type from the Selected Types pane, perform one of the following actions

- Click the type that you want to remove and then click the left-pointing arrow.
- Click the type that you want to remove and then select the **Delete** command from the Edit menu.
- Click and drag the type across to the **Classes and Interfaces** command from the Edit menu.
- Click the type, right-click within the pane, and then select the **Remove** command from the popup menu that is displayed.

   The selected type is then removed from the Selected Types pane and the class is enabled in the **Classes and Interfaces** pane.

To remove a group of types from the Selected Types pane

1. To remove a consecutive group in the Selected Types pane, click the first type in the group, hold down the **Shift** key, and then click the last type in the group.

   To remove a non-consecutive group in the Selected Types pane, click the first type in the group, hold down the **Ctrl** key, and then click each subsequent type that you want to remove.

2. Perform one of the following actions.
   - Click the left-pointing arrow.
   - Select the **Delete** command from the Edit menu.
   - Drag the types across to the **Classes and Interfaces** command from the Edit menu.
   - Right-click and then select the **Remove** command from the popup menu that is displayed.

   The selected types are then removed from the Selected Types pane and become enabled in the **Classes and Interfaces** pane.

To remove a feature from the Selected Features pane, perform one of the following actions

- Click the feature that you want to remove and then click the left pointing arrow.
- Click the feature that you want to remove and then select the **Delete** command from the Edit menu.
Click and drag the feature across to the Features pane.

Click the feature, right-click within the pane, and then select the **Remove** command from the popup menu that is displayed.

The selected feature is then removed from the Selected Features pane.

To remove a group of features from the Selected Features pane

1. To remove a group of consecutive features in the Selected Features pane, click the first feature in the group, hold down the Shift key, and then click the last feature in the group.

To remove a group of non-consecutive features in the Selected Features pane, click the first feature of the group, hold down the Ctrl key, and then click each subsequent feature that you want to remove.

2. Perform one of the following actions.
   - Click the left-pointing arrow.
   - Select the **Delete** command from the Edit menu.
   - Drag the features across to the Features pane at the lower left of the sheet
   - Right-click and then select the **Remove** command from the popup menu that is then displayed.

The selected features are then removed from the Selected Features pane.

**Development Changes Can Affect Your View**

If when you open a view, you may see features in the Selected Features pane highlighted with a red or a mauve background color. This indicates development changes have impacted the view as follows

- A red background indicates the feature is used in reports but has been removed from the class. To remedy this situation, right-click and select **Usage** to find the reports using the feature, remove the feature from the reports, and then remove the feature from the view.

- A mauve background indicates the feature is a method to which a parameter has been added. To remedy this, check the Show Methods check box in the Selected Types pane.

**Deleting a Reporting View**

Use the **Delete** command from the View menu to delete an existing reporting view.
To delete an existing reporting view

1. Select the **Delete** command from the View menu.

   The Delete View dialog, shown in the following image, is then displayed.

![Delete View dialog](image)

2. In the **Views** list box, select the view that you want to delete.

3. Click the **Delete** button. A dialog is then displayed, which enables you to confirm that you are sure that you want to delete the view.

4. To confirm the deletion, click the **Yes** button. Alternatively, click the **No** button to cancel the deletion and retain the view.

   The selected view is then deleted.

**Notes**

You cannot delete a view that has reports defined against it, and you cannot delete a view that is currently open. The view must first be closed.

As a precaution against accidental deletion, you should extract each of the views that you create. If you then accidentally delete a view, you can reload it by using the **Load** command. For details, see "Unloading a Reporting View Definition", later in this chapter.

---

**Closing a Reporting View**

Use the **Close** command from the View menu to close a reporting view.

**To close a reporting view**

1. Select the **Close** command from the View menu.

   The reporting view is then closed and the reporting view is saved automatically.
Unloading a Reporting View Definition

Use the **Unload definition** command from the View menu to store your reporting view definition as a file that you can retrieve, if required. For details about loading an extracted reporting view definition, see "Loading a Reporting View Definition", in the following subsection.

To unload a reporting view definition

1. Select the **Unload definition** command from the View menu.

   The Unload View dialog, shown in the following image, is then displayed.

   ![Unload View Dialog](image)

2. In the **Views** list box, select the reporting view that you want to unload. (You must specify the view you want to unload, even if only one view is displayed.)

3. In the **File Name** text box, enter the name and location of the file to which you want to unload the reporting view definition. You must specify a file with the .rwv suffix.

   If you are unsure of your file name or location, click the **Browse** button. The common File dialog is then displayed, to enable you to select the appropriate file.

4. Click the **Extract** button.

   The reporting view is then saved to your specified file.

Loading a Reporting View Definition

Use the **Load definition** command from the View menu to load a reporting view definition. For details about unloading a reporting view definition, see "Unloading a Reporting View Definition", in the previous subsection.
Notes  If the view that you are loading already exists (that is, you are loading a different version of the view), make sure that the existing view does not contain features in error that are used in existing reports. If in the view that you are loading, an alias is associated with a different feature or path name, make sure that:

- The feature or path name is valid
- The type of the new feature or path name is the same as the old feature or path name

To load a reporting view definition

1. Select the **Load definition** command from the View menu.

   The Load View dialog, shown in the following image, is then displayed.

   ![Load View dialog](image)

2. In the **File Name** text box, enter the name and location of the view definition file that you want to load. (View definition files have the `.rwv` suffix.)

   If you are unsure of your file name or location, click the **Browse** button. The common File dialog is then displayed, to enable you to select the appropriate file.

3. The **Replace view** check box is checked by default, which means that if a reporting view with the same name already exists, view items (types, features, root collections, joins, and script methods) that are not in the incoming view extract file and are not used in any existing report definitions are removed. Those items that are used in existing reports are retained.

Note  Two reports can have the same name only if they belong to different views and they are saved in different folders. When a report for the same name and same folder but for a different view is loaded, the report is loaded into a subfolder with the same name as the report. If the folder does not already exist, it is created. The folder creation and the change of report folder are output to the `jadereportwriter.log` file.
Alternatively, uncheck the **Replace view** check box to merge an existing view with the loaded extract file. If a reporting view already exists with the same name as the view in the extract file, it is updated from the file. Existing types, features, root collections, joins, and script methods have their details overwritten from the extract file. Existing view items that are not in the extract file remain unchanged. New view items from the extract file that do not exist in the existing view are added to the view.

When merging views, the view load also checks the path and feature aliases in the incoming file against the existing view for a mismatch between an incoming path alias and an existing feature alias, or the reverse. If the existing field is unused, it is replaced by the incoming field; otherwise, the existing field is left unchanged and an error is reported.

4. Click the **Load** button. A progress dialog is displayed while the reporting view is loading. Click the **Cancel** button on the progress dialog to abandon the load process at any time, if required.

Your reporting view is then loaded and you can open it in the JADE Report Writer Configuration application window. For details, see "Opening a Reporting View", earlier in this chapter.

The batch JADE Load utility (**jadloadb**) enables you to load report configuration or definition files into an existing schema.

For details about loading a reporting view into an existing JADE user schema (for example, when you load a new user schema and there are associated JADE Report Writer reporting views that are to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the **JADE Development Environment User's Guide**, and "Loading a Schema and Forms in Batch Mode", in the **JADE Schema Load Utility User's Guide**.

### Unloading All Report Writer Data to a Single File

The JADE Report Writer enables you to unload all report data to a single output file from the:

- Configuration application menu
- Batch JADE Load utility

For details, see "Unloading All Report Data from the Configuration Application" or "Unloading All Report Data from the Batch JADE Load Utility", respectively.

### Unloading All Report Data from the Configuration Application

Use the **Unload All** command from the View menu to unload all view, folder, user, system option, report definitions, and template definitions to a flat file (for example, when upgrading from one JADE release to another JADE release in which the class number range has changed).

The **Unload All** command and its corresponding **Load All** command provide a transfer and backup utility for all the report writer data created by using the JADE Report Writer Designer and the JADE Report Writer Configuration applications.

#### To extract all report writer data to a flat file

1. Select the **Unload All** command from the View menu. The Unload All dialog, shown in the following image, is then displayed.
2. In the File Name text box, enter the name and location of the file to which you want to extract all of your report writer data. You should define a file with the default .rwa suffix. If you are unsure of your file name or location, click the Browse button. The common File dialog is then displayed, to enable you to select the appropriate file location.

3. Click the Unload button, to begin the unload process and extract all report writer data to your specified file. Alternatively, click the Close button to return to the JADE Report Writer Configuration application window.

Unloading All Report Data using the Non-GUI Client Application

The jadclient non-GUI client application enables you to extract all report data to a flat file (for example, when upgrading from one JADE release to another from one JADE release to another JADE release in which the class number range has changed).

You must specify the executeSchema parameter with a value of JadeReportWriterSchema, the executeClass parameter with a value of JadeReportWriterGlobal, the executeMethod parameter with a value ofunloadAllToFile, and the executeParam parameter with the name and output location of your report data file, which should have the default .rwa suffix, as shown in the following example.

```
jadclient path=d:\jade\system ini=d:\jade\myjade.ini app=RootSchemaApp schema=RootSchema executeSchema=JadeReportWriterSchema executeClass=JadeReportWriterGlobal executeMethod=unloadAllToFile executeParam=d:\jade\rpts\alldata.rwa
```

The syntax of the execute parameters in the jadclient command line is as follows.

```
jadclient path=database-path
  ini=initialization-file-name
  app=RootSchemaApp
  schema=RootSchema
  executeSchema=JadeReportWriterSchema
  executeClass=JadeReportWriterGlobal
  executeMethod=unloadAllToFile
  executeParam=output-location\output-file-name-prefix.rwa
```

**Note** As these execute element parameters are case-sensitive, you must specify the values exactly or an error is output.
Loading All Report Writer Data from One File

The JADE Report Writer enables you to load all report data from a single flat file from the:

- Configuration application menu
- Batch JADE Load utility

For details, see "Loading All Report Data from the Configuration Application" or "Loading All Report Data from the Batch JADE Load Utility", respectively.

Loading All Report Data from the Configuration Application

Use the Load All command from the View menu to load all view, folder, user, system option, report definitions, and template definitions from a flat file (for example, when upgrading from one JADE release to another from one JADE release to another JADE release in which the class number range has changed).

The Load All command and its corresponding Unload All command provide a transfer and backup utility for all report writer data created by using the JADE Report Writer Designer and the JADE Report Writer Configuration applications.

To load all report writer data from a single extract file

1. Select the Load All command from the View menu.
   
   The Load All dialog, shown in the following image, is then displayed.

   ![Load All dialog]

2. In the File Name text box, enter the name and location of the file from which you want to load all report writer data. (The file should have the default .rwa suffix.) If you are unsure of your file name or location, click the Browse button. The common File dialog is then displayed, to enable you to select the appropriate file location.

3. Click the Load button, to begin the load process and load all view, folder, user, system option, report definitions, and template definitions. A progress dialog is displayed while the data is loading. Click the Cancel button on the progress dialog to abandon the load process at any time, if required. Alternatively, click the Close button to return to the JADE Report Writer Configuration application window.

The batch JADE Load utility (jadloadb) enables you to load all report writer data from an existing file into an existing schema. For details, see "Loading All Report Data from the Batch JADE Load Utility".
For details about loading data into an existing JADE user schema (for example, when you load a new user schema and there is associated JADE Report Writer data to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the JADE Development Environment User’s Guide.

Loading All Report Data from the Batch JADE Load Utility

The `jadloadb` batch JADE Load utility enables you to specify the fully qualified name of a single unload, or extract, file that contains all JADE Report Writer view, folder, system option, user, and report definitions that you want to load (for example, when upgrading from one JADE release to another from one JADE release to another JADE release in which the class number range has changed), as shown in the following example.

```
jadloadb path=d:\jade\system reportLoadAllFile=d:\jade\rpts\alldata.rwa ini=d:\jade\myjade.ini
```

When loading a report view from the `all` file, existing view items that are unused or are not in the loaded report all file are replaced.

Removing Undefined View Items

Use the Remove Undefined command from the View menu to remove unused view definition items that no longer exist in the associated JADE schema.

The Remove Undefined command checks each collection, type, and feature definition in the current reporting view against the associated schema entity and deletes those view items that no longer exist in the schema.

**To remove undefined view items**

1. Select the Remove Undefined command from the View menu.

   Unused view definition items for schema entities that no longer exist are then removed from your reporting view.
The View dialog, shown in the following image, is then displayed, with details of items removed from the view. If no items have been removed from the view, the text **No unused items were found in this view** is displayed instead and the **More** button is disabled.

![View dialog](image)

2. To toggle the display of details of removed items, click the **More** button.

### Highlighting Changed Items

Use the **Highlight changes** command from the View menu to highlight view items where the corresponding schema entity has been added or changed. This enables you to keep your view definition in step with the development of your JADE system.

The **Highlight changes** command highlights types, features, and root collections in the reporting view where the equivalent JADE schema entity has changed since a specified date and time.

The date and time information for highlighting is saved between your JADE Report Writer sessions, but the JADE Report Writer Configuration application always starts with no highlighting applied.
To highlight changed items in your reporting view

1. Select the Highlight changes command from the View menu.

The highlight changes dialog, shown in the following image, is then displayed. The name of the current view is displayed in the title bar.

2. Uncheck the No changes highlighted check box to highlight changes to the associated JADE schema entities in your reporting view. This check box is checked by default, meaning that by default, changes are not highlighted in your reporting view.

The fields under the Highlight changes since caption are then enabled.

The No changes highlighted check box remains unchecked as long as the current view is open or until it is explicitly checked again; that is, until you close and reopen the current view, or exit the JADE Report Writer Designer application and start it again, or you check the No changes highlighted check box.

3. To highlight changes from a specified date and time, enter a date and time in the Date and Time text boxes, respectively. Enter the time in 24-hour clock format. For convenience, the date and time you enter are stored with the corresponding field until they are changed.

4. Click the Close button to close the dialog and return to your reporting view.

Types, features, and root collections that have been changed or added in the associated schema are highlighted in your reporting view on the Types & Features and Root Collections sheets by a yellow background.

The date since the change was applied is displayed in the title bar for the appropriate pane, as shown in the following image.
**Note** Highlighted changes correspond to modifications to items in your JADE schema. Some changes (for example, a change of item text) may not be relevant to your reporting view. It is your responsibility to determine the nature and effect, if any, of changes to your JADE schema on your reporting views and reports.

### Viewing Bubble Help

Use the bubble help when working with views to display details of the classes and features in your view. Bubble help is displayed by checking the **Show View bubble help** check box on the User Preferences dialog. For details about specifying your user preferences, see "Preferences Command", later in this chapter.

Bubble help is displayed for classes and features in your views; that is, classes, properties, methods, and collections on the **Types & Features** and **Root Collections** sheets.

**To view bubble help for a class or feature**

1. Select a class or feature in your reporting view.
2. Rest the cursor on the selected item for a few seconds.

A yellow bubble help popup is displayed next to the cursor, with details of the selected object.

### Validating a Reporting View Definition

Use the **Validate** command from the View menu to validate a reporting view.

The **Validate** command checks each collection, type, and feature definition in the selected reporting view, to ascertain that each item exists in the associated schema. The results are displayed automatically.

**To validate a reporting view definition**

1. Select the **Validate** command from the View menu.

The Validate View dialog, shown in the following image, is then displayed.

2. In the **Views** list box, select the reporting view that you want to validate.
3. Click the **Validate** button.
The selected reporting view is then validated and the results of the validation are displayed in the Views list box.

If your database has changed in the areas that have been included in your reporting view, any inconsistencies are reported. You may then have to change your view or recreate it.

**Building a Default Reporting View Definition**

Use the **Build to file** command from the View menu to quickly create a reporting view. The **Build to file** command extracts all candidate classes and features for the schema that you specify and adds them to a new reporting view. You can then load this reporting view by using the **Load definition** command and edit it manually.

Creating a reporting view in this way differs from the standard operation, in which you individually specify the types and features that form your reporting view.

For details about the standard selection of types and features to create a view, see "Selecting the Schema, Types, and Features for Your Reporting View", earlier in this chapter.

To build a reporting view definition

1. Select the **Build to file** command from the View menu.
   
   The Build View to File dialog, shown in the following image, is then displayed.

   ![Build View to File dialog](image)

2. In the **Schemas** list box, select a schema from the schema hierarchy that is displayed. The new reporting view is based on the selected schema.

3. In the **Build Reporting View Name** text box, enter the name of the reporting view that you want to build.

4. If you want to include transient classes in your view, check the **Include Transient Classes** check box.
   
   By default, the **Include Transient Classes** check box is unchecked.
Note  The transient classes option enables you to build complex queries by combining data into a composite transient class and then using the JADE Report Writer to report on the transient data. For more details, see "Reporting on Transient Classes", earlier in this chapter.

5. If you want all classes to have the check box in the Show Methods column of the Select Types table selected, when the view is opened, check the Show Param Methods check box. As explained in "Selecting the Features for Your View", earlier in this chapter, methods with primitive parameters are displayed in addition to methods with no parameters, which are always shown.

6. In the File Name text box, enter the extract file to which you want to save your reporting view.
   To select a file name location, click the Browse button. The common File dialog is then displayed, to enable you to select the appropriate file.

7. Click the Build button. Alternatively, click the Close button to abandon your selections.
   A progress dialog is displayed while the view is being built. Click the Cancel button on the progress dialog to abandon the build process at any time, if required.

The build process extracts all candidate classes and features from your selected schema.

Checking Your Reporting View Usage

Use the Usage command from the View menu to check which reports are based on your current reporting view.

To check the usage of a reporting view

1. Select the Usage command from the View menu.
   
   The Where Used dialog is then displayed, as shown in the following image, providing a list of reports that are based on the current view.

![Where Used dialog](image)

2. Click the Close button to close the dialog.

Building Your JADE Root Collection Paths

Reports are based on root collections, which provide the primary source of data for your reports.
A **collection** is a basic structure used to store multiple object references or primitive values. In the JADE Report Writer, a **root collection** is a collection (or group) of similar objects. A root collection path is a navigable path by which a root collection is accessed. A root collection path is defined by all instances of a class (for example, `Client.instances`) or by following an object reference to a JADE collection (for example, `Company.firstInstance.allAgents`).

**Note** You can define a root collection path only through the types and features that are already selected for a view, and only those types and features selected for a view are reported on through a root collection.

Define each JADE Report Writer root collection to provide a path to a collection of objects that can be reported on at run time. (For details, see “Selecting the Schema, Types, and Features for Your Reporting View”, earlier in this chapter.)

Use the **Root Collections** sheet of the JADE Report Configuration window to define and build JADE collection paths.

**To access the Root Collections sheet**

- Click on the **Root Collections** tab in the JADE Report Configuration window.

The **Root Collections** sheet, shown in the following image, is then displayed.

The top-level schema and lowest-level schema that you specified for this view are displayed under the **Schemas** caption. The list box in the **Root Object** pane displays all classes defined for the lowest-level schema up to the highest-level schema for selection.
For details about selecting the top-level and lowest-level schemas, see "Creating a New Reporting View" or "Opening a Reporting View", earlier in this chapter. By expanding the Object class, you can then select your collection path.

The build and selection procedures are described in the following subsections.

- Building Your Collection Path
- Selecting Your Collection Path

### Building Your Collection Path

You can build a collection path by entering the path manually, by selecting the elements of the path individually, or you can accept the default collection path for a selected class.

**To build a root collection path, perform one of the following actions**

- Accept the default root collection path.

Select a collection class that is already referenced by a feature of an existing type, as shown in the following image.

In the Root Collection Path pane at the lower left of the Root Collections sheet, the path is then set to the first instance of your selected collection, as shown in the following image. The traffic light icon changes from red to green, to indicate that a valid root collection path is selected.
Build the elements of the collection, as follows.

a. Select the class that is the root of your collection.

The class is then displayed in the Root Collection Path pane at the lower left of the Root Collections sheet, as shown in the following image. The traffic light icon remains red because the root collection path is still incomplete.

b. Enter the next element in the collection path by selecting it from the Build Path combo box, which is shown in the following image.

Select one of the elements. If you select the instances element, your collection path is complete. The collection then comprises all instances of the selected class.

c. If you select the firstInstance element, enter your collection name as the next element of the path or select it from the Build Path combo box again.

The Build Path combo box displays the following collections after you have selected the firstInstance element

to complete your collection path, select one of the collections.

d. If you decide to change the elements of your collection path before you select it for inclusion in your view, click the Remove last path element button or press the Backspace key to remove the last path element.

You should then follow steps b and c, earlier in this instruction, to rebuild your collection path.
When you have built a valid root collection path, the traffic light icon displayed at the right of the Root Collection Path pane turns from red to green, as shown in the following image.

If the light does not turn green, the root collection path is incomplete or invalid. Repeat one of the procedures in this subsection and ensure that you have selected a valid path.

Having created a root collection path, you can then select it for inclusion in your reporting view. For details, see "Selecting Your Collection Path", in the following subsection.

Selecting Your Collection Path

When you have built your collection path (described under "Building Your Collection Path", earlier in this chapter), you can then select a root collection for inclusion in your reporting view.

To select a root collection path, perform one of the following actions

- Click the right-pointing arrow in the Root Collection Path pane of the Root Collections sheet.
- Drag the root collection path from the Root Collection Path pane to the Selected Report Root Collections pane of the Root Collections sheet.
- Right-click in the Root Collection Path pane and then select the Select command from the popup menu that is displayed.
- Click the right-pointing arrow in the Root Object pane of the Root Collections sheet. (The arrow in the Root Object pane is enabled only if a collection is selected in the Root Object pane.)

The root collection path is then displayed in the Selected Report Root Collections pane of the Root Collections sheet, as shown in the following image.

To remove a selected root collection path, perform one of the following actions

- Click the left-pointing arrow in the Selected Report Root Collections pane.
- Drag the root collection path from the Selected Report Root Collections pane to the Root Object pane of the Root Collections sheet.
- Right-click in the Selected Report Root Collections pane and then select the Remove command from the popup menu that is displayed.

The root collection path is then removed from the Selected Report Root Collections pane.
Selecting Script Methods

The JADE Report Writer Configuration application provides access to existing primitive type methods that you can use in the JADE Report Writer Designer application to create custom script fields that add a variety of data reporting options to your reports.

These methods provide date and time formats and formatting options for other primitive types. They also provide selection options that you can use when creating user scripts in the JADE Report Writer Designer application.

To access the Script Methods sheet

- Click on the Script Methods tab of the JADE Report Configuration window.

The Script Methods sheet, shown in the following image, is then displayed.

![Script Methods Sheet](image)

Use the Script Methods sheet of the JADE Report Configuration window to select the script methods that you want to make available to a schema from within the JADE Report Writer Designer application. Most commonly, the date and time methods are used.

Note: Primitive type methods in your user schema and those in the RootSchema other than those that are made available by default are not displayed in the Script Maintenance dialog of the JADE Report Writer Designer application unless you select them in the Script Methods tab of the JADE Report Configuration window.

For a detailed description of using scripts in the JADE Report Writer Designer application, see Appendix A. A shorter overview is provided in "Creating a Script" under "Using the Catalog of Available Fields Dialog", in Chapter 4.

To select the schema for which you want to select script methods

- Select the appropriate schema from the Schema list box in the top-left pane of the Script Methods sheet, as shown in the following image.
Primitive type methods for the selected schema and for all superschemas, up to and including the RootSchema, are then displayed in the Available Methods pane.

To select your script methods

1. Expand a folder in the Available Methods pane to display the available methods, shown in the following image in which the Date folder is expanded.

2. To select methods, perform one of the following actions.
   - Click a method and then click the right-pointing arrow or the add button (►), or double-click on the method.
   - Select a range of consecutive methods by clicking the first method in the range, holding down the Shift key, and then selecting the last method in the range.
Click the right-pointing arrow or the add button (>) to complete the selection.

- Select a group of non-consecutive methods by clicking the first selected method, holding down the Ctrl key, and then selecting each subsequent method.

Click the right-pointing arrow or the add button (>) to complete the selection.

The selected methods are then copied to the Selected Methods pane, shown in the following image.

**To select all script methods**

- Click the add all button (>>).

All script methods are then copied to the Selected Methods pane.

**Note** You should not apply all script methods to a schema unless you know that your report designers are technically oriented, as some of the script methods are specialized.

**To remove a script method from the selection, perform one of the following actions**

- Click a method in the Selected Methods pane at the right of the Script Methods sheet and then click the remove button (<).

- Select a group of consecutive methods in the Selected Methods pane at the right of the Script Methods sheet. Click the first method in the range, hold down the Shift key, and then select the last method in the range. Click the remove button (<) to complete the removal.

- Select a group of non-consecutive methods in the Selected Methods pane at the right of the Script Methods sheet. Click the first selected method, hold down the Ctrl key, and then select each subsequent method. Click the remove button (<) to complete the removal.

The selected methods are then removed from the Selected Methods pane.

**To remove all script methods from the selection**

- Click the remove all button (<<).
Creating Root Collection Joins

Use the joins feature to join related data that exists in more than one root collection.

You would typically use this feature to join collections that have been converted from external non-object-oriented databases (for example, from a relational database), although it must be emphasized that a well-designed JADE system that makes full use of JADE’s relationship protocols would normally remove the need to create collection joins.

An example of using joins would be a situation in which you had two collections containing names and addresses (for example, a collection of agents and a collection of clients).

If you wanted to produce a report of people who appeared in both collections, you could join these collections in the JADE Report Writer Configuration application. The data would effectively become one list in the JADE Report Writer Designer application, from which your report designers could select fields for inclusion in their reports.

Use the Joins sheet of the JADE Report Configuration window to create and maintain joins.

**To access the Joins sheet**

- Click on the Joins tab of the JADE Report Configuration window.

The Joins sheet, shown in the following image, is then displayed.

Creating joins is further described in the following subsections.

- Selecting the Collections to Join
- Selecting the Fields to Join
- Creating Selection Criteria for Your Join
Selecting the Collections to Join

To select the collections to join

1. In the Join pane at the top left of the sheet, click the Add button.
   The Add Join dialog, shown in the following image, is then displayed.

   ![Add Join Dialog](image)

2. In the Join Name text box, enter a name for your join.
3. Select a collection to join in the Join Left Hand Collection list box and then select the collection to which it is to join in the Join Right Hand Collection list box.
   The collections that are displayed are those that you have included in your reporting view. For details, see "Building Your JADE Root Collection Paths", earlier in this chapter.
4. Click the OK button. Alternatively, click the Cancel button to abandon your selections.
   The joined collections are then displayed in the panes at the right of the window.

To change a join selection

1. Click the Change button in the Join pane of the Joins sheet. The Change Join dialog is then displayed.
2. In the Join Name text box, enter a name for your join.
3. Select a collection to join in the Join Left Hand Collection list box and then select the collection to which it is to join in the Join Right Hand Collection list box.
4. Click the OK button. Alternatively, click the Cancel button to abandon your selections.
   The joined collections are then displayed in the panes at the right of the window.

To delete a join

- Click the Delete button in the Join pane of the Joins sheet.

   A confirmation dialog is then displayed. Click the Yes button to confirm the deletion or click the Cancel button to abandon the deletion.
Selecting the Fields to Join

Select the fields that are to be joined between your two collections by using the graphical join feature displayed in the panes at the right of the Joins sheet.

To select the join fields, perform the following actions

- Click the field in the collection displayed on one side and then drag it to the field displayed in the collection on the other side.

A join line is then drawn between the two fields, as shown in the following image.

In the example shown in the previous image, two collections are joined based on the name fields in both collections. This enables report designers to design a report that in this case displays records in which agents are also clients.

By default, the join is based on a comparison relationship (join key) of is equal to. In the above example, this equates to producing records in which agents are clients and clients are agents. You can select a different relationship between the join fields, if required.

To select a different join key

1. Select a comparison value from the Comparison list box in the Join Relationship group box at the lower left of the Joins sheet.

   The available comparison operators are shown in the following image.

2. Negate the comparison by checking the NOT check box, if required.

   In the example in the previous image, negating the is greater than comparison that is selected changes the comparison to is NOT greater than. By default, the NOT check box is not checked.

3. If you do not want the comparison to be case-sensitive, uncheck the Case-sensitive check box. By default, the Case-sensitive check box is checked.

4. Click the Add button.
The new join key is then applied to the selected relationship. It is applied to the field selected in the collection on the left side in relation to the field selected on the right side.

To delete a join key

1. Select the join to delete by clicking the join line that is drawn between your joined collection fields.
   The Delete button in the Join Relationship pane is then enabled.
2. Click the Delete button.
   A confirmation dialog is then displayed. Click the Yes button to confirm the deletion or click the Cancel button to abandon the deletion.
   When you confirm the deletion, the join key is deleted and the line joining the collection fields is then removed.

Creating Selection Criteria for Your Join

Having selected the collections to join, you can make the join selective on the value of a field in one of the collections, if required.

With any field type, you can apply standard comparison operators to make your selection.

If a selection field is a string value, you can also use pattern matching with the starts with, ends with, and like comparison operators.

The is one of and is between operators enable you to specify multiple comparison values; for example, to specify a range of days that fall between certain dates.
To create selection criteria for your join

1. Click the Selection button in the Join pane at the top left of the Joins sheet.

   The Join Selection dialog, shown in the following image, is then displayed.

   ![Join Selection Dialog]

2. Select a field to use as a selection field from the Available Fields list box at the left of the dialog.

   The selected field and the right-pointing arrow are then highlighted. The list of fields in the Available Fields list box is derived from the collections that you have selected to join.

3. Click the right-pointing arrow to complete the selection. Alternatively, double-click the field to make the selection.

   The selected field is then displayed in the Selection Field list box at the right of the dialog. In the previous image, the client name field is selected.

4. Select an operator from the Operator list box at the right of the dialog.
In the following image, the operator **is equal to** is selected.

5. In the **Value** text box of the Join Selection dialog, enter a value with which your selection field is to be compared.

   If you use the **starts with**, **ends with**, or **like** comparison operators with a string value, you can also use pattern matching. If you use the **is one of**, or **is between** operators, you can also specify multiple values by adding them to the list of values. For details, see the instructions later in this section.

   In the following image, the value **Smith** has been entered.

   In the examples in steps 3 through 5 earlier in this instruction, the following selection formula has been built.

   \[
   \text{Clients: client name is equal to Smith}
   \]

   When this selection criterion is applied, the join applies only to clients named **Smith**.

6. **Check** the **Not** check box to negate your selection criterion formula.

   If you check this box, the formula that you have built as a selection criterion is negated. For example, if you formulated **Clients: client name is equal to Smith** and you then check the **Not** check box, your join criteria is based on all clients except those named **Smith**.

7. **Uncheck** the **Case-sensitive** check box if you do not want to apply case-sensitivity to your selection.

   The **Case-sensitive** check box is enabled only if your selection contains alphabetic characters. By default, this check box is checked.

8. **Click** the **Update Criteria** button to add your selection criterion formula to the **Selection Items** list box at the bottom of the sheet.

   You can enter any number of selection criteria. (Follow steps 2 through 8 of this instruction for each one that you create.) For example, you could add another formula, as follows.

   \[
   \text{Clients: email is null}
   \]
If you then check the **Not** check box for this formula, you effectively refine join criteria to those clients named **Smith**, but only those who have an e-mail address. The following image shows the **Selection Items** list box as it is displayed with these selection criteria applied.

9. Update a selection criterion in the **Selection Items** list box by double-clicking the entry, if required. The values are then redisplayed in the relevant controls and you can change them as required.

10. Click the **Close** button when you have completed your selections.

Using the **starts with**, **ends with**, or **like** comparison operators with string values enables pattern matching.

**To use pattern matching with string selection criteria**

1. Select one of the following operators from the **Operator** list box.
   - To compare a character or sequence of characters at the start of the selection string value, use **starts with**.
   - To compare a character or sequence or characters at the end of the selection string value, use **ends with**.
   - To apply pattern matching to the selection string value, use **like**.

2. Enter selection criteria in the **Value** text box, using a single pattern string. The pattern string can be any sequence of characters and it can include any of the following wildcard characters.
   - `?` or `_` representing any single character
   - `*` or `%` representing any substring sequence of one or more characters, including an empty substring

You can use the backslash character (`\`) to nullify any wildcard character so that it is treated as a normal character in the pattern string. For example, `\?` is treated as a literal question mark character (that is, `?`) and not as a wildcard character.

Selecting the **is one of** or **is between** comparison operators enables you to specify multiple comparison values.

**To specify multiple comparison values**

1. Select the **is one of** or **is between** comparison operator from the **Operator** list box.

A list box is then displayed underneath the **Value** text box, and two buttons are displayed to enable you to add multiple comparison values, as shown in the following image.

2. Specify a value in the **Value** text box and then click the **Add value to list button** to add this value to the list of comparison values. Add any additional values to the list, as required.
Chapter 3   Configuring the JADE Report Writer

3.  To remove a comparison value from the list, select the required value and then click the **Remove value from list** button.

   The selected value is then deleted from the list of comparison values.

4.  Click the **Update Criteria** button when you have finished building your list of selection values.

   The following image shows a selection item where the selection criterion is all client names between Smith and Jones.

![Selection Item Image]

**Obtaining Database Statistics**

Use the **Statistics** sheet of the JADE Report Configuration window to obtain statistics about class instances and collection dimensions.

» **To access the Statistics sheet**

  - Click on the **Statistics** tab of the JADE Report Configuration window.
The **Statistics** sheet, shown in the following image, is then displayed.

![Statistics Sheet](image)

The statistics are derived from the types and collections that you have included in your reporting view.

**To display class and collection statistics**

1. Select the **Statistics** sheet of the JADE Report Configuration window. A subset of your application is then displayed, as shown in the following image.

   ![Subset Display](image)

   These statistics can be used when running a report as part of the query optimization.

2. Expand the **Object** folder to display the classes and collections against which you want to run statistics.

3. Select the classes and collections against which you want to run statistics.

   To select more than one entity, use the standard action; that is, hold down the Shift key and then click the first and last entities in a range or hold down the Ctrl key and then click the entities you require that are not in a consecutive range.

4. Click the **Update** button to update statistics on the selected classes and collections.
The statistics are then updated, as shown in the following image of a typical statistics display.

For the selected classes, the display shows the number of instances of that class in your database. In the example in the above image, there are eight instances of the Agent class.

For selected collections, the display shows the average size of the collection and the standard deviation for that calculated average. In the example in the above image, the allSalesItems collection for the Agent class has an average of 13 entries over the eight agents in that class and the standard deviation is 4.17.

The allSalesItems collection for the Company class has an average size of 106 and a standard deviation of zero (0), as there is only one instance of the Company class, which encompasses all 106 sale items.

Using the JADE Report Configuration Menus

This section describes the JADE Report Configuration application menus in the following subsections.

- View Menu
- Folders Menu
- System Formats Menu
- Users Menu
- Configuration Menu
- Type Menu
- Edit Menu
- Window Menu
- Help Menu

View Menu

Use the commands in the View menu to manage your configuration views.
The View menu commands are listed in the following table, which also lists the subsections in this chapter that describe these commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>For details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Starts a new view</td>
<td>Creating a New Reporting View</td>
</tr>
<tr>
<td>Open</td>
<td>Opens an existing view</td>
<td>Opening a Reporting View</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes a view</td>
<td>Deleting a Reporting View</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the current reporting view</td>
<td>Closing a Reporting View</td>
</tr>
<tr>
<td>Unload definition</td>
<td>Extracts and stores a retrievable reporting view definition</td>
<td>Unloading a Reporting View Definition</td>
</tr>
<tr>
<td>Load definition</td>
<td>Loads an extracted reporting view definition</td>
<td>Loading a Reporting View Definition</td>
</tr>
<tr>
<td>Remove undefined</td>
<td>Removes unused reporting view definition</td>
<td>Removing Undefined View Items</td>
</tr>
<tr>
<td>Highlight changes</td>
<td>Highlights changed schema entities</td>
<td>Highlighting Changed Items</td>
</tr>
<tr>
<td>Validate</td>
<td>Validates your reporting view</td>
<td>Validating a Reporting View Definition</td>
</tr>
<tr>
<td>Build to file</td>
<td>Builds a default definition to file</td>
<td>Building a Default Reporting View Definition</td>
</tr>
<tr>
<td>Unload All</td>
<td>Extracts all report writer data to one file</td>
<td>Unloading All Report Writer Data to a Single File</td>
</tr>
<tr>
<td>Load All</td>
<td>Loads all report writer data from one file</td>
<td>Loading All Report Writer Data from One File</td>
</tr>
<tr>
<td>Usage</td>
<td>Displays the reports that use this reporting view</td>
<td>Checking Your Reporting View Usage</td>
</tr>
<tr>
<td>Exit Configuration</td>
<td>Closes the JADE Report Writer application</td>
<td></td>
</tr>
</tbody>
</table>

**Folders Menu**

Use the commands in the Folders menu to create and maintain folders that contain your report designs.

Folders enable you to organize your report designs. Although the use of folders is not mandatory, if you intend to create many reports, a means of grouping them for ease of reference, distribution of work, and for security purposes is advisable.

The commands in the Folders menu are listed in the following table and are described in the subsections that follow.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maintain</td>
<td>Maintains your folder hierarchy and content</td>
</tr>
<tr>
<td>Unload</td>
<td>Saves an extracted definition of your folders</td>
</tr>
<tr>
<td>Load</td>
<td>Loads your folder extract file</td>
</tr>
</tbody>
</table>

**Maintain Command**

Use the **Maintain** command to access the Folder Maintenance window that enables you to create and maintain your folders.
You can use the Folder Maintenance window to work with folders or you can use the List command to also view and maintain the names and locations of the reports stored inside your folders.

Folder maintenance is described in the following subsections.

- Accessing the Folder Maintenance Window
- Listing Folder Contents
- Creating a New Folder
- Using the Folder Edit Commands
- Closing the Folder Maintenance Window

### Accessing the Folder Maintenance Window

To access the Folder Maintenance window, perform one of the following actions:

- Select the Maintain command from the Folders menu.

Select the Folder Maintenance command of the Configuration menu when you have an open reporting view.

The Folder Maintenance window, shown in the following image, is then displayed.

![Folder Maintenance Window](image)

Two parent folders are provided, by default. These folders, named Reports and Templates, are designed to enable you to store reports and templates in separate locations. However, you can rename these folders to support your own naming or filing convention, if required. For details, see "Using the Folder Edit Commands", later in this chapter.
Within the supplied parent folders, you can create any number of folders and any number of levels of folders within folders, as shown in the following image.

### Listing Folder Contents

**To list folder contents**

1. Click the List toolbar button.

   The reports and templates contained in your folders are then displayed, as shown in the following image.

```
Initially, only the contents of the first level of folders are listed. Open a lower-level folder to display its contents.

2. To hide the reports and templates contained in your folders, click the List button while reports and templates are displayed. The folder contents are then hidden again.
```
Creating a New Folder

To create a new folder

1. Click the parent folder in which you want to create the new folder.

2. Perform one of the following actions.
   - Click the New toolbar button.
   - Select the New Folder command from the Edit menu.

The new folder is then added as a child folder to the selected folder, as shown in the following image in which a new child folder has been added to the Reports parent folder. The default new folder name, New Folder, is displayed and selected, to enable you to enter a new folder name.

3. Type a name for the new folder and then press the Enter key or click anywhere in the window. You cannot use the slash character (/) in your folder name.

Using the Folder Edit Commands

This subsection describes the commands that are available from the Edit menu of the Folder Maintenance window and from the icon buttons on the toolbar.

To rename the selected folder, report, or template

1. Display the rename box by performing one of the following actions.
   - Click again on the selected folder, report, or template.
   - Click the Rename toolbar button.
   - Select the Rename command from the Edit menu.

The rename box, shown in the following image, is then displayed.

2. Enter the new name for the folder, report, or template.
   - You cannot use the slash character (/) in your folder name.

3. Click anywhere in the window or press the Enter key, to complete the name entry and save your new name.
The new name is then displayed for the selected folder, as shown in the following image.

![Folder renamed](image)

The renamed folder is repositioned in alphabetical order among all other folders at the same level.

**To delete the selected folder, report, or template, perform one of the following actions**

- Click the **Delete** toolbar button.
- Select the **Delete** command from the **Edit** menu.

A dialog is then displayed, prompting you to confirm the deletion. If you are deleting a parent folder, the dialog cautions you that you are also about to delete all of the subfolders. Click the **Yes** button to proceed with the deletion or click the **No** button to abandon the deletion.

**Note**  You cannot delete a folder while it, or one of its subfolders, contains templates or reports.

**To cut the selected folder, report, or template, perform one of the following actions**

- Click the **Cut** toolbar button.
- Select the **Cut** command from the **Edit** menu.

The folder (and all of its subfolders) is then copied to the clipboard and deleted from the current position. You can then paste the folder (along with its subfolders) within another parent folder (described later in this subsection).

When you cut and paste a folder, all of the contents of the folder (any subfolders and reports or templates contained in that folder) are moved with that folder.

**Note**  You cannot cut the default folders provided by the Report Writer Configuration application.

**To copy the selected folder, perform one of the following actions**

- Click the **Copy** toolbar button.
- Select the **Copy** command from the **Edit** menu.

The folder (and all its subfolders) is then copied to the clipboard but remains in the current position. You can then paste the folder (along with its subfolders) within another parent folder (described later in this subsection). Only the folder (and its subfolders) is copied. The reports and templates contained in the folder are not copied.

**Notes**  You cannot copy the default folders provided by the Report Writer Configuration application.

You cannot copy reports or templates.

**To paste a copied or cut folder, or a cut report or template, into the selected parent folder, perform one of the following actions**

- Click the **Paste** toolbar button.
- Select the **Paste** command from the **Edit** menu.
The folder (and all of its subfolders), report, or template, is then moved from the clipboard into the selected parent folder. You cannot paste a folder into one of its own subfolders.

**Closing the Folder Maintenance Window**

To close the Folder Maintenance window, perform one of the following actions:

- Click the Close toolbar button.
- Click the Close button at the top right of the window.

The Folder Maintenance window is then closed and the originating window is displayed. If you accessed folder maintenance from the Configuration menu of the JADE Report Configuration View window, that window is then displayed.

If you accessed folder maintenance from the Folders menu of the JADE Report Configuration window, that window is then displayed.

**Unload Command**

Use the Unload command from the Folders menu to unload a definition of your folders to a file.

**Note** The Unload command unloads only a definition of the existing folder hierarchy and not the contents (reports and templates) of those folders. If you intend to backup your reports and templates to a separate file, use the Unload Definition command from the File menu of the JADE Report Writer Designer application. For details, see "Unload Definition Command", in Chapter 4.

**To unload your folders**

1. Select the Unload command from the Folders menu.

The Extract Folders dialog, shown in the following image, is then displayed.
2. Enter the full location and name for your folder definition file in the File Name text box or click the Browse button to display a common dialog in which you can select your file location and name.

3. Click the Extract button to save your folder definitions to the specified file. Alternatively, click the Close button to abandon the unload operation.

The folders are then saved to the specified file. For details about retrieving unloaded folders by using the Load command, see "Load Command", in the following subsection.

Load Command

Use the Load command from the Folders menu to load folders from your folder definition files.

To load your folders

1. Select the Load command from the Folders menu.

The Load Folders dialog, shown in the following image, is then displayed.

2. Enter the full location and name for your folder definition file in the File Name text box or click the Browse button to display a common dialog in which you can select your extract file location and name.

3. Click the Load button to load your folders. Alternatively, click the Close button to abandon the load.

The folders are then loaded into your report configuration.

For details about loading a report folder definition into an existing JADE user schema (for example, when you load a new user schema and there are associated JADE Report Writer report folders that are to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the JADE Development Environment User’s Guide or "Loading a Schema and Forms in Batch Mode", in the JADE Schema Load Utility User’s Guide.

System Formats Menu

Use the commands in the System Formats menu to set and maintain system-wide default values for your report formats. All system formats have default values. The Systems Formats menu is visible only when there is no reporting view open. You can override system formats in your JADE Report Writer Designer session. For details, see "Setting Report Formats", in Chapter 4.
The commands in the System Formats menu, listed in the following table, are described in the subsections that follow.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maintain</td>
<td>Maintains your system formats</td>
</tr>
<tr>
<td>Unload</td>
<td>Unloads your system formats to file</td>
</tr>
<tr>
<td>Load</td>
<td>Loads your system formats extract file</td>
</tr>
</tbody>
</table>

**Maintain Command**

Use the **Maintain** command from the System Formats menu to set and maintain the system formats that apply as default values in the JADE Report Writer Designer application.

To display the System Formats dialog, perform one of the following actions

- Select the **Maintain** command from the System Formats menu.
- Select the **System Formats** command from the Configuration menu when you have an open reporting view.

The System Formats dialog is then displayed with the **Number** sheet uppermost.

The following table lists the sheets of the System Formats dialog.

<table>
<thead>
<tr>
<th>Sheet</th>
<th>Enables you to set default…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>Number formats</td>
</tr>
<tr>
<td>Currency</td>
<td>Currency formats</td>
</tr>
<tr>
<td>Date</td>
<td>Date formats</td>
</tr>
<tr>
<td>Time</td>
<td>Time formats</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>Timestamp formats</td>
</tr>
<tr>
<td>Boolean</td>
<td>Boolean formats</td>
</tr>
</tbody>
</table>

Each sheet of the System Formats dialog is described in the following subsections.

**Number Sheet**

Use the **Number** sheet of the System Formats dialog to set the default formats for numeric fields.
To set the default formats for numeric fields

1. Click the Number tab of the System Formats dialog.

The Number sheet, shown in the following image, is then displayed.

2. In the Negative list box (in the Default Whole Number Format group box or the Default Decimal Number Format group box), select the format you require when printing negative numbers.

   The default value is Leading Sign, which indicates that the negative sign (-) is printed to the left of the whole or decimal negative number without an intervening space.

3. In the 1000’s Separator text box (in the Default Whole Number Format group box or the Default Decimal Number Format group box), enter the character or characters that you want to use to separate thousands.

   The default value is a comma character (,). The maximum number of separator characters is three.

4. In the Decimal Separator text box of the Default Decimal Number Format group box, enter the character that you want to use to separate the whole numbers from the decimals in place of the decimal point.

   The default value is a period character (.). The maximum number of separator characters is three.

5. In the Decimals text box of the Default Decimal Number Format group box, enter the number (in the range 0 through 9) of decimal places that you want printed.

   The default value of 2 indicates that decimal numbers are printed to two decimal places.

6. Uncheck the Show Leading Zero for Decimals check box of the Default Decimal Number Format group box to suppress the printing of zero (0) in front of the decimal point when the number is less than 1.
By default, the **Show Leading Zero for Decimals** check box is checked (that is, leading zeros are printed).

7. Check the **Suppress If Zero** check box (in the Default Whole Number Format group box or the Default Decimal Number Format group box) to suppress the printing of a whole or decimal number if it is zero (0).

By default, the **Suppress If Zero** check box is unchecked, indicating that the whole or decimal number is printed if it is zero (0).

8. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

9. Click the **Apply** button to apply the changes that you have made or click the **Close** button to close the System Formats dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.

**Currency Sheet**

Use the **Currency** sheet of the System Formats dialog to set the default formats for currency fields.

> **To set the default formats for currency fields**

1. Click the **Currency** tab of the System Formats dialog.

   The **Currency** sheet, shown in the following image, is then displayed.

2. In the **Positive** list box, select how you want the currency symbol printed in relation to the currency amount
for a positive currency value.

The default value is **Leading Symbol**, indicating that the currency sign is printed to the left of the currency amount without an intervening space.

3. In the **Negative** list box, select how you want a negative currency amount printed.

The default value is **Sign, Symbol, Number**, indicating that the negative sign is printed to the left of the currency symbol which is printed to the left of the currency amount and that there are no intervening spaces.

4. In the **Currency Symbol** text box, enter the currency symbol that you require.

The default value is the standard dollar sign ($).

5. In the **1000's Separator** text box, enter the character or characters that you want to use to separate the thousands in your currency amount.

The default value is a comma character (,). The maximum number of separator characters is three.

6. In the **Decimals Separator** text box, enter the character that you want to use to separate the whole numbers from the decimals in your currency amount.

The default value is a period character (.). The maximum number of separator characters is three.

7. In the **Decimals** text box, enter the number (in the range 0 through 9) of decimal places that you want printed.

The default value is 2.

8. Uncheck the **Show Leading Zero for Decimals** check box to suppress the printing of zero (0) in front of the decimal point when the currency amount is less than 1.

By default, leading zeros are printed with currency amounts of less than 1.

9. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

10. Click the **Apply** button to apply the changes that you have made or click the **Close** button to close the System Formats dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**Date Sheet**

Use the **Date** sheet of the System Formats dialog to set the default formats for date fields.

**Note** When entering separator text for long or short date formats in any of the controls in this dialog, you cannot use more than three characters as separator text. If the separator text contains any of the characters d, M, y, g, h, H, m, s, or t, they are removed.

The apostrophe character (‘) is not displayed as such when used as a separator.
To set the default formats for date fields

1. Click the Date tab of the System Formats dialog.

The Date sheet, shown in the following image, is then displayed.

![System Formats](image)

2. In the Order list box (Default Short Date Format group box or the Default Long Date Format group box), select how you want the date order printed; that is, the sequence of day, month, and year. The default value is Day, Month, Year.

3. In the Separator text box of the Default Short Date Format group box, enter the character that you want to use to separate the numbers of your short date format. The default value is the slash character (/).

4. In the Day Name list box of the Default Long Date Format group box, select the way in which you want the day of the week printed.

Select the full day name or the day name abbreviated to the first three letters of the day name; for example, Wed for Wednesday. By default, the full day name is printed.

5. In the Day combo box (Default Short Date Format group box or Default Long Date Format group box), select the way in which you want the day number printed when the day number is less than 10.

Select the option to print the leading zero (0) or not to print the leading zero. By default, the leading zero is printed; for example, 05.

6. In the Day Separator text box of the Default Long Date Format group box, enter the character or characters that you want to use to separate the day name from the remainder of the date in your printed dates.

The usual preferences are a comma character (,) or a comma followed by a space ( , ).
The default value is a single-character comma (shown in the sample in the previous image). If you do not enter a separator character, there is always a space between the day name and the remainder of the date. The maximum number of separator characters is three.

7. In the Month combo box of the Default Short Date Format group box, select the way in which you want the month number printed when the month number is less than 10.

Select the option to print the leading zero (0) or not to print the leading zero. By default, the leading zero is printed; for example, 09.

8. In the Month list box of the Default Long Date Format group box, select the way in which you want the month printed in the long date format.

The month portion of the date can be printed as the full name of the month (for example, September), the abbreviated name of the month (for example, Sep), the number of the month with a leading zero for months less than ten (09), or the month number alone (9).

By default, the abbreviated name of the month is printed; for example, Sep.

9. In the Year combo box (in the Default Short Date Format group box or the Default Long Date Format group box), select the way in which you want the year printed. Select the four-digit format or the two-digit format. By default, the four-digit format is printed; for example, 2004.

10. In the Date Separator text box of the Default Long Date Format group box, enter the character or characters that you want to use to separate the day, month, and year parts of your printed dates as an alternative to a space.

If no character is entered in this text box, a space is used. The character that you enter replaces the space; for example, if you enter a comma character (,), the result is that a comma character alone is printed between the parts of the date.

By default, there is no entry; that is, one space is printed between the day, month, and year (shown in the sample in the previous image). The maximum number of separator characters is three.

11. Uncheck the Default to Short Date Format check box if you want dates printed in long date format in the JADE Report Writer Designer application. The Default to Short Date Format check box is checked, by default.

12. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

13. Click the Apply button to apply the changes that you have made or click the Close button to close the System Formats dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

**Time Sheet**

Use the Time sheet of the System Formats dialog to set the default formats for time fields.
To set the default formats for time fields

1. Click the Time tab of the System Formats dialog. The Time sheet, shown in the following image, is then displayed.

![System Formats dialog](image)

2. Select the 12 Hour Clock option button if you want your report times printed in the 12-hour clock format or the 24 Hour Clock option button if you want your report times printed in the 24-hour clock format. The default value is 12 Hour Clock.

3. Check the Show Seconds check box if you want to include seconds in your printed times. By default, this check box is unchecked, indicating that seconds are not printed.

4. Uncheck the Show Time Marker as Suffix check box if you want the time marker printed as a prefix to the time value; for example, pm12:06.

   For 12-hour clock format, the default time markers are am and pm. You can change these, by using the Marker text box, described later in this instruction.

   The Show Time Marker as Suffix check box is checked by default, indicating that the time marker is printed as a suffix to the time value.

5. Uncheck the Show Leading Zero for Hours < 10 check box if you want to suppress the printing of the leading zero (0) when the hour value is less than 10.

   The Show Leading Zero for Hours < 10 check box is checked by default, indicating that the leading zero (0) is printed when the hour value is less than 10; for example, 09:06pm.

6. In the Separator text box, enter the character that you want to separate the hours and minutes (and seconds,
if the **Show Seconds** check box is checked) of your default time format.

The default value is a colon character (\(\colon\)).

You cannot use more than three characters as separator text. If the separator text contains any of the \(d, M, y, g, h, H, m, s,\) or \(t\) characters, they are removed. The apostrophe character (‘) is not displayed as such when used as a separator character.

7. In the **Marker** text box, enter time markers to indicate pre-noon and post-noon times.

   If you selected the **12 Hour Clock** option button, the default markers are **am** and **pm**. If you want to create your own default markers, enter up to 30 characters in the **Marker** text box.

   If you selected the **24 Hour Clock** option button, only one **Marker** text box is displayed. If you want a marker printed against the times in your report, enter up to 30 characters in the **Marker** text box. By default, there is no marker for the **24 Hour Clock** option.

8. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

9. Click the **Apply** button to apply the changes that you have made or click the **Close** button to close the System Formats dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**TimeStamp Sheet**

Use the **TimeStamp** sheet of the System Formats dialog to set the default formats for timestamp fields.

Timestamps are variables made from a concatenation of date and time values. In JADE, they are mostly used to flag the precise time that objects are created.

**Note** When entering separator text for long or short date formats and time formats in any of the controls in this dialog, you cannot use more than three characters as separator text. If the separator text contains any of the characters \(d, M, y, g, h, H, m, s,\) or \(t\), they are removed.

The apostrophe character (‘) is not displayed as such when used as a separator.
To set the default formats for timestamp fields

1. Click the **TimeStamp** tab of the System Formats dialog.

   The **TimeStamp** sheet, shown in the following image, is then displayed.

   ![System Formats dialog](image)

   There are two further sheets on this dialog, which enable you to specify the timestamp format display of dates and times. They are enabled when the corresponding **Show Date** and **Show Time** check boxes are checked. The **Date** sheet is selected by default, as shown in the above image.

2. Uncheck the **Show Date** check box to print only the time portion of the timestamp.

   This check box is checked by default, indicating that both the date portion and the time portion of the timestamp are printed. When this check box is checked, the **Date** sheet on this dialog is enabled to further specify the default date format.

3. Uncheck the **Show Time** check box to print only the date portion of the timestamp.

   This check box is checked by default, indicating that the date portion and the time portion of the timestamp are printed. When this check box is checked, the **Time** sheet on this dialog is enabled so that you can further specify the default time format.

4. In the Order group box, click the **Date Then Time** option button to print the date portion of the timestamp in front of the time portion; for example, **09/02/2004 02:18**.

   This option is selected by default, indicating that the date portion of the timestamp is printed in front of the time portion. Alternatively, click the **Time Then Date** option button to print the time portion of the timestamp in front of the date portion; for example, **02:18 09/02/2004**.
This group box is enabled only when the Show Date and Show Time check boxes are checked.

5. In the Date/Time Separator text box, enter the character or characters that you want to use to separate the date portion from the time portion of the timestamp. The default value is a single space.

   This text box is enabled only when the Show Date and Show Time check boxes are checked.

6. Click on the Date tab to display the Date sheet, which enables you to specify options for the default display of dates, as follows.

   a. Select the Use Short Date option button if you want the date portion of the timestamp to use the short date format. The short date format does not include the day name; for example, 0902200402:18.

      The default value is Use Short Date.

   b. Select the Use Long Date option button if you want the date portion of the timestamp to use the long date format. The long date format includes the day name; for example, Fri/09/02/200402:18.

   c. In the Order list box, select how you want the date order printed; that is, the sequence of day, month, and year.

      The default value is Day, Month, Year.

   d. In the Separator text box (visible only if you selected the Use Short Date option button), enter the character that you want to use to separate the numbers of your short date format.

   e. In the Day Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the day portion from the date portion of the timestamp.

      By default, there is no separator.

   f. In the Date Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the date portion from the time portion of the timestamp.

      By default, there is no separator.

   g. In the Day Name list box (visible only if you selected the Use Long Date option button), select the way in which you want the day of the week printed.

      Select either the full day name or the day name abbreviated to the first three letters; for example, Wed for Wednesday. By default, the abbreviated day name is printed.

   h. In the Day list box, select the way in which you want the day number printed when the day number is less than 10.

      Select the option to print the leading zero (0) or not to print the leading zero. By default, the leading zero is printed; for example, 05.

   i. In the Day Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the day value from the month value in the date portion of the timestamp.

      The default value is the slash character (/).

   j. In the Month list box, select the way in which you want the month number printed when the month number is less than 10. By default, the leading zero is printed; for example, 09.

      Select the option to print the leading zero (0) or not to print the leading zero.

   k. In the Date Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the month value from the year value in the date portion of the timestamp.
The default value is the slash character (/).

i. In the **Year** list box, select the way in which you want the year printed. Select the four-digit format or the two-digit format. The default value is the four-digit format; for example, 2004.

7. Click on the **Time** tab to display the **Time** sheet, to specify options for the default display of the time portion of the timestamp.

The **Time** sheet, shown in the following image, is then displayed.

![Time sheet](image)

- **a.** Define time formats, perform the following actions, if required.
- **b.** Select the **12 Hour Clock** option button if you want your report times printed in the 12-hour clock format or the **24 Hour Clock** option button if you want your report times printed in the 24-hour clock format.

  The default value is **12 Hour Clock**.

- **c.** Check the **Show Seconds** check box if you want to include seconds in your printed times.

  This check box is unchecked by default, indicating that seconds are not printed.

- **d.** Uncheck the **Show Time Marker as Suffix** check box if you want the time marker printed as a prefix to the time value; for example, **pm12:06**.

  For the 12-hour clock format, the default time markers are **am** and **pm**. You can change these, by using the **Marker** text boxes, described later in this instruction.

  The **Show Time Marker as Suffix** check box is checked by default, indicating that the time marker is printed as a suffix to the time value.

- **e.** Uncheck the **Show Leading Zero for Hours < 10** check box if you want to suppress the printing of the leading zero (0) when the hour value is less than 10.

  This check box is checked by default, indicating that the leading zero is printed when the hour value is less than 10; for example, **09:06pm**.

- **f.** In the **Separator** text box, enter the character that you want to separate the hours and minutes (and seconds, if the **Show Seconds** check box is checked) of your default time format.

  The default value is a colon character (:).

- **g.** In the **Marker** text boxes, enter time markers to indicate pre-noon and post-noon times.

  If you selected the **12 Hour Clock** option button, there are two **Marker** text boxes for pre-noon and post-noon times, respectively. The default values for these markers are **am** and **pm**. If you want to create your own default markers, enter up to 30 characters in the **Marker** text box.
If you selected the 24 Hour Clock option button, only one Marker text box is displayed. If you want a marker printed against the times in your report, enter up to 30 characters in the Marker text box. By default, there is no marker for the 24 Hour Clock option.

8. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

9. Click the Apply button to apply the changes that you have made or click the Close button to close the System Formats dialog.

   To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog.

   To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

### Boolean Sheet

Use the Boolean sheet of the System Formats dialog to set the default formats for Boolean fields.

**To set the default formats for Boolean fields**

1. Click the Boolean tab of the System Formats dialog.

   The Boolean sheet, shown in the following image, is then displayed.

2. In the Display When Value is TRUE text box, enter the text that you want printed when the Boolean value is true. The default value is true.
3. In the **Display When Value is FALSE** text box, enter the text that you want printed when the Boolean value is *false*. The default value is *false*.

4. Click another tab if you want to make changes on the other sheets of the System Formats dialog.

5. Click the **Apply** button to apply the changes that you have made or click the **Close** button to close the System Formats dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog.

   To abandon any changes that you have made but not yet applied, do *not* click the **Apply** button immediately prior to clicking the **Close** button.

### Unload Command

Use the **Unload** command from the System Formats menu to unload your system formats to a file.

» **To unload your system formats**

1. Select the **Unload** command from the System Formats menu.

   The Unload System Formats dialog, shown in the following image, is then displayed.

![Unload System Formats dialog](image)

2. Enter the full location and name for your formats definition file in the **File Name** text box or click the **Browse** button to display a common dialog in which you can select your file location and name.

3. Click the **Extract** button to save your system formats to the specified file.

   Alternatively, to abandon the unloading process, click the **Close** button without unloading system formats.

   The system formats are then saved to the specified file. For details about retrieving system formats saved to files by using the **Load** command, see "Load Command", in the following subsection.
Load Command

Use the **Load** command from the System Formats menu to load system formats from a system formats definition file.

For details about loading report format definitions into an existing JADE user schema (for example, when you load a new user schema and there are associated JADE Report Writer report formats that are to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the JADE Development Environment User’s Guide, or "Loading a Schema and Forms in Batch Mode", in the JADE Schema Load Utility User's Guide.

**To load your system formats**

1. Select the **Load** command from the System Formats menu.

   The Load System Formats dialog, shown in the following image, is then displayed.

   ![Load System Formats Dialog](image)

   2. Enter the full location and name for your system formats definition file in the **File Name** text box or click the **Browse** button to display a common dialog in which you can select your file location and name.

   3. Click the **Load** button to load your system formats from the specified file. Alternatively, click the **Close** button to abandon the loading of system formats.

   The system formats are then loaded into your report configuration.

Users Menu

Use the commands in the Users menu to set default options that you want to apply to your JADE Report Writer sessions.

You can override user options in your JADE Report Writer Designer session. For details, see "Setting User Preferences", in Chapter 4. All user options have default values.
The commands in the Users menu are listed in the following table and are described in the subsections that follow.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferences</td>
<td>Maintains your user preferences</td>
</tr>
<tr>
<td>Unload</td>
<td>Unloads your user preferences to a file</td>
</tr>
<tr>
<td>Load</td>
<td>Loads your user preferences from an extract file</td>
</tr>
</tbody>
</table>

**Preferences Command**

Use the Preferences command from the Users menu to set default preferences that you want to apply to your JADE Report Writer Designer and JADE Report Writer Configuration sessions.

To display the User Preferences dialog, perform one of the following actions:

- Select the Preferences command from the Users menu.
- Select the User Preferences dialog by selecting the User Preferences command of the Configuration menu when you have an open reporting view.

The Options sheet of the User Preferences dialog, shown in the following image, is then displayed.
To set your report preferences on the Options sheet of the User Preferences dialog

1. To automatically align your report fields so that they are attached to the nearest point on the grid, check the Snap to Grid check box. By default, this option is not activated and report fields are not attached to the nearest grid point.

   Note  Use the grid to facilitate the precise placement of items in your layout. The controls in the Grid Options group box (see steps 1 through 5 of this instruction) provide options that enable you to align fields to the grid, show or hide the grid, and customize the look of the grid.

   Although the grid helps you to place items on your layout, the grid display is optional.

2. To disable the grid lines on your report design layout, uncheck the Show Grid Lines check box. The grid lines are displayed, by default.

3. In the Grid Width text box, enter the width in pixels of your grid columns, if required. The default value is 8 pixels.

4. In the Grid Height text box, enter the height in pixels of your grid rows, if required. The default value is 22 pixels.

   Note  A pixel is a picture element and is the smallest element that can be displayed on the screen.

5. In the Grid Style list box, select a style for your grid lines, if required. The grid styles are listed in the following table.

<table>
<thead>
<tr>
<th>Grid Style</th>
<th>Grid lines are…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dot at Grid Intersection</td>
<td>Formed from dots</td>
</tr>
<tr>
<td>Cross at Grid Intersection</td>
<td>Formed from crosses</td>
</tr>
<tr>
<td>Grid Lines</td>
<td>Solid lines</td>
</tr>
</tbody>
</table>

   The default value is Dot at Grid Intersection.

6. To remove the horizontal ruler from the display, uncheck the Show Horizontal Ruler check box. The horizontal ruler is displayed, by default.

7. To remove the vertical ruler from the display, uncheck the Show Vertical Ruler check box. The vertical ruler is displayed, by default.

8. To display bubble help captions in your JADE Report Writer Configuration window when configuring your views, check the Show View bubble help check box. When bubble help is displayed for reporting views, resting the cursor on a class or feature for a few seconds displays a description of the class, property, method, or collection.

9. To display section (frame) names inside the sections of the report design layout as background images, check the Show Watermark check box. This provides a wider layout on which to design your report.

   By default, the display shows the section (frame) names to the left of the report design layout.

10. In the Keep Last Used # text box, enter the number of entries for recently opened report designs to be displayed at the bottom of the File menu, if required.

   Tip   The last-used list provides you with a quick way of opening a recently used report design.

11. To display the field description instead of the text field captions within the field delimiters on your report...
design layout, uncheck the **Show Text Field Caption, instead of Description** check box.

This check box is checked by default, which means that text field captions are displayed. Text field captions show the basic format of the field; that is, a series of X characters for string fields and a series of 9 characters for numeric fields. The number of characters displayed reflects the maximum length of the field.

The following image on the left shows two database fields with their text field captions displayed. (The top field is a currency field that shows the dollar currency symbol.) In the image on the right, the field descriptions are displayed within field delimiters.

The parameter, script, or summary field name is always displayed on the status bar when a field of that type is selected.

12. To bypass the Welcome dialog when you start your JADE Report Writer Designer session, uncheck the **Show the Welcome dialog when Report Designer is initiated** check box. This check box is checked by default, indicating that the Welcome dialog is displayed when you start your JADE Report Writer Designer session.

For details about using the Welcome dialog, see "Opening an Existing Report" or "Starting a Report from Scratch", in Chapter 4.

13. To set the toolbars that are displayed in the JADE Report Designer application, click the **Toolbars** tab to display the **Toolbar** sheet.
The toolbar sheet, shown in the following image, is then displayed.

![User Preferences for Samuel Butler](image)

- To use the toolbar sheet to set the way the toolbars are displayed
  - In the **Toolbars** list box, click one of the toolbar titles to change the display status of the toolbar.

Highlighted (white on blue background) toolbars are visible on the JADE Report Designer window. Non-highlighted toolbars are hidden (for example, the **Alignment Tools** in the previous image). All toolbars are displayed, by default.

**Note** You can relocate a visible toolbar by clicking and dragging the icon that is positioned at the left of the toolbar.

For details about using the toolbars, see "Using the Layout Commands", in Chapter 4. For details about the Quick Launch Tools toolbar, see "Using the Quick Launch Tools", in Chapter 4.

- To apply your user preferences settings
  1. Click the **Apply** button.
  2. Click the **Close** button if you do not want to make more preference changes.

Your user preferences are then applied.

**Unload Command**

Use the **Unload** command from the Users menu to save a definition file of your user preferences.
To unload your user preferences

1. Select the Unload command from the Users menu. The Extract Users dialog, shown in the following image, is then displayed.

![Extract Users dialog](image)

2. Enter the full location and name for your file in the File Name text box or click the Browse button to display a common dialog in which you can select your user preferences definition file location and name.

3. To save your user preferences to the specified file, click the Extract button. Alternatively, click the Close button to abandon the unloading process.

Your user preferences are then saved to the specified file. For details about retrieving user preferences saved to a definition file by using the Load command, see "Load Command", in the following subsection.

Load Command

Use the Load command from the Users menu to load user preferences from a file.

To load your user preferences

1. Select the Load command from the Users menu. The Load Users dialog, shown in the following image, is then displayed.
2. Enter the full location and name for your user preferences file in the File Name text box or click the Browse button to display a common dialog in which you can select your file location and name.

3. Click the Load button to load your user preferences. Alternatively, click the Close button to abandon the load process.

The user preferences are then loaded into your report configuration.

For details about loading user preferences into an existing JADE user schema (for example, when you load a new user schema and there are associated JADE Report Writer user options that are to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the JADE Development Environment User's Guide, or "Loading a Schema and Forms in Batch Mode", in the JADE Schema Load Utility User's Guide.

Configuration Menu

Use the commands in the Configuration menu to set system formats, user preferences, and maintain report folders.

The Configuration menu is available only when a reporting view is open.

The commands in the Configuration menu are listed in the following table and are described in the following subsections.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Formats</td>
<td>Sets system properties and formats</td>
</tr>
<tr>
<td>Folder Maintenance</td>
<td>Maintains folders for storage of reports</td>
</tr>
<tr>
<td>User Preferences</td>
<td>Sets system-wide user preferences</td>
</tr>
<tr>
<td>Exit Configuration</td>
<td>Exits from the Report Writer Configuration application</td>
</tr>
</tbody>
</table>
System Formats Command

Use the System Formats command from the Configuration menu to change the initial system default values for report formats. You can override default system formats in the JADE Report Writer Designer application, if required. For details, see "Setting Report Formats", in Chapter 4.

All system formats have default values, set when your version of JADE Report Writer is installed. You can change these default values to apply to all reports and tailor them for each individual report.

To display the System Formats dialog, perform one of the following actions

- Select the System Formats command from the Configuration menu.
- Select the Maintain command from the System Formats menu on the JADE Report Configuration window when there is no reporting view open.

The System Formats dialog is then displayed with the Number sheet uppermost. For details about using the System Format dialog, see "Maintain Command" under "System Formats Menu", earlier in this chapter.

Folder Maintenance Command

Use the Folder Maintenance command from the Configuration menu to create and maintain the folders that contain your report designs.

Folders provide a means of organizing your report designs. Although the use of folders is not mandatory, if you intend to create many reports, a means of grouping them for ease of reference, distribution of work, and for security purposes is advisable.

To access the Folder Maintenance window, perform one of the following actions

- Select the Folder Maintenance command from the Configuration menu. The Configuration menu is available only when at least one reporting view is open.
- Select the Maintain command from the Folders menu when you do not have an open reporting view.

For details about folder maintenance, see "Maintain Command" under "Folders Menu", earlier in this section.

User Preferences Command

Use the User Preferences command from the Configuration menu to set default options that you want to apply to your JADE Report Writer Designer and JADE Report Writer Configuration sessions for an individual user.

To access the User Preferences dialog, perform one of the following actions

- Select the User Preferences command from the Configuration menu.
- Select the Preferences command from the Users menu on the JADE Report Configuration window when there is no open reporting view.

The Options sheet of the User Preferences dialog is then displayed. For details about using the User Preferences dialog, see "Preferences Command" under "Users Menu", earlier in this section.

Type Menu

Note  This menu is titled Type, Feature, Join, or Collection, depending on the kind of item that you have selected.
Use the **Usage** command from the Type menu, Feature menu, Join menu, or Collection menu to display the names of the reports in which the selected type, feature, join, or collection is used.

**To display the usage of the selected type, feature, join, or collection**

1. Select the type, feature, join, or collection whose usage you want to display.
2. Select the **Usage** command from the appropriate menu.

The Where Used dialog, shown in the following image, is then displayed, listing the reports in which the selected type, feature, join, or collection is used.

![Where Used Dialog](image)

### Feature Menu

For details, see "**Type Menu**", earlier in this section.

### Collection Menu

For details, see "**Type Menu**", earlier in this section.

### Join Menu

For details, see "**Type Menu**", earlier in this section.

### Edit Menu

Use the commands on the Edit menu to further manage your selection of types and features.

The commands in the Edit menu are listed in the following table and are described in the following subsections.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Moves the selected type, feature, or collection to the clipboard</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected type, feature, or collection to the clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes a type, feature, or collection from the clipboard into another reporting view</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delete</td>
<td>Removes a type, feature, or collection from the appropriate pane</td>
</tr>
<tr>
<td>Rename</td>
<td>Changes the alias name of the selected type, feature, or collection</td>
</tr>
<tr>
<td>Find Class</td>
<td>Searches for a class in the Classes and Interfaces pane</td>
</tr>
</tbody>
</table>

**Cut Command**

Use the **Cut** command from the Edit menu to move one or more types, features, or collections from the appropriate pane to the clipboard.

The selected types, features, or collections are then removed from the appropriate pane and stored in the clipboard to enable you to paste them from the clipboard into another view.

» **To cut the selected types, features, or collections, perform one of the following actions**

  - Select the **Cut** command from the Edit menu
  - Press Ctrl+X

The selected types, features, or collections are then moved to the clipboard.

**Copy Command**

Use the **Copy** command from the Edit menu to copy one or more types, features, or collections from the appropriate pane to the clipboard.

The selected types, features, or collections are then copied from the appropriate pane and stored in the clipboard to enable you to paste them from the clipboard into another view.

» **To copy the selected types, features, or collections, perform one of the following actions**

  - Select the **Copy** command from the Edit menu
  - Press Ctrl+C

The selected types, features, or collections are then copied to the clipboard.

**Paste Command**

Use the **Paste** command from the Edit menu to paste the contents of the clipboard into another reporting view.

**Note** The types, features, or collections that you are pasting must exist in the schema upon which the target reporting view is based.

» **To paste copied or cut types, features, or collections to a different reporting view, perform one of the following actions**

  - Select the **Paste** command from the Edit menu
  - Press Ctrl+V

The contents of the clipboard are then pasted into the appropriate pane of the target reporting view.
Delete Command

Use the Delete command from the Edit menu to remove a type, feature, or collection from the appropriate pane.

To remove the selected type

- Select the Delete command from the Edit menu

The selected type, feature, or collection is then removed from the appropriate pane.

You can also remove types, features, and collections from within the JADE Report Configuration window. For details, see "Removing Types and Features", earlier in this chapter.

Rename Command

Use the Rename command from the Edit menu to change the alias name of a selected type, feature, or root collection.

To rename the selected type, feature, or root collection

- Select the Rename command from the Edit menu

A box is then displayed around the selected type, feature, or root collection, enabling you to type a new alias name.

You can also change the alias name of types, features, and collections from within the JADE Report Configuration window. For details, see "Selecting the Types for Your View" and "Selecting the Features for Your View", earlier in this chapter.

Find Class Command

Use the Find Class command from the Edit menu to locate a class in the currently selected schema.

You can select the Find Class command from the Type and Features sheet or the Root Collections sheet of your JADE Report Configuration window.

To find a class for the currently selected schema

1. To display the Find Class dialog, perform one of the following actions.
   - Select the Find Class command from the Edit menu.
   - Press F4.
The Find Class dialog, shown in the following image, then displays an alphabetical list of classes.

![Find Class dialog](image)

2. Enter the class that you want to find in the **Find Class** text box or select it from the **Select Required Class** list box.

   When you enter the first few characters of your class in the **Find Class** text box, the focus in the **Select Required Class** list box moves down to the classes that start with those characters. In the previous image, as the letter **S** has been entered, the focus has moved down to those classes beginning with that letter.

   You therefore do not have to remember or type in all characters of the class name to select the class that you want to locate if the class is not displayed in the list box at first.

3. Click the **OK** button to start the search.

   Alternatively, click the **Cancel** button to abandon the search.

   The selected class is then highlighted in the **Classes and Interfaces** pane of the Reporting View Configuration window.

**Window Menu**

The Window menu provides standard commands that enable you to select tiling or cascading of windows. It also displays a list of the currently enabled windows.

The commands in the Window menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Arranges open windows in an overlapping pattern</td>
</tr>
<tr>
<td>Tile Horizontal</td>
<td>Resizes and arranges windows horizontally without overlap</td>
</tr>
<tr>
<td>Tile Vertical</td>
<td>Resizes and arranges windows vertically without overlap</td>
</tr>
</tbody>
</table>

For details, see "Using the Window Menu", in Chapter 2.
Help Menu

Use the commands in the Help menu to access the online *JADE Report Writer User’s Guide* for help and to display current version information for the JADE Report Writer application.

The commands in the Help menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Displays details about the current version of the JADE Report Writer application</td>
</tr>
</tbody>
</table>

For details, see "Using the Online User's Guide" or "Displaying JADE Report Writer Application Version Information" under "Using the Help Menu", in Chapter 2.
Chapter 4  Designing JADE Reports

This chapter covers the following topics.

- Overview
- Opening a New or Existing Report Design
  - Starting a Report from Scratch
  - Opening an Existing Report
  - Starting a Template
  - Opening a Template
- Using the Sections of a Report
  - Report Section Descriptions
  - Creating and Manipulating Extra Frames
  - Changing the Section Properties
- Designing a Report
  - Using Administrative Functions
  - Using the Detail Functions
- Using the JADE Report Writer Designer Menus
  - File Menu
  - Edit Menu
  - View Menu
  - Insert Menu
  - Report Menu
  - Profile Menu
  - Layout Menu
  - Window Menu
  - Help Menu

Overview

The JADE Report Writer Designer application enables you to define the layout and content of your reports. It provides you with a graphical approach to designing your reports, enabling you to place text, database fields, and graphics in the appropriate places on the report and then providing the option to set properties for those items.

Report designs must be based upon a previously created reporting view. For details about creating a reporting view, see "Configuring the JADE Report Writer", in Chapter 3.
Chapter 4    Designing JADE Reports

The JADE Report Writer Designer application incorporates the following features.

- Full graphical interface for designing reports
- Creation and use of templates
- Profiles to provide different views of the same report
- System preferences to tailor the report design formats
- User preferences for toolbar, layout, and appearance options
- Report options and formats for text, currency, numbers, date, and time
- Scripting facility for calculating and setting field values
- Report organization through group levels
- Report totals at group and report levels
- Sorting capability
- Header, footer, and page numbering at group and report levels
- Print preview

Select multiple items by:
- Clicking and dragging a rectangle so that all fields, lines, and boxes within the rectangle are selected
- Right-clicking in a report section and selecting the Select All command from the popup menu to select all fields, lines, and boxes in the section
- Selecting the Edit menu Select All command to select all fields, lines, and boxes in the report

Opening a New or Existing Report Design

Use the functions described in the following sections to start a new report or template, or to open an existing report or template.

- Starting a Report from Scratch
- Opening an Existing Report
- Starting a Template
- Opening a Template

For details about creating templates, see "Creating Templates", later in this chapter.

Starting a Report from Scratch

Start a new report from the Welcome dialog or from the New Report command on the File menu of the JADE Report Designer window. By default, the Welcome dialog is displayed when you initiate the JADE Report Writer Designer application. However, you can disable the Welcome dialog, in which case you start a new report using the New Report command.
Chapter 4  Designing JADE Reports

To create a new report from the Welcome dialog


   The Welcome to the JADE Report Designer dialog, shown in the following image, is then displayed.

   ![Welcome to the JADE Report Designer](image)

   - **Open a Report**: Select the desired report.
   - **Show this dialog at startup**: Check or uncheck as needed.

2. Click the New Report button.

   You can also create a new template by clicking the New Template button. For details about creating a new template, see "Opening a Template", later in this section.

3. If you do not want the Welcome dialog displayed at start-up, uncheck the Show this dialog at startup check box. The Welcome dialog is then no longer displayed when you next start up the JADE Report Writer Designer application.

   If you decide to bypass the Welcome dialog when you next start up, you can start a new report from within the JADE Report Writer Designer application, as described later in this subsection. You can choose to display the Welcome dialog again on start-up by using the User Preferences command from within the JADE Report Writer Designer application. For details, see "Setting User Preferences" under "Designing a Report", later in this chapter.

   The Select Collections and Joins to Report on dialog, described later in this subsection, is then displayed.

To create a report from within the JADE Report Writer Designer application

1. To initiate a new report, perform one of the following actions.
   - Select the New Report command from the File menu
   - Press Ctrl+N
   - Click the New Report toolbar button
The Select Collections and Joins to Report on dialog, shown in the following image, is then displayed.

2. In the Reporting View list box, select a reporting view on which to base your report.

The available collections and joins for the selected reporting view are then displayed in the Available list box. Your report must be based on at least one root collection or report join. The report collections or joins that you select are used to access all of the data that is required in the report.

Reporting views and associated collection paths are created in the configuration phase of the JADE Report Writer. For details, see "Configuring the JADE Report Writer", in Chapter 3.

3. Select or remove collections or joins in one of the following ways.

   □ Select a collection or join from the Available list box and then click the add (>) button, or double-click the collection or join.

   The selected collection or join name is then displayed in the Selected list box.

   If you selected a join name, the join name in the Available list box is disabled; that is, it is grayed out in the Available list box and you cannot select it there again.

   A selected collection is not disabled, as you can create collection self-joins by selecting a collection more than once. The procedure to do this is described later in this subsection.

   □ To remove a selected collection or join name, select it in the Selected list box and then click the remove (<) button, or double-click the collection or join.

   The selected collection or join name is then removed from the Selected list box. The join name in the Available list box becomes enabled again; that is, you can select it.

   □ To remove all selected collection and join names from the Selected list box, click the remove all (<<) button. All collections and joins are then removed from the Selected list box.

4. Enter your new report name in the New Report Name text box.
Chapter 4  Designing JADE Reports

5. If you want to apply properties from a previously created report, enter the name of a report in the **Copy Options from Report** text box. All report properties, formats, and templates are copied from the specified report. This enables you to have a base report design that you can apply to all of your reports.

If you are unsure of your report name or location, click the Browse button (...). The Find Report dialog is then displayed, to enable you to select the appropriate report file. Use the Find Report dialog to select a report in the same way that you use the Open Report dialog to select the report to open. For details, see "Opening an Existing Report", later in this chapter. For details about setting report properties, see "Setting Report Properties", later in this chapter.

6. Click the **OK** button. A new report layout is then displayed, to enable you to begin designing your report.

Having specified the collections on which to report, you are then ready to start designing your report. For details, see "Designing a Report", later in this chapter.

**To create self-joins**

1. Select collections or joins as described in the above procedure.

2. To create a self-join, while selecting collections on which to report in step 3 of the above instruction, select and add the same collection more than once to the **Selected** list box. The Rename Collection dialog, shown in the following image, is then displayed.

![Rename Collection dialog](image)

3. In the **New Alias** list box, enter a new alias name for this joined collection. The join alias name cannot be the same name as that of any existing collection or alias.

4. Click the **OK** button. Alternatively, click the **Cancel** button to abandon the join. The joined collection name is then displayed in the **Selected** list box of the Select Collections and Joins to Report on dialog.

Having specified the collections on which to report, you are then ready to start designing your report. For details, see "Designing a Report", later in this chapter.

**Opening an Existing Report**

Open an existing report from the Welcome dialog or from the **Open Report** command from the File menu of the JADE Report Designer window.

By default, the Welcome dialog is displayed when you initiate the JADE Report Writer Designer application. However, you can disable the Welcome dialog, in which case open a report by using the **Open Report** command.

For details about accessing the JADE Report Writer Designer application, see "Invoking a JADE Report Writer Application", in Chapter 2.
To open a report from the Welcome dialog


The Welcome to the JADE Report Designer dialog, shown in the following image, is then displayed.

2. In the Open a Report list box, select a report to open or select all reports to display the Open Report dialog. The Open a Report list box displays your recently used reports.

   If you want to open a report that is not listed, select all reports. The Open Report dialog is then displayed. For details about using this dialog, see the following instruction in this subsection, starting from step 2.

3. If you do not want the Welcome dialog displayed at startup, uncheck the Show this dialog at startup check box. The Welcome dialog is then no longer displayed when you next start up the JADE Report Writer Designer application.

   If you decide to bypass the Welcome dialog when you next start up, you can open a report from within the JADE Report Writer Designer application, described in the following instruction in this subsection.

   You can choose to display the Welcome dialog again on startup by using the User Preferences command from within the JADE Report Writer Designer application. For details, see “Setting User Preferences” under “Designing a Report”, later in this chapter.

   Alternatively, click the Close button to abandon your selection.

The selected report is then opened in the JADE Report Writer Designer application window.

To open a report

1. To display the Open Report dialog, perform one of the following actions.
   - Select the Open Report command from the File menu
   - Press Ctrl+O
   - Click the Open Report toolbar button
The Open Report dialog, shown in the following image, is then displayed.

2. Select the report that you want to open from the Reports list box or enter the name in the Report name text box.

The Show reports for current schema only check box is checked by default for all schemas apart from the JadeReportWriterSchema. Only reports defined for the current schema or any superschema of the current schema are displayed for selection. To display all reports defined in the database for selection, uncheck the Show reports for current schema only check box.

If your report is stored in a folder, double-click the folder name and then select your report from the list that is displayed. (For details about creating folders, see "Folders Menu", in Chapter 3.)

3. To filter the list of report names in the Reports list box, perform one or both of the following actions.

   - To display only those reports that contain specific text in their report description, enter text in the Text contains text box. For example, if you enter Pay, only those reports that contain Pay in their description are displayed, providing a refined selection list.

   - To display only those reports modified during that period, select a last modified period from the Last modified list box. For example, if you select last week, only those reports modified in the week prior to the current week are displayed. The system default value of any time means that reports modified in any period are displayed.

4. To further refine the display of reports, perform one of the following actions.

   - Click the Display Details button to display details relating to the last modified dates of the displayed reports. (This is the default display.)

   - Click the Display as List button to display the reports as a simple list.

   - Click the Display Properties button to display the report properties relating to the displayed reports.

5. Click the Open button.
Alternatively, click the **Cancel** button to abandon your selections.

The selected report is then opened in the JADE Report Writer Designer application window. For details about modifying your report design, see "Designing a Report", later in this chapter.

### Starting a Template

Create templates to provide standardized layout designs for your reports. For details about creating templates, see "Creating Templates", later in this chapter.

Start a new template from the Welcome dialog or from within the JADE Report Writer Designer application by using the appropriate File menu commands.

#### To create a new template from the Welcome dialog

1. Start the JADE Report Writer Designer application. The Welcome to JADE Report Designer dialog is then displayed.
2. Click the **New Template** button.
3. If you do not want the Welcome dialog displayed at start-up, uncheck the **Show this dialog at startup** check box.

   The Welcome dialog is then no longer displayed when you next start up the JADE Report Writer Designer application.

   If you decide to bypass the Welcome dialog when you next start up, you can create a new template from within the JADE Report Writer Designer application, as described later in this subsection.

   You can choose to display the Welcome dialog again on startup by using the **User Preferences** command from within the JADE Report Writer Designer application. For details, see "Setting User Preferences" under "Designing a Report", later in this chapter.
4. Alternatively, click the **Close** button to abandon your selections and close the JADE Report Writer Designer application.

   The JADE Report Writer Designer application window is then displayed with a blank template.

For details about creating templates, see "Creating Templates", later in this chapter.

#### To create a template, perform one of the following actions

- Select the **New template** command from the File menu
- Press **Ctrl+T**
- Click the **New Template** toolbar button

The JADE Report Writer Designer application window is then displayed with a blank template.

For details about creating and attaching templates, see "Creating Templates", later in this chapter. For details about modifying your report design, see "Designing a Report", later in this chapter.

### Opening a Template

Open an existing template from the Welcome dialog or from within the JADE Report Writer Designer application by using the appropriate File menu commands.
To open a template from the Welcome dialog

1. Start the JADE Report Writer Designer application. The Welcome to JADE Report Designer dialog is then displayed.

2. Click the Open a Template button.
   
The Open Template dialog is then displayed. For details about using this dialog, see the procedure described in the following instruction in this subsection, starting from step 2.

3. If you do not want the Welcome dialog displayed at start-up, uncheck the Show this dialog at startup check box. The Welcome dialog is then no longer displayed when you next start up the JADE Report Writer Designer application.

   If you decide to bypass the Welcome dialog when you next open a template, you can open a template from within the JADE Report Writer Designer application, described later in this subsection. You can choose to display the Welcome dialog again on start-up by using the User Preferences command from within the JADE Report Writer Designer application. For details, see "Setting User Preferences" under "Designing a Report", later in this chapter.

4. Alternatively, click the Close button to abandon your selections and close the JADE Report Designer application.

The selected template is then opened in the JADE Report Writer Designer application window. For details about creating templates, see "Creating Templates", later in this chapter.

To open a template

1. To display the Open Template dialog, perform one of the following actions.
   
   - Select the Open Template command from the File menu
   - Press Ctrl+E
   - Click the Open Template toolbar button
The Open Template dialog, shown in the following image, is then displayed.

2. Select the template that you want to open from the Templates list box or enter the name in the Template name text box.

   If your report template is stored in a folder, double-click the folder name and then select your report from the list that is displayed. For details about creating folders, see "Folders Menu", in Chapter 3.

3. To filter the list of report names in the Templates list box, perform one or both of the following actions.

   - To display only those templates that contain that text in their description, enter text in the Text contains text box. For example, if you enter Pay, only those templates that contain Pay in their description are displayed, providing a refined selection list.

   - To display only those templates modified during that period, select a last modified period from the Last modified list box. For example, if you select last week, only those templates modified in the week prior to the current week are displayed. The default value is any time, which means that templates modified in any period are displayed.

4. To further refine the display of templates, perform one of the following actions.

   - Click the Display Details button to display details relating to the last modified dates of the displayed templates. (This is the default display.)

   - Click the Display as List button to display the templates as a simple list.

   - Click the Display Properties button to display the template properties relating to the displayed templates.

5. Click the Open button.

   Alternatively, click the Cancel button to abandon your selections.

The selected template is then opened in the JADE Report Writer Designer application window.
For details about creating and attaching templates, see "Creating Templates", later in this chapter. For details about modifying your report design, see "Designing a Report", later in this chapter.

### Using the Sections of a Report

When you start a new report design in the JADE Report Writer Designer application, five report sections are automatically created for you. These sections are also referred to as report frames, and represent the distinct sections of a report; that is, headers, detail frames, and footers.

The following image shows the default sections or frames that are displayed when starting a new report design.

(For details about starting a new report, see "Starting a Report from Scratch", earlier in this chapter.)

Each section is a distinct report entity. For example, the **Detail** section defines the layout of your detail lines.

In most cases, the detail lines are repeated many times between headers and footers, although the **Detail** section appears as one section in your design.

You can also specify group sections. Groups provide a way of grouping your data and therefore provide an additional header and footer section, as shown in the following image.

For details about creating group sections, see "Creating Groups", later in this chapter.
The following subsections describe the report sections in more detail.

- Report Section Descriptions
- Creating and Manipulating Extra Frames
- Changing the Section Properties

**Report Section Descriptions**

The sections of your report are described in the following subsections.

- Report Header Section
- Page Header Section
- Detail Section
- Page Footer Section
- Report Footer Section
- Group Sections
- Group Header and Footer

**Report Header Section**

The report header is printed once only, on the first page of your report. Use this section to print a report title and any other details that you want to be displayed on the front of your report.

**Page Header Section**

The page header is printed once at the top of each page. If your report header is not printed on its own page, the page header is printed below the report header on the first page of your report. The page header is printed at the top of the page on subsequent pages.

Use the page header to print details that you want to appear at the top of every page. Typically, you would use the page header to print the date and page number on each page and to print the field headings.

**Note** The JADE Report Writer Designer application can print field headings automatically if you set the Build Linked Header option in your report properties. For details, see "Using the Details Sheet" under "Setting Report Properties", later in this chapter.

The popup menu and Section Properties dialog enable you to specify that you want to suppress the printing of the page header section on the first page of the report, by selecting the Skip on First Page menu command and Skip Page Header on first page check box, respectively.

**Detail Section**

Use the Detail section to define your detail line or lines.

The JADE Report Writer Designer application prints the detail section, based on the input records provided by the database collection or collections that are defined for your report. It prints them repetitively until it encounters an end of page, end of group, or end of data.
The following image shows a portion of a typical printed report.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Samuels</td>
<td>Box of nails</td>
<td>12.00</td>
</tr>
<tr>
<td></td>
<td>Hammer</td>
<td>36.00</td>
</tr>
<tr>
<td></td>
<td>Screwdriver</td>
<td>18.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>66.00</strong></td>
</tr>
<tr>
<td>Smith</td>
<td>2m ladder</td>
<td>250.00</td>
</tr>
<tr>
<td></td>
<td>10 lt paint</td>
<td>70.00</td>
</tr>
<tr>
<td></td>
<td>100mm brush</td>
<td>16.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>346.00</strong></td>
</tr>
<tr>
<td>Stanton</td>
<td>Tool Kit</td>
<td>180.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>180.00</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Total Sales</strong></td>
<td><strong>8,996.00</strong></td>
</tr>
</tbody>
</table>

The detail line in the above report extract simply consists of product and price. The following image shows how this detail section would look in your report design.

In this example, the product and price are printed repetitively until a change of group is encountered, at which point a group footer is printed with a group total. The grouping is on customer. A report footer is printed containing the report total at the end of the report. Group sections, group headers and footers, and the report footer are described later in this section.

**Note** The group header in this example is the customer name. It is printed adjacent to the first line of detail for its group. This is achieved by setting the Combine With the Following option when defining the section properties. For more details, see "Setting the Section Properties", later in this chapter.

**Page Footer Section**

Use the Page Footer section to print a footer at the bottom of each page. You would typically use this section to print a report identification or you could print the date and page number here instead of in the page header.

The popup menu and Section Properties dialog enable you to specify that you want to suppress the printing of the page footer section on the first page of the report, by selecting the Skip on First Page menu command and Skip Page Footer on first page check box, respectively.

**Report Footer Section**

Use the Report Footer section to print end of report detail. This would normally consist of grand totals for the report, but it can include any static data that you want to print at the end of the report.


**Group Sections**

Group sections, or groups, enable you to group report detail according to certain categories. In the previous example, itemized sales in the **Detail** section are grouped by customer.

Groups also enable you to summarize data when the group changes. For example, you can total the sales for each customer. Whenever you define a group, the Report Writer Designer application automatically inserts a group header and group footer section to contain the detail section the group encloses.

For more details about creating and using groups, see "Creating Groups", later in this chapter.

**Group Header and Footer**

Group header and footer sections are automatically inserted when you define a group. They are inserted at a level between the report header and footer, and the detail section.

Typically, you would use the group header to print a group title and the group footer to print the group totals or some other summary.

For an example of group headers and footers, see the example shown in "Detail Section", earlier in this section. In this example, the grouping is based on customer name. The customer name is the group header and the total for each group is in the group footer.

For full details about creating groups, see "Creating Groups", later in this chapter.

**Creating and Manipulating Extra Frames**

You are not restricted to the default report sections that the JADE Report Writer Designer application provides.

You can create multiple frames based on any of the report sections, if required.

**To create a new frame**

1. Right-click in the section in which you want to create a new frame.

   A popup (or context) menu, shown in the following image, is then displayed.

   ![Popup Menu](image)

   - **Properties...**
   - **New**
   - **Select All**
   - **Visible**
     - **Print at Bottom of Page**
     - **Start New Page Before**
     - **Start New Page After**
     - **Restart Page # After**
     - **Suppress print**
     - **Combine with Following**

2. Select the **New** command from the popup menu.

   The new frame is then automatically created. When you first create a second frame of any section, the JADE Report Writer Designer application numbers the frames starting at number one (#1) for the original frame, number two (#2) for the second frame, and so on.
In the following example, a second detail frame has been created.

Multiple frames follow the rules for the relevant section; that is, all frames are printed each time the section is required to be printed for the static frames (headers and footers) and all detail frames are printed for each record retrieved before details of the next record are printed.

**To move a frame**

1. Right-click in the frame that you want to move.
   
   A popup menu, shown in the following image, is then displayed.

   ![Popup Menu](image)

   - Properties...
   - New
   - Select All
   - Visible
   - Print at Bottom of Page
   - Start New Page Before
   - Start New Page After
   - Restart Page # After
   - Suppress print
   - Combine with Following
   - Move Up
   - Move Down
   - Delete

2. Select the **Move Up** command to move the frame up one place within the section or select the **Move Down** command to move the frame down one place within the section.

**Note** The **Move Up**, **Move Down**, and **Delete** commands are enabled only if you have selected a section that contains multiple frames. The **Move Up** command is *not* enabled if you have selected the top frame of a section and the **Move Down** command is *not* enabled if you have selected the bottom frame of a section.

**To delete a frame**

1. Right-click on the frame that you want to delete.

2. Select the **Delete** command on the popup menu that is then displayed.

   A confirmation dialog is then displayed.

3. Click the **Yes** button to delete the frame or click the **No** button to abandon the deletion.

**Note** The **Delete** command is enabled only if you have selected a section that contains multiple frames.
You can also delete a frame (when there is more than one in the section) by using the Section Properties dialog. For details about displaying the Section Properties dialog, see "Changing the Section Properties", in the following subsection. For full details about changing the section properties, see "Setting the Section Properties" under "Using Administrative Functions", later in this chapter.

## Changing the Section Properties

Each report section has properties that are applicable to that section; for example, page header section or detail section. The JADE Report Writer Designer application sets default values, which you can change these at any time during your design session.

### To access the section properties

1. Right-click the section that has properties you want to change. A popup menu that provides options that relate to that section type is then displayed, as shown in the following image.

   ![Section Properties Menu](image)

   - Properties...
   - New
   - Select All

   ![Visible Options](image)

   - Visible
     - Print at Bottom of Page
     - Start New Page Before
     - Start New Page After
     - Restart Page # After
     - Suppress print
     - Combine with Following

2. Select one of the property commands in the middle section of the menu or select the Properties command to access the Section Properties dialog.

For full details about changing the section properties, see "Setting the Section Properties" under "Using Administrative Functions", later in this chapter.

## Designing a Report

This section provides details about designing reports using the JADE Report Writer Designer application. Designing a report is described in the following subsections.

- Report Design Overview
- Using Administrative Functions
  - Setting User Preferences
  - Setting Report Properties
  - Setting Report Formats
  - Setting the Section Properties
  - Creating or Maintaining Profiles
Using Administrative Functions

The JADE Report Writer Designer application is a highly graphical tool for creating reports. When a blank report form is displayed, you can immediately proceed to insert fields into the default frames. However, you can perform a number of administrative functions before you create the report detail. Although you can perform these functions after you have created some detail, it is more efficient to deal with the administrative functions before you start to create the report detail.

The administrative functions include setting report properties and formats, attaching standard templates, and creating report profiles.

The following table lists the subsections that describe the administrative functions in detail.

<table>
<thead>
<tr>
<th>Administrative Function</th>
<th>Describes how to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting User Preferences</td>
<td>Tailor the appearance of your JADE Report Designer window</td>
</tr>
<tr>
<td>Setting Report Properties</td>
<td>Set a number of defaults, including field alignments, fonts, outputs, and parameters</td>
</tr>
</tbody>
</table>

Report Design Overview

Use the following overall procedure to create reports in the JADE Report Writer Designer application.

1. Start a new report from scratch. For details, see "Starting a Report from Scratch", earlier in this chapter.
2. Perform administrative steps to tailor your report.
   Administrative steps include setting report properties, setting report formats, attaching standard templates, creating profiles, and so on. For details, see "Using Administrative Functions", later in this section.
3. Insert and maintain report detail. Inserting and maintaining report detail involves adding and maintaining the fields of the report and setting the properties of those fields. For details, see "Using the Detail Functions", later in this section.

You can perform part or all of step 3 before step 2, by accepting the report defaults that are initially set by the JADE Report Writer Designer application.

Before you begin to design any report, you can also set user preferences to control the appearance and toolbars of the report layout window. For details, see "Setting User Preferences", later in this chapter.
### Administrative Function | Describes how to...
---|---
Setting Report Formats | Set your default field formats, including numbers, currency, Boolean, dates, and times
Setting the Section Properties | Set defaults that are applicable to a section (frame) of a report
Creating or Maintaining Profiles | Apply different sort and selection criteria to a report

You can also create standard report templates before designing your reports. Templates provide standard layouts that you can attach to new or existing reports. You would typically design templates to provide a standard look for your company or departmental reports; for example, they can provide standard headings or standard footers.

Although creating templates can be an administrative function, their construction is similar to constructing reports and the process is therefore described in "Using the Detail Functions", later in this chapter.

### Setting User Preferences

Use the User Preferences command from the File menu to change the defaults that apply to your JADE Report Writer Designer work session.

To display the User Preferences dialog, perform one of the following actions

- Select the User Preferences command from the File menu
- Press Ctrl+U

The Options sheet of the User Preferences dialog, shown in the following image, is then displayed.
Chapter 4  Designing JADE Reports

To change your report options on the Options sheet of the User Preferences dialog

1. To automatically align your report fields so that they are attached to the nearest point on the grid, check the **Snap to Grid** check box from the Grid Options group box. By default, report fields are not aligned to the nearest grid point and this option is not activated.

   **Note**  Use the grid to facilitate the precise placement of items on your layout. The controls in the Grid Options group box (see steps 1 through 5) provide options that enable you to align to the grid, show or hide the grid, or customize the appearance of the grid.

Although you can use the grid to help you place items on your layout, the grid display is optional.

2. To disable the grid lines on your report design layout, uncheck the **Show Grid Lines** check box. By default, the grid lines are not displayed.

3. In the **Grid Width** text box, enter the width in pixels of your grid columns, if required. The default value is 8 pixels.

4. In the **Grid Height** text box, enter the height in pixels of your grid rows, if required. The default value is 22 pixels.

   **Note**  A pixel is a picture element and is the smallest element that can be displayed on the screen.

5. In the **Grid Style** list box, select a style for your grid lines, if required.

   The grid styles are listed and described in the following table.

<table>
<thead>
<tr>
<th>Grid Style</th>
<th>The grid is…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dot at Grid Intersection</td>
<td>Formed from dots</td>
</tr>
<tr>
<td>Cross at Grid Intersection</td>
<td>Formed from crosses</td>
</tr>
<tr>
<td>Grid Lines</td>
<td>Solid lines</td>
</tr>
</tbody>
</table>

   The default value is **Dot at Grid Intersection**.

6. To remove the horizontal ruler from the display, uncheck the **Show Horizontal Ruler** check box from the General group box. By default, the horizontal ruler is displayed.

7. To remove the vertical ruler from the display, uncheck the **Show Vertical Ruler** check box. By default, the vertical ruler is displayed.

8. To display bubble help captions in your JADE Report Writer Configuration window, check the **Show View bubble help** check box.

   When bubble help is displayed for reporting views, resting the cursor on a class or feature for a few seconds displays a description of the class, property, method, or collection. For details, see "Viewing Bubble Help", in Chapter 3.

9. To display section (frame) names inside the sections of the report design layout, check the **Show Watermark** check box. You would do this to provide a wider layout on which to design your report.

   By default, the display shows the section (frame) names to the left of the report design layout.

10. In the **Keep Last Used #** text box, enter the number of entries for recently opened report designs to be displayed at the bottom of the **File** menu, if required.

   **Tip**  The last-used list provides you with a quick way of opening a recently used report design.
11. To display the field description instead of the text field captions within the field delimiters on your report design layout, uncheck the Show Text Field Caption, instead of Description check box.

This check box is checked by default, indicating that text field captions are displayed. Text field captions show the basic format of the field; that is, a series of X characters for string fields and a series of 9 characters for numeric fields.

The number of characters that is displayed reflects the maximum length of the field.

The following image on the left shows two database fields with their text field captions displayed. (The top field is a currency field that shows the dollar currency symbol.) In the image on the right, the field descriptions are displayed within field delimiters.

12. To bypass the Welcome dialog when you start your JADE Report Writer Designer session, uncheck the Show the Welcome dialog when Report Designer is initiated check box.

This check box is checked by default, indicating that the Welcome dialog is displayed when you start your JADE Report Writer Designer session. For details about using the Welcome dialog, see "Opening an Existing Report" or "Starting a Report from Scratch", earlier in this chapter.
13. To change the way toolbars are displayed, click the **Toolbars** tab to display the **Toolbar** sheet. The **Toolbar** sheet, shown in the following image, is then displayed.

![Toolbar Sheet](image)

To use the **Toolbar** sheet to change the way the toolbars are displayed

- In the **Toolbars** list box, click one of the toolbar titles to change the display status of the toolbar.

Highlighted (white on blue background) toolbars are visible on the JADE Report Designer window. Non-highlighted toolbars (for example, the **Alignment Tools** in the previous image) are hidden. By default, all toolbars are displayed.

**Note** You can relocate a visible toolbar by clicking and dragging the icon that is positioned at the left of the toolbar.

For details about using the toolbars, see "Using the Layout Commands", later in this chapter. For details about using the Quick Launch Tools toolbar, see "Using the Quick Launch Tools", later in this chapter.

**To apply your user preferences changes**

1. Click the **Apply** button.

2. Click the **Close** button if you have no more changes to make.

Your user preferences are then applied.
Setting Report Properties

As the JADE Report Writer Designer application provides default values for all of the properties, you can create a report design without changing any report properties. However, most report designs call for deviation from the standard defaults, especially if the output is sent to a medium other than hard-copy (that is, to a printer).

You can set report properties in advance of any physical design or you can change them at any time during the design. The sheets of the Report Properties dialog provide you with flexibility in field alignment, fonts, output style, and page style. In addition, you can set the values of previously defined parameters.

To display the Report Properties dialog

Select the Properties command from the Report menu.

The Report Properties dialog is then displayed with the Details sheet uppermost.

The subsections listed in the following table describe the sheets of the Report Properties dialog.

<table>
<thead>
<tr>
<th>Subsection</th>
<th>Describes how to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Details Sheet</td>
<td>Change report details such as description, field alignment, and field spacing. Also provides an option to build linked headers.</td>
</tr>
<tr>
<td>Using the Font Sheet</td>
<td>Set the default font, font size, and font style.</td>
</tr>
<tr>
<td>Using the Output Sheet</td>
<td>Set default output styles.</td>
</tr>
<tr>
<td>Using the Default Sheet</td>
<td>Set output file type defaults.</td>
</tr>
<tr>
<td>Using the Page Sheet</td>
<td>Set defaults for page layout.</td>
</tr>
<tr>
<td>Using the Preview Sheet</td>
<td>Set defaults applicable to print preview.</td>
</tr>
<tr>
<td>Using the Parameters Sheet</td>
<td>Apply values to report parameters.</td>
</tr>
</tbody>
</table>

Each sheet of the Report Properties dialog is described in the following subsections.

Using the Details Sheet

Use the Details sheet of the Report Properties dialog to apply a report description and to change the default values for field alignment and spacing.
To enter a report description and change field alignment and spacing detail

1. Click the Details tab of the Report Properties dialog.

The Details sheet, shown in the following image, is then displayed.

2. In the Description text box, enter a description for this report, if required.

As well as providing documentation for the report, the description can be searched during the open process, providing you with the ability to locate reports with a particular content. For more details, see "Opening an Existing Report", earlier in this chapter.

3. To print page headers and footers even if there is no report detail to print, check the Report when no Data check box.

When this check box is not selected (that is, it is unchecked) and there is no data to print, no report is produced. When you check the Report when no Data check box and there is no data, the report header, page header, report footer, and page footer are printed but no detail or group sections.

By default, this check box is not checked.

4. In the Default Field Alignment group box, change the default values for the way in which numeric and non-numeric fields are aligned, if required.

Select alignment values from the Numeric list box and the Non-numeric list box.
Chapter 4  Designing JADE Reports

You can also change alignment by using the samples in the green window in the Default Field Alignment group box. Click to the left or right of the sample to change the alignment.

By default, numeric fields are right-aligned and non-numeric fields are left-aligned.

5. In the Templates list box, select a template to apply to the current report. The Templates list box lists only those templates that you have attached to the current report. Use the up and down arrows to change the sequence in which the templates are applied to your report.

For details about creating templates, see "Creating Templates", later in this chapter. For details about attaching templates, see "Attach Template" under "Report Menu", later in this chapter.

Specify the order of report and template headers by selecting the Template headers, Before option button, or the After Report option button.

Specify the order of report and template footers by selecting the Template footers, Before option button, or the After Report option button. By default, template sections are printed before the corresponding report ones.

6. In the Detail Section group box, change the default values for the minimum and maximum spacing (in pixels) between fields, if required.

If you set the minimum spacing, this spacing is preserved when you move report fields. This enables you to insert a new field between two existing fields while still preserving the spacing between the fields.

If you set the maximum spacing, this spacing is preserved when you move report fields. If you delete a field, the fields that follow the deleted field (that is, those to the right) are automatically moved across while still preserving the maximum spacing between the fields.

By default, the minimum and maximum spacing are set to zero (0). The zero setting for the maximum spacing means that there is no maximum limit to the spacing between fields.

**Notes**  As changes to the minimum and maximum spacing are not applied to existing fields, you should set these values before you build your detail section.

This setting is intended for use in reports that have a straightforward layout (for example, text-only and with minimal formatting). Realignment using these minimum and maximum spacing values is therefore ignored if there is more than 50 percent difference in height between the narrowest and widest report detail fields.

7. Check the Build Linked Header check box if you want to create an automatic header for fields that you enter in the Detail section.

The automatic header is applied to the Page Header section and uses the initial text of your field alias. You can change your field alias name by using the Title text box of the Field Properties dialog. For details about the Field Properties dialog, see "Setting Field Properties" under "Using the Detail Functions", later in this chapter.

The page header field is automatically moved when you move the associated report detail field and is automatically deleted when you delete the associated report detail field.

By default, the Build Linked Header check box is not checked. Accept the default value if you want to create your own headings in the Page Header section. For details, see "Inserting a Literal" under "Using the Detail Functions", later in this chapter.

**Note**  Linked headers for existing fields are not created when you select this option. If you want to apply this option to all detail fields, you should do so before you start to build your detail section.

To link and unlink headers independently of this option, use the Link Header and Unlink Header commands from the Edit menu. For details, see "Linking and Unlinking Headers", later in this chapter.
8. Click another tab if want to make changes on other sheets of the Report Properties dialog.
   Alternatively, click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

To save your recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog.

To abandon any changes that you have made but not yet applied, do *not* click the **Apply** button immediately prior to clicking the **Close** button.

**Note** The options in the **Detail Section** group box apply only to the detail section of your report.

---

**Using the Font Sheet**

Use the **Font** sheet of the Report Properties dialog to change the font default values for your report.

The default font values are:

- MS Sans Serif
- Size 8 points
- Western Script
- Standard type (not bold, italic, or underline)
To change the font default values


   The Font sheet, shown in the following image, is then displayed.

2. In the Default Font list box, select a font.

   The selected font becomes the default value for the text of your report.

3. In the Size list box, select a point size for your font.

   The selected size becomes the default value for the font that is selected.

4. In the Script list box, select a script style to apply to your default font.

   The selected script becomes the default value for the font that is selected.

   **Note** Not all fonts have multiple script styles.

5. Click one or more of the following buttons to change the default font style.

   - The Bold button toggles the **bold** style on or off
   - The Italic button toggles the *italic* style on or off
   - The Underline button toggles the **underline** style on or off
6. In the **Color** list box, select a color to apply to your default font.

   If you select the **Custom** color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the **OK** button to apply the selected color or click the **Cancel** button to close the Color dialog without making any changes.

   The RGB color values that relate to your selected color are displayed to the right of the **Color** list box.

7. Check the **Use Default Font** check box to reset all of the font default values back to the system default values.

8. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

9. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**Note** You can change fonts for individual fields by using the field properties. For details, see "**Setting Field Properties**" under "**Using the Detail Functions**", later in this chapter.

### Using the Output Sheet

Use the **Output** sheet of the Report Properties dialog to set options that apply to data extract files. You can extract data files in the following formats:

- HTML (HyperText Markup Language)
- Delimiter-separated file
- Text
- RTF (Rich Text Format)
- XML (Extensible Markup Language)

The **Output** sheet enables you to set options relating to each extract file format.

For details about extracting data files, see "**Extract Data**" under "**File Menu**", later in this chapter.

**To access the Output sheet of the Report Properties dialog**

* Click the **Output** tab of the Report Properties dialog.
The **Output** sheet, shown in the following image, is then displayed.

![Report Properties dialog](image)

**To set HTML output options in the HTML Options group box**

1. If your report has one or more **Group** sections, check the **Build Table of Contents** check box to build a table of contents.

   The resulting HTML specifies two frames. The frame on the left displays the group heading values and the frame on the right displays the report text. Each group heading provides a hyperlink jump to the equivalent group heading location within the report text.

2. Check the **Show Pages at Full Screen Width** check box to produce full-screen HTML pages regardless of the screen resolution.

   As full-screen HTML pages are not produced regardless of the screen resolution by default, HTML pages are built with horizontal positioning in pixels and the page width is consequently the same as the current printer page width.

3. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

4. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.
Chapter 4  Designing JADE Reports

To set XML output options in the XML Options group box

1. In the Overall Tag text box, enter the value for the highest-level XML tag around the rest of the extracted data; for example, if the value of the tag in the Overall Tag text box is report:

   <report>
     ... report data
   </report>

2. In the Detail Tag text box, enter the tag for the parent element of the elements corresponding to the fields in the detail section; for example, if the value of the tag in the Detail Tag text box is detail:

   <detail>
     <name> Peter Smallsmith </name>
     <address> 645 Gregan Road </address>
   </detail>

   Group fields are written with the group alias as the tag.

3. Check the Report Header check box to include the report headers in the XML output. If the check box is checked, you must enter a value for the tag of the parent element of the elements corresponding to the fields in the report header section in the Report Header text box.

4. Check the Page Header check box to include the page headers in the XML output. If the check box is checked, you must enter a value for the tag of the parent element of the elements corresponding to the fields in the page header section in the Page Header text box.

5. Check the Numbers in Printed Format check box to extract numbers as strings formatted in the same way as they are printed. By default, this check box is not checked, indicating that numbers are extracted as numeric values.

6. Check the Dates in Printed Format check box to extract dates as strings formatted in the same way as they are printed. By default, this check box is not checked, indicating that dates are extracted in the standard format.

7. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

8. Click the Apply button to apply the changes you have made or click the Close button to close the Report Properties dialog.

   To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog.

   To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

To set delimiter-separated file output options in the Delimiter-Separated File Options group box

1. Select one of the following field separator options under Field Separator: one of.

   - To set the field delimiter as a tab character, select the Tab option button.
   - To set the field delimiter as a comma character (,), select the Comma option button.
   - To set your own delimiter character, enter a field delimiter character in the Other Character text box.

   The default field separator value is the comma character (,).

2. In the Field Delimiter text box, enter the delimiter character for a non-numeric field. The default field delimiter value is the quotes character (").
3. Specify the end-of-line delimiter by selecting the **Crlf** or **Lf** option button next to **End-of-line Delimiter**. The default end-of-line delimiter value is **Crlf**.

The standard file end-of-line delimiter is a **Cr** (carriage return) followed by an **Lf** character.

4. In the **Extract** group box, select options for the report data to be included in the extract file.
   - To extract data from report headers and include this data in the extracted file, check the **Report Headers** check box. By default, this check box is not checked, indicating that report header detail is not extracted.
   - To extract data from report footers and include this data in the extracted file, check the **Report Footers** check box. By default, this check box is not checked, indicating that report header detail is not extracted.
   - To extract data from group headers, check the **Group Headers** check box. Group header data is then included in the extracted file at the top of each group of detail data. By default, this check box is not checked, indicating that group header detail is not extracted.

   To combine extracted group header data with details on the same line, check the **Combine Groups and Detail** check box.

   - To extract data from group footers, check the **Group Footers** check box. Group footer data is then included in each column at the base of each set of detail data. By default, this check box is not checked, indicating that group footer detail is not extracted.

   - To combine group header data and group details in the extract file, check the **Combine Groups and Detail** check box. This means that group headers that you have specified for extraction are included in each line of group detail data.

   By default, this check box is not checked, indicating that group headers and group details are not combined in the extract file. This control is enabled when you specify group headers for extraction. You cannot combine group footers with detail.

   - To extract numbers as strings formatted in the same way as they are printed, check the **Numbers in Printed Format** check box. By default, this check box is not checked, indicating that numbers are extracted as numeric values.

   - To extract dates as strings formatted in the same way as they are printed, check the **Dates in Printed Format** check box. By default, this check box is not checked, indicating that dates are extracted in the standard format.

   - To extract a frames (detail, group, and so on) as multiple records if its content spans more than one line, check the **Each Frame as Multiple Lines** check box. By default, this check box is not checked, indicating that each frame is extracted as a single record.

5. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

6. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

### To set text file output options in the **Text File Options** group box

1. In the **Lines per Page** text box, enter the number of lines after which a new-page character is written to the extract file. The default value of zero (0) indicates that no pagination is required.

2. In the **Record Length** text box, enter the maximum length of each record written.
If you enter a record length and the extracted data exceeds that length, the individual data item text might be truncated and spacing between fields might be scaled to fit the data proportionally within the record.

By default, there is no maximum record length and no truncation occurs.

3. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

4. Click the Apply button to apply the changes that you have made or click the Close button to close the Report Properties dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not applied, do not click the Apply button immediately prior to clicking the Close button.

Using the Default Sheet

Use the Default sheet of the Report Properties dialog to set default options for the output of your report.

The Default sheet provides options for setting the default output type for your report, particularly for reports that are run programmatically; that is, from a JADE application. You can also set the default output file name and location.

To change the default output options for your report

1. Click the Default tab of the Report Properties dialog. The Default sheet, shown in the following image, is then displayed.

2. In the Default Output Type group box, select a default output type for the report.
When the report is extracted or run from an application, the output type defaults to the option that you select.

Output type options for your report are as follows.

- Printer
- HTML (HyperText Markup Language)
- Delimiter-separated file
- Text
- RTF (Rich Text Format)
- XML (Extensible Markup Language)

The Output sheet of the Report Formats dialog enables you to set options relating to each extract file format.

3. In the Output File Name text box, specify the default file name and file location path for the report output. This path must be visible when the report is run.

4. To specify that the output file location path and file name in the Output File Name text box is specified from the perspective of the local (client) workstation, check the Use Client File System check box.

If you do not check this box, the output file path and file name is treated as specified from the perspective of the application server. By default, the output file uses the file system of the client workstation.

**Note** The application server executes JADE application logic in JADE thin client mode. It communicates with the JADE database on the server node and one or many presentation (thin) clients; that is, local client workstations.

5. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

6. Click the Apply button to apply the changes that you have made or click the Close button to close the Report Properties dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not applied, do not click the Apply button immediately prior to clicking the Close button.

**Using the Page Sheet**

Use the Page sheet of the Report Properties dialog to maintain the page options for your report.

The Page sheet provides options to change the size, orientation, margins, and copies of your report.
To change the page options for your report:

1. Click the **Page** tab of the Report Properties dialog.

   The **Page** sheet, shown in the following image, is then displayed.

2. In the **Paper Size** list box, select a type and size for your report pages. The default value is **A4 210x297 mm**. Your report is then scaled to fit the page size that you have selected.

3. In the **Orientation** group box, select the page orientation. The default value is **Portrait**.

   Select the **Portrait** option button to align the long edge of the page with the vertical or select the **Landscape** option button to align the long edge of the page with the horizontal, as shown by the sample page that is displayed.

4. In the **Page Margins** group box, change the default sizes (in millimeters) for your report margins, if required.
   - In the **Top** text box, enter the size of the margin between the top edge of the page and the printing. The default value is zero (0) millimeters.
   - In the **Bottom** text box, enter the size of the margin between the bottom edge of the page and the printing. The default value is zero (0) millimeters.
   - In the **Left** text box, enter the size of the margin between the left edge of the page and the printing. The default value is 10 millimeters.
   - In the **Right** text box, enter the size of the margin between the right edge of the page and the printing. The default value is 10 millimeters.
In the **Border Width** text box, enter the size in pixels of the border to be printed around the printed page. The default value is zero (0), indicating that no border is to be printed.

5. In the Report Options group box, change or set the following report options, if required.

- In the **Number of Copies** text box, enter the number of copies of the report to be printed. The default value is **1**.
- In the **Start Page Number** text box, enter the starting page number for the report. The default value is **1**.
- Check the **Collate Printer Output** check box if the number of copies of the report requested is greater than **1** and you want the printer to collate the copies; that is, you want the printer to group the copies separately. By default, this check box is unchecked, indicating that output is not collated. This option applies only if your printer has collating capability.
- Check the **Print Report Summary** check box if you want JADE Report Writer to print a summary of its activity after your report is printed. By default, this check box is unchecked, indicating that no summary is printed.
- The default **Single Sided** option button indicates that your report is printed on one side of the paper.
- Select the **Double-Sided Horizontally** option button if you want your report printed on both sides of the paper in landscape orientation. This option applies only if your printer has double-sided (duplex) printing capability.
- Select the **Double-Sided Vertically** option button if you want your report printed on both sides of the paper in portrait orientation. This option applies only if your printer has double-sided (duplex) printing capability.

6. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

7. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

### Using the Preview Sheet

Use the **Preview** sheet of the Report Properties dialog to maintain options that apply to your print preview display.

These options apply only to the print preview that is displayed when you click the **Print Preview** tab on your main JADE Report Designer window. They do not apply to printing, even if you have requested printing from the **Print Preview** sheet. For more details, see Chapter 5.
To change the print preview options for your report

1. Click the Preview tab of the Report Properties dialog.

The Preview sheet, shown in the following image, is then displayed.

2. In the Maximum objects to report text box, limit the size of your preview display by specifying the maximum number of detail items that are returned from the report query for the preview. The default value of zero (0) indicates that there is no limit to the number of detail items to be returned.

3. In the Maximum pages to print text box, limit the size of your preview display by specifying the maximum number of pages to print. The default value of zero (0) indicates that there is no limit to the number of pages to print or preview.

4. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

5. Click the Apply button to apply the changes you have made or click the Close button to close the Report Properties dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

Using the Parameters Sheet

Use the Parameters sheet of the Report Properties dialog to set report parameters prior to previewing a report.
When printing or extracting data, the parameter value entry is automatically requested and uses the same format as that shown on the Parameters sheet of the Report Properties dialog.

Object parameters, which can be printed and used in scripts, are treated as String values and the return value from the Object class jadeReportWriterDisplay method for the object is used as the value.

Use the Parameters sheet to set your parameter values explicitly while testing your report. This means that you do not have to enter your parameters each time you test your report by performing a print preview.

For details about creating and using parameter fields, see "Using the Param Sheet" under "Using the Catalog of Available Fields Dialog", later in this chapter.

To set a report parameter prior to previewing

1. Click the Parameters tab of the Report Properties dialog.

The Parameters sheet, shown in the following image, is then displayed.

![Parameters Sheet](image)

Parameters that you have created previously are listed in the Parameter Name column.

2. Click on the parameter whose value you want to change.

3. In the Parameter Value column, enter or select a value for the appropriate parameter.

You can place a parameter field directly into your report, but as you would typically use it to provide a variable to apply to a report field, you may not necessarily print the parameter itself. For example, you can apply an exchange rate to print a currency value in an alternative currency. For details about using a parameter and applying it through a script, see "Using the Param Sheet" and "Using the Script Sheet" under "Using the Catalog of Available Fields Dialog", later in this chapter.
4. In the **Ignore** column, check the check box for the appropriate parameter to specify that the parameter is ignored in selection. This overrides the **User value must be entered** option on the **Param** sheet of the Catalog of Available fields dialog, and the "Parameter Value must be entered for <parameter name>" message box is not displayed when a parameter value is not entered.

When this check box is checked in the JADE Report Writer Designer application, if the parameter selection item is self-contained, it is dropped from the selection. If it is in a selection block within brackets, it is replaced with **true** for an AND block and **false** for an OR block. This is done to make the code generation easier. The specified parameter is therefore treated as an **all** action when applied as a selection criterion (for example, when running a report for a specific department but all cost centers). Bracketing and negation are unchanged for the selection overall.

**Notes** If you use two or more parameters in a single selection (for example, **is between** or **is one of**), you must check the **Ignore** check box for each of the parameters for the **all** selection to take effect. If not, the values of these parameters are used.

When reports are run from the user system, the **JadeReportWriterReport** class **getExtraParameterDetails** method can be called to return the value of the **User value must be entered** option for a specified parameter name. This can be used to enforce entry of a value for the parameter. For more details about the **getExtraParameterDetails** method, see Chapter 1 of the **JADE Encyclopaedia of Classes, Volume 1**.

For details about using parameters as selection criteria, see "Using the Selection Criteria Sheet" under "Creating or Maintaining Profiles", later in this chapter.

Both primitive and object parameters can optionally have a different value printed when the ignore flag is set for the parameter. To do this, re-implement the **Application** class **jadeReportWriterParamLiteral** method to return the required literal (for example, "<All>"). Parameters with their ignore flag set are reported as this value in the report body. If the method returns null (""), which is the default behavior, the parameter value is still reported. In either case, parameters used in scripts continue to use the parameter value rather than the method value.

5. Click another tab if you want to make changes on other sheets of the Report Properties dialog.

6. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Properties dialog.

   To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.

### Setting Report Formats

This section describes the Report Formats dialog, which enables you to set field formats for an individual report, including numbers, currency, Boolean values, dates, times, and timestamps.

Standard system-wide report format default values are set in the JADE Report Writer Configuration application. (For details, see "System Formats Menu", in Chapter 3.)

You can create a report design without changing any of these standard report formats. You can also accept the standard default values and change individual field formats by using the field properties. For details, see "Setting Field Properties" under "Using the Detail Functions", later in this chapter.

Having changed the report formats, you can also return to the default formats set by the JADE Report Writer Configuration application at any time.

You can change report formats in advance of any physical design or you can change them at any time during the report design.
To display the Report Formats dialog

- Select the Formats command from the Report menu.

The Report Formats dialog is then displayed, with the **Number** sheet uppermost. The subsections listed in the following table describe the sheets of the Report Formats dialog.

<table>
<thead>
<tr>
<th>Subsection</th>
<th>Describes how to set default...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Number Sheet</td>
<td>Number formats</td>
</tr>
<tr>
<td>Using the Currency Sheet</td>
<td>Currency formats</td>
</tr>
<tr>
<td>Using the Date Sheet</td>
<td>Date formats</td>
</tr>
<tr>
<td>Using the Time Sheet</td>
<td>Time formats</td>
</tr>
<tr>
<td>Using the TimeStamp Sheet</td>
<td>Timestamp formats</td>
</tr>
<tr>
<td>Using the Boolean Sheet</td>
<td>Boolean formats</td>
</tr>
</tbody>
</table>

Each sheet of the Report Formats dialog is described in the following subsections.

**Using the Number Sheet**

Use the **Number** sheet of the Report Formats dialog to set the default formats for numeric fields.

**To change the default report formats for numeric fields**

1. Click the **Number** tab of the Report Formats dialog.

   The **Number** sheet, shown in the following image, is then displayed.
2. The **Use System Default** check boxes are checked by default. The check box on the left applies to whole number formats and the check box on the right applies to decimal formats. If you make any changes to the controls on this dialog, the corresponding **Use System Default** check box automatically unchecks itself, indicating that system default values set by the JADE Report Writer Configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck these check boxes.

To revert to the system default values at any time during the report design process, you can check either or both of the **Use System Default** check boxes.

The Samples group box at the bottom of the sheet displays samples of the selected formats.

3. In the **Negative** list box (in the Default Whole Number Format group box or Default Decimal Number Format group box), select the format for printing negative numbers.

The default **Leading Sign** value indicates that the negative sign (-) is printed to the left of the whole number or decimal without an intervening space.

4. In the **1000's Separator** text box (in the Default Whole Number Format group box or Default Decimal Number Format group box), enter the character that you want to separate thousands.

The default value is a comma character (,). The maximum number of separator characters is three.

5. In the **Decimals Separator** text box of the Default Decimal Number Format group box, enter the character that you want to separate the whole numbers from the decimals.

The default value is a period character (.). The maximum number of separator characters is three.

6. In the **Decimals** text box of the Default Decimal Number Format group box, enter the number (in the range 0 through 9) of decimal places you want printed.

The default value is 2.

7. To suppress the printing of zero (0) in front of the decimal point when the number is less than 1, uncheck the **Show Leading Zero for Decimals** check box of the Default Decimal Number Format group box.

By default, the **Show Leading Zero for Decimals** check box is checked.

8. To suppress the printing of a number or decimal if it is zero (0), check the **Suppress If Zero** check box (in the Default Whole Number Format group box or Default Decimal Number Format group box).

By default, the **Suppress If Zero** check box is unchecked, indicating that the number or decimal is printed if it is zero (0).

9. Click another tab if you want to make changes on other sheets of the Report Formats dialog.

10. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Formats dialog.

    To save the recent changes when you close the dialog, click the **Apply** button immediately prior to closing the dialog.

    To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.

**Using the Currency Sheet**

Use the **Currency** sheet of the Report Formats dialog to change the default report formats for currency fields.
To change the default report formats for currency fields

1. Click the Currency tab of the Report Formats dialog.

   The Currency sheet, shown in the following image, is then displayed.

   ![Currency Sheet](image)

2. The Use System Default check box is checked by default. If you make any changes to the controls on this dialog, the Use System Default check box automatically unchecks itself, indicating that the system default values set by the JADE Report Writer Configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

   To revert to the system default values at any time during the report design process, you can check the Use System Default check box.

   The Sample group box at the bottom of the sheet displays samples of the selected formats.

3. In the Positive list box, select how you want the currency symbol displayed in relation to the currency amount for a positive currency value.

   The default value of Leading Symbol indicates that the currency sign is printed to the left of the currency amount without an intervening space.

4. In the Negative list box, select how you want a negative currency amount displayed.

   The default value of Sign, Symbol, Number indicates that the negative sign is printed to the left of the currency symbol, which is printed to the left of the currency amount, and that there are no intervening spaces.

5. In the Currency Symbol text box, enter the currency symbol that you require.

   The default value is the standard dollar sign ($).
6. In the **1000's Separator** text box, enter the character that you want to separate the thousands in your currency amount.

   The default value is a comma character (,). The maximum number of separator characters is three.

7. In the **Decimal Separator** text box, enter the character that you want to use to separate the whole numbers from the decimals in your currency amount.

   The default value is a period character (.). The maximum number of separator characters is three.

8. In the **Decimals** text box, enter the number (in the range 0 through 9) of decimal places that you want printed.

   The default value is 2.

9. To suppress the printing of zero (0) in front of the decimal point when the currency amount is less than 1, uncheck the **Show Leading Zero for Decimals** check box.

   By default, leading zeros are printed with currency amounts of less than 1.

10. Click another tab if you want to make changes on other sheets of the Report Formats dialog.

11. **Using the Date Sheet**

    Use the **Date** sheet of the Report Formats dialog to change the default report formats for your date fields.

    **Note** When entering separator text for long or short date formats in any of the controls in this dialog, you cannot use more than three characters as separator text.

    If the separator text contains any of the characters d, M, y, g, h, H, m, s, or t, they are removed. The apostrophe character (’) is not displayed as such when used as a separator.
To change the default report formats for date fields

1. Click the Date tab of the Report Formats dialog.

   The Date sheet, shown in the following image, is then displayed.

<table>
<thead>
<tr>
<th>Report Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>Use System Default</td>
</tr>
<tr>
<td>Default Short Date Format</td>
</tr>
<tr>
<td>Order: Day, Month, Year</td>
</tr>
<tr>
<td>Separator:</td>
</tr>
<tr>
<td>Day:</td>
</tr>
<tr>
<td>05</td>
</tr>
<tr>
<td>[ 5 or 05 ]</td>
</tr>
<tr>
<td>Default to Short Date Format</td>
</tr>
<tr>
<td>Samples:</td>
</tr>
<tr>
<td>10/12/2003</td>
</tr>
</tbody>
</table>

2. The Use System Default check boxes are checked by default. The check box on the left applies to short date formats and the check box on the right applies to long date formats.

   If you make any changes to the controls on this dialog, the corresponding Use System Default check box automatically unchecks itself, indicating that system default values set by the JADE Report Writer Configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck either of these check boxes.

   To revert to the system default values at any time during the report design process, you can check either or both of the Use System Default check boxes. Note that setting both the short and long date system formats to the system default values also sets the Default to Short Date Format option to the system default.

   The Samples group box at the bottom of the sheet displays samples of the selected formats.

3. In the Order list box (Default Short Date Format group box or Default Long Date Format group box), select how you want the date order printed; that is, the sequence of day, month, and year. The default value is Day, Month, Year.

4. In the Separator text box of the Default Short Date Format group box, enter the character that you want to separate the numbers of your short date format. The default value is the slash character (/).

5. In the Day Name list box of the Default Long Date Format group box, select the way in which you want the day of the week printed. Select the full day name or the day name abbreviated to the first three letters of the day name; for example, Wed for Wednesday.
6. In the Day list box (Default Short Date Format group box or Default Long Date Format group box), select the way in which you want the day number printed when the day number is less than 10.

Select the option to print the leading zero (0) or not to print the leading zero.

By default, the leading zero is printed; for example, 05.

7. In the Day Separator text box of the Default Long Date Format group box, enter the character or characters that you want to separate the day name from the remainder of the date in your printed dates.

The usual preferences are a comma character (,) or a comma followed by a space (, ).

The default value is a single character comma. (For an example, see the sample in the previous image.) If no separator character is entered, there is always a space between the day name and the remainder of the date. The maximum number of separator characters is three.

8. In the Month list box of the Default Short Date Format group box, select the way in which you want the month number printed when the month number is less than 10.

Select the option to print the leading zero (0) or not to print the leading zero.

The default value is to print the leading zero; for example, 09.

9. In the Month list box of the Default Long Date Format group box, select the way in which you want the month printed in the long format.

The month portion of the date can be printed as the full name of the month (for example, September), the abbreviated name of the month (for example, Sep), the number of the month with a leading zero for months less than ten (09), or the month number alone (9).

By default, the abbreviated name of the month is printed; for example, Sep.

10. In the Year list box (in the Default Short Date Format group box or Default Long Date Format group box), select the way in which you want the year printed. Select the four-digit format or the two-digit format.

By default, the four-digit format is printed; for example, 2004.

11. In the Date Separator text box of the Default Long Date Format group box, enter the character or characters that you want to use to separate the day, month, and year parts in your printed dates as an alternative to a space.

If no character is entered in this text box, a space used. The character that you enter replaces the space; for example, if you enter a comma character (,), the result is that a comma character alone is printed between the parts of the date.

By default, there is no entry; that is, one space is printed between the day, month, and year. (For an example, see the sample in the previous image.) The maximum number of separator characters is three.

12. If you want dates to be shown in long date format in the JADE Report Writer Designer application, uncheck the Default to Short Date Format check box.

By default, the Default to Short Date Format check box is checked.

13. Click another tab if you want to make changes on other sheets of the Report Formats dialog.

14. Click the Apply button to apply the changes you have made or click the Close button to close the Report Formats dialog.
To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

**Using the Time Sheet**

Use the **Time** sheet of the Report Formats dialog to change the default report formats for your time fields.

**To change the default report formats for time fields**

1. Click the **Time** tab of the Report Formats dialog.
   
The **Time** sheet, shown in the following image, is then displayed.

2. The **Use System Default** check box is checked by default. If you make any changes to the controls on this dialog, the **Use System Default** check box automatically unchecks itself, indicating that the system defaults set by the configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

   To revert to the system default values at any time during the report design process, you can check the **Use System Default** check box.

   The Sample group box at the bottom of the sheet displays a sample of the selected format.

3. Select the **12 Hour Clock** option button if you want your report times printed in 12-hour clock format or select the **24 Hour Clock** option button if you want your report times printed in 24-hour clock format.

   The default value is **12 Hour Clock**.

4. If you want to include seconds in your printed times, check the **Show Seconds** check box.
By default, this check box is unchecked, indicating that seconds are not printed.

5. If you want the time marker printed as a prefix to the time value (for example, \texttt{pm12:06}), uncheck the \textbf{Show Time Marker as Suffix} check box.

   For the 12-hour clock format, the default time markers are \texttt{am} and \texttt{pm}. You can change these by using the \textbf{Marker} text box, described in step 8 of this instruction.

   By default, the \textbf{Show Time Marker as Suffix} check box is checked, indicating that the time marker is printed as a \texttt{suffix} to the time value.

6. If you want to suppress the printing of the leading zero (\texttt{0}) when the hour value is less than \texttt{10}, uncheck the \textbf{Show Leading Zero for Hours < 10} check box.

   By default, this check box is checked, indicating that the leading zero is printed when the hour value is less than \texttt{10}, for example, \texttt{09:06pm}.

7. In the \textbf{Separator} text box, enter the character that you want to separate the hours and minutes (and seconds, if the \textbf{Show Seconds} check box is checked) of your default time format.

   You cannot use more than three characters as separator text. If the separator text contains any of the characters \texttt{d, M, y, g, h, m, s, or t}, they are removed. The apostrophe character (\texttt{'}) is not displayed as such when used as a separator character.

   The default value is a colon character (\texttt{:}).

8. In the \textbf{Marker} text box, enter time markers to indicate pre-noon and post-noon times.

   If you selected the \textbf{12 Hour Clock} option button, the default markers are \texttt{am} and \texttt{pm}. If you want to create your own default markers, enter up to 30 characters in the \textbf{Marker} text box.

   If you selected the \textbf{24 Hour Clock} option button, only one \textbf{Marker} text box is displayed. If you want a marker to be printed against the times in your report, enter up to 30 characters in the \textbf{Marker} text box. By default, there is no marker for the \textbf{24 Hour Clock} option.

9. Click another tab if you want to make changes on other sheets of the Report Formats dialog.

10. Click the \textbf{Apply} button to apply the changes you have made or click the \textbf{Close} button to close the Report Formats dialog.

    To save the recent changes when you close the dialog, you must click the \textbf{Apply} button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the \textbf{Apply} button immediately prior to clicking the \textbf{Close} button.

\section*{Using the TimeStamp Sheet}

Use the \textbf{TimeStamp} sheet of the Report Formats dialog to change the default report formats for your timestamp fields. Timestamps are variables made from a concatenation of date and time values. In JADE, they are mainly used to flag the precise time that objects are created.

\textbf{Note} When entering separator text for long or short date formats and time formats in any of the controls in this dialog, you cannot use more than three characters as separator text. If the separator text contains any of the characters \texttt{d, M, y, g, h, m, s, or t}, they are removed. The apostrophe character (\texttt{'}) is not displayed as such when used as a separator.

\textbf{To change the default report formats for timestamp fields}

1. Click the \textbf{TimeStamp} tab of the Report Formats dialog. The \textbf{TimeStamp} sheet, shown in the following image, is then displayed.
Two further sheets on this dialog enable you to specify the timestamp format of dates and times. These sheets are enabled when the corresponding Show Date and Show Time check boxes are checked. The Date sheet is selected by default, as shown in the previous image.

2. The Use System Default check box is checked by default. If you make any changes to the controls on this dialog, the Use System Default check box automatically unchecks itself, indicating that the system defaults set by the configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box. To revert to the system default values at any time during the report design process, you can check the Use System Default check box.

The Sample group box at the bottom of the sheet displays a sample of the selected format.

3. To print only the time portion of the timestamp, uncheck the Show Date check box.

By default, this check box is checked, indicating that the date portion and the time portion of the timestamp are printed. When this check box is checked, the Date sheet on this dialog is enabled to further specify the default date format.

4. To print only the date portion of the timestamp, uncheck the Show Time check box.

By default, this check box is checked, indicating that the date portion and the time portion of the timestamp are printed. When this check box is checked, the Time sheet on this dialog is enabled to further specify the default time format.

5. To print the date portion of the timestamp in front of the time portion (for example, 09/02/2004 02:18), select the Date Then Time option button in the Order group box.

By default, this option button is selected, indicating that the date portion of the timestamp is printed in front of the time portion.
Alternatively, to print the time portion of the timestamp in front of the date portion (for example, 02:18 09/02/2004), select the Time Then Date option button.

This group box is enabled only when the Show Date and Show Time check boxes are checked.

6. In the Date/Time Separator text box, enter the character or characters that you want to use to separate the date portion from the time portion of the timestamp. The default value is a single space.

This text box is enabled only when the Show Date and Show Time check boxes are checked above.

7. To specify options for the default display of dates, click on the Date tab to display the Date sheet and then perform the following actions, if required.
   a. If you want the date portion of the timestamp to use the short date format, select the Use Short Date option button. The short date format does not include the day name and does not separate the day, month, and year; for example, 0902200402:18.
   b. If you want the date portion of the timestamp to use the long date format, select the Use Long Date option button. The long date format includes the day name; for example, Fri/09/02/200402:18. The default value is Use Short Date.
   c. In the Order list box, select how you want the date order printed; that is, the sequence of day, month, and year. The default value is Day, Month, Year.
   d. In the Separator text box (visible only if you selected the Use Short Date option button), enter the character that you want to separate the numbers of your short date format.
   e. In the Day Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the day portion from the date portion of the timestamp. By default, there is no separator.
   f. In the Date Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the date portion from the timestamp. By default, there is no separator.
   g. In the Day Name list box (visible only if you selected the Use Long Date option button), select the way in which you want the day of the week printed. Select the full day name or the day name abbreviated to the first three letters of the day name; for example, Wed for Wednesday. By default, the abbreviated day name is printed.
   h. In the Day list box, select the way in which you want the day number printed when the day number is less than 10. Select the option to print the leading zero (0) or not to print the leading zero. By default, the leading zero is printed; for example, 05.
   i. In the Day Separator text box (visible only if you selected the Use Long Date option button), enter the character that you want to separate the day value from the month value in the date portion of the timestamp. The default value is the slash character (/).
   j. In the Month list box, select the way in which you want the month number printed when the month number is less than 10. Select the option to print the leading zero (0) or not to print the leading zero. By default, the leading zero is printed; for example, 09.
   k. In the Date Separator text box (visible only if you have selected the Use Long Date option button), enter the character that you want to separate the month value from the year value in the date portion of the timestamp. The default value is the slash character (/).
   l. In the Year list box, select the way in which you want the year printed.

Select the four-digit format or the two-digit format. By default, the four-digit format is printed; for example, 2004.
8. To specify options for the default display of the time portion of the timestamp, click on the **Time** tab to display the **Time** sheet. The Time sheet, shown in the following image, is then displayed.

![Time Sheet]

- **a.** the **Time** sheet, perform the following actions, if required.
  - **b.** If you want your report times to be printed in 12-hour clock format, select the **12 Hour Clock** option button or select the **24 Hour Clock** option button if you want your report times to be printed in 24-hour clock format. The default value is **12 Hour Clock**.
  - **c.** If you want to include seconds in your printed times, check the **Show Seconds** check box. By default, this check box is unchecked, indicating that seconds are not printed.
  - **d.** If you want the time marker to be printed as a **prefix** to the time value (for example, **pm12:06**), uncheck the **Show Time Marker as Suffix** check box.
    
    For the 12-hour clock format, the default time markers are **am** and **pm**. You can change these by using the **Marker** text boxes, described later in this procedure. By default, the **Show Time Marker as Suffix** check box is checked, indicating that the time marker is printed as a suffix to the time value.
  - **e.** If you want to suppress printing of the leading zero (0) when the hour value is less than **10**, uncheck the **Show Leading Zero for Hours < 10** check box. By default, this check box is checked, indicating that the leading zero is printed when the hour value is less than **10**; for example, **09:06pm**.
  - **f.** In the **Separator** text box, enter the character that you want to separate the hours and minutes (and seconds, if the **Show Seconds** check box is checked) of your default time format. The default value is a colon character (:) .
  - **g.** In the **Marker** text boxes, enter time markers to indicate pre-noon and post-noon times.

    If you selected the **12 Hour Clock** option button, there are two **Marker** text boxes for pre-noon and post-noon times, respectively. The default markers are **am** and **pm**. If you want to create your own default markers, enter up to 30 characters in the **Marker** text box.

    If you selected the **24 Hour Clock** option button, only one **Marker** text box is displayed. If you want a marker to be printed against the times in your report, enter up to 30 characters in the **Marker** text box.

    By default, there is no marker for the **24 Hour Clock** option.

9. **Click another tab** if you want to make changes on other sheets of the Report Formats dialog.

10. **Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Formats dialog.

    To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.
Using the Boolean Sheet

Use the Boolean sheet of the Report Formats dialog to change the default report formats for Boolean fields.

To change the default report formats for Boolean fields

1. Click the Boolean tab of the Report Formats dialog.

   The Boolean sheet, shown in the following image, is then displayed.

2. The Use System Default check box is checked by default. If you make any changes to the controls on this dialog, the Use System Default check box automatically unchecks itself, indicating that the system default values set by the JADE Report Writer Configuration application are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

   To revert to the system default values at any time during the report design process, you can check the Use System Default check box.

3. In the Display When Value is TRUE text box, enter the text that you want printed when the Boolean value is true. The default value is true.

4. In the Display When Value is FALSE text box, enter the text that you want printed when the Boolean value is false. The default value is false.

5. Click another tab if you want to make changes on other sheets of the Report Formats dialog.

6. Click the Apply button to apply the changes you have made or click the Close button to close the Report Formats dialog.
To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**Setting the Section Properties**

The Section Properties dialog is displayed when you select the **Properties** command on the popup menu that is displayed when you right-click inside a section on the report.

Use the Section Properties dialog to set and maintain default values that apply to individual sections of your report.

When you create a new report, the main sections that are automatically included are:

- Report header
- Page header
- Detail
- Page footer
- Report footer

You can also create group headers and footers.

Report sections are created with default properties that you can change by using the Section Properties dialog. You can also change some section properties by using commands that you access directly from the right-click popup menu without displaying the Properties dialog. You can change section properties in advance of any physical design or you can change them at any time during the design process.

For a description of report sections, see "Using the Sections of a Report", earlier in this chapter.

**To display the context-sensitive popup menu for a section**

- Right-click while your cursor is over the section whose properties you want to change. (Ensure that the cursor is not within a field, or the field properties popup menu is displayed instead of the section properties popup menu.)

The section properties popup menu, shown in the following image, is then displayed.
Some section properties are available on the popup menu when you right-click in a section.

The full range of properties is available when you select the Properties command from the popup menu.

The section properties are described in the following subsections.

- Changing the Section Properties on the Popup Menu
- Changing the Section Properties using the Properties Command
- Changing the Section Properties using a Format Script

**Changing the Section Properties on the Popup Menu**

To change the section properties on the section properties popup menu

1. Select the **Visible** popup menu command if you do not want this section printed. Selecting this command toggles the visibility on or off. The section is printed if there is a check mark symbol (✓) displayed at the left of the command.

   The section is not printed if there is no check mark symbol displayed at the left of the command. The section remains visible in your layout but the space is filled with cross-hatching (that is, it is grayed out). All sections are visible by default.

2. Select the **Print at Bottom of Page** popup menu command if you want the section printed at the bottom of the page. The check mark symbol (✓) is then displayed at the left of the command.

   Selecting this command toggles the option on or off. The section is printed at the bottom of the page only when a check mark symbol (✓) is displayed at the left of the command. This option is enabled for all sections other than the Page Header and Page Footer sections.

   By default, sections are not automatically printed at the bottom of the page, except for the Page Footer section, which is printed at the bottom of the page by definition (the option is set and cannot be changed).

3. Select the **Start New Page Before** popup menu command if you want this section printed on a new page. The check mark symbol (✓) is then displayed at the left of the command.

   This option applies only to the following sections:
   - Report Header Section (the option is set and cannot be changed)
   - Detail Section
   - Group Sections
   - Report Footer Section

   Clicking on this command toggles the option on or off. The section is printed on a new page only when a check mark symbol (✓) is displayed at the left of the command. By default, sections are not printed automatically on a new page.

4. Select the **Start New Page After** popup menu command if you want to start a new page after printing this section. The check mark symbol (✓) is then displayed at the left of the command.

   This option applies only to:
   - Report Header Section
   - Detail Section
Chapter 4  Designing JADE Reports

- Group Sections
- Report Footer Section (the option is set and cannot be changed)

Selecting this command toggles the option on or off. A new page is started after printing this section only when a check mark symbol (✓) is displayed at the left of the command. By default, a new page is not started automatically after printing sections.

5. Select the Restart Page # After popup menu command if you want to start numbering pages starting at 1 after printing this report section. The check mark symbol (✓) is then displayed at the left of the command.

Selecting this command toggles the option on or off. Page numbering restarts at 1 after the section is printed only when a check mark symbol (✓) is displayed at the left of the command. By default, numbering is not restarted after the section is printed.

6. Select the Suppress Print popup menu command if you do not want to print this section if there is no data in the fields of the section. The check mark symbol (✓) is then displayed at the left of the command.

Selecting this command toggles the option on or off. Printing of the section is suppressed if fields contain no data only when a check mark symbol (✓) is displayed at the left of the command. By default, sections are printed whether or not data exists in section fields.

7. Select the Combine with Following popup menu command if you want to position the section that follows this section so that it is printed horizontally adjacent to this section; that is, the two sections are combined. The check mark symbol (✓) is then displayed at the left of the command.

Selecting this command toggles the option on or off. The following section is combined with this section only when a check mark symbol (✓) is displayed at the left of the command.

By default, sections are not automatically combined; that is, the section that follows this section is printed below this section.

8. Select the Skip on First Page popup menu command if you want to suppress of the Page Header or Page Footer sections on the first page of the report.

The New command creates an additional section of the same type. For example, by distributing fields into a number of Detail sections and applying the Suppress Print command to those sections, you can avoid printing blank lines on a report.

The Select All command selects all fields, lines, and boxes in a section. (Use the Edit menu Select All command to select all fields, lines, and boxes in the report.)

The Delete command removes an additional section that was created by using the New command.

The Move Up and Move Down commands on the section properties popup menu apply only to multiple frame sections. For details, see "Using the Sections of a Report", earlier in this chapter.
Changing the Section Properties using the Properties Command

To change section properties using the section properties popup menu

1. Select the Properties command from the section properties popup menu.

   The Section Properties dialog, shown in the following image, is then displayed.

   ![Section Properties dialog](image)

   The section that has the focus is highlighted and the properties at the right of the dialog apply to that section. However, you can select another section from the list, if required. The pane at the right differs slightly from section to section. The type of section is displayed at the top of the pane; for example, **Group Header Section**.

2. If you do not want the current section printed, uncheck the **Visible in the Report** check box.

   The section remains visible in your layout but the space is filled with cross-hatching (that is, it is grayed out). By default, all sections are visible in the report.

3. If you want the current section printed at the bottom of the page, check the **Print at the bottom of the Page** check box.

   This check box is enabled only for Report Header, Detail, Group, and Report Footer sections. For these sections, the check box is not checked by default; that is, the sections are not printed at the bottom of the page. As the page footer is printed only at the bottom of the page, this check box is checked automatically for the Page Footer section and cannot be changed.
4. If you want the current section printed on a new page, check the **New Page BEFORE Printing** check box. This check box is enabled only for the following sections.
   - **Detail Section**
   - **Group Sections**
   - **Report Footer Section**

By default, the check box is not checked for these sections, indicating that the section is not printed automatically on a new page.

As the report header is always printed on a new page, this check box is checked automatically for the Report Header section and cannot be changed.

5. If you want to start a new page after printing this section, check the **New Page AFTER Printing** check box. This check box is enabled only for the following sections.
   - **Report Header Section**
   - **Detail Section**
   - **Group Sections**

By default, the check box is not checked for these sections, indicating that a new page is not printed automatically after the section is printed.

As a new page is always started after printing a footer, this check box is checked automatically for the Page Footer section and the Report Footer section and cannot be changed.

6. If you want to start numbering pages at 1 after printing the current report section, check the **Restart Page Number after printing** check box.

   By default, the check box is not checked, indicating that page numbering is not restarted after the section is printed.

7. If you do not want to print the current section if there is no data in the fields of this section, check the **Suppress Printing if No data** check box.

   By default, the check box is not checked, indicating that the section is printed regardless of whether data is present.

8. If you do not want to print the page header section or page footer section on the first page of the report, select the **Skip Page Header on first page** or **Skip Page Footer on first page** check box. These check boxes are displayed only when the **Page Header Section** or **Page Footer Section** is selected.

   By default, the check box is not checked, indicating that the page header or footer section is printed on the first page.

9. If you want to reprint the group header at the top of the next page, check the **Reprint Group Header at top of page** check box. This check box is visible only when you have selected a group header in the pane at the left.

   By default, the check box is not checked, indicating that the group header is not printed at the top of the next page.

10. If you want to position the section that follows the current section so that it is printed horizontally adjacent to this section (that is, the two sections are combined), check the **Combine with the following** check box.

    Typically, you would use this check box when you have a group header at the left of your page and you want detail to be printed so that it is indented to the right of the group header rather than directly below it.
In the following example, the group header is the type of garment and the stock detail section is printed to the right of it rather than below it.

<table>
<thead>
<tr>
<th>Men's Jeans</th>
<th>Blue</th>
<th>25</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dark Blue</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td>Grey</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Fawn</td>
<td>16</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Women's Jeans</th>
<th>Blue</th>
<th>55</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Light Blue</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td>Pink</td>
<td>93</td>
</tr>
</tbody>
</table>

By default, the check box is not checked, indicating that the section that follows the current section is printed below this section.

11. If you want to restrict the height of the section to the value that you enter in the Height text box, check the Fixed Height when Printing check box.

This check box is checked by default for all sections except the Page Footer section, indicating that the section is expanded if the detail does not fit. By default, the Page Footer is of a fixed height.

12. To change the default height for a section, enter the number of pixels in the Height text box. (The maximum number of pixels is 9999 and the default value is 60 pixels.)

If you do not check the Fixed Height when Printing check box to restrict the height of the section (described in step 10 of this instruction), the JADE Report Writer may expand a section beyond the value entered in this field if the detail does not fit when printing.

**Note**  A pixel is a picture element. It is the smallest element that can be displayed on the screen.

13. Change the background color of a section by selecting a color in the Color list box.

If you select the Custom color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the OK button to apply the selected color or click the Cancel button to close the Color dialog without making any changes. By default, each section has a white background.

14. If you want the display to show the attached templates, check the Show Template(s) check box. When the display of templates is selected, you can display template properties by selecting a template in the pane at the left but you cannot change the properties of that template. By default, the check box is not checked, indicating that the attached templates are not shown.

15. Use the up and down arrows below the display to relocate group sections or frames within any section, if required. Creating and maintaining group sections is described in "Creating Groups" under "Using the Detail Functions", later in this chapter.

16. If you want to return all of the settings for a section to the default values, click the Default button.

17. If you want to delete the currently selected group section or frame, click the Delete button. (The Delete button is displayed only if you have selected to view the properties of a group section. The Delete button is also displayed if there is more than one frame defined in a section and one of those frames is selected.)

If you are deleting a group section, a confirmation dialog is then displayed. Click the Yes button to delete the section or click the No button to abandon the deletion. Frames are deleted immediately.

18. Click the Format Script button to define section format scripts. If a format script exists for the current section, the button is blue. If no script exists, the button is grey. For more details, see "Changing the Section Properties using a Format Script", later in this subsection.
19. Click the Apply button to apply your section property changes and then click the Close button if you do not want to make more changes. To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

Changing the Section Properties using a Format Script

The Format Script dialog enables you to set properties for report sections from within scripts. This provides conditional control of properties such as item color and visibility so that they depend on values being reported. The properties displayed in the Format Properties category of the Fields list box depend on the section from which the format script dialog is accessed.

Click the Format Script button on the section properties dialog to define section format scripts. If a format script exists for the select section, the Format Script button is blue, if no script exists, the Format Script button is grey. The Format Script form, shown in the following image, is then displayed. Setting the section values in the format script, overrides the selections made on the Section Properties dialog.

The Format Script dialog that you use to define and maintain format scripts is similar to that used for user scripts, except that a format script does not require a name and return type. In addition, a format script is always a full script rather than a single expression.

For details about writing scripts, see Appendix A, "Using JADE Report Writer Scripts".
Chapter 4  Designing JADE Reports

Creating or Maintaining Profiles

Profiles enable you to produce the same report detail in different ways. Creating a profile is neither mandatory nor necessary before you start your report design. For example, having designed and printed a report, you can later decide that you need to print the same report in another way.

If the original report was a customer list in customer name sequence, you can decide to produce the same report in customer account number sequence. By creating profiles for the two variations of the same report, you or another user need only specify the profile name to print the required report.

If the original specification for your report is detailed enough to include provisions for different editions of the same report detail, you can create your profiles as an administrative function. (For details, see "Using Administrative Functions", earlier in this chapter.) You can use profiles to create different editions of your report by performing one or more of the following actions:

- Changing the sort order.
- Changing the selection criteria; for example, you may want to restrict a customer list to those customers in one district.
- Creating different groupings of the data; for example, you may want to group your customer list by district in one report but by account number prefix in another report.

**Note**  The number of group sections is the same for each profile but the Group-by controls of any group section can be different for each profile. For details, see "Creating Groups", later in this chapter.

To access the Profile Properties dialog, perform one of the following actions:

- Select the **New** command from the Profiles menu. (Use this command to create a new profile.) The Profile Properties dialog is then displayed with the **Profile** sheet uppermost. The other sheet tabs are displayed but disabled until a profile name is entered and applied.
- Select the **Properties** command from the Profiles menu. (Use this command to modify an existing profile.) The Profile Properties dialog is then displayed with the **Profile** sheet uppermost.
- Select the **Group Properties** command, the **Sort Order** command, or the **Selection Criteria** command from the Profiles menu. (Use these commands when you are modifying an existing profile and you know the sheet that you want to modify.) The Profile Properties dialog is then displayed, with the relevant sheet uppermost.

The subsections listed in the following table describe the sheets of the Profile Properties dialog.

<table>
<thead>
<tr>
<th>Subsections</th>
<th>Describes how to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Profile Sheet</td>
<td>Set or change the profile name and description.</td>
</tr>
<tr>
<td>Using the Sort Order Sheet</td>
<td>Specify or change the sort sequence.</td>
</tr>
<tr>
<td>Using the Selection Criteria Sheet</td>
<td>Specify or change selection criteria.</td>
</tr>
<tr>
<td>Using the Group Sheet</td>
<td>Specify or change the report grouping.</td>
</tr>
</tbody>
</table>

**Using the Profile Sheet**

Use the **Profile** sheet of the Profile Properties dialog to specify or change the name and description of your profile.
To specify or change the profile name and description

1. Click the Profile tab of the Profile Properties dialog.

The Profile sheet, shown in the following image, is then displayed. The Profile sheet is displayed by default when you select the New command or the Properties command from the Profile menu to display the Profile Properties dialog.

When you create a new profile, the other tabs on the Profile Properties are disabled until you specify and apply a new profile name.

2. In the Name text box, enter a name for your profile. (The maximum length of the profile name is 30 characters.)

You must enter a name in this text box when you create a new profile. Click the Apply button after entering a name to enable the other sheets of the Profile Properties dialog.

3. In the Text text box, enter an optional description of the profile. This provides you with documentation that describes the purpose of the profile.

4. To make this the default profile for your report, check the Set as default check box.

The default profile is the one that is used to display your report layout whenever you open the JADE Report Writer Designer application.

You can change the profile view by selecting another profile in the All Profiles list box at the top left of your layout on the main JADE Report Writer Designer window.

5. Click the Add button if you want to add a new profile. Use this button if you want to add a new profile but you
did not access the Profile Properties dialog by using the **New** command from the Profile menu.

If the **Profile** sheet is currently displayed, the controls are cleared ready for you to enter the new profile details.

If any other sheet of the Profile Properties dialog is currently displayed, the **Profile** sheet is then displayed with the controls cleared ready for you to enter the new profile details.

To enter your profile details, perform steps 2 through 4.

6. Check the **Copy new profile from** check box and then select an existing profile from the associated combo box if you want the new profile to have the same sort order, selection criteria, and group specification as an existing profile.

   Alternatively, do not check the box if the new profile is to have no sort order or selection criteria. (It will have the current group specification.)

7. Click another tab if you want to make changes on other sheets of the Profile Properties dialog.

8. Click the **Apply** button to apply the additions or changes you have made or click the **Close** button to close the Profile Properties dialog.

   To save the recent additions or changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any additions and changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**Using the Sort Order Sheet**

Use the **Sort Order** sheet of the Profile Properties dialog to specify a sort order for your report when the currently selected profile is applied.

This sheet enables you to select fields to control the sequence of your report. You can select multiple fields, specify ascending or descending sequences at the field level, and specify case-sensitivity at the field level.
To specify or change the sort order

1. Click the Sort Order tab of the Profile Properties dialog.

   The Sort Order sheet, shown in the following image, is then displayed. (The Sort Order sheet is displayed by default when you select the Sort Order command from the Profile menu to display the Profile Properties dialog.)

   ![Sort Order Sheet](image)

2. Select a field on which to sort from the Available Fields list box in the center of the dialog. The selected field and the right arrow are then highlighted.

   The list of fields in the Available Fields list box is derived from the database fields specified in the reporting view during the configuration phase and the report fields that you have defined in the current design. Available report scripts are only those that do not, directly or indirectly, reference a summary field. If you are creating profiles before starting to design your layout, only the database fields are displayed. For details about configuring your reporting view, see "Selecting the Schema, Types, and Features for Your Reporting View", in Chapter 3.

   Fields of maximum length (for example, allSaleItems::fullDescription of type String with max length) specified as sort fields are used as fields with a maximum length of 100. (Maximum length fields are not valid as sort fields, as they exceed the JADE-defined limit for use in collection operations.)

   **Note** If the total length of the combined sort and group fields exceeds the JADE-defined limit of 512 characters for the keyed dictionary used to implement sorting, string fields are reduced to 50 characters, and if the limit is still exceeded, the lower-order fields are dropped until the total length is less than the limit.

3. Click the right arrow to complete the selection of the sort field.
The selected field is then displayed in the Sort Fields list box at the right of the dialog and disabled (dimmed) in the Available Fields list box at the left. In the previous image, the name field has been selected.

4. For string fields, uncheck the Case-sensitive check box if you do not want to include case-sensitivity when sorting on this field; that is, you want capital letters to have the same value as their lowercase counterparts.

By default, the check box is checked for string fields, indicating that sorting is case-sensitive. Case-sensitivity does not apply to single character fields, and in this case the check box is disabled.

5. Select the Descending option button if you want to sort this field in descending order.

By default, sorting is in ascending sequence.

6. If required, select another field to sort on by using the steps 2 through 5, earlier in this instruction.

The following image shows the result when the date database field is selected with the Descending option.

When this profile is applied to the report, the data is printed in client name sequence and the sales are printed starting with the most recent sale for each client.

7. If you want to remove a field from the sort sequence, select it in the Sort Fields list box and then click the left arrow.

The selected field is then removed from the Sort Fields list box and enabled again in the Available Fields list box.

8. If you want to change the order of the sort fields in the Sort Fields list box, select the field you want to move and then click the up arrow or the down arrow, as required.
In the image shown in step 6, only the up arrow is enabled because the selected field is the last field in the list and can only move up. In this example, if you click the up arrow, the field `Clients::allRetailSales -> date` is moved above the `Clients::name` field.

This effectively changes the report to show detail in reverse date sequence, printing a client name list within each date.

9. Click another tab if you want to make changes on other sheets of the Profile Properties dialog.

10. Click the Apply button to apply the additions or changes you have made or click the Close button to close the Profile Properties dialog.

To save the recent additions or changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any additions and changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

**Using the Selection Criteria Sheet**

Use the Selection Criteria sheet of the Profile Properties dialog to specify selection criteria for your report when this profile is applied.

Base your selection criteria on the fields of your reporting view or the report fields that you have defined in the current design. For example, you can select all customers from a customer list who have the name Smith.

With any field type, you can apply standard comparison operators to make your selection. If a selection field is a string value, you can also use pattern matching with the starts with, ends with, and like comparison operators.

If a selection field is a database reference field, you can compare object classes with the is, is one of, and is empty comparison operators.

Comparison values must be compatible with the Character primitive type.
To specify or change the selection criteria

1. Click the **Selection Criteria** tab of the Profile Properties dialog.

   The **Selection Criteria** sheet, shown in the following image, is then displayed. (The **Selection Criteria** sheet is displayed by default when you select the **Selection Criteria** command from the Profile menu to display the Profile Properties dialog.)

2. Select a field to use as a selection field from the **Available Fields** list box at the left of the dialog. The following conditions apply.

   - You can select a report script only if it returns a **Boolean** value (that is, **true** or **false**).
     
     **Tip** You can use a report script that returns a **Boolean** to frame complex selection criteria that cannot be expressed in this dialog as an **if** statement that returns **true** when the selection criteria are met.

   - If you select a reference database field (that is, a database field that points to other database fields, as indicated by the plus (+) or minus (-) sign displayed to the left of the field), a list of subclasses is displayed under the **Value** caption, to enable you to specify an object class as a selection field. For details, see step 5 of this instruction.

   - If you select a reference database field that points to another object that is not a primitive type or a collection, you can also specify an object parameter as a selection field. See step 5 of this instruction for details.

   The selected field is then highlighted and the right arrow is enabled.
Chapter 4  Designing JADE Reports

The list of fields in the Available Fields list box is derived from the database fields that you specified in the reporting view during the configuration phase and the report fields that you defined in the current design. Available report scripts are only those that do not, directly or indirectly, reference a summary field. If you are creating profiles before starting to design your layout, only the database fields are displayed here. For details about configuring the JADE Report Writer, see Chapter 3, "Configuring the JADE Report Writer".

3. Click the right arrow to complete the selection. Alternatively, double-click the field to select it. The selected field is then displayed in the Selection Field text box at the right of the dialog. In the previous image, the client name field has been selected.

4. Select an operator from the Operator list box at the right of the dialog. The example in the following image shows the operator is equal to selected.

5. In the Value text box, enter a value with which your selection field is compared. To make this entry, perform one of the following actions.

- Enter a value directly in the Value text box.

  If you use the starts with, ends with, or like comparison operators with a string value, you can also use pattern matching. If you use the is one of or is between operator, you can also specify multiple values by adding them to the list of values. For details, see the instructions later in this section.

  The following image shows an example in which the value Smith is entered.

In the examples in steps 3 through 5, the following selection formula has been built.

Clients::client name is equal to "Smith"

When this profile is applied, the report then prints detail items that apply only to clients named Smith.

If the operator is greater than or equal to is selected in step 4, the report is then produced for clients named Smith and all those higher alphabetically; for example, Stevens, Trubshaw, and Widmerpool.

- Select another database field as a comparison item. Click a database field in the Available Fields list box and then click the right arrow that is displayed to the left of the Value text box. The selected database item is then displayed in the Value text box.
Only database items that are primitive types (such as String, Integer, and so on) can be used as comparison items. References and collections are not allowed. The primitive types must match (for example, String can be compared to String or Character), as for any other comparison. There are no other restrictions on the relationship between the two specified database items; for example, they do not need to be of the same object class.

- Specify an object class as the comparison value. If you have specified a reference database field as a selection field, the valid operators are is kind of, is, and is empty. If you select the is kind of or is operators, a list of subclasses is displayed under the Value caption. Select an object class from the list box.

When objects are read from the specified reference field as the report is run, the selection criteria is met if the class of the object matches the selection. For an is kind of comparison, it is matched if the object class is the same as, or is a superclass of, the specified class. For an is comparison, it is matched if the object class is the same as the specified class.

If the database item is not a collection reference and is null, the is empty comparison is true. If the database item is a collection and has no entries (that is, it is of zero size), the is empty option is true.

- Use a report parameter as the comparison value. Click a parameter in the Available Fields list box and then click the right arrow that is then displayed to the left of the Value box. The selected parameter item is then displayed in the Value text box.

You can compare a reference field against an object parameter, if required. The comparison operator can only be is equal to or is not equal to.

When selection criteria using parameters as comparison values are updated, the Value text box is disabled. To clear a parameter from the Value text box, click the left arrow that is displayed to the left of the Value box. This arrow is displayed only when a parameter is used as a comparison value. Clearing the Value text box enables you to enter a literal value, rather than another parameter.

For details about creating parameters, see "Using the Param Sheet" under "Using the Catalog of Available Fields Dialog", later in this chapter.

- Select a script as the comparison value. The script must return the same value type as the selection field, which must be a database field followed by an operator.

6. Check the Not check box to negate your selection criterion formula. If you check this check box, the formula you have built as a selection criterion is negated. For example, if you formulate Clients::client name is equal to Smith and then check the Not check box, a report is produced that shows all clients except those named Smith when this profile is applied.

7. Check the Case-sensitive check box to make the comparison case-sensitive. Case-sensitive comparisons match the capitalization (case) of string fields as well as the characters. The Case-sensitive check box is enabled only for string fields and checked by default. Uncheck this option, to remove case-sensitivity.

8. Click the Update Criteria button to add your selection criterion formula to the Selection Items list box at the bottom of the sheet.

You can enter any number of selection criteria, by following steps 2 through 8 of this procedure for each selection criterion that you create. For example, you could add another formula, as follows.

Clients::email is null

If you then select the box at the right of the Not check box for this formula, you effectively refine your selections to those clients named Smith who do not have an e-mail address.
The following image shows the **Selection Items** list box as it would be displayed with these selection criteria applied.

![Selection Items Example](image)

9. Selection criteria are first selected and then they are grouped. By default, multiple selection criteria are linked by a Boolean **AND** operator. This means that where you add more than one selection criterion, they must all apply. The example in the above image narrows the selection to all clients whose name is **Smith** and whose e-mail address is null (that is, they have no e-mail address). You can change the item grouping to use the Boolean logical **OR** operator, to group selection criteria in cases where one criterion or the other can apply.

- Use a different operator to select the selection criteria that you want to link. Hold down the Shift or Ctrl key while clicking to select more than one item. Include at least two items in your selection. The selection must be contiguous, or it will include unrelated existing conditions. To apply an **AND** operator or an **OR** operator, click on the with **AND** button or the with **OR** button, respectively.

Brackets then group the selected items and the logical operator is set to the new value. If the selected items were already grouped (indicated by brackets around them), the grouping remains unchanged and only the **AND** or **OR** operator is set to the new value.

The example in the following image shows the **Selection Items** list box with two criteria selected and linked by a Boolean **OR** operator. In this example, the selection is narrowed to clients whose name is **Smith** or **Jones** and whose e-mail address is null. Note the brackets around the selected criteria, indicating that the criteria **Smith OR Jones** are grouped and will be applied before the **email is null** criterion.

![Selection Items Example](image)

- To restart selection grouping, click the **Clear All** button. This removes all groupings and reverts to the default; that is, a list of selection items linked by **AND**. When an existing selection criterion is deleted, all existing grouping is automatically cleared.

10. When you have entered several selection items, you can change their order by selecting the item to be moved and clicking on the up arrow to move items up in the list or the down arrow to move them down the list. You can move selection items within the list, to make them contiguous for grouping. (See step 8 in this instruction for details.)

If you use grouped selection criteria, changing the order of these selection items invalidates these criteria. You can therefore move selection criteria only when there are no existing groups. To clear any existing groups, click the **Clear All** button.

11. Update a selection criterion in the **Selection Items** list box by double-clicking the entry, if required. You can change the values that are then redisplayed in the relevant fields to meet your requirements.
12. To delete an existing selection criterion, click once on the selection criterion in the Selection Items list box. The Remove Selected Item button, displayed as a left arrow to the upper right of the Selection Items list box, is then enabled, changing from gray to blue. Click this button to remove the selection criterion.

13. Click another tab if you want to make changes on other sheets of the Profile Properties dialog.

14. Click the Apply button to apply the additions or changes you have made or click the Close button to close the Profile Properties dialog. To save the recent additions or changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any additions and changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

Using the starts with, ends with, or like comparison operators with string values enables pattern matching.

To use pattern matching with string selection criteria

1. Select one of the following operators from the Operator list box.
   - To compare a character or sequence of characters at the start of the selection string value, use starts with.
   - To compare a character or sequence of characters at the end of the selection string value, use ends with.
   - To apply pattern matching to the selection string value, use like.

2. Enter selection criteria in the Value text box, by using a single pattern string. The pattern string can be any sequence of characters and can include any of the following wildcard characters.
   - ? or _ representing any single character
   - * or % representing any substring sequence of one or more characters, including an empty substring

You can use the backslash (\) character to nullify any wildcard character so that it is treated as a normal character in the pattern string. For example, \? is treated as a literal question mark character (that is, ?) and not as a wildcard character.

Selecting the is one of or is between comparison operators enables you to specify multiple comparison values.

To specify multiple comparison values

1. Select the is one of or is between comparison operator from the Operator list box. A list box is then displayed underneath the Value text box, and two buttons are displayed to enable you to add multiple comparison values, as shown in the following image.

2. Specify a value in the Value text box and then click the Add value to list button to add this value to the list of comparison values. Add any additional values to the list, as required.

3. To remove a comparison value from the list, select the required value and then click the Remove value from
To specify selection criteria involving related data

It is important to understand how selection criteria involving a feature of a related entity are evaluated when a report is run or previewed. For example, if a report is based on a root collection of sale items and each sale item is supposed to have a related agent.

It is impossible to evaluate one of its features if for some reason the related entity does not exist. For example, design a sale items report where the related entity is the agent offering the item for sale, as shown in the following image.
In this example, either of the following selection criteria must be met.

- The agent for the sale item is Hank Williams
  
  \[\text{SaleItem::myAgent->name} \text{ is equal to } "\text{Hank Williams}" \text{[case sensitive]}\]

- The sale date is after 1 October 1999
  
  \[\text{SaleItem::forSaleDate} \text{ is greater than to } "1 \text{ October 1999}"\]

If a sale item does not have an agent (the agent is null or empty) in the first part of the condition, it is not possible to evaluate the name of the agent. The Report Writer discards the sale item without attempting to evaluate the second part of the condition regarding the date of sale.

You can guard against sale items not having a valid agent, as shown in the following image.
In this example, you could also have reversed the order of the conditions, as shown in the following image.

![Image of item grouping with conditions reversed]

**Note** To gather statistics when running a report, set the following parameters in the JADE initialization file (`jade.ini`).

```plaintext
[JadeReportWriter]
QueryDataFailureTraceOn   = true
QueryExecTraceOn          = true
QueryOptimizationTraceOn  = true
QueryPrepTraceOn          = true
QueryReadFailureOptionOff = true
QueryStatisticsTraceOn    = true
```

Examine the JADE message log file (`jommsg.log`) for the number of `NumIfDefineds`, which are null or empty references to entities encountered when running the report.

```
2004/08/19 12:28:22 02838-2794 JadeAQE: NumIfDefineds : 0
```

### Using the Group Sheet

Use the **Group** sheet of the Profile Properties dialog to update group properties.

In the JADE Report Writer Designer application, groups enable you to group your data under various headings and produce subtotals when a group changes. For example, if a customer report is grouped by customer, each group could show all purchases made by one customer with a subtotal showing the total purchases for that customer.

As groups are defined on report fields, creating groups is not an administrative function that you can do initially. Creating groups is therefore described in "Creating Groups" under "Using the Detail Functions", later in this chapter.

### Using the Detail Functions

The following subsections describe adding and maintaining the detail of your report.

- **Report Detail Overview**
- **Inserting Report Fields**
- **Linking and Unlinking Headers**
- **Using the Catalog of Available Fields Dialog**
  - Using the System Sheet
  - Using the Param Sheet
When you start a new report design, the default layout displays the default sections.

The basic tool for creating and maintaining report fields is the Catalog of Available Fields dialog, from which you can simply click, drag, and drop fields from the catalog straight onto your report layout, as shown in the following image.

After inserting your fields into your report, change their properties by using the properties commands or manipulate them by using layout commands.

The Catalog of Available Fields dialog also enables you to create parameters, scripts, summary fields, and method fields to complete your report design. The following table lists the major steps required to design a report.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Function</th>
<th>For details, see subsection ...</th>
<th>Located ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Perform the Administrative Functions</td>
<td>Using Administrative Functions</td>
<td>Earlier in this chapter</td>
</tr>
<tr>
<td>2</td>
<td>Start a new report</td>
<td>Starting a Report from Scratch</td>
<td>Earlier in this chapter</td>
</tr>
</tbody>
</table>
The sequence in the previous table is not mandatory. As discussed under "Using Administrative Functions", earlier in this chapter, you could begin designing your report by inserting fields (by using step 6 in the preceding table) and then create report profiles and set report properties at a later stage.

As the step of attaching templates (step 3, in the preceding table) assumes that you have already constructed report templates, creating additional frames (in step 4) would not be necessary in most cases when you start designing a report from scratch. The default sections usually provide sufficient scope for starting to build report layouts.

This section deals with steps 6 through 12 for designing a report in the preceding table.

## Inserting Report Fields

The JADE Report Writer Designer application provides an easy-to-use drag and drop feature that enables you to place report items on your layout.

Although this subsection assumes that you select fields from the Catalog of Available Fields dialog, you can also drag and drop fields from the items on the Insert menu. For details about the Insert menu, see "Insert Menu", later in this chapter.

This subsection describes the functions that are common to inserting any field from the System sheet of the Catalog of Available Fields dialog. The procedures required to insert fields, described in the following subsections, differ from field to field.

- Inserting a Literal
- Inserting a Picture
- Inserting a Line
- Inserting a Box
Inserting a Special Field

Inserting a Database Field

For details about creating and inserting parameter, script, and summary fields, and displaying their usage, see "Using the Catalog of Available Fields Dialog", later in this chapter.

To display the Catalog of Available Fields dialog, perform one of the following actions

- Press the F6 key
- Select the Catalog command from the View menu

The Catalog of Available Fields dialog is then displayed in the JADE Report Writer Designer application window.

It is convenient to leave the dialog displayed while you develop your layout, as it provides all of the tools that you require to complete the details of your report. For details about using the Catalog of Available Fields dialog, see "Using the Catalog of Available Fields Dialog", later in this chapter.

To insert a report field on the layout using the drag and drop technique

1. Click the field that you want to add to your report and then hold down the mouse button.
2. While continuing to hold down the mouse button, move the cursor across the layout (that is, drag the field). For most fields, the cursor becomes a dotted rectangle that you can place accurately.

   Tip For greater accuracy in placing fields, you can display a grid on the layout. For details, see "Show/Hide Grid" under "View Menu", later in this chapter. If you select the Snap to Grid command, fields are neatly aligned by "sticking" to the points of the grid. For details, see "Snap to Grid" under "View Menu", later in this chapter.

3. Release the mouse button (that is, drop the field) when the selected field is in the required position.

   Absolute accuracy is not essential at this point, as you can refine the positioning at any time during your design session. For details, see "Using the Layout Commands", later in this section. Moving your field is also described later in this subsection.

   The field is inserted at the point where you released the mouse button (or dropped it).

   Notes You can also drag and drop fields from the Insert menu. For details, see "Insert Menu", later in this chapter.

   The instructions in this section and the following subsections are based on using the Catalog of Available Fields dialog to access field types.

   You can change field properties by selecting the Properties command from the popup menu that is displayed when you right-click on a field. For details, see "Setting Field Properties", later in this chapter.

To insert a report field by using the Select button on the Catalog of Available Fields dialog

1. Click the field that you want to add to your report.
2. Click the Select button.
3. Click on the position on your report at which the field is to be placed.

   Absolute accuracy is not essential at this point, as you can refine the position at any time during your design session. For details, see "Using the Layout Commands", later in this section. Moving your field is also
described later in this subsection.

The field is inserted at the point that you specified.

**To resize a report field**

1. Click once on the field to display the resizing handles, which are the small blue squares positioned around the field when the field is selected, as shown in the following image of an example of a literal field.

   ![Resizing handles example](image)

   This literal text is larger than the default receiving field that the JADE Report Writer Designer application displays when a literal is dropped into the layout. In this case, you need to extend the field so that the whole literal is visible.

   **Note** If this is a new field that you have just dragged and dropped into position, resizing handles are displayed by default.

2. Click one of the resizing handles and then hold down the mouse button.

   A double-headed arrow is displayed over the resizing handle, as shown in the three examples in the following image.

   ![Resizing handle examples](image)

   These examples show the directions in which the box can be stretched, depending on the resizing handle that you click.

3. To enlarge the box, drag (that is, hold down the mouse button) a resizing handle in a direction indicated by the arrows and then release the mouse button at the required point.

   The following image shows the box enlarged by dragging the resizing handle at the far right (that is, the third example in the previous image).

   ![Box enlargement example](image)

4. If your field is too big to fit into its section, enlarge the section by performing the following actions.

   a. Click and then hold down the mouse button on the section separator below the section that you want to enlarge. The section adjustment pointer is displayed on the line, as shown in the following image.
b. While continuing to hold down the mouse button, drag the line down until your field fits the section, as shown in the following image.

You can also resize fields by using commands on the Field Properties dialog or the layout commands. For details, see "Setting Field Properties" and "Using the Layout Commands", later in this chapter.

**To move a report field**

1. Click once inside the field. The cursor then changes to a crossed arrows symbol, the move handle.

   **Note** If this is a new field that you have just dragged and dropped into position, the cursor changes to a crossed arrows symbol (↑) when you move into the field area.

2. Move the field by performing the following actions.
   a. Click in the field.
   b. Hold down the mouse button.
   c. Drag the field to the new position.
   d. Drop the field at that position by releasing the mouse button.

You can also move fields by performing one of the following actions.

- Use the commands from the Field Properties dialog or the layout commands. For details, see "Setting Field Properties" and "Using the Layout Commands", later in this chapter.

- Select a line or box and use the arrow keys. Each keystroke moves the field one pixel in the appropriate direction.
  
  The Shift+arrow key combination moves the selected field one grid position when the snapping to grid option is enabled or one pixel if the snap to grid option is disabled.

**To delete a report field**

1. Right-click over the field that you want to remove from your layout.

2. Select the **Delete** command from the popup menu that is then displayed.

   A dialog is then displayed, prompting you to confirm your deletion.

3. Click the **Yes** button to delete the field. Alternatively, click the **No** button to cancel the deletion and retain your field.

   The field is then removed from your layout.
To review a report field

Hold your cursor on the field for a few seconds until a line of description (or bubble help) is displayed below the field, as shown in the following image.

In this example, the cursor has been moved over the third field from the left in the detail section and a description of the field is displayed below the field.

The field in this example is a database field whose bubble help shows a short description of a sale item from the retail sales list of the current client.

Inserting a Literal

Literal fields enable you to insert your own text into the report.

The most common use of literals is the creation of heading, subheading, and field caption text. For example, the following image shows a literal heading applied to the report header.

To insert a literal

1. Drag and drop the Literal field from the Catalog of Available Fields dialog to your layout. For general details about using the drag and drop procedure, see "Inserting Report Fields", earlier in this section. A rectangular image is then displayed at the point at which you dropped the literal, as shown in the following image.

2. To type an entry, click inside the rectangle. A solid box is displayed inside the image, as shown in the following image.

   Note If you change an existing literal field entry (that is, the blue resizing handles are not visible around the field), you need to click twice inside the box (once to select the field and once more to display the solid box). Alternatively, right-click over the field and select the Text command from the popup menu that is then displayed.

3. Type your literal text inside the solid box, as shown in the following image.

   To break the current line and begin a new line while you are entering your text, press Ctrl+Enter. A carriage return is inserted and the caret is moved to the beginning of new line underneath the existing text line. In this example, Sales By Customer has been typed into the box. However, the default box is not wide enough to display the full heading.
4. Use the resizing handles (that is, the small blue squares on the perimeter of the field image) to resize the field. For details about resizing fields, see "Inserting Report Fields", earlier in this section.

5. If you want to move the field before you complete its entry, place the cursor inside the field so that the pointer changes to a crossed arrows symbol, click and hold down the mouse button, and then drag the field to a new position and drop it (that is, release the mouse button). For details about moving fields, see "Inserting Report Fields", earlier in this section.

6. Click outside the field to complete the insertion of your literal field.

The field is then displayed with bold delimiters, as shown in the following image.

Change the font of your literal by using the field properties. For details, see "Setting Field Properties", later in this chapter.

**Inserting a Picture**

You can insert pictures into any of your report sections. The JADE Report Writer Designer application accepts all of the common picture types (for example, bitmaps, icons, and portable network graphics).

» **To insert a picture**

1. Drag and drop the **Picture** field from the Catalog of Available Fields dialog to your layout. For details about using the drag and drop feature, see "Inserting Report Fields", earlier in this section.

   As you move the cursor across to the layout while you continue to hold down the mouse key, the pointer becomes a dotted-line rectangle, enabling you to accurately choose the location for your picture. When you release the mouse button, a common File dialog is then displayed, to enable you to specify the location and name of your picture file.

2. Locate and select your file in the dialog and then click the **Open** button.

   The selected picture is then displayed on your layout in required location, as shown in the following image.

   ![Image](Image)

   In this example, the picture is a logo for the Erewhon company that has been inserted into the Report Header section.

3. Use the resizing handles (the small blue squares on the perimeter of the field image) to resize the field. For details about resizing fields, see "Inserting Report Fields", earlier in this section.

4. If you want to move the field before you complete its entry, place the cursor inside the field so that the pointer changes to a crossed arrows symbol, click and hold down the mouse button, and then drag the field to a new position and drop it (that is, release the mouse button). For details about moving fields, see "Inserting Report Fields", earlier in this section.

5. Click outside the field to complete the insertion of your literal field.

The field is then displayed with bold delimiters.
Inserting a Line

Use graphical lines to separate parts of your report text. The JADE Report Writer Designer application enables you to draw vertical or horizontal lines of various widths and colors.

To insert a line

1. Drag the Line field from the Catalog of Available Fields dialog to your layout. For details about using the drag and drop feature, see "Inserting Report Fields", earlier in this section.

   A small rectangular marker is attached to the cursor and marks the point at which you dropped the field, as shown in the following image.

   ![Marker Image]

2. Move the cursor (that is, move the mouse without clicking the mouse button) to finalize the position of the start of your line.

3. Click and hold down the mouse button and then drag the cursor to the end-point of the line that you want to draw.

4. Release the mouse button at the end-point of the line you want to draw.

   The line is displayed in the place that you marked, as shown in the following image.

   ![Line Image]

**Note** You can draw vertical lines across multiple sections, if required.

To change the length of the line

1. Select the line that you want to change.

2. Place the cursor on the end of the line.

   A double-headed arrow symbol, which is a resizing arrow, is then displayed at the cursor position.

3. Click and hold down the mouse button, and then drag to the left or right to change the length of the line.

4. Release the mouse button to complete the line to length change.
You can also use the Ctrl+arrow keys to change the length of a line from the right or bottom margin by one pixel in the direction indicated by the arrow each time the key is pressed. Select the line whose length you want to expand or shrink, hold down the Ctrl key, and then use the:

- Right arrow key (→), to expand from the right
- Left arrow key (←), to reduce from the right
- Up arrow key (↑), to expand from the bottom
- Down arrow key (↓), to reduce from the bottom

**To change the width of the line**

1. Place the cursor anywhere on the line and then right-click.
2. Select the **Width** command on the popup menu that is then displayed.

   A popup submenu is then displayed, providing the line width options shown in the following image.

   ![Width Options](image)

   The width sizes are in pixel units. The default value is 2 pixels. The check mark symbol (✓) is displayed at the left of the width size that is currently selected.

3. Select another line width from the list of sizes.

   The line is then redrawn with your selected line width.

**To move the line vertically**

1. Select the line that you want to move.
2. Place the cursor in the middle of the line; that is, on the black dot.

   A double-headed arrow symbol is then displayed at the pointer position.

3. Click and hold down the mouse button, and then drag the line up or down, as required.
4. Release the mouse button to complete the move.

   You can also move fields by selecting a line or box and using the arrow keys. Each keystroke moves the field one pixel in the appropriate direction. The Shift+arrow key combination moves the selected field one grid position when the snap to grid option is enabled or one pixel if the snap to grid option is disabled.

**To change the color of the line**

1. Place the cursor anywhere on the line and then right-click.
2. Select the **Color** command on the popup menu that is then displayed.
A popup submenu is then displayed, providing the color options shown in the following image.

```
<table>
<thead>
<tr>
<th>Width</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Black</td>
</tr>
<tr>
<td></td>
<td>Blue</td>
</tr>
<tr>
<td></td>
<td>Dark Blue</td>
</tr>
<tr>
<td></td>
<td>Gray</td>
</tr>
<tr>
<td></td>
<td>Dark Gray</td>
</tr>
<tr>
<td></td>
<td>Light Green</td>
</tr>
<tr>
<td></td>
<td>Yellow</td>
</tr>
<tr>
<td></td>
<td>Green</td>
</tr>
<tr>
<td></td>
<td>Custom</td>
</tr>
<tr>
<td></td>
<td>Mauve</td>
</tr>
<tr>
<td></td>
<td>Purple</td>
</tr>
<tr>
<td></td>
<td>Red</td>
</tr>
<tr>
<td></td>
<td>Light Yellow</td>
</tr>
</tbody>
</table>
```

The check mark symbol (✓) is displayed at the left of the color that is currently selected. The default color is Black.

3. Select a color from the list of colors.

4. To apply a custom color that you have specified, select the Custom command. The common Color dialog is displayed, to enable you to select or define a custom color. When you have made your selection, click the OK button to apply the selected color or click the Cancel button to close the Color dialog without making any changes.

The line is then redrawn in your selected color. Alternatively, use the Horizontal or Vertical Line Properties dialog and specify a custom color using the Color combo box. For details, see "Specifying Line Properties", later in this section.

**To delete the line**

1. Place the cursor anywhere on the line and then right-click.

2. Select the Delete command from the popup menu that is then displayed.

The line is then removed from your layout.

### Specifying Line Properties

Use the Horizontal or Vertical Line Properties dialog to precisely specify the width, color, and position of your lines.

**To specify the properties of a line**

1. Place the cursor anywhere on the line (that is not a sizing handle) and then right-click.

2. Select the Properties command from the popup menu that is then displayed.
The Line Properties dialog is then displayed, as shown in the following image.

![Horizontal Line Properties dialog](image)

The title bar of this dialog is displayed as Horizontal Line Properties or Vertical Line Properties, indicating whether the currently selected line is horizontal or vertical.

3. Select a line width from the **Width** combo box. The width sizes are in pixel units. The default value is 2 pixels.

4. Select a line color from the **Color** combo box. The default color is **Black**.

   If you select the **Custom** color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the **OK** button to apply the selected color or click the **Cancel** button to close the Color dialog without making any changes.

5. Under the **Start Position** caption, specify the starting position of the line. The list box displays the frame in which the line starts. The position of the line is measured in pixels relative to the top left corner of the designated frame, in the two text boxes below.

   - Select the frame the in which the line starts from the list box under the **Start Position** caption.
   - Specify the horizontal position of the start of the line from the left edge of the frame in pixels in the horizontal position text box under the **Start Position** caption.

      Alternatively, click on one of the horizontal position buttons to move the start of the line left or right one pixel at a time.

   - Specify the vertical position of the start of the line from the top edge of the frame in pixels in the vertical position text box under the **Start Position** caption.

      Alternatively, click on one of the vertical position buttons to move the line up or down one pixel at a time.
6. Under the End Position caption, specify the position of the end of the line. The list box displays the frame in which the line ends. It is disabled for horizontal lines because horizontal lines cannot cross frames. The position of the line is measured in pixels relative to the top left corner of the designated frame, in the two text boxes below.

   - Select the frame in which the line ends from the list box under the End Position caption. Only a vertical line can cross multiple frames.
   - Specify the horizontal position of the end of the line from the left edge of the frame in pixels in the horizontal position text box under the End Position caption. This text box is disabled for a vertical line because the horizontal position of the end of a vertical line is always the same as that of the start.

   Alternatively, click on one of the horizontal position buttons to move the end of the line left or right one pixel at a time.

   - Specify the vertical position of the end of the line from the top edge of the frame in pixels in the vertical position text box under the End Position caption. This text box is disabled for a horizontal line because the vertical position of the end of a horizontal line is always the same as that of the start.

   Alternatively, click on one of the vertical position buttons to move the line up or down one pixel at a time.

   **Note** A line can be moved within a frame by changing the relevant top and left values, and moved between frames by changing the start and end frames. For the end frame, the frames that come before the selected start frame are disabled, as the end frame must be the same as or below the start frame. If you change a line start or end value so that it is greater or less than the corresponding end or start value, the start and end positions are reversed in the dialog, to maintain their relative values.

7. Click the Apply button to apply your changes immediately to the currently selected line.

8. Click the Delete button to delete the currently selected line.

9. Click the Next button to select the next line or box. Lines and boxes are selected in the order in which they were defined. This can be useful when an existing drawing object is too small to be easily visible.

10. Click the Close button to close the Line Properties dialog and return to the report layout.

**Inserting a Box**

Use graphical boxes to contain or highlight parts of your report text. The JADE Report Writer Designer application enables you to draw boxes of various sizes and colors.

- **To insert a box**

  1. Drag the Box field from the Catalog of Available Fields dialog to your layout. For details about using the drag and drop feature, see "Inserting Report Fields", earlier in this section.
A small rectangular marker is attached to the cursor, marking the point at which you dropped the field, as shown in the following image in which the pointer has been placed at the top left of the Erewhon logo.

2. Move the cursor (that is, move the mouse without clicking the mouse button) to finalize the position of the start of your box.

3. Click and hold down the mouse button and then drag the cursor to the farthest point of your box; that is, to the opposite corner. The following image shows the cursor at the end-point for drawing a box around the logo before you release the mouse button.

4. Release the mouse button at this point. The box is then displayed in the place that you marked, as shown in the following image.

**Note** You can draw boxes across multiple sections, if required.
To change the line width of the box

1. Place the cursor anywhere on the perimeter line of the box and then right-click.
2. Select the **Width** command on the popup menu that is then displayed.

   A popup submenu is then displayed, providing the line width options shown in the following image.

   ![Width Menu]

   The width sizes are in pixel units. The default value is 2 pixels.
   The check mark symbol (✓) is displayed at the left of the line-width size that is currently selected.
3. Select another line width from the list of sizes.
   The box is then redrawn with your selected line width.

To change the size of the box

1. Select the box that you want to resize; that is, click on any part of the line of the box.
2. Place the cursor on any of the resizing handles (that is, the black dots in the middle of each side and in each corner of the box).
3. Drag the cursor in the direction in which you want to extend the box.
4. Release the mouse button to complete the resize operation.

   You can also use the Ctrl+arrow keys to change the size of a box from the right or bottom margin by one pixel in the direction indicated by the arrow each time the key is pressed. Select the box whose size you want to expand or shrink, hold down the Ctrl key, and then use one of the following.
   - Right arrow key (→), to expand from the right
   - Left arrow key (←), to reduce from the right
   - Up arrow key (↑), to expand from the bottom
   - Down arrow key (↓), to reduce from the bottom

To change the color of the box

1. Place the cursor anywhere on the perimeter line of the box and then right-click.
2. Select the **Color** command on the popup menu that is then displayed.
A popup submenu is then displayed, providing the color options shown in the following image.

<table>
<thead>
<tr>
<th>Width</th>
<th>Color Properties...</th>
<th>Delete</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>□ Black</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Blue</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dark Blue</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Gray</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dark Gray</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Light Green</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Yellow</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Green</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Custom</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mauve</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Purple</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Red</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Light Yellow</td>
<td></td>
</tr>
</tbody>
</table>

The check mark symbol (✓) is displayed at the left of the color that is currently selected. The default color is Black.

3. Select a color from the list of colors.

4. To apply a custom color that you have specified yourself, select the Custom command. The common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the OK button to apply the selected color or click the Cancel button to close the Color dialog without making any changes.

The box is then redrawn in your selected color. To apply a custom color that you have specified yourself, use the Box Properties dialog and specify a custom color using the Color combo box. For details, see "Specifying Box Properties", later in this section.

**Specifying Box Properties**

Use the Box Properties dialog to precisely specify the line width, line color, and position of your boxes.

» To specify the properties of a box

1. Place the cursor anywhere on the edge of the box (that is not a sizing handle) and then right-click.

2. Select the Properties command from the popup menu that is then displayed.
The Box Properties dialog is then displayed, as shown in the following image.

3. Select a line width from the **Width** combo box. The width sizes are in pixel units. The default value is 2 pixels.

4. Select a line color from the **Color** combo box. The default color is **Black**. If you select the **Custom** color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the **OK** button to apply the selected color or click the **Cancel** button to close the Color dialog without making any changes.

5. Under the **Start Position** caption, specify the position of the top left corner of the box. The list box displays the frame in which the box starts. The position of the top left corner of the box is measured in pixels relative to the top left corner of the designated frame, in the text boxes below.
   - Select the frame the box starts in from the list box under the **Start Position** caption.
   - Specify the horizontal position of the box from the left edge of the frame in pixels in the horizontal position text box under the **Start Position** caption.
     Alternatively, click on one of the horizontal position buttons to move the left edge of the box left or right one pixel at a time.
   - Specify the vertical position of the top of the box from the top of the frame in pixels in the vertical position text box under the **Start Position** caption.
     Alternatively, click on one of the vertical position buttons to move the top of the box up or down one pixel at a time.

6. Under the **End Position** caption, specify the position of the bottom right corner of the box. The list box displays the frame in which the box ends. The position of the bottom right corner of the box is measured in pixels relative to the top left corner of the designated frame, in the text boxes below.
   - Select the frame in which the box ends from the list box under the **End Position** caption.
   - Specify the horizontal position of the right side of the box from the left edge of the frame in pixels in the horizontal position text box under the **End Position** caption.
Alternatively, click on one of the horizontal position buttons to move the right edge of the box left or right one pixel at a time.

- Specify the vertical position of the bottom of the box from the top edge of the frame in pixels in the vertical position text box under the **End Position** caption.

Alternatively, click on one of the vertical position buttons to move the bottom of the box up or down one pixel at a time.

**Note:** You can move a box within a frame by changing the relevant top and left values, and move a box between frames by changing the start and end frames. For the end frame, the frames that come before the selected start frame are disabled, as the end frame must be the same as or below the start frame.

If you change a box start or end value so that it is greater or less than the corresponding end or start value, the start and end positions are reversed in the dialog, to maintain their relative values.

7. Click the **Apply** button to apply your changes immediately to the currently selected box.

8. Click the **Delete** button to delete the currently selected box.

9. Click the **Next** button to select the next box or line. Boxes and lines are selected in the order in which they were defined. This can be useful when an existing drawing object is too small to be easily visible.

10. Click the **Close** button to close the Box Properties dialog and return to the report layout.

### Inserting a Special Field

The JADE Report Writer Designer application provides a set of special fields that you can use in your reports.

Special fields include standard content fields; for example, date, time, and page number, as well as various fixed reporting fields (for example, report title and description).

If the **Special Fields** folder is not opened up in the Catalog of Available Fields dialog, click the box at the left of the **Special Fields** folder to open up the folder. The field items in the folder are then displayed and the plus sign (+) in the box is replaced with a minus sign (-).

**To insert a special field**

- Drag and drop the special field from the Catalog of Available Fields dialog to your layout. For details about using the drag and drop feature, see "Inserting Report Fields", earlier in this section.

The special field is then placed at the point at which it was dropped, as shown in the following image in which the **Report Date** field has been inserted into the **Report Header** section.

![Report Date field in Report Header](image)

Some special fields contain system settings; for example, the **Report Date** field contains the current date. Other special fields require you to have previously entered the appropriate detail.
The following table lists each special field with a brief description.

<table>
<thead>
<tr>
<th>Special Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Date</td>
<td>Automatically provides the current date.</td>
</tr>
<tr>
<td>Report Time</td>
<td>Automatically provides the current time.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Automatically provides the report name.</td>
</tr>
<tr>
<td>Report Description</td>
<td>Provides the report description. Requires you to have previously entered a</td>
</tr>
<tr>
<td></td>
<td>description in the Report Properties dialog. For details, see &quot;Setting Report</td>
</tr>
<tr>
<td></td>
<td>Properties&quot; under &quot;Using Administrative Functions&quot;, earlier in this chapter.</td>
</tr>
<tr>
<td>Page Number</td>
<td>Automatically provides page numbering.</td>
</tr>
<tr>
<td>Page n of m</td>
<td>Automatically provides the current page (n) of total pages (m).</td>
</tr>
<tr>
<td>Total Pages</td>
<td>Automatically provides the total number of pages in the report.</td>
</tr>
<tr>
<td>Group Field Name</td>
<td>Provides the current group field name. Requires you to have created a group</td>
</tr>
<tr>
<td></td>
<td>section. For details, see &quot;Creating Groups&quot;, later in this chapter. This</td>
</tr>
<tr>
<td></td>
<td>field has no effect if you attempt to drag and drop it into a non-group</td>
</tr>
<tr>
<td></td>
<td>section or if you drag and drop it into an unrelated group.</td>
</tr>
<tr>
<td>Group Field Alias</td>
<td>Provides the current group field alias. Requires you to have created a group</td>
</tr>
<tr>
<td></td>
<td>section. For details, see &quot;Creating Groups&quot;, later in this chapter. This</td>
</tr>
<tr>
<td></td>
<td>field has no effect if you attempt to drag and drop it into a non-group</td>
</tr>
<tr>
<td></td>
<td>section or if you drag and drop it into an unrelated group.</td>
</tr>
<tr>
<td>Reporting View Name</td>
<td>Automatically provides the name of the reporting view on which your report</td>
</tr>
<tr>
<td></td>
<td>is based.</td>
</tr>
<tr>
<td>Profile Name</td>
<td>Automatically provides the profile name (the selected profile when the report</td>
</tr>
<tr>
<td></td>
<td>is printed) that is displayed in the Profile field at the top left of your</td>
</tr>
<tr>
<td></td>
<td>layout.</td>
</tr>
<tr>
<td>Profile Description</td>
<td>Requires you to have previously entered a description in the Profile Properties</td>
</tr>
<tr>
<td></td>
<td>dialog. For details, see &quot;Creating or Maintaining Profiles&quot; under &quot;Using Administrative Functions&quot;, earlier in this chapter.</td>
</tr>
<tr>
<td>System Name</td>
<td>Returns the name of the system from the \texttt{global.jadeReportWriterSystemName} method. You can reimplement the System Name special field, which defaults to null (&quot;&quot;), in your user schemas to return any value that you require; for example, to return an overall system identifier for use in report or page headers.</td>
</tr>
<tr>
<td>Application Name</td>
<td>Returns the name of the application from the \texttt{app.jadeReportWriterAppName} method. You can reimplement the Application Name special field, which defaults to the name of the application of the receiver, in your user schemas to return any value that you require; that is, to return a system identifier that may depend on the current JADE application or user.</td>
</tr>
<tr>
<td>User ID</td>
<td>Automatically provides your user id.</td>
</tr>
</tbody>
</table>

**Inserting a Database Field**

Most of the detail of your report is usually derived from database fields. The database fields that are visible in the Catalog of Available Fields dialog depend on the reporting view on which this report is based.

For details about assigning a reporting view, see "Opening a New or Existing Report Design", earlier in this chapter. For details about creating a reporting view, see Chapter 3.

In the Catalog of Available Fields dialog, view all of the database fields that are available by opening up any folders that have a box to the left that contains a plus sign (+). Click the box to open up the folder. The field items in the folder are then displayed and the plus sign (+) in the box is replaced with a minus sign (-).
To insert a database field

1. Click the database field that you want to add to your report and then hold down the mouse button.
2. While continuing to hold down the mouse button, move the mouse across the layout (that is, drag). The cursor becomes a dotted rectangle that you can place accurately.
3. Release the mouse button (that is, drop) when your field is in the required position.

The database field is inserted at the point where you released the mouse button, or dropped it.

Database fields are displayed on the layout in their maximum length format and their format types are displayed, as shown in the following image.

```
<table>
<thead>
<tr>
<th>Percentage of total</th>
<th>$9,999.99</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Sales</td>
<td>$99,999.99</td>
</tr>
</tbody>
</table>
```

In this example, the field containing a line of **X** characters is a string field and the number of **X** characters indicates the maximum length of the field. The 9 characters indicate numeric fields and currency fields. Currency fields are preceded by a dollar sign ($).

You can change numeric and currency field formats by using the Report Formats dialog. For example, you may want periods instead of commas to delineate the thousands in numbers (for European systems) or you may want the dollar sign in a different position for currency fields (or another currency symbol entirely). For details changing field formats, see "Setting Report Formats" under "Using Administrative Functions", earlier in this chapter.

### Linking and Unlinking Headers

Linking fields in the page header section and the detail section enables you to create column headings that appear on every page and assists in the accurate layout of your reports.

Use the **Link Header** and **Unlink Header** commands from the Edit menu to individually link and unlink page header and detail fields.

**Note** Checking the **Build Linked Header** check box on the Report Properties dialog enables you to automatically build linked page headers. However, once this option is set, linked fields cannot be unlinked. As items created when this option was not set are not linked if this option is subsequently set, you should set this option before beginning your report layout.

The **Link Header** and **Unlink Header** commands from the Edit menu are applied independently of this option. For details about using the **Build Linked Header** check box, see "Using the Details Sheet" under "Setting Report Properties", earlier in this chapter.

To link page header fields and detail fields

1. While holding down the Shift key to enable multiple selections, select both fields you want to link. Select a report field in the report layout detail section for which you want to create a linked header and select a literal field in the report layout page header section. Linked page header fields must be literal fields. For details about inserting report fields, see "Inserting Report Fields", earlier in this chapter. For details about inserting literals, see "Inserting a Literal", earlier in this chapter.
2. Select the Link Header command from the Edit menu. The selected fields are linked. The dimensions of the literal field are adjusted to match those of the report field.

Linked fields are moved and resized simultaneously, in proportion to each other. Changes to the alignment of one linked field are duplicated in the other.

Initially, the text displayed by the header field is that (if any) of the literal field. Once the field is linked, it can no longer be changed directly. Change the header text by changing the Title property of the linked report details field, by using the Title text box of the Field Properties dialog. For details about the Field Properties dialog, see "Setting Field Properties" under "Using the Detail Functions", later in this chapter.

The page header is automatically deleted when you delete the linked report detail field.

To unlink linked page header and detail fields

1. Select either of the linked fields.

2. Select the Unlink Header command from the Edit menu.

The linked fields are then unlinked.

Using the Catalog of Available Fields Dialog

Use the Catalog of Available Fields dialog to select, and in some cases create, fields that you want printed on your report.

In the "Inserting Report Fields" subsection earlier in the current section, the Catalog of Available Fields dialog is described as the major tool you should use to paint fields on your report layout. That subsection describes dragging fields from the System sheet of the Catalog of Available Fields dialog straight onto your layout, including literals, pictures, lines, boxes, special fields (system fields such as date, time, userid, and so on), and database fields.

The Catalog of Available Fields dialog also enables you to create, add, and update parameter fields, script fields, summary fields, and method fields and to display the usage of database field items, parameter fields, script fields, summary fields, and method fields.

These functions are described in the following subsections.

- Using the System Sheet
- Using the Param Sheet
- Using the Script Sheet
- Using the Summary Sheet
- Using the Variables Sheet
- Using the Methods Sheet
- Displaying Field Usage

To access the Catalog of Available Fields dialog, perform one of the following actions

- Press the F6 key
- Select the Catalog command from the View menu
- Click the Toggle Catalog button on the Quick Launch Tools toolbar

The Catalog of Available Fields dialog is then displayed.
Individual field items in the Catalog of Available Fields, including report fields, parameters, summary fields, and script fields, have a graphical icon displayed to the left of the field to indicate the primitive type (for example, *String, Binary, Decimal*, and so forth) of the item. These display icons and their corresponding primitive types are listed in the following table.

<table>
<thead>
<tr>
<th>Display Icon</th>
<th>Primitive Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Binary Icon]</td>
<td>Binary</td>
<td>Container for arbitrary binary data</td>
</tr>
<tr>
<td>![Boolean Icon]</td>
<td>Boolean</td>
<td>One of the logical truth values represented by true and false</td>
</tr>
<tr>
<td>![Character Icon]</td>
<td>Character</td>
<td>A variable as a single ANSI or Unicode character</td>
</tr>
<tr>
<td>![Date Icon]</td>
<td>Date</td>
<td>Represents a specific day since the start of the Julian period</td>
</tr>
<tr>
<td>![Decimal Icon]</td>
<td>Decimal</td>
<td>A variable with a specific decimal currency and number format</td>
</tr>
<tr>
<td>![Integer Icon]</td>
<td>Integer</td>
<td>Represents the set of positive and negative whole numbers</td>
</tr>
<tr>
<td>![Integer64 Icon]</td>
<td>Integer64</td>
<td>Represents the set of positive and negative whole numbers</td>
</tr>
<tr>
<td>![Point Icon]</td>
<td>Point</td>
<td>Represents a point in two dimensional space</td>
</tr>
<tr>
<td>![Real Icon]</td>
<td>Real</td>
<td>Represents a floating point number</td>
</tr>
<tr>
<td>![String Icon]</td>
<td>String</td>
<td>A variable as a sequence of characters</td>
</tr>
<tr>
<td>![StringUtf8 Icon]</td>
<td>StringUtf8</td>
<td>A variable as a sequence of characters</td>
</tr>
<tr>
<td>![Time Icon]</td>
<td>Time</td>
<td>A variable representing the time of day since midnight to the nearest millisecond</td>
</tr>
<tr>
<td>![TimeStamp Icon]</td>
<td>TimeStamp</td>
<td>A variable representing the date and time since midnight to the nearest millisecond</td>
</tr>
<tr>
<td>![TimeStampInterval Icon]</td>
<td>TimeStampInterval</td>
<td>A variable representing the time difference between two timestamp values</td>
</tr>
<tr>
<td>![TimeStampOffset Icon]</td>
<td>TimeStampOffset</td>
<td>A variable representing a timestamp value but including the offset for the time zone</td>
</tr>
</tbody>
</table>

*Note* These icons are also used to display the type of fields elsewhere in the JADE Report Writer applications. For details about JADE primitive types, see the *JADE Encyclopaedia of Primitive Types*.

It is convenient to leave the dialog displayed while you develop your layout, as it provides all of the tools you require to complete the details of your report. However, you can move the dialog to a more convenient part of the screen, if required.
To move the Catalog of Available Fields dialog

- Click on the title bar (the blue bar at the top of the dialog), hold down the mouse button, drag the dialog, and then drop it (that is, release the mouse button) at the required position.

Using the System Sheet

The **System** sheet of the Catalog of Available Fields dialog displays all of the system fields that are available. These include fields such as literals, pictures, boxes, and lines, special fields such as date, time, and userid, and all of the database fields that are available through the reporting view and collections on which this report is based.

For details about using the **System** sheet, see "Inserting Report Fields", earlier in this chapter.

Using the Param Sheet

The **Param** sheet of the Catalog of Available Fields dialog enables you to create report parameters.

The following image shows the **Param** sheet with parameters that have previously been created.

![Catalog of Available Fields dialog](image)

The exchange rate parameter is a good example of a report parameter, as it is easy to see why you would want to be able to apply a rate that changes periodically. If your report publishes currency amounts, you may be called upon to publish those amounts in various currencies. In this example, there is one conversion rate only, to keep the concept simple.

After creating your parameter, you need to apply it. You can add a parameter as a simple field and apply parameters in report selection criteria or in scripts.

You can treat a parameter like any other report field and drag and drop it into a design layout for printing and display. In the case of an exchange rate parameter, you might want to publish the exchange rate the report is based on, along with the other data.
You can create selection criteria from the Profile Properties dialog. Typically, you create selection criteria to refine a report; for example, your selection criterion could be that you want records only for customers named Smith. However, by using a parameter as a selection criterion, you can apply a run time criterion. For details about creating selection criteria, see "Using the Selection Criteria Sheet", under "Creating or Maintaining Profiles", earlier in this chapter.

Scripts provide a more programmatic capability for applying parameters. In the case of the exchange rate, you would typically apply it to a database field; for example, an item price or to a summary total that is accumulated in the report.

The following image shows a footer section of a report design in which a United States (US) dollar amount (that is, the value on the farthest right) is printed along with total sales value (the underlined value). The US dollar amount is a script field called in $US, and the script on which it is based is shown in the following image. The script code is a simple multiplication of report total by the exchange rate parameter.

When you run the report, set the value of your parameter (in this example, the exchange rate parameter) by using the Report Parameters dialog. To summarize, the steps for creating, applying, and setting a parameter are listed in the following table.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>For details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Create a parameter</td>
<td>&quot;Creating a Parameter&quot;, later in this section.</td>
</tr>
<tr>
<td>2.</td>
<td>Apply the parameter to a report field</td>
<td>&quot;Using the Script Sheet&quot;, later in this chapter.</td>
</tr>
<tr>
<td>3.</td>
<td>Set the parameter value before running the report</td>
<td>&quot;Using the Parameters Sheet&quot; under &quot;Setting Report Properties&quot;, earlier in this chapter.</td>
</tr>
</tbody>
</table>

Perform step 3 in the preceding table each time you run the report with a changed parameter value.

**Inserting a Parameter in Your Layout**

Report parameters can function without being displayed in your report. In the example of the exchange rate, you may want to print the exchange rate as well as print the currency value derived from applying the parameter in a simple script.

To insert a parameter into your report, simply use the drag and drop technique, described in "Inserting Report Fields", earlier in this chapter.

Parameter field maintenance is described in the following subsections.

- Creating a Parameter
- Updating a Parameter
- Deleting a Parameter
Creating a Parameter

To create a new report parameter

1. Click the New button on the toolbar of the Catalog of Available Fields dialog. The Add Parameter Field dialog, shown in the following image, is then displayed.

2. In the Name text box, enter the name of your parameter. The name can be up to 30 characters in length. You cannot use an existing parameter name.

3. Select the Primitive option button to specify that the parameter type that you require is a primitive type.

4. Select the Type from View option button to specify that the parameter type that you require is an object of a type specified in your reporting view. The Details group box is disabled for object type parameters.

5. In the Type list box, select the type of field that you require. Select a primitive type (for example, Decimal, Binary, Boolean, String) for primitive type parameters or an object defined in your reporting view for object parameters.

   **Note**  To enable the specification of object parameter values when printing or extracting your report, additional JADE methods must be reimplemented in your user schema. For details, see "Object Parameters", in Chapter 1.

6. In the Length text box, enter the length of your field if you selected Binary, Decimal, or String in the Type list box.

   Decimal parameters can have a maximum length of 23. The maximum integer portion (whole number) length for a Decimal parameter is 12. For other primitive types, this text box is disabled.

7. In the Decimals text box, enter the number of decimal places if you selected Decimal in the Type list box.
The maximum number of decimal places is 15. For other primitive types, this text box is disabled.

8. Check the **User value must be entered** check box to specify that a parameter is not optional and that a value must be entered. If a parameter value is not entered on the **Parameters** sheet of the Report Properties dialog, or on the Report Parameters dialog, the message "Parameter Value must be entered for <parameter name>" is then displayed.

**Notes** If the ignore option is set for parameter on the **Parameters** sheet of the Report Properties form or on the Extract Data form, it overrides the **User value must be entered** option, and the message is not displayed.

When reports are run from the user system, the **JadeReportWriterReport** class **getExtraParameterDetails** method can be called to return the value of the **User value must be entered** option for a specified parameter name. This can be used to enforce entry of a value for the parameter. For more details about the **getExtraParameterDetails** method, see Chapter 1 of the *JADE Encyclopaedia of Classes, Volume 1*.

9. In the **User prompt** text box, enter an alternative name for the parameter. This is used as an alternative to the parameter name as a prompt for the parameter value.

10. Click the **Apply** button to complete the creation of the parameter. Alternatively, click the **Close** button without clicking the **Apply** button to abandon your entries.

The new parameter is then added to the list of parameters on the **Param** sheet of the Catalog of Available Fields dialog.

**Updating a Parameter**

- **To update a parameter**
  1. Select the parameter on the Catalog of Available Fields dialog.
  2. Click the **Update** button on the toolbar of the Catalog of Available Fields dialog.
The Update Parameter Field dialog, shown in the following image, is then displayed.

3. Make the required changes on the dialog. For details about entering your specifications, see steps 2 through 9 of the previous subsection, "Creating a Parameter".

4. Click the Apply button to complete the update of the parameter. Alternatively, click the Close button without clicking the Apply button to abandon your entries.

The parameter is then updated with your changes.

Deleting a Parameter

To delete a parameter

1. Select the parameter on the Catalog of Available Fields dialog.

2. Click the Delete button on the toolbar of the Catalog of Available Fields dialog.

The parameter is then deleted and removed from the list of parameters on the Param sheet of the Catalog of Available Fields dialog.

Note You cannot delete a parameter that has been applied to your layout until you have removed the applicable fields from your layout.

Using the Script Sheet

Scripts provide you with a programmatic means of deriving field values. In the previous "Using the Param Sheet" subsection, an example script was described in which an exchange rate was applied to a currency field to print that field in another currency.
The following example shows the script for that currency conversion.


{!grand total} * {?exchange rate}

In this example, grand total is a summary field and exchange rate is the parameter. In the expression, one value is simply multiplied by the other. In the JADE Report Writer Designer application, the script facility enables you simply to point and click in order to build an expression. Alternatively, you can write and apply JADE code to derive a report field value.

The following subsections describe how to create and maintain script fields, and provide a single expression script as an example.

For details about writing more-advanced scripts, see Appendix A, "Using JADE Report Writer Scripts".

- Creating a Script
- Updating a Script
- Deleting a Script

Creating a Script

This subsection describes how to derive a simple expression (using the exchange rate example) and apply the resulting script field to your report layout. For full details about creating scripts, see Appendix A, "Using JADE Report Writer Scripts".
To display the Add Script Field dialog

1. Click the Script tab of the Catalog of Available Fields dialog. The Script sheet is then displayed.

2. Click the New button on the toolbar of the Catalog of Available Fields dialog. The Add Script Field dialog is then displayed, as shown in the following image.

To enter the script name and define the return type of your expression

1. Enter a name for your script field in the Script Name text box. You can use any character to name your script. The script name can be up to 30 characters long.

   In the previous image, inUSD has been entered as the script name to provide the example using the exchange rate.

2. Click the Define Return Type button at the right of the Return Type list box.
The Define Script Return Type dialog, shown in the following image, is then displayed.

3. In the **Type** list box, select the primitive type that you want for the result of your expression (for example, **Decimal**, **Binary**, **String**, **Real**, and so on).

4. In the **Length** text box, enter the length of result field if you selected **Binary**, **Decimal**, or **String** in the **Type** list box. For other primitive types, this text box is not enabled.

5. In the **Decimals** text box, enter the number of decimal places if you selected **Decimal** in the **Type** list box. For other primitive types, this text box is not enabled.

6. Click the **Apply** button to apply the primitive type that you have selected.

The Define Script Return Type dialog is then closed and the return type that you selected is displayed in the **Return Type** list box of the Add Script Field dialog, as shown in the following image.

In this example, the **Decimal** primitive type has been selected as the return type (that is, the output type for the result of your script). The script field (which has been named inUSD) receives the result of the expression as a decimal number.

**To build the expression in the Add Script Field dialog**

1. In the **Fields** list box, select a field as the operand of your expression. Open up one of the field categories by clicking the plus (+) symbol and then double-click the required field.
The following image shows the Summary Fields category opened up and the grand total field selected. In the example, this field is to be expressed in US dollars when the script is applied to the report.

The selected field is then moved to the result area, as shown in the previous image.

The exclamation mark (!) character indicates that this is a summary field; that is, a field that accumulates values as the report runs.

For details about summary fields, see "Using the Summary Sheet", later in this chapter.

2. Select an operator from the Commands list box.

An arithmetic operator is required in the exchange rate example, as the value (grand total) is to be multiplied by the exchange rate.

Open up the Arithmetic operators category by clicking the plus (+) symbol and then double-click the required field.

The following image shows the Arithmetic operators category opened up and the multiply operator selected.
In the result area, the asterisk symbol (*) represents the multiplication operator.

3. In the **Fields** list box, select the operand of your expression. Open up one of the Fields categories by clicking the plus (+) symbol and then double-click the required command.

In the exchange rate example, the value (**grand total**) is to be multiplied by the exchange rate. The exchange rate in this example has been set up as a report parameter. (For details, see "Using the Param Sheet", earlier in this section.)
The following image shows the Parameter Fields category opened up and the exchange rate field selected.

4. Click the Save button to apply the expression to the script.
5. Click the Close button.

The Add Script Field dialog is then closed and the new script is added to the list on the Script sheet of the Catalog of Available Fields dialog.

To apply your script to your report

Drag and drop the script field into the report layout.

For details about inserting fields into your layout, see "Inserting Report Fields", earlier in this chapter, and for details about creating scripts, see Appendix A, "Using JADE Report Writer Scripts".

The Commands pane, Fields pane, and the Methods pane of the Add Script Field or Update Script Field dialog are described in:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Primitive type methods documented in Chapter 1 of the JADE Encyclopaedia of Primitive Types
Chapter 4  Designing JADE Reports

The primitive type methods that are available to you are displayed in the Available Methods list box of the Script Methods sheet of the JADE Report Writer Configuration window. Initially, a selection of these methods is displayed in the Methods list box of the Add Script Field and Update Script Field dialogs of the JADE Report Writer Designer application.

If you encounter errors in your scripts, see "Resolving Errors in Scripts", in Appendix A.

Updating a Script

To update a script

1. Select the script on the Script sheet of the Catalog of Available Fields dialog by clicking it.
2. Click the Update button on the toolbar of the Catalog of Available Fields dialog.
   The Update Script Field dialog is then displayed.
3. Make the required changes on the dialog. For details about entering the fields, see "Creating a Script", in the previous subsection.
4. Click the Save button to complete the update of the script. Alternatively, click the Close button without clicking the Save button to abandon your entries.

The script is then updated with your changes.

Deleting a Script

To delete a script

1. Select the script on the Catalog of Available Fields dialog by clicking it.
2. Click the Delete button on the Catalog of Available Fields dialog toolbar.

The script is then deleted and removed from the list of scripts on the Script sheet of the Catalog of Available Fields dialog.

Note  You cannot delete a script that has been applied to your layout until you have removed the applicable fields from your layout.

Using the Summary Sheet

Use the Summary sheet of the Catalog of Available Fields dialog to create and maintain your summary fields. Summary fields enable you to automatically maintain running totals, and they provide automatic calculation of average, maximum, and minimum values.

When you select the field that you want to summarize, that value is accumulated automatically when the report runs. In your design, place the summary field in the section (usually a footer) in which you want your summary total printed.

Note  The value of a summary field based on a script field depends on the sections of the report that include the script field. If the script field is included only in a header or footer section, the script field values in that section are summarized; otherwise, the script field is evaluated for each detail section, and those values are summarized.

You can place your summary field in exactly the same way that you place other field types, by dragging it from the Catalog of Available Fields dialog and dropping it in place in your layout. For details about inserting report fields, see "Inserting Report Fields", earlier in this chapter.
Maintaining a summary field is described in the following subsections.

- Creating a Summary Field
- Updating a Summary Field
- Deleting a Summary Field

Creating a Summary Field

This subsection describes creating a summary field and inserting it into your report.

To display the Add Summary Field dialog

1. Click the Summary tab of the Catalog of Available Fields dialog. The Summary sheet is then displayed.
2. Click the New button on the Catalog of Available Fields dialog toolbar.

The Add Summary Field dialog is then displayed, as shown in the following image.

To build the summary field

1. In the Name text box, enter the name that you require for your summary. The name must start with a lowercase letter and can contain spaces. The summary field name can be up to 30 characters long. The example name (grand total) in the previous image is a grand total that is printed at the end of the report.
2. In the **Summary Function** list box, select the type of function that you want to perform. The following table describes the available summary functions.

<table>
<thead>
<tr>
<th>Summary Function</th>
<th>Provides ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count</td>
<td>A total of the number of occurrences of the target field</td>
</tr>
<tr>
<td>Distinct Count</td>
<td>A count of the unique values of the target field</td>
</tr>
<tr>
<td>Non-null Count</td>
<td>A count of all non-null items of the target field</td>
</tr>
<tr>
<td>Max</td>
<td>The maximum value of the target field</td>
</tr>
<tr>
<td>Min</td>
<td>The minimum value of the target field</td>
</tr>
<tr>
<td>Sum</td>
<td>A total of the target field</td>
</tr>
<tr>
<td>Average</td>
<td>The average value of the target field</td>
</tr>
<tr>
<td>Non-zero Average</td>
<td>The average value of all non-zero items of the target field</td>
</tr>
</tbody>
</table>

The **Sum**, **Average**, and **Non-zero Average** functions are displayed only for numeric fields. In the example in the previous image, the **Sum** function is selected.

3. Check the **Running Total** check box if you want to print the field as a running total periodically during the report, rather than one final total at the end of a group or at the end of the report. By default, this check box is not checked, indicating that only an end of group or report total is required.

4. In the **Summary Field** list box, select the field to which you want to apply the summary function, as shown in the following image.

![Summary Field Image](image)

In this example, the sale item price has been selected from the available database fields, to accumulate the total sales for the report.

Note that **Clients** is an alias for the **allClients** feature. The **price** feature is qualified as **RetailSaleItem.price**, since **RetailSaleItem** is the subclass of **SaleItem** used in the report.

5. In the **Reset** group box in the lower part of the dialog, select how and when you want your summary field reset. For example, you would want the total to be reset every time the group changes if you want to accumulate a total by group.

Select one of the **Reset** option buttons, as follows.

- Select the **Never** option button if you never want your summary field reset during the running of the report.
  
  Typically, select this option if you want to accumulate a grand total.

- Select the **When Database Field Changes** option button if you want your summary field reset each time a selected database field changes.
In the list box below the **When Database Field Changes** option button, select the database field that determines when your summary field is reset. For example, you could create totals for each client by selecting the client name field, as shown in the following image.

![When Database Field Changes](image)

In this example, your summary field is reset each time the client name changes.

- Select the **When Group Changes** option button if you want your summary field reset each time a report group changes.

In the list box below the **When Group Changes** option button, select the group field that determines when your summary field is reset, as shown in the following image.

![When Group Changes](image)

In this example, **Group #1 (Customer)** is selected and the summary field is reset each time the group changes. For details about creating groups, see "Creating Groups", earlier in this chapter.

- Select the **After Printing** option button if you want your summary field to be reset only after printing.

This option is in contrast to the **Never** option, in which your summary field is *not* reset between print runs during the same JADE Report Writer Designer session.

6. Click the **Apply** button to create the summary field.

7. Click the **Close** button.
The Add Summary Field dialog is then closed and the new summary field is added to the list on the **Summary** sheet of the Catalog of Available Fields dialog, as shown in the following image.

In this example, **grand total** is a report total; that is, the reset option is **Never**. It is a summary of all prices of the sale items printed in the report.

When you have created your summary field, you can then insert it into your report.

**To insert your summary field into your report**

- Drag and drop the summary field into the report layout, as shown in the following image.

For details about inserting fields into your layout, see "Inserting Report Fields", earlier in this chapter.
Updating a Summary Field

To update a summary field

1. On the Catalog of Available Fields dialog, select the summary field that you want to update, by clicking on it.
2. Click the Update button on the Catalog of Available Fields dialog toolbar.
   
   The Update Summary Field dialog is then displayed.
3. Make the required changes on the dialog. For details about entering your specifications, see "Creating a Summary Field", in the previous subsection.
4. Click the Apply button to complete the update of the script. Alternatively, click the Close button without clicking the Apply button to abandon your entries.
   
   The summary field is then updated with your changes.

Note: You cannot rename a summary field that has been used in a script field.

Deleting a Summary Field

To delete a summary field

1. Select (that is, click) the summary field on the Catalog of Available Fields dialog.
2. Click the Delete button on the Catalog of Available Fields dialog toolbar.
   
   The summary field is then deleted and removed from the list of summary fields on the Summary sheet of the Catalog of Available Fields dialog.

Note: You cannot delete a summary field that has been applied to your layout until you have removed the applicable fields from your layout.

Using the Variables Sheet

The Variables sheet of the Catalog of Available Fields dialog enables you to create report variables.
The following image shows the **Variables** sheet with variables that have previously been created.

Report variables are used in scripts in the same way as parameters. Where a report variable is used in more than one script, the order in which the scripts are executed is important. For more details about report execution, see "Report Execution", in Appendix A.

To check on the usage of the currently selected item in the current report, use the **Usage** command, by right-clicking on the field. The script for each reporting phase is then displayed in order in which they will be executed for each item within that phase. For more details, see "Displaying Field Usage", later in this section.

Alternatively, you can view the order in which scripts and summaries are evaluated when the report is run from the Report Script and Summary Evaluation dialog. For more details, see "Evaluation Phases", later in this chapter.

The following subsections describe how to create and maintain report variables,

- Creating Report Variables
- Updating Report Variables
- Deleting Report Variables
Creating Report Variables

To create a new report variable

1. Click the New button on the toolbar of the Catalog of Available Fields dialog.
2. Add Report Variable dialog, shown in the following image, is then displayed.

![Add Report Variable Dialog]

3. In the Name text box, enter the name of your report variable. The name can be up to 30 characters in length. You cannot use an existing report variable name.
4. In the Type list box, select the type of field that you require; for example, Decimal, Binary, Boolean, String.
5. In the Length text box, enter the length of your field if you selected Binary, Decimal, or String in the Type list box.
   - Decimal parameters can have a maximum length of 23. The maximum integer portion (whole number) length for a Decimal parameter is 12. For other primitive types, this text box is disabled.
6. In the Decimals text box, enter the number of decimal places if you selected Decimal in the Type list box.
   - The maximum number of decimal places is 15. For other primitive types, this text box is disabled.
7. In the Initial Value text box, enter an initial value for the variable, if required.
8. Click the Apply button to complete the creation of the report variable. Alternatively, click the Close button without clicking the Apply button to abandon your entries.

The new report variable is then added to the list of variables on the Variables sheet of the Catalog of Available Fields dialog.

Updating Report Variables

To update a report variable

1. Select the report variable on the Catalog of Available Fields dialog.
2. Click the Update button on the toolbar of the Catalog of Available Fields dialog.
Alternatively, double-click on the list entry in the Catalog of Available Fields dialog.

The Update Report Variables Field dialog, shown in the following image, is then displayed.

![Update Report Variable Dialog](image)

3. Make the required changes on the dialog. For details about entering your specifications, see steps 2 through 6 of the previous subsection, "Creating Report Variables".

4. Click the Apply button to complete the update of the parameter. Alternatively, click the Close button without clicking the Apply button to abandon your entries.

The report variable is then updated with your changes.

**Deleting Report Variables**

To delete a report variable

1. Select the report variable on the Catalog of Available Fields dialog.
2. Click the Delete button on the toolbar of the Catalog of Available Fields dialog.

The report variable is then deleted and removed from the list of parameters on the Variables sheet of the Catalog of Available Fields dialog.

**Note** You cannot delete a report variable that has been applied to your layout until you have removed the applicable fields from your layout.

**Using the Methods Sheet**

The Methods sheet of the Catalog of Available Fields dialog enables you to create method fields.

A method field, or more accurately a *method with parameters* field, is a special type of database field. The value of a method field depends on the values of its method parameters.
Note If the view does not include a method with parameters then you will not be able to create a corresponding method field. For more details about including methods with parameters in a view, see "Selecting the Features for Your View", in Chapter 3.

The following image shows the Methods sheet with a method field that has previously been created.

There are no examples of method fields in the Erewhon system, so the following hypothetical example is presented.

Suppose that the price of a retail sale item is not fixed, and that different prices are offered to different clients. For example, there could be a standard price for most clients, and a discount price that is only available to selected clients. The price could also depend on whether tax is included.

Instead of there being a price database field for a sale item (as in the Erewhon system), there could be a pricePlusTax method field that takes two parameters: the price list offered to the client (standard or discount) and whether tax is to be included.

Note It is important to distinguish between the parameters that are required by a method field (method parameters), and the parameters supplied by a user at the start of report execution (report parameters). For more details about report parameters, see "Using the Param Sheet", earlier in this section.

A method parameter can have its value entered by the report designer, or take its value from a report parameter entered by the report user.

You can treat a method field like any other report field and drag and drop it into a design layout for printing and display.

The following subsections describe how to create and maintain method fields,

- Creating a Method Field
- Updating a Method Field
Creating a Method Field

To create a method field

1. Click the New button on the Catalog of Available Fields dialog. The Add Method Field dialog is then displayed.

2. In the Method Field list box, select the method whose value you want to change or add. In the image, the pricePlusTax method field has been selected.

   This list box displays the full path (from the root collection of the report) of the method to be executed. The list box is similar to the one on the System sheet of the Catalog of Available Fields, which shows Database items. However, the Method Field list box shows only methods with parameters from the view definition, for the current root collection or collections, and all subsequent references and collections.

3. In the Name text box, enter the name of your method field. The name value can be the same as the field you selected in the previous step, but it must be unique within the method fields of the report.

   The Method Parameters table displays the parameter name (for example, type or includeTax) in the first column and parameter type (for example, String or Boolean) in the second column. The fourth column has a Report Param check box, which determines how the value of the method parameter is to be specified in the third column. The fifth column has a Database Field check box, which enables you to specify the database item to be used as the method parameter.

4. If you check the Report Param check box, the cell in the third column becomes a combo box, enabling you to specify the method parameter by selecting from a list of report parameters of the appropriate type.
parameters are defined on the **Param** sheet of the Catalog of Available Fields.)

Bubble help in the text box portion of the value combo box displays the type and length of the method parameter.

If there are no parameters with a matching type, the check box in the fourth column is disabled. If report parameters of the correct type exist, they are displayed in the drop-down list portion of the combo box, to enable you to select the required parameter value.

5. If you check the **Database Field** check box, the cell in the third column becomes a combo box, enabling you to specify the method parameter by selecting from a list of database items that have been used in the report. (If the database item has not been used and is required as a method parameter, you can add it to the report as an invisible field. The database item will then be displayed in the combo box.)

If there are no database items with a matching type, the check box in the fifth column is disabled. If database items of the correct type exist, they are displayed in the drop-down list portion of the combo box, to enable you to select the required database item.

If the **Report Param** or the **Database Field** check boxes are not checked, the cell in the third column becomes a text box, enabling you to specify the required method parameter by entering a literal value directly.

6. Click the **Apply** button to create your method field with the specified parameter value. Alternatively, click the **Close** button if you decide not to create a method field.

The new method field is then added to the list of methods with parameters on the **Methods** sheet of the Catalog of Available Fields.

When you have defined a method field, it is displayed in the catalog list so that you can drag it onto your report on the Designer window in the same manner as other catalog items.

**Updating a Method Field**

To update a method field

1. Select the method field in the Catalog of Available Fields dialog and then click the **Update** button. Alternatively, double-click on the list entry in the Catalog of Available Fields dialog.
The Update Method Field dialog, shown in the following image, is then displayed.

2. Make the required changes on the dialog. For details about entering specifications, see steps 2 through 6 of the previous subsection, "Creating a Method Field".

3. Click the Apply button to update your method field. (Alternatively, click the Close button to abandon your changes.)

The method field is then updated with your changes.

Deleting a Method Field

To delete a method field

1. Select (that is, click) the method field in the Catalog of Available Fields dialog.

2. Click the Delete button on the toolbar of the Catalog of Available Fields.

The method field is then deleted and removed from the list of methods with parameters on the Methods sheet of the Catalog of Available Fields.

Note: You cannot delete a method field that has been applied to your layout until you have removed the applicable fields from your layout.

Displaying Field Usage

Use the Usage command, accessed by right-clicking in the Fields list box on any of the sheets of the Catalog of Available Fields dialog, to check on the usage of the currently selected item in the current report.
This command is available on each of the sheets of the Catalog of Available Fields dialog, to enable you to check on the usage of database fields, parameter fields, script fields, and summary fields. On the System sheet, it can be applied only to database fields and not to special fields or literal fields.

**To display the usage of the currently selected field**

1. Select a report field from the list box on one of the sheets of the Catalog of Available Fields dialog. Right-click on the selected field. A popup menu, shown in the following image, is then displayed.

2. Select the Usage command.

The Where Used dialog, shown in the following image, is then displayed.

![Where Used dialog](image)

If the selected field is not used in the current report, the list box is empty.

3. To delete a field used in a report layout, if required, select the item usage.

The Delete button is then enabled. Click the Delete button. The usage is deleted from the list box and the corresponding field is deleted from the report layout. This action is the same as selecting and deleting the field in the JADE Report Writer Designer application report layout.

4. When you have finished checking on the usage of the selected field, click the Close button to close the Where Used dialog.

The details displayed in the Where Used dialog depend on the type of field selected and how it is used in the current report.

The following table lists the ways in which you can use selected fields and the formats used to detail that usage when displayed in the Where Used dialog.

<table>
<thead>
<tr>
<th>Field Usage</th>
<th>Details Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>In report layout</td>
<td>section-type, top vertical-position, left horizontal-position</td>
</tr>
<tr>
<td>As group-by field in profile</td>
<td>Group-by field in &quot;profile-name&quot;</td>
</tr>
</tbody>
</table>
### Setting Field Properties

When you have placed fields on the JADE Report Writer Designer application layout, access the properties for any field by clicking the right mouse button while your cursor is positioned over the field.

Alternatively, you can display the Field Properties dialog for any report field except lines and boxes by double-clicking on it.

When you right-click on a report field, a popup menu is displayed. The commands that are displayed on the popup menu depend on the field that you select. The following image shows the popup menu that is displayed when you right-click on a literal value.

![Popup Menu](image)

Each popup menu provides commands that set common properties (for example, the **Visible**, **Border**, and **Alignment** commands shown in the previous image) and each popup menu provides a **Delete** command.

The **Properties** command is displayed on popup menus for all fields except for lines and boxes. The **Properties** command provides the main dialog for setting and changing individual field properties.

The commands listed in the following table are described in the following subsections and are common to all field popup menus except for lines and boxes.

<table>
<thead>
<tr>
<th>Command</th>
<th>Enables you to …</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties Command</td>
<td>Set properties using the Properties dialog</td>
</tr>
<tr>
<td>Visible Command</td>
<td>Change the visibility of the field</td>
</tr>
<tr>
<td>Border Command</td>
<td>Place a border around the field</td>
</tr>
<tr>
<td>Alignment Command</td>
<td>Align the field within its boundaries</td>
</tr>
<tr>
<td>Delete Command</td>
<td>Delete a field</td>
</tr>
</tbody>
</table>

---

**Field Usage**

<table>
<thead>
<tr>
<th>Sort criterion in profile</th>
<th>Sort criterion in &quot;profile-name&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection criterion in profile</td>
<td>Selection criterion in &quot;profile-name&quot;</td>
</tr>
<tr>
<td>In script code</td>
<td>Script &quot;script-name&quot; source</td>
</tr>
<tr>
<td>In summary field</td>
<td>Summary &quot;summary-name&quot; summarized field</td>
</tr>
<tr>
<td>As summary field reset field</td>
<td>Summary &quot;summary-name&quot; reset field</td>
</tr>
</tbody>
</table>

---

**Details Format**
The following table lists the popup menu commands that apply to specific fields.

<table>
<thead>
<tr>
<th>Command</th>
<th>Field Type</th>
<th>Enables you to …</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Literal</td>
<td>Enter the text of your literal</td>
</tr>
<tr>
<td>Data Source</td>
<td>Database</td>
<td>Change the data source for your field</td>
</tr>
<tr>
<td>Script</td>
<td>Script</td>
<td>Update script detail</td>
</tr>
<tr>
<td>Summary</td>
<td>Summary</td>
<td>Update summary field detail</td>
</tr>
<tr>
<td>Parameter</td>
<td>Parameter</td>
<td>Update parameter field detail</td>
</tr>
<tr>
<td>Width</td>
<td>Line and Box</td>
<td>Change the line width</td>
</tr>
<tr>
<td>Color</td>
<td>Line and Box</td>
<td>Change the line color</td>
</tr>
</tbody>
</table>

**Properties Command**

Use the **Properties** command from the popup menu that is displayed when you right-click on a report field in your layout to set or change the general properties for that report field. Fields representing lines and boxes cannot access the Field Properties dialog.

When you select the **Properties** command, the Field Properties dialog is displayed.

- **To display the Field Properties dialog**
  1. Right-click while your cursor is over a report field on your layout. The appearance of the popup menu that is displayed differs from field to field.

The following image is an example of a popup menu for a report field.

![Popup Menu Example](image-url)
2. Select the **Properties** command from the popup menu. Alternatively, double-click a report field. The Field Properties dialog, shown in the following image, is then displayed.

![Field Properties dialog](image)

The sheets of the Field Properties dialog differ, depending on the field for which the dialog has been displayed. The subsections that describe the sheets of the Field Properties dialog are listed in the following table.

<table>
<thead>
<tr>
<th>Subsections</th>
<th>Applicable Field Type</th>
<th>Describes…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Common Sheet</td>
<td>All</td>
<td>Some common properties</td>
</tr>
<tr>
<td>Using the Layout Sheet</td>
<td>All</td>
<td>The position and size of the field</td>
</tr>
<tr>
<td>Using the Number Sheet</td>
<td>Numeric and Currency fields</td>
<td>Numeric and currency formats</td>
</tr>
<tr>
<td>Using the Font Sheet</td>
<td>All except picture fields</td>
<td>The font of the field</td>
</tr>
<tr>
<td>Using the Date Sheet</td>
<td>Date fields</td>
<td>Date formats</td>
</tr>
<tr>
<td>Using the Time Sheet</td>
<td>Time fields</td>
<td>Time formats</td>
</tr>
<tr>
<td>Using the Picture Sheet</td>
<td>Picture fields</td>
<td>Picture position</td>
</tr>
<tr>
<td>Using the Format Scripts dialog</td>
<td>All</td>
<td>How to format scripts</td>
</tr>
</tbody>
</table>
Using the Common Sheet

The Common sheet of the Field Properties dialog, shown in the following image, is displayed by default when your first access the dialog.

1. For literal report fields only, change the value of the literal by overwriting the value in the Content text box at the top of the sheet.
   
   To break the current line and begin a new line while you are entering your text, press Ctrl+Enter. A carriage return is inserted and the caret is moved to the beginning of new line underneath the existing text line.

   The Content text box is enabled only for literal report fields. For all other report fields, this text box displays the field description that is automatically derived from the database name and which cannot be changed by using this dialog.

2. In the Title text box (which is not visible for literal report fields), enter one of the following values.
   
   - The page heading value for a linked header field.
     
     To specify that you want linked headers, use the Details sheet of the Report Properties dialog. For details, see "Using the Details Sheet" under "Setting Report Properties", earlier in this chapter.
   
   - The tag field, when you extract to an XML file.
     
     For details about extracting to an XML file, see "Using the Output Sheet" under "Setting Report Properties", earlier in this chapter.

3. Uncheck the Visible check box if you do not want your report field to be visible on your report. Report fields are visible by default; that is, the Visible check box is checked.

4. If you want the JADE Report Writer Designer application to resize your field if the contents are too large to fit into the field, check the Auto-Size check box.
Any time that the content of your report field is longer than the field width when you check this check box, the field height is automatically increased to enable all field data to be printed with word wrapping (that is, your text wraps to the next line when it reaches the right of the field).

This check box is not checked by default.

5. Check the RTF check box to display RTF strings as formatted text in your report.

This check box is enabled only for string fields. If your database supports RTF, string fields are interpreted and displayed as formatted text when this option is checked.

6. Check the Suppress Duplicate Values check box if you want the JADE Report Writer Designer application to suppress the printing of this report field if it has the same value in the frame that is printed immediately before the current frame.

This check box is not checked by default; that is, the report field is printed regardless of any duplication.

7. Select a border style from the Border Style list box. The default value is None, indicating that no border is printed.

Click the Single option to create a single line border around your report field.

8. Select an alignment option from the Alignment list box.

To align the content of the report field within the boundaries of the report field, select the Left, Right, or Center option.

By default, the field is aligned according to the default report field alignment specified in the Report Properties dialog. For details, see "Using the Details Sheet" under "Setting Report Properties", earlier in this chapter.

You can also change the alignment by using the sample that is shown in the green sample text box below the Alignment list box. Click to the left or right of the sample to change the alignment.

9. Select a field background color from the Background Color list box. The field background color is applied only to the selected text field. Background color does not apply to pictures.

If you select the Custom color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the OK button to apply the selected color or click the Cancel button to close the Color dialog without making any changes.

If you select None, no background color is set; that is, the field background is transparent so that the frame background color is printed. This is the default field background color option.

10. Click the Format Script button to define field format scripts. The Format Scripts dialog is then displayed. If a format script exists for the current field, the button is blue. If no script exists, the button is grey. For more details, see "Setting Field Properties using a Format Script", later in this section.

11. Click another tab if you want to make changes on other sheets of the Field Properties dialog.

12. Click the Apply button to apply the changes that you have made or click the Close button to close the Field Properties dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

Using the Layout Sheet

The Layout sheet of the Field Properties dialog is displayed when you click the Layout tab. Use the Layout sheet to change the absolute position and size of your report field.
Your field position and size are set when you paint the field onto your layout. (For details, see "Inserting Report Fields", earlier in this chapter.) These values are displayed by default in the boxes on the Layout sheet. An example of the Layout sheet is shown in the following image.

To change the absolute position and size of your field

- Use the buttons beside the text boxes to change the values in the text boxes. Clicking once on a move or size button increases or decreases the position or size value by one pixel.
- To enter absolute values, perform the following actions.
  a. In the Left/Right text box, enter the horizontal start position of your field, measured in pixels from the start of the frame.
  b. In the Up/Down text box, enter the vertical start position of your field, measured in pixels from the top of the frame.
  c. In the Width text box, enter the width of your field, measured in pixels.
  d. In the Depth text box, enter the height of your field, measured in pixels.
- Click another tab if you want to make changes on other sheets of the Field Properties dialog.

To select a field to be output to an XML extract file

Check the XML attribute check box if the property value of the field is to be an attribute of the associated frame or section element rather than a child element within it when the report is run to extract data in XML format. For example, the XML output for a detail section with two fields f1 and f2 as elements (that is, the XML attribute check box is not checked) is as follows.

```
<detail>
  <f1>f1 value</f1><f2>f2 value</f2>
</detail>
```
If field f2 has the XML attribute check box checked, the XML output is as follows.

```xml
<detail f2="f2 value">
  <f1> f1 value </f1>
</detail>
```

Click the Apply button to apply the changes that you have made or click the Close button to close the Field Properties dialog. To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

### Using the Number Sheet

The Number sheet of the Field Properties dialog is displayed when you click the Number tab. (The Number tab is visible only when you have selected a number or currency field.) Use the Number sheet to change the number or currency formats for the current report field.

Number and currency formats have system default values. You can set your own report-wide default values by using the Report Formats dialog, if required. (For details about setting number and currency default formats, see "Setting Report Formats" under "Using Administrative Functions", earlier in this chapter.) Use the Number sheet to override the default values for the current field.

An example of the Number sheet is shown in the following image.

![Field Properties Dialog](image)

To change the properties on the Number sheet of the Field Properties dialog:

1. Check the **Use Default Format** check box to reset all of the number properties to the default values. If you select this option, the report default values or the system default values are displayed and take effect.

   For details about setting number and currency default formats, see "Setting Report Formats" under "Using Administrative Functions", earlier in this chapter.
The Use Default Format check box is checked by default. If you make any changes to the format of a numeric or currency field on this dialog, the Use System Default check box automatically unchecks itself, indicating that the report defaults are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

The Sample Field group box at the bottom of the sheet displays samples of the selected formats.

2. Select the Number option button or the Currency option button to indicate whether this report field is a numeric or a currency field.

There are some differences in the remaining controls on the dialog, depending on whether you select the number option or the currency option.

3. In the Positive list box (visible for currency fields only), select how you want the currency symbol displayed in relation to the currency amount.

4. In the Negative list box, select how you want the negative sign (-) displayed in relation to the number or currency amount.

5. In the Currency Symbol text box (visible for currency fields only), enter the currency symbol that you require.

6. In the 1000's Separator text box, enter the character that you want to use to separate the thousands in your number or currency values.

7. In the Decimals Separator text box, enter the character that you want to use to separate the whole numbers from the decimals in your number or currency values.

8. In the Decimals text box, enter the number (0 through 9) of decimal places that you want printed.

9. To suppress the printing of zero (0) in front of the decimal point when the number or currency amount is less than one (1), uncheck the Show Leading Zero for Decimals check box.

10. To suppress the printing of a number or decimal if it is zero (0), check the Suppress If Zero check box (visible only for number fields).

11. Click another tab if you want to make changes on other sheets of the Field Properties dialog.

12. Click the Apply button to apply the changes you have made or click the Close button to close the Report Formats dialog.

To save the recent changes when you close the dialog, you must click the Apply button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the Apply button immediately prior to clicking the Close button.

Using the Font Sheet

The Font sheet of the Field Properties dialog is displayed when you click the Font tab. (The Font tab is not visible for the properties of a picture field). Use the Font sheet to change the font or typeface of the text in your report field.

Text fonts have system default values but you can set your own report-wide font default values by using the Report Properties dialog, if required. (For details about setting font defaults, see "Setting Report Properties" under "Using Administrative Functions", earlier in this chapter.) Use the Font sheet to override the defaults for the current field.

Note: You can also set the font properties for the current field, by using the Font Tools toolbar.
An example of the Font sheet is shown in the following image.

To change the properties on the Font sheet of the Field Properties dialog

1. In the **Font** list box, select a font.
2. In the **Size** list box, select a point size for your font.
3. Click one or more of the following buttons to change the default font style.
   - The **B** button toggles the **bold** style on or off
   - The **I** button toggles the **italic** style on or off
   - The **U** button toggles the **underline** style on or off
4. In the **Color** list box, select a color to apply to your default font.

   If you select the **Custom** color, the common Color dialog is displayed to enable you to select or define a custom color. When you have made your selection, click the **OK** button to apply the selected color or click the **Cancel** button to close the Color dialog without making any changes.

   The RGB (Red, Green, and Blue color scheme) color values that relate to the selected color are displayed to the right of the **Color** list box.

5. Check the **Use Default Font** check box to reset all font default values to the default values.

   The **Use Default Font** check box is checked by default. If you make any changes to the font settings on this dialog, the **Use System Default** check box automatically unchecks itself, indicating that the report font defaults are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

6. Click another tab if you want to make changes on other sheets of the Field Properties dialog.
7. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report
Properties dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

**Using the Date Sheet**

The **Date** sheet of the Field Properties dialog is displayed when you click the **Date** tab. (The **Date** tab is visible only when you are working with the properties of a date or timestamp field.) Use the **Date** sheet to override the default date formats for the current field, if required.

You can use separator text for some date formats, to a maximum of three characters. If the separator text contains any of the characters `d`, `M`, `y`, `g`, `h`, `m`, `s`, or `t`, they are removed. The apostrophe character (‘) is not displayed as such when used as a separator character.

Date formats have system default values, but you can set your own report-wide default values by using the Report Properties dialog, if required. (For details about setting date defaults, see "Setting Report Properties" under "Using Administrative Functions", earlier in this chapter.)

An example of the **Date** sheet is shown in the following image.

![Field Properties dialog](image)

This image shows the Field Properties dialog when a date field is selected. A timestamp field displays both the date and time. For a timestamp field, the **Show Time**, **Date Then Time**, and **Date/Time Separator** controls are also visible on the **Date** sheet.

**To change the properties on the Date sheet of the Field Properties dialog**

1. Check the **Use Default Format** check box to reset all of the **Date** formats to the default values. If you select this option, the report default values or the system default values are displayed and take effect. For details about setting date default formats, see "Setting Report Properties" under "Using Administrative Functions", earlier in this chapter.
Chapter 4  Designing JADE Reports

The **Use Default Format** check box is checked by default. If you make any changes to the format of a date on this dialog, the **Use System Default** check box automatically unchecks itself, indicating that the report defaults are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box. The Sample Field group box at the bottom of the sheet displays an example of the selected format.

2. Select the **Use Short Date** option button if you want the date printed in the short date format. The short date format does not include the day name and does not separate the day, month, and year; for example, **230714**. Select the **Use Long Date** option button if you want the date displayed in the long date format. The long date format includes the day name; for example, **Tuesday 28 August 2004**. There are some differences in the remaining controls on this dialog, depending on the option that you select and whether you have selected a date field or a timestamp field.

3. To display the date portion of the timestamp before the time portion or a timestamp field, check the **Date Then Time** check box. This check box is not visible for a date field. It is enabled only if the timestamp field displays both date and time.

4. To display the date portion of the timestamp for a timestamp field, check the **Show Date** check box. This check box is not visible for a date field.

5. To separate the time portion of the timestamp from the date portion in the **Date/Time Separator** text box for a timestamp field, enter the character or characters to use as a separator or separators, to a maximum of five characters. This text box is not visible for a date field.

6. In the **Order** list box, select how you want the date order printed; that is, the sequence of day, month, and year.

7. In the **Separator** text box (displayed only if you selected **Use Short Date** in step 2), enter the character that you want to use to separate the numbers of your short date format.

8. In the **Day Name** list box (displayed only if you selected **Use Long Date** in step 2), select the way in which you want the day of the week printed. Select the full day name or the day name abbreviated to the first three letters of the day name; for example, **Wed** for Wednesday.

9. In the **Day** list box, select the way in which you want the day number printed when the day number is less than **10**. Select the option to print the leading zero (0) or not to print the leading zero. If you selected **Use Long Date** in step 2, enter the character or characters that you want to separate the day name from the day number in the text box at the far right of the **Day** list box.

10. In the **Month** list box, select the way in which you want the month printed.

    If you selected **Use Short Date** in step 2, select the way in which you want the month number printed when the month number is less than **10**. Select the option to print the leading zero (0) or not to print the leading zero.

    If you selected **Use Long Date** in step 2, select the way in which you want the month printed; for example, **September** or **09**.

    If you want to print the name of the month, select the full or the abbreviated name (that is, the first three characters; for example, **Sep**).

    If you want the month number printed, select the option to print months less than **10** with or without a leading zero (0).

11. If you selected **Use Long Date** in step 2, enter the character or characters that you want to separate the day number from the month in the **Day Separator** text box.

    A space is used if you do not enter a character in this text box. The character that you enter replaces the space; for example, if you enter a comma character (,), a comma character alone is printed between the parts of the date.
12. In the **Year** list box, select the way in which you want the year printed. Select the four-digit format or the two-digit format (for example, **2004** or **04**).

13. If you selected **Use Long Date** in step 2, enter the character or characters that you want to separate the month from the year in the **Date Separator** text box. If you do not enter a character in this text box, a space is used. The character that you enter replaces the space; for example, if you enter a comma character (,), a comma character alone is printed between the parts of the date.

14. Click another tab if you want to make changes on other sheets of the Field Properties dialog.

15. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Formats dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.

### Using the Time Sheet

The **Time** sheet of the Field Properties dialog is displayed when you click the **Time** tab. (The **Time** tab is visible only when you are looking at the properties of a time or timestamp field.) Use the **Time** sheet to override the default time formats for the current field, if required.

You can use separator text for some formats. You cannot use more than three characters as separator text. If the separator text contains any of the characters **d, M, y, g, h, H, m, s, or t**, they are removed. The apostrophe character (') is not displayed as such when used as a separator character.

The time formats have system default values, but you can set your own report-wide default values by using the Report Properties dialog. (For details about setting time defaults, see "Setting Report Properties" under "Using Administrative Functions", earlier in this chapter.)

An example of the **Time** sheet is shown in the following image.
The preceding image shows **Time** sheet of the Field Properties dialog when a timestamp field is selected. A timestamp field displays both the date and time. For a time field the **Show Time, Time Then Date**, and **Date/Time Separator** controls are not enabled and not visible.

**Tip** Use the scroll buttons at the top of the Field Properties dialog to view other tabs (such as the **Common** tab) that may be obscured when the **Date** and **Time** tabs are displayed.

To change the properties on the **Time** sheet of the Field Properties dialog

1. **Check the Use Default Format** check box to reset all of the **Time** formats to the default values.
   
   If you select this option, the report default values or the system default values are displayed and take effect. For details about setting date and time default formats, see "Setting Report Properties" under "Using Administrative Functions", earlier in this chapter.
   
   The **Use Default Format** check box is checked by default. If you make any changes to the format of a time field on this dialog, the **Use System Default** check box automatically unchecks itself, indicating that the report defaults are no longer being used. Alternatively, to begin making your changes, you can manually uncheck this check box.

   The Sample Field group box at the bottom of the screen displays an example of the selected format.

2. **Select the 12 Hour Clock** option button if you want your report times printed in 12-hour clock format or the **24 Hour Clock** option button if you want your report times printed in 24-hour clock format.

3. **If you want to include seconds in the time**, check the **Show Seconds** check box.

4. **If you want the time marker printed as a prefix to the time value** (for example, **pm12:06**), uncheck the **Show Time Marker as Suffix** check box.

5. **If you want to suppress the printing of the leading zero (0) when the hour value is less than 10**, uncheck the **Show Leading Zero for Hours < 10** check box.

6. **In the Separator text box**, enter the character that you want to separate the hours and minutes (and seconds, if the **Show Seconds** check box is checked) of your default time format.
   
   There are some differences in the remaining controls on the dialog, depending on the options that you select, and whether you have selected a time field or a timestamp field.

7. **To display the time portion of the timestamp for a timestamp field**, check the **Show Time** check box. This check box is not visible for a time field.

8. **To display the time portion of the timestamp before the date portion for a timestamp field**, check the **Time Then Date** check box. This check box is not visible for a time field. It is enabled only if the timestamp field displays both the time and date.

9. **To separate the time portion of the timestamp from the date portion for a timestamp field**, enter the character or characters to use in the **Date/Time Separator** text box. You can enter up to five characters as separator text. This text box is not visible for a time field.

10. **In the Marker text box**, enter time markers to indicate pre-noon and post-noon times.
   
   If you selected the **12 Hour Clock** option, there are two markers for the pre-noon and post-noon periods. If you want to create your own default markers, enter up to 30 characters in the **Marker** text box.

   If you selected the **24 Hour Clock** option, only one **Marker** text box is displayed. If you want a marker printed for the time, enter up to 30 characters in the **Marker** text box.

11. **Click another tab if you want to make changes on other sheets of the Field Properties dialog.**
12. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Formats dialog.

To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any changes that you have made but not yet applied, do *not* click the **Apply** button immediately prior to clicking the **Close** button.

**Using the Picture Sheet**

The **Picture** sheet of the Field Properties dialog is displayed when you click the **Picture** tab. (The **Picture** tab is visible only for the properties of a picture field.) Picture properties control the placement of your picture field within its field delimiters (field boundaries).

An example of the **Picture** sheet is shown in the following image.

![Picture Sheet Example](image)

To change the properties on the Picture sheet of the Field Properties dialog

1. Select a stretch property for your picture field from the **Stretch** drop-down list box (as shown in the previous image). The following table lists the stretch properties that are available.

<table>
<thead>
<tr>
<th>Picture Stretch Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No stretching is performed. If you have applied one of the stretch properties and you then apply <strong>None</strong>, the picture returns to its original size.</td>
</tr>
<tr>
<td>To Control</td>
<td>Stretches the picture to fit the field boundaries.</td>
</tr>
<tr>
<td>Control To</td>
<td>Shrinks the field boundaries to fit the picture.</td>
</tr>
<tr>
<td>Picture Stretch Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Proportional</td>
<td>The field boundaries are sized in proportion to the picture. The picture is then stretched to fit the field boundaries so that the picture is always drawn in isotropic proportions to its original size. If you then change the size of the field boundaries, the width or the height decreases (not increases) to keep the same proportional view of the picture.</td>
</tr>
<tr>
<td>Picture Proportional</td>
<td>The picture is sized proportionally to fit the field boundaries. The picture is centered horizontally or vertically if the resized picture does not fill the height or width of the field boundaries.</td>
</tr>
<tr>
<td>Center Picture</td>
<td>Centers the picture horizontally and vertically within the field boundaries.</td>
</tr>
</tbody>
</table>

2. Click another tab if you want to make changes on other sheets of the Field Properties dialog.

3. Click the **Apply** button to apply the changes you have made or click the **Close** button to close the Report Formats dialog. To save the recent changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog.

   To abandon any changes that you have made but not yet applied, do **not** click the **Apply** button immediately prior to clicking the **Close** button.

### Setting Field Properties using a Format Script

The Format Script dialog enables you to set properties for report fields from within scripts. This provides conditional control of properties such as item color and visibility so that they depend on values being reported.

Click the **Format Script** button on the field properties dialog to define field format scripts. If a format script exists for the selected field, the **Format Script** button is blue, if no script exists, the **Format Script** button is grey.
The Format Script form, shown in the following image, is then displayed. Setting the field values in the format script, overrides the selections made on the Field Properties dialog.

The Format Script dialog that you use to define and maintain format scripts is similar to that used for user scripts, except that a format script does not require a name and return type. In addition, a format script is always a full script rather than a single expression.

For details about writing scripts, see Appendix A, "Using JADE Report Writer Scripts".

**Visible Command**

Use the **Visible** command from the popup menu that is displayed when you right-click on a report field in your layout to change the visibility of the current field.

- **To change the visibility of the current field**
  - Click the **Visible** command on the popup menu.

  Clicking this command toggles the visibility of the current field on or off. The option is set and the field is made visible on your printed report when the check mark symbol (✓) is displayed next to the command.

**Border Command**

Use the **Border** command from the popup menu that is displayed when you right-click on a report field in your layout to set a border around the current field.
To set a border around the current field

1. Select the Border command on the popup menu.
   A submenu is then displayed on the popup menu.
2. Select the Single option to create a single line border around your report field.
   The check mark symbol (✓) is then displayed next to the Single option.

Alignment Command

Use the Alignment command from the popup menu that is displayed when you right-click on a report field in your layout to align your report field within the field boundaries.

To align the current field

1. Select the Alignment command on the popup menu.
   A submenu is then displayed on the popup menu.
2. Select the appropriate option to print the field left, center, or right of the field boundary.
   The check mark symbol (✓) is then displayed next to the selected option.

Delete Command

Use the Delete command from the popup menu that is displayed when you right-click on a report field in your layout to delete the selected field; that is, remove it from the layout.

To remove the current field from the layout

1. Select the Delete command on the popup menu.
   A delete confirmation dialog is then displayed.
2. Click the Yes button to delete the field. Alternatively, click the No button to cancel the deletion.
   The field is then removed from your layout.

Using the Layout Commands

The JADE Report Writer Designer application provides a number of commands to enable you to refine the positions of your report fields.

The layout commands, listed in the following table, are available from the toolbar and from the Layout menu.

<table>
<thead>
<tr>
<th>Toolbar Buttons</th>
<th>Layout Menu</th>
<th>Commands</th>
<th>Enables you to …</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="left" alt="Left Arrow" /></td>
<td>Not applicable</td>
<td>Move fields to the left</td>
<td></td>
</tr>
<tr>
<td><img src="right" alt="Right Arrow" /></td>
<td>Not applicable</td>
<td>Move fields to the right</td>
<td></td>
</tr>
<tr>
<td><img src="up" alt="Up Arrow" /></td>
<td>Not applicable</td>
<td>Move fields up</td>
<td></td>
</tr>
<tr>
<td><img src="down" alt="Down Arrow" /></td>
<td>Not applicable</td>
<td>Move fields down</td>
<td></td>
</tr>
</tbody>
</table>
### Layout Commands

<table>
<thead>
<tr>
<th>Toolbar Buttons</th>
<th>Layout Menu</th>
<th>Commands</th>
<th>Enables you to …</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Not applicable" /></td>
<td>Not applicable</td>
<td>Make fields thinner</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Not applicable" /></td>
<td>Not applicable</td>
<td>Make fields wider</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Not applicable" /></td>
<td>Not applicable</td>
<td>Make fields shallower</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Not applicable" /></td>
<td>Not applicable</td>
<td>Make fields deeper</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Center Vertically</td>
<td>Center the selected fields vertically</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Center Horizontally</td>
<td>Center the selected fields horizontally</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Bottom</td>
<td>Align fields to the top edge of the selected master field</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Top</td>
<td>Align fields to the top edge of the selected master field</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Left</td>
<td>Align fields to the left edge of the selected master field</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Alignment:" /></td>
<td>Right</td>
<td>Align fields to the right edge of the selected master field</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Size:" /></td>
<td>Same Width</td>
<td>Make selected fields the same width</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Size:" /></td>
<td>Same Height</td>
<td>Make selected fields the same height</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Size:" /></td>
<td>Same Height and Width</td>
<td>Make selected fields the same height and width</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Space Evenly Down</td>
<td>Space fields evenly down the frame</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Space Evenly Across</td>
<td>Space fields evenly across the frame</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Spread Down Container</td>
<td>Spread fields down the frame</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Spread Across Container</td>
<td>Spread fields across the frame</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Horizontally Adjacent</td>
<td>Attach fields horizontally</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Spacing:" /></td>
<td>Vertically Adjacent</td>
<td>Attach fields vertically</td>
<td></td>
</tr>
</tbody>
</table>

The following subsections describe the layout commands in more detail.
To select multiple fields, perform one of the following actions:

- Using the right mouse button, click on an empty area in a section; that is, do not click on a field or shape. While holding the mouse button down, drag a rectangle over an area of the report, even across section boundaries. When you release the mouse button, all fields, lines, and boxes within the rectangle are selected.

- Using the left mouse button, click the first field, hold down the Shift key or the Ctrl key and click the other fields on the report. Clicking on a field a second time deselects it.

- Using the right mouse button, click on an empty area in a section; that is, do not click on a field. Select the Select All command from the popup menu that is displayed, to select all fields, lines, and boxes in the section.

- Select the Edit menu Select All command, to select all fields, lines, and boxes in the report.

A control that is already selected in the frame remains the master control, for alignment and sizing purposes. In addition, right-clicking on an item makes it the new master item, without changing the list of previously selected items. When you then apply a layout command, it is applied to all selected fields.

To specify the master field, perform one of the following actions:

- Select the master field last when selecting multiple fields.

- After selecting a group of fields, right-click on the field that is to be the master field.

The Alignment commands then align your selected fields relative to the last field that you selected and the Size commands resize fields relative to the last field that you selected.

Move Field(s) to the Left Button

Click the Move Field(s) to the Left toolbar button command to move the selected field or fields one pixel to the left. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Move Field(s) to the Right Button

Click the Move Field(s) to the Right toolbar button command to move the selected field or fields one pixel to the right. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Move Field(s) Up Button

Click the Move Field(s) Up toolbar button to move the selected field or fields up one pixel. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Move Field(s) Down Button

Click the Move Field(s) Down toolbar button to move the selected field or fields down one pixel. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)
Make Field(s) Thinner Button

Click the Make Field(s) Thinner toolbar button to move the right edge of the selected field or fields one pixel to the left. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Make Field(s) Wider Button

Click the Make Field(s) Wider toolbar button to move the right edge of the selected field or fields one pixel to the right. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Make Field(s) Shallower Button

Click the Make Field(s) Shallower toolbar button to move the bottom edge of the selected field or fields up one pixel. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Make Field(s) Deeper Button

Click the Make Field(s) Deeper toolbar button to move the bottom edge of the selected field or fields down one pixel. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

Center Vertically Command

Use the Center Vertically command to center a field or group of fields relative to the vertical axis of your report section. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To center a field or group of fields vertically, perform one of the following actions

- Click the Center Vertically toolbar button.
- Select the Alignment command on the Layout menu and then select the Center Vertically command from the submenu that is displayed.

The selected field or fields are then aligned so that they are centered vertically in the report section or frame.

Center Horizontally Command

Use the Center Horizontally command to center a field or group of fields relative to the horizontal axis of your report section. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To center a field or group of fields horizontally, perform one of the following actions

- Click the Center Horizontally toolbar button.
- Select the Alignment command on the Layout menu and then select the Center Horizontally command from the submenu that is displayed.

The selected field or fields are then aligned so that they are centered horizontally in the report section or frame.

Top Command

Use the Top command to align a group of fields so that their top edges are aligned to the top edge of the selected master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)
To align a group of fields to the top of the master field, perform one of the following actions

- Click the Align Top toolbar button.
- Select the Alignment command on the Layout menu and then select the Top command from the submenu that is displayed.

The selected fields are then aligned to the top edge of the master field.

**Bottom Command**

Use the Bottom command to align a group of fields so that their bottom edges are aligned to the bottom edge of the selected master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To align a group of fields to the bottom of the master field, perform one of the following actions

- Click the Align Bottom toolbar button.
- Select the Alignment command on the Layout menu and then select the Bottom command from the submenu that is displayed.

The selected fields are then aligned to the bottom edge of the master field.

**Left Command**

Use the Left command to align a group of fields so that their left edges are aligned to the left edge of the selected master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To align a group of fields to the left of the master field, perform one of the following actions

- Click the Align Left toolbar button.
- Select the Alignment command on the Layout menu and then select the Left command from the submenu that is displayed.

The selected fields are then aligned to the left edge of the master field.

**Right Command**

Use the Right command to align a group of fields so that their right edges are aligned to the right edge of the selected master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To align a group of fields to the right of the master field, perform one of the following actions

- Click the Align Right toolbar button.
- Select the Alignment command on the Layout menu and then select the Right command from the submenu that is displayed.

The selected fields are then aligned to the right edge of the master field.

**Same Width Command**

Use the Same Width command to make the selected fields the same width as the master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)
To make selected fields the same width as the master field, perform one of the following actions

- Click the Same Width toolbar button.
- Select the Size command on the Layout menu and then select the Same Width command from the submenu that is displayed.

The selected fields are then stretched or contracted to the same width as the master field.

**Same Height Command**

Use the Same Height command to make the selected fields the same height as the master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To make selected fields the same height as the master field, perform one of the following actions

- Click the Same Height toolbar button.
- Select the Size command on the Layout menu and then select the Same Height command from the submenu that is displayed.

The selected fields are then stretched or contracted to the same height as the master field.

**Same Height and Width Command**

Use the Same Height and Width command to make the selected fields the same height and width as the master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To make selected fields the same height and width as the master field, perform one of the following actions

- Click the Same Height and Width toolbar button.
- Select the Size command on the Layout menu and then select the Same Height and Width command from the submenu that is displayed.

The selected fields are then stretched or contracted to the same height and width as the master field.

**Space Evenly Down Command**

Use the Space Evenly Down command to space a group of fields so that the vertical distance between each field is the same. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To space a group of fields evenly down, perform one of the following actions

- Click the Space Evenly Down toolbar button.
- Select the Spacing command on the Layout menu and then select the Space Evenly Down command from the submenu that is displayed.

The selected fields are then spaced so that the vertical distance between each field is the same.

For a description of the difference between the Space and Spread commands, see the note in "Using the Layout Commands", earlier in this section.
Space Evenly Across Command

Use the Space Evenly Across command to space a group of fields so that the horizontal distance between each field is the same. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To space a group of fields evenly across, perform one of the following actions

- Click the Space Evenly Across toolbar button.
- Select the Spacing command on the Layout menu and then select the Space Evenly Across command from the submenu that is displayed.

The selected fields are then spaced so that the horizontal distance between each field is the same.

For a description of the difference between the Space and Spread commands, see the note in "Using the Layout Commands", earlier in this section.

Spread Down Container Command

Use the Spread Down Container command to space a group of fields down a section or frame so that each field has an equal vertical space adjacent to it. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To spread a group of fields evenly down, perform one of the following actions

- Click the Spread Down Container toolbar button.
- Select the Spacing command on the Layout menu and then select the Spread Down Container command from the submenu that is displayed.

The selected fields are then spread so that the each field is bounded by the same vertical space.

For a description of the difference between the Space and Spread commands, see the note in "Using the Layout Commands", earlier in this section.

Spread Across Container Command

Use the Spread Across Container command to space a group of fields across a section or frame so that each field has an equal horizontal space adjacent to it. (For details about selecting a group of fields, see "Using the Layout Commands", earlier in this section.)

To spread a group of fields evenly across, perform one of the following actions

- Click the Spread Across Container toolbar button.
- Select the Spacing command on the Layout menu and then select the Spread Across Container command from the submenu that is displayed.

The selected fields are then spread so that the each field is bounded by the same horizontal space. For a description of the difference between the Space and Spread commands, see the note in "Using the Layout Commands", earlier in this section.

Vertically Adjacent Command

Use the Vertically Adjacent command to attach fields vertically to the master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)
To attach fields vertically to the master field, perform one of the following actions

- Click the Vertically Adjacent toolbar button.
- Select the Spacing command on the Layout menu and then select the Vertically Adjacent command from the submenu that is displayed.

The selected fields are then moved up or down the report section or frame to become attached to the master field.

Horizontally Adjacent Command

Use the Horizontally Adjacent command to attach fields horizontally to the master field. (For details about selecting a group of fields and the master field, see "Using the Layout Commands", earlier in this section.)

To attach fields horizontally to the master field, perform one of the following actions

- Click the Horizontally Adjacent toolbar button.
- Select the Spacing command on the Layout menu and then select the Horizontally Adjacent command from the submenu that is displayed.

The selected fields are then moved left or right in the report section or frame to become attached to the master field.

Using Guidelines

The JADE Report Writer Designer application enables you to create vertical and horizontal guidelines to assist in positioning, moving, and resizing fields. Guidelines provide a visual indication of fields linked to them.

You can move existing guidelines or you can delete guidelines by dragging guidelines that you want to delete out of the ruler. When you move a guideline, all attached controls are moved and resized.

When using guidelines:

- Move a field or control to snap (attach) it to the grid; moving a guideline to a control does not attach it.
- You cannot attach lines and boxes to guidelines, but text and pictures only.
- Moving an attached control away from the guideline does not move the guideline but breaks the attachment of the control to the guideline.
- Moving a guideline breaks the attachment to other guidelines only when the moving of the control takes it away from other guidelines.
- Guidelines are not saved with the report.
- You cannot shrink a section size less than lowest (largest) horizontal guideline. Horizontal guidelines can be moved only within their section, and not between sections.
- When you select the Snap to Grid command from the View menu, guidelines also snap to the grid when moved.
- You cannot add guidelines to attached template frames within reports.

To create a guideline

- Click on the horizontal or vertical ruler with the left mouse button.
A gray guideline is then displayed on the report. To reposition the guideline, move the triangular slider, shown in the following image, along the ruler.

To delete a guideline

- Drag the triangular slider off the ruler, upwards for a vertical guideline or to the left for a horizontal ruler.

To align a field to a guideline

- Move the field close to the guideline.

The guideline then becomes attached, indicated by the red sizing handles shown in the following image, so that the attached field moves when you move the guideline.

To move fields by moving a guideline

- Drag the triangular slider along the ruler to the new position.

All fields attached to the guideline, indicated by the red sizing handles, move with it.

To resize fields by moving a guideline

- When fields are sandwiched between two guidelines, moving one of the guidelines causes the attached controls to be resized so that they remain attached to both guidelines.
Using the Quick Launch Tools

The JADE Report Writer Designer application provides a Quick Launch Tools toolbar to enable you to access the most commonly used report design and layout display tools. The Quick Launch Tools toolbar buttons enable you to use the menu commands listed in the following table.

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Menu Command</th>
<th>Enables you to toggle the display of the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog</td>
<td>Catalog</td>
<td>Catalog of Available Fields dialog</td>
</tr>
<tr>
<td>Field</td>
<td>Field Properties</td>
<td>Field Properties dialog</td>
</tr>
<tr>
<td>Show Watermark</td>
<td>Watermark</td>
<td>Watermark</td>
</tr>
<tr>
<td>Show/Hide Grid</td>
<td>Layout grid</td>
<td>Layout grid</td>
</tr>
<tr>
<td>Show Rulers</td>
<td>Rulers</td>
<td>Rulers</td>
</tr>
</tbody>
</table>

Creating Groups

Report groups enable you to group data by subcategory and optionally produce totals by group.

A group is a simple concept; for example, if you want to print a report showing customer sales, you could group on customer name and therefore show a sales item list for each customer. The following image shows a section of a report that groups customer sales by customer.

<table>
<thead>
<tr>
<th>Name</th>
<th>Item</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Samuels</td>
<td>Box of nails</td>
<td>12.00</td>
</tr>
<tr>
<td></td>
<td>Hammer</td>
<td>36.00</td>
</tr>
<tr>
<td></td>
<td>Screwdriver</td>
<td>15.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>66.00</strong></td>
</tr>
<tr>
<td>Smith</td>
<td>2m ladder</td>
<td>260.00</td>
</tr>
<tr>
<td></td>
<td>10 ft pant</td>
<td>70.00</td>
</tr>
<tr>
<td></td>
<td>100mm brush</td>
<td>16.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>346.00</strong></td>
</tr>
<tr>
<td>Stanton</td>
<td>Tool Kit</td>
<td>180.00</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td><strong>180.00</strong></td>
</tr>
</tbody>
</table>
When you create a group, the JADE Report Writer Designer application automatically creates a group header and group footer section. In the above example, the customer name is in the group header section and the total line is in the group footer.

You can create groups at other levels for the same report. In the above example, you could provide another level of grouping based on location (such as retail areas). This group would be at a higher level and would typically provide totals (summaries) by location. Your report would then have three levels of summary: customer totals, area totals, and a grand total.

You can use profiles to change group detail. Profiles enable you to run different editions of your report simply by choosing a profile against which to run it.

Within your profiles, you can select alternative fields on which to group data. Using the above example, if one profile has its grouping based on customer, a second profile could have grouping based on product. When you run the report, you select the profile with which the report runs.

For details about creating report profiles, see "Creating or Maintaining Profiles" under "Using Administrative Functions", earlier in this chapter.

Creating, updating, and using groups are described in the following subsections.

- Creating a New Group
- Updating an Existing Group
- Using Groups Example

Creating a New Group

As groups are specific to a report, if you create three groups levels, those three group levels are inherited by each profile that you create for your report.

In profiles, you can specify different fields on which to group, but each profile inherits the same number of groups you have created for your report.

Each subsequent group after the first group that you create for a report must be specified at a different level; that is, the subsequent group encompasses the previous group or is encompassed by the previous group.

In the customer list example, you would specify grouping by date at a higher level than the customer grouping. If you had specified grouping by date as the first group, you would then introduce customer grouping at a lower level.

To create the first group for a report

1. Select the Group command from the Insert menu. The Add New Group Section dialog, shown in the following image, is then displayed.
2. In the **Group Alias** text box, enter a name for your group; for example, **Customer**.

3. In the **Group by Field** list box, select the field or script field on which your group is to be based.

   In the example in the above image, the field `Clients::name` is selected. In this case, the group is created before report fields are placed in the report design. When the report is run, the group footer is printed for the next client each time the client (customer) name changes.

   Fields of maximum length (for example, `allSaleItems::fullDescription` of type `String` with `max` length) specified as group fields are used as fields with a maximum length of 100. (Maximum length fields are not valid as group fields, as they exceed the JADE defined limit for use in collection operations.)

   Only script fields that do not, directly or indirectly, reference summary fields are displayed.

4. Select the **Ascending** option button or the **Descending** option button to specify the order of this group. For example, if you select the **Ascending** sequence when grouping on client name, groups print from **Abrahams** to **Zabotinsky**. If you select the **Descending** sequence, the same data produces groups from **Zabotinsky** to **Abrahams**.

5. Click the **OK** button to apply the new group to your report.

   To abandon your entries, click the **Close** button before you click the **OK** button.

When you apply the new group, the group header section and a group footer section are automatically added to your report. The **Group Alias** name and the **Group By** field that you specified are positioned automatically in your group header.

**To create a second group for the same report**

1. Follow the procedure that you used to create your first group, described in the previous instruction.

   The Position Group group box is shown for the second and any subsequent group. For the second group, two position options are enabled.
Use the additional Position Group group box on the Add New Group Section dialog to position this group in relation to the first group, as shown in the following image.

2. To select the relationship of this group to the group that you added previously, select the As highest-level option button or the As lowest-level option button.

In the example in the above image, the date field has been selected at a higher level than the previous group (which was grouped on client name and which was called Customer).

The report design now contains report fields, one of which you can use for the new group.

This grouping results in the JADE Report Writer Designer application grouping the sales data by date and by customer within that sales data.

The following image shows the sequence that is produced if total sales are required by customer group, by date group, and for the entire report.

```
REPORT
  DATE 1
  CUSTOMER 1
  SALE ITEM 1
  SALE ITEM 2
  SALE ITEM 99
  CUSTOMER 1 TOTAL

  CUSTOMER 2
  SALE ITEM 1
  SALE ITEM 2
  SALE ITEM 99
  CUSTOMER 2 TOTAL

  CUSTOMER 99...

  DATE 1 TOTAL
```
DATE 2
CUSTOMER 1
SALE ITEM 1
SALE ITEM 2
SALE ITEM 99
CUSTOMER 1 TOTAL

CUSTOMER 2
SALE ITEM 1
SALE ITEM 2
SALE ITEM 99
CUSTOMER 2 TOTAL

CUSTOMER 99 ...

DATE 2 TOTAL

DATE 99 ...

REPORT TOTAL

To create a third or subsequent group for the same report

1. Follow same procedure that you used to create your first group, described earlier in this section. When adding a third or subsequent group, three position options are enabled on the Position Group group box on the Add New Group Section dialog, as shown in the following image.

![Position Group Options](image)

2. To specify the position of the new group in relation to the group that has the focus on your layout (that is, the one that you clicked), click the Before selected group option button.

Your new group is then positioned at a higher level than the selected group.

Alternatively, select one of the other option buttons to position the new group at the highest or lowest level, as described in the previous instruction.

Updating an Existing Group

Use the Profile Properties dialog to update groups. You can update your groups against any profile. If you are not using profiles, you can update the group against the default profile. However, changing group details for different profiles can provide you with different versions of your report.

If you make group changes based on profiles, you can run any version of your report by specifying a unique profile name for each version. For example, one profile can produce your report in ascending group sequence and you can then specify another profile to print the report in descending sequence. You can also specify a different Group by Field field and therefore change the entire grouping sequence. Update report groups by using the Group sheet of the Profile Properties dialog.
To display the Group Sheet of the Profile Properties dialog, perform one of the following actions:

- Select the Properties command from the Profile menu and then click the Group tab.
- Select the group that you want to update on your layout (that is, click in any space within the group) and then select the Group command from the Edit menu.

The Group sheet of the Profile Properties dialog is then displayed, as shown in the following image.

To update a report group:

1. In the All Profiles list box, select a profile name to which this group is to be attached. If you have not created any profiles, the group is automatically attached to the default profile.
2. To change the alias name, enter a new alias name for your group in the Alias text box.
3. To change the field on which your group is based, select the field from the Group-by Field list box. Fields of maximum length (for example, allSaleItems::fullDescription of type String with max length) specified as group fields are used as fields with a maximum length of 100. (Maximum length fields are not valid as group fields, as they exceed the JADE-defined limit for use in collection operations.)
4. Select the Ascending option button or the Descending option button to change the order of groups.
   For example, if you select the Ascending sequence when grouping on client name, groups print from Abrahams to Zabotinsky. If you select the Descending sequence, the same data prints groups from Zabotinsky to Abrahams.
5. Click another tab if you want to make changes on other sheets of the Profile Properties dialog.
6. Click the **Apply** button to apply the additions or changes you have made or click the **Close** button to close the Profile Properties dialog.

   To save the recent additions or changes when you close the dialog, you must click the **Apply** button immediately prior to closing the dialog. To abandon any additions and changes that you have made but not yet applied, do not click the **Apply** button immediately prior to clicking the **Close** button.

You can change the order of groups within your report and delete groups by using the section properties. For details, see "Setting the Section Properties", earlier in this chapter.

### Using Groups Example

The following is a typical example of how you might use the report groups feature of the JADE Report Writer Designer application.

**To utilize a group (based on a typical example)**

1. Manipulate header detail in your **Group Header** section.

   *Group Field Alias* and *Group Field Name* are automatically placed in your **Group Header** section when you create a group. In the customer report example, *Group Field Alias* is the literal **Customer** (see the previous image) and *Group Field Name* is the field that you selected for your grouping.

   Your first group header may appear as follows.

   ```
   Customer    |    
   Names
   ```

   These fields automatically provide header detail in your group header but use the default font and font size when created.

   Change the look of these fields by using the field properties and the layout commands. For details, see "Setting Field Properties" and "Using the Layout Commands", earlier in this chapter.

2. Create footer detail in your **Group Footer** section. The **Group Footer** section is where you typically insert a summary field, which is usually a report subtotal for the group. In the **Customer** group example, this is a total of the sales against each customer.
The summary field, created in advance, is available on the Summary sheet of the Catalog of Available Fields dialog, shown as `totalPrice` in the following image.

For details about creating summary fields, see "Using the Summary Sheet" under "Using the Catalog of Available Fields Dialog", earlier in this chapter.

3. Drag and drop the summary field into the appropriate group footer section of your report. For details about inserting fields, see "Inserting Report Fields", earlier in this chapter.

With your group header in place and your summary field in the group footer, the JADE Report Writer prints the group footer automatically, followed by the next group header when the group field name changes. In this example, the group field name changes when the customer name (that is, the database field `Client::name`) changes.

The JADE Report Writer Designer application automatically accumulates the summary field (that is, `totalPrice`, in this example).

If you have selected the option to reset When Group Changes when creating your summary field, the summary field is reset after the group footer is printed. In this example, `totalPrice` is set to zero (0) automatically after the group footer is printed, ready to accumulate sales for the next customer.

**Creating Templates**

Create standard report frames and content by using templates. When you start a new template, you are provided with the same blank design layout that is provided when you start a new report. It contains the standard sections: report header, page header, detail, page footer, and report footer.

Move fields to the template sections in exactly the same way that you move fields to the report frames, except that you have no access to the database fields.

Templates enable you to create standard report frames that you can use for many or all of the reports in your organization. Specific database fields are therefore not relevant to templates.
When you attach a template to a report, the template frames are added to the report frames, as shown in the following image.

If you do not want all of the default template sections printed, make the sections that you do not want printed invisible by unchecking the **Visible in the Report** check box in the Section Properties dialog.
In the following example, a report header showing the company letterhead as a standard header is printed.

In this example, a standard template is attached that provides the Erewhon letterhead graphic. The sample report at the top is the same report before the template (with its graphical header section) is applied. All other template sections in this example have been made invisible.

The steps that are required to create a template are listed in the following table.

<table>
<thead>
<tr>
<th>Step</th>
<th>For more details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start a New Template</td>
<td>&quot;Starting a Template&quot;, earlier in this chapter.</td>
</tr>
<tr>
<td>Create template detail</td>
<td>The procedure described in &quot;Inserting Report Fields&quot;, earlier in this chapter, except that you cannot insert database script or summary fields.</td>
</tr>
<tr>
<td>Make unwanted sections invisible</td>
<td>&quot;Visible Command&quot; under &quot;Setting the Section Properties&quot;, earlier in this chapter.</td>
</tr>
</tbody>
</table>

When you have created a template, use the **Attach Template** command from the Report menu to apply it to your report. For details, see "Attach Template" under "Report Menu", later in this chapter.

If you want to update the template, open the template by using the **Open Template** command from the File menu. For details, see "Opening a Template", earlier in this chapter.

### Using the JADE Report Writer Designer Menus

This section covers the JADE Report Writer Designer application menus, which are described in detail in the following subsections.

- **File Menu**
- **Edit Menu**
File Menu

Use the File menu to administer your JADE Report Writer Designer application session. The commands provided by the File menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Report</td>
<td></td>
<td>Starts a new report</td>
</tr>
<tr>
<td>New Template</td>
<td></td>
<td>Starts a new template</td>
</tr>
<tr>
<td>Open Report</td>
<td></td>
<td>Opens an existing report</td>
</tr>
<tr>
<td>Open Template</td>
<td></td>
<td>Opens an existing template</td>
</tr>
<tr>
<td>Close and Save</td>
<td></td>
<td>Saves and closes the report</td>
</tr>
<tr>
<td>Abandon Changes</td>
<td></td>
<td>Closes without saving</td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td>Saves the current report</td>
</tr>
<tr>
<td>Rename/Reposition</td>
<td></td>
<td>Renames a report or moves it to a different folder</td>
</tr>
<tr>
<td>Save As Copy</td>
<td></td>
<td>Makes another copy of your report or template</td>
</tr>
<tr>
<td>Delete Report</td>
<td></td>
<td>Deletes a report</td>
</tr>
<tr>
<td>Delete Template</td>
<td></td>
<td>Deletes a template</td>
</tr>
<tr>
<td>Refresh Preview</td>
<td></td>
<td>Refreshes the preview from the database</td>
</tr>
<tr>
<td>Print</td>
<td></td>
<td>Prints the current report</td>
</tr>
<tr>
<td>Print Setup</td>
<td></td>
<td>Changes print options</td>
</tr>
<tr>
<td>Extract Data</td>
<td></td>
<td>Extracts the report in various other formats</td>
</tr>
<tr>
<td>Unload Definition</td>
<td></td>
<td>Extracts report and template definitions to a flat file</td>
</tr>
<tr>
<td>Load Definition</td>
<td></td>
<td>Retrieves report and template definitions from a flat file</td>
</tr>
<tr>
<td>User Preferences</td>
<td></td>
<td>Provides session change options for the JADE Report Writer Designer Application</td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td>Closes the JADE Report Writer Designer application</td>
</tr>
</tbody>
</table>
**Note**  As a template can be printed only when attached to a report, the **Print**, **Print Preview**, **Print Setup**, and **Extract Data** commands are not enabled for templates.

### New Report Command

Use the **New Report** command from the File menu to start a report from scratch.

**To start a new report, perform one of the following actions**

- Select the **New Report** command from the File menu
- Press Ctrl+N
- Click the **New Report** toolbar button

The Select Collections and Joins to Report on dialog is then displayed. For details about using the **New Report** command and the Select Collections and Joins to Report on dialog, see "Starting a Report from Scratch", earlier in this chapter.

### New Template Command

Use the **New Template** command from the File menu to start a new template.

**To start a new template, perform one of the following actions**

- Select the **New template** command from the File menu
- Press Ctrl+T
- Click the **New Template** toolbar button

The JADE Report Writer Designer window is then displayed with a blank template.

For details about creating templates, see "Creating Templates", earlier in this chapter.

### Open Report Command

Use the **Open Report** command from the File menu to open an existing report.

**To open an existing report, perform one of the following actions**

- Select the **Open Report** command from the File menu
- Press Ctrl+O
- Click the **Open Report** toolbar button

The Open Report dialog is then displayed. For details about using the **Open Report** command and the Open Report dialog, see "Opening an Existing Report", earlier in this chapter.

### Open Template Command

Use the **Open Template** command from the File menu to open an existing template.
To open an existing template, perform one of the following actions

- Select the Open Template command from the File menu
- Press Ctrl+E
- Click the Open Template toolbar button

The Open Template dialog is then displayed. For details about using the Open Template command and the Open Template dialog, see "Opening a Template", earlier in this chapter.

Close and Save Command

Use the Close and Save command from the File menu to close a report or template and save it during the close process.

To close and save a report or template, perform one of the following actions

- Select the Close and Save command from the File menu
- Click the Close toolbar button

The report or template is then saved and closed.

Abandon Changes Command

Use the Abandon Changes command from the File menu to close a report or template without saving any changes made since the previous save or since the report or template has been opened, if a save has not been performed.

To close a report or template without saving

- Select the Abandon Changes command from the File menu

The report or template is then closed without saving any changes made.

Save Command

Use the Save command from the File menu to save a report or template.

To save a report or template, perform one of the following actions

- Select the Save command from the File menu
- Press Ctrl+S
- Click the Save toolbar button

The report or template is then saved, and your Report Designer session remains active.

Rename/Reposition Command

Use the Rename/Reposition command from the File menu to rename or relocate a report or template.

To display the Rename dialog, perform one of the following actions

- Select the Rename/Reposition command from the File menu
- Press Ctrl+R
The Rename dialog, shown in the following image, is then displayed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Last modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent and Supplier Reports</td>
<td>Folder</td>
</tr>
<tr>
<td>Client Reports</td>
<td>Folder</td>
</tr>
<tr>
<td>Annual Summary Report</td>
<td>22 December 2003, 11:40:31</td>
</tr>
<tr>
<td>Client Sales Report</td>
<td>22 December 2003, 11:39:16</td>
</tr>
<tr>
<td>New Report 2</td>
<td>22 December 2003, 11:03:36</td>
</tr>
<tr>
<td>Tender Sales Items</td>
<td>22 December 2003, 11:41:40</td>
</tr>
</tbody>
</table>

- **Report name**: End of Year
- **Show reports for current schema only**: checked

### To rename your report or template

1. Enter a new name for the current report or template in the **Report name** text box or the **Template name** text box, as appropriate. For details about creating folders, see "Folders Menu", in Chapter 3.

2. To further refine the display of reports or templates, perform one of the following actions.
   - To display details relating to the last modified dates of the displayed reports or templates, click the **Display Details** button. (This is the default display.)
   - To display the reports or templates as a simple list, click the **Display as List** button.
   - To display the report or template properties of the selected report or template, click the **Display Properties** button.

   The **Show reports for current schema only** check box is checked by default. Only reports defined for the current schema or any superschema are displayed. To display all reports defined in the database, uncheck the **Show reports for current schema only** check box.

3. Click the **Save** button. Alternatively, click the **Cancel** button to abandon your changes.

The current report is then saved. The report name change or folder change is immediate.

### To relocate your report or template

1. Double-click the current folder until the required folder is displayed.

2. Click the **Save** button. Alternatively, click the **Cancel** button to abandon your selections.

The current report or template is then saved into the selected folder. (For details about creating folders, see "Folders Menu", in Chapter 3.)
Save As Copy Command

Use the Save As Copy command from the File menu to make another copy of your report or template. The current report or template is not affected.

To make a copy of a report or template
1. Display the Copy Report dialog by performing one of the following actions.
   - Select the Save As Copy command from the File menu
   - Press Ctrl+A

   The Copy Report dialog, shown in the following image, is then displayed.

![Copy Report Dialog]

2. If you want to save your report using the same name, select another folder. Double-click a folder name at the right of a folder symbol to open that folder.

   If you want to save a copy to the current folder, enter a new name in the Report name text box or the Template name text box, as appropriate.

   If you want to save a copy to a different folder with a new name, select another folder. Double-click a folder name at the right of a folder symbol to open that folder. Enter a new name in the Report name text box or the Template name text box, as appropriate.

   If you want to copy a report or template other than the one that is currently displayed, select a different report from the Reports list and follow the instructions earlier in this step.

   For details about creating folders, see "Folders Menu", in Chapter 3.
3. To further refine the display of reports or templates, perform one of the following actions.
   - To display details relating to the last modified dates of the displayed reports or templates, click the **Display Details** button. (This is the default display.)
   - To display the reports or templates as a simple list, click the **Display as List** button.
   - To display the report or template properties of the selected report or template, click the **Display Properties** button.

   The **Show reports for current schema only** check box is checked by default. Only reports defined for the current schema or any superschema are displayed. To display all reports defined in the database, uncheck the **Show reports for current schema only** check box.

4. Click the **Copy** button. Alternatively, click the **Cancel** button to abandon your selections.

The selected report or template is then copied. The name of the original report or template remains unchanged.

### Delete Report Command

Use the **Delete Report** command from the File menu to delete a report.

#### To delete a report

1. Select the **Delete Report** command from the File menu. The Delete Report dialog, shown in the following image, is then displayed.

   ![Delete Report Dialog](image-url)

2. Select the report that you want to delete from the **Report** list box or enter the name in the **Report name** text box.

3. Filter the list of report names in the **Reports** list box in one or both of the following ways.
   - To display only those reports that contain that text in their report description, enter text in the **Text contains** text box. For example, only those reports that mention **Pay** in their description are displayed if
you enter Pay, providing a refined selection list.

- To display only those reports modified during a specified period, select a last modified period from the Last modified list box. For example, only those reports that were modified in the week prior to the current week are displayed if you select Last Week. The default value of any time means that reports modified in any period are displayed.

4. To further refine the display of reports, perform one of the following actions.

- To display details relating to the last modified dates of the displayed reports, click the Display Details button. (This is the default display.)
- To display the reports as a simple list, click the Display as List button.
- To display the report properties of the selected report, click the Display Properties button.

The Show reports for current schema only check box is checked by default. Only reports defined for the current schema or any superschema are displayed for selection. To display all reports defined in the database for selection, uncheck the Show reports for current schema only check box.

5. Click the Delete button. Alternatively, click the Cancel button to abandon your selections.

The Delete Confirmation message box is then displayed.

Click the Yes button to confirm the deletion. Alternatively, click the No button to abandon the deletion.

**Note** You can recover a report after it has been deleted while the current session of the JADE Report Writer Designer application is still running (that is, before you have exited from the application by using the Exit command from the File menu).

A temporary copy of the deleted report is made and given the name of the report with a suffix of before delete. This temporary copy is displayed in the Open Report dialog and you can restore it by opening it and then saving it.

**Delete Template Command**

Use the Delete Template command from the File menu to delete a template.
To delete a template

1. Select the **Delete Template** command from the File menu.

The Delete Template dialog, shown in the following image, is then displayed.

![Delete Template dialog](image)

2. Select the template that you want to delete from the **Templates** list box or enter the name in the **Template name** text box.

3. Filter the list of template names in the **Templates** list box in one or both of the following ways.

   - To display only those templates that contain that text in their report description, enter text in the **Text contains** text box. For example, only those templates that mention **Pay** in their description are displayed if you enter **Pay**, providing a refined selection list.
   
   - To display only those templates modified during that period, select a last modified period from the **Last modified** list box. For example, only those templates that were modified in the week prior to the current week are displayed if you select **Last Week**. The default value is **any time**, which means that reports modified in any period are displayed.

4. To further refine the display of templates, perform one of the following actions.

   - To display details relating to the last modified dates of the displayed templates, click the **Display Details** button. (This is the default display.)
   
   - To display the reports as a simple list, click the **Display as List** button.
   
   - To display the report properties of the selected template, click the **Display Properties** button.

5. Click the **Delete** button. Alternatively, click the **Cancel** button to abandon your selections.

The Delete Confirmation message box is then displayed.

Click the **Yes** button to confirm the deletion. Alternatively, click the **No** button to abandon the deletion.
Chapter 4  Designing JADE Reports

**Note**  You can recover a template after it has been deleted while the current session of the JADE Report Writer application is still running (that is, before you have exited from the application by using the **Exit** command from the File menu).

A temporary copy of the deleted template is made and given the name of the template, with a suffix of **before delete**. This temporary copy is displayed in the Open Template dialog and you can restore it by opening it and then saving it.

**Print Command**

Use the **Print** command from the File menu to print your current report.

To print the current report, perform one of the following actions

- Select the **Print** command from the File menu
- Press Ctrl+P
- Click the **Print** toolbar button

The common Print dialog is displayed unless you click the **Print** toolbar button, in which case the report is printed to your default printer.

The **All** option is selected by default. Select the **Pages** option if you want to print the pages from the start up to the page number entered in the **to** text box and a final page for report footers. The **from**: text box is ignored.

You could print a limited number of pages to test the report layout. The output will not correctly reflect any selection done by the report, because not all pages are printed.

A progress dialog is displayed while the report prints. Click the **Stop** button to stop the printing and retain the print output produced up to this point. Click the **Cancel** button to stop the printing and discard the print output.

**Note**  As a template can be printed only when attached to a report, the **Print**, **Print Preview**, **Print Setup**, and **Extract Data** commands are not enabled for templates.

For full details about printing reports, see Chapter 5, "Printing and Extracting JADE Reports".

**Refresh Preview Command**

Use the **Refresh Preview** command from the File menu to refresh the preview of the current report from the database.

To refresh a report preview from the database

- Select the **Refresh Preview** command from the File menu.

The preview is then built or rebuilt by using data from the database rather than data saved from a previous query. A preview of the current report is then displayed.

A progress dialog is displayed while the print preview is being refreshed and built. Click the **Cancel** button to abandon the print preview.

For full details about printing reports, see Chapter 5, "Printing and Extracting JADE Reports".

**Print Setup Command**

Use the **Print Setup** command from the File menu to set or modify your printer settings.
The **Print Setup** command uses common dialogs to enable you to specify advanced documentation options and printer connection options. For more details, see your *Microsoft Windows User’s Guide*.

### Extract Data Command

Use the **Extract Data** command from the File menu to extract your report to a file.

**To extract your report data**

1. Select the **Extract Data** command from the File menu.

   The Report Parameters dialog, shown in the following image, is then displayed.

   ![Report Parameters Dialog](image)

   - **Parameter Name**: exchange rate
   - **Parameter Value**: 0.45
   - **Parameter Name**: seasonal index
   - **Parameter Value**: 1
   - **Parameter Name**: performance bonus
   - **Parameter Value**: 5
   - **Parameter Name**: company
   - **Parameter Value**: Erewhon Investments Inc

   **Extract output format**:
   - HTML (HyperText Markup Language)
   - XML (Extensible Markup Language)
   - RTF (Rich Text Format)

   - **Maximum Objects to Extract**: 0 (0 for no limit)
   - **Output file name**: *.htm

   - **Use Client File System? (otherwise JadeAppServer File System)**

   - **OK**
   - **Cancel**

2. In the Enter Report Parameter Values group box, specify any parameter values used in your report. Enter or select the parameter value for the listed parameter in the **Parameter Value** column.

**Note** You can specify object parameters in the relevant combo box only when the appropriate JADE methods are reimplemented in the schema from which your JADE Report Writer application is run. If objects are not displayed for selection, consult your application developer.
Chapter 4  Designing JADE Reports

If the **User value must be entered** check box on the **Param** sheet of the Catalog of Available fields dialog is checked, you must enter a parameter value. If you do not enter a parameter value, the message "Parameter Value must be entered for <parameter name>" is then displayed.

Alternatively, check the check box under the **Ignore** column to specify that the parameter is ignored in selection. This overrides the **User value must be entered** option, and the message box is not displayed. Any selection criteria using this parameter are dropped from the query when the report data is extracted. The specified parameter is therefore treated as an all action when applied as a selection criterion.

**Note**  When reports are run from the user system, the **JadeReportWriterReport** class **getExtraParameterDetails** method returns the value of this options for a specified parameter name. This can be used to code checks that a value has been entered for parameters. For details about the **getExtraParameterDetails** method, see Chapter 1 of the JADE Encyclopaedia of Classes, Volume 1.

3. In the Extract output format group box, select an extract output format by selecting one of the option buttons. By default, the **HTML (HyperText Markup Language)** option is selected.

4. In the **Maximum Objects to Extract** text box, enter a non-zero value to limit the output to this number of query results when testing the report extract layout. The extract file will not correctly reflect any selection done by the report, because not all results are included.

5. In the **Output file name** text box, enter the name and location of the file to which you want to extract your report. The appropriate file extension is already displayed in this text box, according to the output format. If you are unsure of your file name or location, click the **Browse** button. The common File dialog is then displayed, to enable you to select the appropriate file.

6. To specify that the output file path and file name specified in the **Output file name** text box is specified from the perspective of the local (client) workstation, check the **Use Client File System** check box.

If you do not check this box, the output file path and file name is treated as specified from the perspective of the application server.

By default, the output file uses the file system of the client workstation.

**Note**  The application server executes JADE application logic in JADE thin client mode. It communicates with the JADE database on the server node and one or many presentation (thin) clients; that is, local client workstations.

7. Click the **OK** button. Alternatively, click the **Close** button to abandon your selections and close the dialog.

Your current report is then extracted to the specified file. For details about extracting to a file, see Chapter 5, "Printing and Extracting JADE Reports".

**Unload Definition Command**

Use the **Unload Definition** command from the File menu to unload report and template definitions to a flat file.

Unlike the **Extract Data** command of the File menu, the **Unload Definition** command does not extract a report file containing all of the data returned by running the report query, but it is a way of saving your report design or layouts to a separate flat file.

The **Load Definition** and **Unload Definition** commands provide a transfer and backup utility for reports created by using the JADE Report Writer Designer application.
To extract report and template definitions to a flat file

1. Select the **Unload Definition** command from the File menu.

   The Report Unload dialog, shown in the following image, is then displayed.

![Report Unload dialog](image)

2. In the **Report Unload** group box, select one of the following options to unload your report definitions to a flat file. To unload:
   - All reports for views of schemas that are the same as or superschemas of the current scheme, select the **All for current schema** option button (the default option).
   - All of your report definitions to a flat file, select the **All** option button.
   - None of your report definitions to a flat file, select the **None** option button. In this case, only the template definitions you select are unloaded to a flat file.
   - Only selected report definitions to a flat file, select the **Selective** option button. When you select this option button, the **Selective Reports** tab is enabled. Click on the **Selective Reports** tab to display the **Selective Reports** sheet, which enables you to select which report definitions are unloaded to a flat file. For details, see "Selecting Reports and Templates to Unload", in the following subsection.

3. In the **Template Unload** group box, select one of the following options to unload your report template definitions to a flat file.

   To unload:
   - All of your report template definitions to a flat file, select the **All** option button.
   - None of your report template definitions to a flat file, select the **None** option button. In this case, only the report definitions you select are unloaded to a flat file.
Only report template definitions that are attached to the reports you have selected to unload to a flat file, select the Used in unloaded reports option button.

Only selected report template definitions to a flat file, select the Selective option button. When you select this option button, the Selective Templates tab is enabled. Click on the Selective Templates tab to display the Selective Templates sheet, which enables you to select which report definitions are unloaded to a flat file. For details, see "Selecting Reports and Templates to Unload", in the following subsection.

4. In the File Name text box, enter the name and location of the file to which you want to extract your selected report and template definitions. You should define a file with the .rwr suffix. If you are unsure of your file name or location, click the Browse button. The common File dialog is then displayed, to enable you to select the appropriate file location.

5. Click the Unload button, to begin the unload process and extract your selected report and template definitions. Alternatively, click the Close button to abandon your selections and return to the JADE Report Writer Designer application window.

Selecting Reports and Templates to Unload

Use the Selective Reports sheet and the Selective Templates sheet of the Report Unload dialog to select the template and report definitions that you want to unload to a flat file. These sheets are enabled only for selective unloads; that is, when you select the Selective Templates or Selective Reports option buttons.

You can specify any of your existing report or template definitions for uploading to a flat file.
To specify templates and reports for unloading to a flat file

1. Click on the Selective Reports tab or the Selective Templates tab of the Report Unload dialog.

The Selective Reports sheet or the Selective Templates sheet of the Report Unload dialog is then displayed. An example of the Selective Reports sheet is shown in the following image.

![Report Unload Dialog](image)

The procedures for selecting reports or templates are the same.

2. All available reports or templates are shown in the list box on the left of the dialog. Reports or templates currently selected for unloading are displayed in the list box on the right of the dialog. The Show reports for current schema only check box is checked by default. Only reports defined for the current schema or any superschema are displayed for selection. To display all reports defined in the database for selection, uncheck the Show reports for current schema only check box.

3. Select the report or template definitions you want to unload, by performing one of the following actions.
   - Click on the name of a single report or template to select it.
   - To select a group of consecutive reports or templates, click the first item in the group, hold down the Shift key, and then click the last item in the group.
   - To select a group of non-consecutive reports or templates, click the first item of the group, hold down the Ctrl key, and then click each subsequent item that you want to include.

4. Click the add selected (►) button to add the selected reports or templates to the list box on the right of the dialog. Alternatively, click the add all (👀) button to add all of the available reports or templates to the list box on the right of the dialog. You can then select reports and templates to exclude from this list, by using the selection techniques described in step 3.
5. Click the remove selected (<) button to remove selected reports or templates from the list box on the right of the dialog. The removed reports or templates become available in the list of reports or templates on the left of the dialog.

Alternatively, click the remove all button (<<) to remove all reports or templates from the list box on the right of the dialog. The removed reports or templates become available in the list of reports or templates on the left of the dialog.

6. Click on the Unload options sheet tab to select options for the unload process, or select further reports or templates for unloading by clicking on the Selective Reports tab or the Selective Templates tab, respectively.

For further details, see "Unload Definition Command", in the previous subsection.

**Specifying Reports and Templates to be Deleted**

Use the Deletions sheet of the Report Unload dialog to select the template and report definitions that you want to be deleted from another Report Writer system.

When the unloaded definitions file (*.rwr) is loaded into another Report Writer system, the reports and templates that you specified are deleted if they exist. (For more details, see "Selecting Template and Report Definitions to Load", later in this chapter.) If a specified report or template does not exist in the target system, the command is ignored. In any case, whether the deletion is successful or not, an entry is made in the jadereportwriter.log file.

**To specify templates to be deleted in the target system**


The Deletions sheet is then displayed. An example of the Deletions sheet is shown in the following image.
2. Enter the name of the report or template to be deleted from the target system. (The reason a list of these names cannot be displayed is that the report or template could already have been deleted from the current report writer system.)

3. Click the add (>) button to add the named report or template to the list.

4. Click the remove (<) button to remove a name from the list.

5. Click on the Unload options sheet tab to select options for the unload process, or select further reports or templates for unloading by clicking on the Selective Reports tab or the Selective Templates tab, respectively.

For further details, see "Unload Definition Command", in the previous subsection.

Load Definition Command

Use the Load Definition command from the File menu to load report and template definitions from a flat file backup file or a transfer file. The Load Definition and Unload Definition commands provide a transfer and backup utility for reports created by using the JADE Report Writer Designer application.

To load report and report template definitions from a flat file

1. Select the Load Definition command from the File menu.

The Open Report Load File dialog, shown in the following image, is then displayed.

2. Enter the full location and name for your .rwr flat file in the File Name text box or click the Browse button to display a common dialog in which you can select your extract file location and name.

3. Click the Open button. (Alternatively, click the Close button to abandon the load process.)
If the selected file contains report definitions that are not in error, the Selective Load sheet is then displayed. Conversely, if all report definitions in the selected file are in error, the Report Errors sheet is displayed. This sheet states that all report definitions in the file are in error and none can therefore be loaded. In addition, it lists each of the report definitions in error and the error (for example, a specified view is not defined for a specified report.)

Click the Close button and perform the appropriate actions to correct the error or errors before retrying the load definition operation.

**Selecting Template and Report Definitions to Load**

If the selected definitions file specified in the File Name text box on the Open Report Load File dialog contains report definitions that are not in error, use the Selective Load sheet, shown in the following image, to select the template and report definitions that you want to load.

A value of T in the Type column indicates a template definition, R a report definition, and D a template or report marked for deletion during the load process. In addition, the cell of the Load as name column displays `<deleted template or report>` for each report marked for deletion.

For details about marking templates and reports for deletion, see "Specifying Reports and Templates to be Deleted", earlier in this chapter.

To select the template and report definitions to load

1. In the Load? column of the Selective Load sheet, uncheck the check box of each template or report that you do not want to load.
Note All definitions are selected for loading by default; that is, the check boxes in the Load? column are checked when the Selective Load sheet is first displayed.

2. Click the Load button to load your template and report definitions from the flat file.

Alternatively, click the Close button to abandon the load process or the Browse button to select another definitions file.

The selected report definition flat file is then loaded.

Any report marked for deletion and selected for loading is deleted and reported in the jadereportwriter.log file. If no report with the specified name is detected, a template with that name is deleted and reported; if neither a report nor template of that name is detected, a message is reported in the log file.

Note As deletions are performed first in the load operation, if the same report is present as both a load and a deletion, the existing report is deleted first and then loaded from the same file.

For details about loading an extracted report definition into an existing JADE user schema (for example, when you load a new user schema and there are associated JADE Report Writer report definitions that are to be loaded as part of the application release), see "Multiple Schema File Syntax", in Chapter 10 of the JADE Development Environment User’s Guide or "Loading a Schema and Forms in Batch Mode", in the JADE Schema Load Utility User’s Guide.

User Preferences Command

To set your user preferences, perform one of the following actions

- Select the User Preferences command from the File menu
- Press Ctrl+U

The User Preferences dialog is then displayed. For details about using the User Preferences dialog, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.

Exit Command

Use the Exit command of the File menu to close the JADE Report Writer Designer window and end your current JADE Report Writer Designer application session.

Edit Menu

Use the Edit menu to access basic editing functions such as Copy, Cut, and Paste for editing scripts in the Script Code sheet of the Add Script Field and Update Script Field dialogs. The Edit menu also provides access to the JADE Report Writer Designer application dialogs that enable you to edit field properties.

The Copy, Cut, and Paste commands are not enabled for fields in the report layout.

The commands provided by the Edit menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Undoes the previous action</td>
</tr>
<tr>
<td>Redo</td>
<td>Reverses the last performed Undo action</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts (logically deletes) the selected code and moves it to the clipboard</td>
</tr>
</tbody>
</table>
## Command Description

- **Copy**
  - Copies the selected code to the clipboard
- **Paste**
  - Pastes code from the clipboard
- **Select All**
  - Selects all fields, lines, and boxes in the report
- **Delete**
  - Deletes the selected fields
- **Script**
  - Displays the Update Script Field dialog for scripted fields
- **Summary**
  - Displays the Update Add Summary Field dialog for summary fields
- **Parameter**
  - Displays the Update Parameter Field dialog
- **Link Header**
  - Links detail and page header fields
- **Unlink Header**
  - Unlinks linked detail and page header fields
- **Section**
  - Displays the Section Properties dialog
- **Group**
  - Displays the Group Properties dialog
- **Field**
  - Displays the Field Properties dialog
- **Field Data Source**
  - Changes the source of the data for the selected field
- **Box**
  - Displays the Box Properties dialog
- **Line**
  - Displays the Vertical or Horizontal Line Properties dialog
- **Profile**
  - Displays the Profile Properties dialog

### Undo Command

Use the **Undo** command from the Edit menu to undo your last action.

You can repeat the **Undo** command to step back and undo previous actions. There is no numerical limit to the number of previous actions that you can undo. However, you cannot undo actions past the point at which the report was last opened.

Use the **Redo** command, described later in this section, to redo previous actions that you have undone by using the **Undo** command.

#### To undo the last action

- Select the **Undo** command from the Edit menu
- Press Alt+BKSP
- Click the **Undo** toolbar button
- Right-click in the Script Code pane and select **Undo** from the menu that is then displayed

Your previous action is then undone.

### Redo Command

Use the **Redo** command from the Edit menu to reverse the last action that was undone.

You can repeat the **Redo** command to step forward and redo actions that were previously undone.
To redo the last action undone

- Select the Redo command from the Edit menu
- Press Ctrl+Y
- Click the Redo toolbar button
- Right-click in the Script Code pane and select Undo from the menu that is then displayed

Your previously undone action is then redone.

Cut Command

Use the Cut command from the Edit menu to move selected script code to the clipboard. Selected script code is deleted and stored in the clipboard, from where you can paste it into a new position.

To cut selected field or fields, perform one of the following actions

- Select the Cut command from the Edit menu
- Press Ctrl+X
- Right-click in the Script Code pane and select Cut from the menu that is then displayed

The selected fields are then deleted from their current position and moved to the clipboard.

Copy Command

Use the Copy command from the Edit menu to copy selected script code to the clipboard. The selected code is copied to the clipboard, from where you can paste it into a new position.

To copy selected code, perform one of the following actions

- Select the Copy command from the Edit menu
- Press Ctrl+C
- Right-click in the Script Code pane and select Copy from the menu that is then displayed

The selected script code is then copied to the clipboard.

Paste Command

Use the Paste command from the Edit menu to paste the clipboard contents into your scripts.

To paste into your script, perform one of the following actions

- Select the Paste command from the Edit menu
- Press Ctrl+V
- Right-click in the Script Code pane and select Paste from the menu that is then displayed

The contents of the clipboard are then pasted into the script code at the current caret location.
Select All Command

Use the Select All command from the Edit menu to select all fields, lines, and boxes in the report. You can then select the Copy command to copy the selected items to the clipboard, for example.

To selected all fields, lines, and boxes in the report, perform one of the following actions
- Select the Select All command from the Edit menu
- Press Ctrl+A

Note: You can select all fields, lines, and boxes in a report section, by selecting the Select All command from the popup menu that is displayed when you right-click in that section or you can click and drag a rectangle so that all fields, lines, and boxes within the rectangle are selected.

Delete Command

Use the Delete command from the Edit menu to delete a field or fields from your report layout.

To delete the selected fields from your report layout, perform one of the following actions
- Select the Delete command from the Edit menu
- Press Ctrl+D
- Press Delete

A confirmation dialog is then displayed. Click the Yes button to continue to delete the current field or fields. Alternatively, click the No button to cancel the deletion.

Script Command

Use the Script command from the Edit menu to modify the script that is attached to the selected field on your report layout. The Script command is enabled only if you have selected a field that has an attached script.

To modify a script
- Select the Script command from the Edit menu

The Update Script Field dialog is then displayed. For details about using the script dialogs, see "Using the Script Sheet", earlier in this chapter.

Summary Command

Use the Summary command from the Edit menu to modify the summary details of the selected field on your report layout. The Summary command is enabled only if you have selected a summary field.

To modify summary detail
- Select the Summary command from the Edit menu

The Update Summary Field dialog is then displayed. For details about using summary fields, see "Using the Summary Sheet", earlier in this chapter.
Parameter Command

Use the Parameter command from the Edit menu to modify the parameter details of the selected field on your report layout. The Parameter command is enabled only if you have selected a parameter field.

To modify parameter details
- Select the Parameter command from the Edit menu

The Update Parameter Field dialog is then displayed. For details about using parameter fields, see "Using the Param Sheet", earlier in this chapter.

Link Header Command

Use the Link Header command from the Edit menu to link report detail fields with page header fields.

To link a selected report detail field with a selected page header field
- Select the Link Header command from the Edit menu

For details about linking and unlinking report header fields, see "Linking and Unlinking Headers", earlier in this chapter.

Unlink Header Command

Use the Unlink Header command from the Edit menu to unlink report detail fields linked to page header fields.

To unlink a selected linked field
- Select the Unlink Header command from the Edit menu

For details about linking and unlinking report header fields, see "Linking and Unlinking Headers", earlier in this chapter.

Section Command

Use the Section command from the Edit menu to modify the properties of a report section.

To modify the section properties of the report section that has focus
- Select the Section command from the Edit menu

The Section Properties dialog is then displayed for the section of your report layout that has the focus. For details about modifying section properties, see "Setting the Section Properties" under "Using Administrative Functions", earlier in this chapter.

Group Command

Use the Group command from the Edit menu to modify the properties of a report group section.

The Group command is enabled only if the focus is in a group section of your report layout.

To modify the group properties of the report group section that has focus
- Select the Group command from the Edit menu
The Group Properties dialog is then displayed for the group section of your report layout that has the focus. For details about modifying group properties, see "Creating Groups" under "Using the Detail Functions", earlier in this chapter.

Field Command

Use the **Field** command from the Edit menu to modify the properties of a field on your report layout.

**To modify the properties of the selected field, perform one of the following actions**

- Select the **Field** command from the Edit menu
- Press F4

The Field Properties dialog is then displayed for the selected field. For details about modifying field properties, see "Setting Field Properties" under "Using the Detail Functions", earlier in this chapter.

Field Data Source Command

Use the **Field Data Source** command from the Edit menu to change the source of the data for the selected field. When you select this command, the Catalog of Available Fields dialog is displayed, from which you can select a different field to apply to the selected report field.

**To change the source of the data for the selected field, perform one of the following actions**

- Select the **Field Data Source** command from the Edit menu
- Press F5

The Catalog of Available Fields dialog is then displayed. For details about inserting report fields, see "Inserting Report Fields" under "Using the Detail Functions", earlier in this chapter.

**Note** While you are selecting a different source for the field, the **Select, New, Update, Delete, and Close** buttons are not visible in the Catalog of Available Fields.

Box Command

Use the **Box** command from the Edit menu to specify the properties of the currently selected box. When you select this command, the Box Properties dialog is displayed. This command is enabled only if a box is selected in the report layout.

**To specify the properties of the currently selected box, perform one of the following actions**

- Select the **Box** command from the Edit menu
- Press F3

The Box Properties dialog is then displayed. For details about using the Box Properties dialog, see "Specifying Box Properties", earlier in this chapter. For details about inserting boxes in report layouts, see "Inserting a Box" under "Inserting Report Fields", earlier in this chapter.

Line Command

Use the **Line** command from the Edit menu to specify the properties of the currently selected line. When you select this command, the Horizontal or Vertical Line Properties dialog is displayed. This command is enabled only if a line is selected in the report layout.
To specify the properties of the currently selected line, perform one of the following actions:

- Select the Line command from the Edit menu.
- Press F3

The Horizontal or Vertical Line Properties dialog is displayed, depending on the selected line.

For details about using the Line Properties dialog, see "Specifying Line Properties", earlier in this chapter. For details about inserting lines in report layouts, see "Inserting a Line" under "Inserting Report Fields", earlier in this chapter.

**Profile Command**

Use the Profile command from the Edit menu to modify the profile properties of current report.

To modify the profile properties of the current report:

- Select the Profile command from the Edit menu.
  Alternatively, select the Properties command from the Profile menu. For details, see "Properties" under "Profile Menu", later in this section.

The Profile Properties dialog is then displayed. For details about modifying profile properties, see "Creating or Maintaining Profiles" under "Using the Detail Functions", earlier in this chapter.

**View Menu**

Use the View menu to control the look of your JADE Report Designer window. The View menu also enables you to access the Catalog of Available Fields dialog.

The commands in the View menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog</td>
<td>![Catalog Icon]</td>
<td>Displays the Catalog of Available Fields dialog</td>
</tr>
<tr>
<td>Toolbars</td>
<td></td>
<td>Enables you to select which toolbars are displayed</td>
</tr>
<tr>
<td>Show/Hide Template</td>
<td>![Hide/Show Icon]</td>
<td>Toggles the visibility of the report template</td>
</tr>
<tr>
<td>Show/Hide Grid</td>
<td>![Grid Icon]</td>
<td>Toggles the visibility of the positioning grid</td>
</tr>
<tr>
<td>Show Rulers</td>
<td>![Ruler Icon]</td>
<td>Enables you to select the rulers and the scale of the rulers</td>
</tr>
<tr>
<td>Show Watermark</td>
<td>![Frame Caption Icon]</td>
<td>Displays the frame captions inside the report frames</td>
</tr>
<tr>
<td>Snap to Grid</td>
<td></td>
<td>Aligns your report fields to the nearest grid location</td>
</tr>
</tbody>
</table>

**Catalog Command**

Use the Catalog command from the View menu to access the Catalog of Available Fields dialog.

The Catalog of Available Fields dialog enables you to select field types and graphically insert them into your report design while also providing maintenance functions for existing parameter, script, and summary fields.
You can continue working on your report layout while the Catalog of Available Fields dialog is open. This provides you with easy access for maintaining the fields on your report layout.

To display the Catalog of Available Fields dialog, perform one of the following actions

- Select the Catalog command from the View menu
- Click the Catalog toolbar button
- Press F6

The Catalog of Available Fields dialog is then displayed. For details about using this dialog, see "Using the Catalog of Available Fields Dialog", earlier in this chapter.

You can also insert and maintain fields by using commands provided by the Insert menu. For details, see "Insert Menu", later in this section.

Toolbars Command

Use the Toolbars command from the View menu to change the visibility options for the toolbars on the JADE Report Designer window.

To change the visibility options for toolbars

- Select the Toolbars command from the View menu

The Toolbars sheet of the User Preferences dialog is then displayed.

Select or deselect a toolbar to change its visibility. For details about the User Preferences dialog, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.

Show/Hide Template Command

Use the Show Template command from the View menu to toggle the display of the frames of the attached template on your report layout.

When you select the Show Template command, the menu caption changes to Hide Template. Select the Hide Template command to hide the frames of the attached template on your report layout.

To display the frames of the attached template on your report layout, perform one of the following actions

- Select the Show Template command from the View menu
- Click the Show the Template Frames toolbar button

If you have attached a template to your report, its frames are then displayed on your report layout and the menu item caption changes to Hide Template.

If you have not attached a template, nothing happens. For details about attaching a template to your report, see "Attach Template" under "Report Menu", later in this chapter.

To hide the frames of the attached template, perform one of the following actions

- Select the Hide Template command from the View menu
- Click the Hide the Template Frames toolbar button

The template frames are then hidden from the report layout and the menu item caption changes to Show Template.
Chapter 4  Designing JADE Reports

The Hide Template command is enabled only if you have template frames displayed on your report layout.

Show/Hide Grid Command

Use the Show Grid command from the View menu to toggle the display of the positioning grid.

When you select the Show Grid command, the menu caption is changed to Hide Grid. Select the Hide Grid command to hide the positioning grid.

To display the positioning grid, perform one of the following actions

- Select the Show Grid command from the View menu
- Click the Toggle Grid toolbar button

The positioning grid is then shown in the format defined in your user preferences and the menu item caption changes to Hide Grid.

For details about changing the format of the positioning grid, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.

The positioning grid helps you to align your report fields. Use the Snap to Grid command, described later in this subsection, if you want to force your fields into the grid guidelines.

To hide the positioning grid, perform one of the following actions

- Select the Hide Grid command from the View menu
- Click the Toggle Grid toolbar button

The positioning grid is then hidden from view and the menu item caption changes to Show Grid.

This Hide Grid command is enabled only if the grid is displayed.

Show Rulers Command

Use the Show Rulers command from the View menu to change the visibility of the rulers that are displayed on the Report Designer.

To change the ruler display, perform one of the following actions

- Select the Show Rulers command from the View menu.
  
  A submenu, shown in the following image, is then displayed.

  ![Rulers Menu]

  Select the Vertical command or the Horizontal command to show or hide the corresponding vertical or horizontal ruler, as required. The check mark symbol (✓) at the left of the menu caption indicates that the specified ruler is visible.

- Click the Toggle Ruler toolbar button. The display of both rulers is then turned on or off.

The rulers are displayed by default. To change the default, modify your user preferences. For details, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.
Show Watermark Command

Use the Show Watermark command from the View menu to display the frame type captions in the frames as watermarks rather than in the area to the left of each frame.

To show the frame types as watermarks, perform one of the following actions

- Select the Show Watermark command from the View menu.
- Click the Toggle Watermark toolbar button. The watermark display is turned on or off.

The report layout is then moved to the left, hiding the frame type captions, and the frame type captions are displayed as background watermarks within the report frames.

The check mark symbol (✓) at the left of the menu caption indicates that the watermark is displayed. If you select the Show Watermark command again, the JADE Report Designer window is returned to its original display with the frame type captions displayed at the left. By default, the watermark is not displayed. Modify your user preferences to change the default value. For details, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.

Snap to Grid Command

Use the Snap to Grid command from the View menu to align your report fields to the nearest grid location when placed in the report layout.

To align your fields to the grid, perform one of the following actions

- Select the Snap to Grid command from the View menu
- Press Ctrl+S

The report field boundaries are then automatically aligned with the nearest grid lines. For details about displaying the grid, see "Show/Hide Grid Command", earlier in this section. You can change the format of the grid from the default value by modifying your user preferences. For details, see "Setting User Preferences" under "Using Administrative Functions", earlier in this chapter.

When you select the Snap to Grid command, guidelines also snap to the grid. For details about guidelines, see "Using Guidelines", earlier in this chapter.

Insert Menu

Use the Insert menu to insert fields and features into your report design. The commands provided by the Insert menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Inserts a…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Literal</td>
<td>Literal field</td>
</tr>
<tr>
<td>Picture</td>
<td>Picture</td>
</tr>
<tr>
<td>Database Field</td>
<td>Database field</td>
</tr>
<tr>
<td>Special Field</td>
<td>Special field (date, time, page number, total pages, and so on)</td>
</tr>
<tr>
<td>Script</td>
<td>Script field</td>
</tr>
<tr>
<td>Summary</td>
<td>Summary field</td>
</tr>
<tr>
<td>Parameter</td>
<td>Parameter field</td>
</tr>
</tbody>
</table>
Literal Command

Use the **Literal** command from the Insert menu to insert a literal value in your JADE Report Designer application layout.

**To insert a literal value**

1. Select the **Literal** command from the Insert menu.
   
   The cursor changes to a circle with a diagonal line across it. When you move the pointer to the design layout, it changes to a standard field rectangle, indicating that you can now place your field.
   
2. Move the cursor onto the report window. Click on the layout at the position at which you want to place the literal.

A field is then displayed, to enable you to enter your literal value. You can also insert and maintain fields by using the Catalog of Available Fields dialog. For details about inserting a literal and maintaining its properties, see "Inserting a Literal", earlier in this chapter.

Picture Command

Use the **Picture** command from the Insert menu to insert a picture in your JADE Report Designer application layout.

**To insert a picture**

1. Select the **Picture** command from the Insert menu. The cursor changes to a circle with a diagonal line across it. When you move the pointer to the design layout, it changes to a standard field rectangle, indicating that you can now place your picture.

2. Move the cursor down and then click on your layout at the position at which you want your picture placed.

A dialog is then displayed, to enable you to select a picture to insert. You can also insert and maintain fields by using the Catalog of Available Fields dialog. For details about inserting a picture, see "Inserting a Picture", earlier in this chapter.

Database Field Command

Use the **Database Field** command from the Insert menu to insert a database field in your JADE Report Designer application layout. You cannot insert database fields into templates.

**To insert a database field**

- Select the **Database Field** command from the Insert menu

The Catalog of Available Fields dialog is then displayed from which you can select the database field to insert. For details about inserting a database field, see "Inserting a Database Field", earlier in this chapter.
Special Field Command

Use the **Special Field** command from the Insert menu to insert a special field; for example, a date, time, page number, page \( n \) of \( m \) field, or total pages.

To insert a special field

1. Select the **Special Field** command from the Insert menu.
   
   A submenu of special fields is then displayed.

2. Select a field from the submenu
   
   The cursor then changes to a circle with a diagonal line across it. When you move the pointer to the design layout, it changes to a standard field marker, indicating that you can now place your field.

3. Move the cursor and then click on your layout at the position at which you want your special field inserted.

The special field is then inserted. You can also insert and maintain fields by using the Catalog of Available Fields dialog. For details about inserting a special field, see "Inserting a Special Field", earlier in this chapter.

Script

Use the **Script** command from the Insert menu to insert a script field into your JADE Report Designer application layout. You cannot insert script fields into templates.

To insert a script field

- Select the **Script** command from the Insert menu.

The **Script** sheet of the Catalog of Available Fields dialog is then displayed, to enable you to select or create a script field for insertion into your report layout.

For details about using script fields, see "Using the Script Sheet" under "Using the Catalog of Available Fields Dialog", earlier in this chapter.

Summary Command

Use the **Summary** command from the Insert menu to insert a summary field into your JADE Report Designer application layout. You cannot insert summary fields into templates.

To insert a summary field

- Select the **Summary** command from the Insert menu

The **Summary** sheet of the Catalog of Available Fields dialog is then displayed, to enable you to select or create a summary field for insertion into your report layout. For details about using summary fields, see "Using the Summary Sheet" under "Using the Catalog of Available Fields Dialog", earlier in this chapter.

Parameter Command

Use the **Parameter** command from the Insert menu to insert a parameter in your JADE Report Designer application layout.

To insert a parameter

- Select the **Parameter** command from the Insert menu.
Chapter 4  Designing JADE Reports

The **Param** sheet of the Catalog of Available Fields dialog is then displayed, to enable you to select or create a parameter field for insertion into your report layout. For details about using parameter fields, see "Using the Param Sheet" under "Using the Catalog of Available Fields Dialog", earlier in this chapter.

**Line Command**

Use the **Line** command from the Insert menu to draw a line on your report.

**To draw a line on your report**

1. Select the **Line** command from the Insert menu. The cursor then changes to a line symbol for accurate placement on your layout.
2. Click at the start point of the line that you want to draw and then drag the cursor to draw the line. Cross-hatching applied to the line color indicates that it is the currently selected object.
3. Click one of the points on the image and then drag to resize or move the line.
4. Click elsewhere in the same frame (or another frame, for vertical lines), to complete the process.
5. Right-click on the line to change its properties.

For details about adding and maintaining a line field, see "Inserting a Line", earlier in this chapter.

**Box Command**

Use the **Box** command from the Insert menu to draw a box on your report.

**To draw a box on your report**

1. Select the **Box** command from the Insert menu. The cursor then changes to a box symbol for accurate placement on your layout.
2. Click at the start point of the box that you want to draw and then drag the cursor to draw the box. Cross-hatching applied to the border of the box indicates that it is the currently selected object.
3. Click one of the points on the image and drag to resize the box.
4. Click elsewhere to complete the process.
5. Right-click on any part of the border of the box to change its properties.

For details about adding and maintaining a box field, see "Inserting a Box", earlier in this chapter.

**Group Command**

Use the **Group** command from the Insert menu to insert a report group. You cannot insert a report group into a template.

**To insert a report group**

- Select the **Group** command from the Insert menu

The Group Properties dialog is then displayed. For details about using the Group Properties dialog, see "Creating Groups" under "Using the Detail Functions", earlier in this chapter.
Profile Command

Use the Profile command from the Insert menu to insert a report profile. You cannot use a report profile in a template.

⇒ To insert a report profile

- Select the Profile command from the Insert menu

Alternatively, select the New command from the Profile menu. For details, see "New Command" under "Profile Menu", later in this section. The Profile Properties dialog is then displayed. For details about using the Profile Properties dialog, see "Creating or Maintaining Profiles" under "Using Administrative Functions", earlier in this chapter.

Report Menu

Use the Report menu to access the maintenance functions for your top-level report details, such as report properties and formats. It also enables you to attach and detach templates. The Report Menu is visible when at least one report is open and is the current window in the JADE Report Writer Application window. The commands in the Report menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Displays the Report Properties dialog</td>
</tr>
<tr>
<td>Formats</td>
<td>Displays the Report Formats dialog</td>
</tr>
<tr>
<td>Root Collections</td>
<td>Displays the Report Collections View dialog</td>
</tr>
<tr>
<td>Joins</td>
<td>Displays the Report Joins dialog</td>
</tr>
<tr>
<td>Query Options</td>
<td>Displays the Report Query Options dialog</td>
</tr>
<tr>
<td>Last Run Status</td>
<td>Displays the Last Run Status dialog</td>
</tr>
<tr>
<td>Evaluation Phases</td>
<td>Displays the order in which scripts and summaries are evaluated when a report is run</td>
</tr>
<tr>
<td>Attach Template</td>
<td>Displays the Attach Template dialog</td>
</tr>
<tr>
<td>Detach Template</td>
<td>Enables you to detach a template</td>
</tr>
</tbody>
</table>

Properties Command

⇒ To maintain the properties for your report

- Select the Properties command from the Report menu

The Report Properties dialog is displayed. For details about maintaining report properties, see "Setting Report Properties", earlier in this chapter.

Formats Command

Use the Formats command from the Report menu to maintain the formats for your report.

⇒ To maintain the formats for your report

- Select the Formats command from the Report menu
The Report Formats dialog is displayed. For details about maintaining report formats, see "Setting Report Formats", earlier in this chapter.

**Root Collections Command**

Use the Root Collections command from the Report menu to select additional root collections and joins from which you can select database fields for your report.

The available root collections and joins are those that were defined for the reporting view your report is based on by selecting valid root collection paths or specifying joins. In the example in the following image, the Clients root collection was selected when the report was created and is therefore indicated as being in use.

Note that Clients is an alias defined in the reporting view for the allClients root collection. (For details, see "Starting a Report from Scratch", earlier in this chapter.)

The Root Collections command enables you to select other root collections and joins on which to report (in the case in this example, allSaleItems is available in the reporting view).

---

**Note** If you add additional root collections, the Report Joins dialog is also displayed on closing this dialog, to enable you to specify any additional join or joins between your report collections. If additional joins are not required, uncheck the Join Keys Required? check box on the Report Joins dialog for each potential join before closing the dialog. A warning dialog is displayed if you attempt to close the Report Joins dialog without specifying a join key or unchecking the Join Keys Required? check box.

For details about the Report Joins dialog, see "Joins Command", in the following section.

---

**To select a collection**

1. Select the Root Collections command from the Report menu

   The Report Collections and View Joins dialog, shown in the following image, is then displayed.

   ![Report Collections and View Joins dialog]

2. In the Available list box, select a root collection or join.

3. Click the Add button to complete the selection.
The selected collection is then moved to the **Selected** list box. Collections or joins that are in use in the current report are displayed in red text.

4. If you want to exclude a collection or join, select it in the **Selected** list box and then click the **Remove** button.

The selected collection or join is then removed from the **Selected** list box.

The collections or joins that are listed in the **Selected** list box are then available for your report. The available fields on the **System** sheet of the Catalog of Available Fields dialog includes fields from all of the selected collections and joins. For details, see "Using the **System** Sheet" under "Using the Catalog of Available Fields Dialog", earlier in this chapter.

### Joins Command

Use the **Joins** command from the Report menu to select the joined collections from which you want to select database fields to insert into your report. The available joins are those that are defined in the reporting view that you selected when starting your report design. The **Joins** command enables you to select or specify other joins to report on in addition to any that you selected when you created the report. (For details, see **"Starting a Report from Scratch"**, earlier in this chapter.) You can also change your join criteria by using the **Joins** command.

To select a join

1. Select the **Joins** command from the Report menu.

   The Report Joins dialog, shown in the following image, is then displayed.
2. In the Report Joins list box, select a join on which to report.

3. If joins are not required for additional report root collections, uncheck the Join Keys Required? check box.

4. Select fields to join and then set your join relationships. For details, see "Selecting the Fields to Join" under "Creating Root Collection Joins", in Chapter 3.

5. Click the Close button when you have completed your join selections and changes.

The join information is then updated.

**Query Options Command**

Use the Query Options command from the Report menu to set the concurrency strategy and current resource limit option values that are applied to the report in the query phase of the report run.

You can specify strategies to isolate the report results during report output from the effects of concurrently updating transactions. Isolating report results during output ensures that the data obtained is consistent and not affected by transactions or updates in the database that occur during the report query process. The default concurrency strategy is a repeatable read optimistic, which resynchronizes every object accessed, locks objects needed later, and checks the edition.

When the report uses database fields from collections within the report root collections or view joins, the Query Options command from the reports menu can also be used to set the inclusion option for reporting on these collections.

The following subsections describe the sheets of the Report Query Options dialog.

- **Using the Options Sheet**
- **Using the Types Sheet**

**Using the Options Sheet**

To set concurrency strategy and resource limit options for a report

1. Select the Query Options command, select the concurrency strategy option from the Report menu. The Report Query Options dialog, shown in the following image, is then displayed.
The Options sheet is selected by default. The Types tab is enabled only when the report uses database fields from collections within the report root collections or view joins.

2. From the Concurrency Strategy list box, select the concurrency strategy option that is used to isolate objects from the effects of other transactions during the query process.

The initial value is set from the view on which the current report is based. For details about setting a default concurrency strategy for views, see "Creating a New Reporting View", in Chapter 3.

The following table lists the concurrency strategies available from the Concurrency Strategy list box. The locks are held during the query evaluation phase.

If automatic cache coherency is set in the report node, the object resynchronization is not done, as the objects in the persistent cache are kept up to date.

<table>
<thead>
<tr>
<th>Concurrency Strategy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Does no explicit resynchronization or locking</td>
</tr>
<tr>
<td>Read Committed</td>
<td>Resynchronizes every object accessed, share locks collections</td>
</tr>
<tr>
<td>Repeatable Read Optimistic</td>
<td>Resynchronizes every object accessed, share locks collections and objects included in the report output</td>
</tr>
<tr>
<td>Repeatable Read Pessimistic</td>
<td>Share locks all objects accessed during report output</td>
</tr>
</tbody>
</table>

3. From the Resource Limit list box, select a resource limit option for which a matching limit value is to be set, if required. The default value of None indicates that no limits are applied.
If you select a resource limit other than None, a corresponding Limit Value control is displayed, enabling you to set a value for that limit. You must enter this limit as an integer value (that is, a positive whole number), except for the time limit, which is a value in hours and minutes. For example, if you select the Objects Read option, the Limit Value text box enables you to enter a value for the maximum number of objects to be read from the database when the report is run.

The Resource Limit options and corresponding Limit Value values are listed in the following table.

<table>
<thead>
<tr>
<th>Resource Limit Option</th>
<th>Limit Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Not applicable (that is, ignored), which is the default value</td>
</tr>
<tr>
<td>Objects Read</td>
<td>Maximum number of objects to read</td>
</tr>
<tr>
<td>Query Operations</td>
<td>Maximum number of query operations</td>
</tr>
<tr>
<td>Query Result Objects</td>
<td>Maximum number of result objects to add</td>
</tr>
<tr>
<td>Run Time</td>
<td>Maximum time in hours and minutes that the report query runs</td>
</tr>
</tbody>
</table>

4. Click the OK button. Alternatively, click the Type tab to set reporting options for collections within the report root collections of view joins or click the Cancel button to abandon your selections and close the dialog.

**Using the Types Sheet**

Use the Types sheet of the Report Query Options dialog to set reporting options for reports using database fields from collections within the report root collections or view joins. The Types sheet of the Report Query Options dialog, accessed by clicking on the Types tab, is enabled only if the report uses database fields from collections within the report root collections or view joins. For example, a report may be based on a root collection of Client objects, with an alias Clients. Each Client object in turn references a collection of retail sale items, allRetailSales. Including database fields from the allRetailSales collection enables the Types tab on the Report Query Options dialog. The JADE Report Designer application automatically analyzes a report when a preview is displayed and when the report is saved, and creates an entry in the Types sheet for each such collection it finds at this time.

For each type that has such a collection, a corresponding Inclusive option check box is displayed. This check box is not checked by default. When this option is set, data from the class (type) is reported whether there is matching data in the associated collection or not. An example of the default, when the Inclusive option is not set, might be a list of customers from whom payment has been received this month, along with payment details. The report shows some additional customer information (customer number and name). Since the report focuses on payments, customers who have not yet paid for the month are not required for reporting.

An example of the inclusive option being set is a list of customer details along with an optional alternative address and contact details held in an associated collection. The customer details are required for reporting, regardless of the existence of alternative contact details.

To specify the inclusion option for collections

1. Select the Query Options command from the Report menu. Click the Types tab. The Types sheet of the Report Query Options dialog, shown in the following image, is then displayed.
The Types sheet lists the classes (the corresponding reporting view type alias is shown) that are associated with collections from within the report root collections or view joins.

2. For each type displayed, select the Inclusive option by clicking the check box, as required.
   
   The default value is not set, indicating that data from the type is not reported when data in associated collections is not present.

3. Click the OK button. Alternatively, click the Options tab to set the concurrency strategy and current resource limit option values or click the Cancel button to abandon your selections and close the dialog.

**Last Run Status Command**

Use the Last Run Status command from the Report menu to display a summary of the status of the last report that was run.

☑ To display details of the last report run

1. Select that Last Run Status command from the Report menu. The Last Run Status dialog, shown in the following image, is then displayed.
Details, including query statistics, of the last report run are displayed in the dialog.

2. When you have reviewed the details, click the Close button to close the dialog.

The Last Run Status dialog displays a summary of the last report that was run, as a design preview, printed report, or report extract. Details that are displayed include:

- Report date and time
- Profile used
- Parameter values
- Elapsed time
- Number of pages or records output
- Query statistics (for all reports except saved query previews); for example, number of objects read, number of objects returned, and so on

If there are errors in the query run (for example, scripts that do not compile and exceptions), these are also displayed in the dialog.

**Evaluation Phases Command**

Use the Evaluation Phases command from the Report menu to view the order in which scripts and summaries are evaluated when the report is run.

To view evaluation phases for a report

- Select the Evaluation Phases command from the Report menu.
The Report Script and Summary Evaluation dialog, shown in the following image is then displayed.

![Report Script and Summary Evaluation Dialog]

Summaries and scripts are evaluated at the following stages when the report is run:

- Reading phase scripts and summaries, in order:
  - Summary: Group_Items'
- Printing phase scripts and summaries, in order:
  - Summary: PageCost'

Evaluation details are displayed in the dialog.

**Attach Template Command**

Use the **Attach Template** command from the Report menu to attach an existing template to your current report design.
To attach a template

1. Select the **Attach Template** command from the Report menu.

   The Attach Template dialog, shown in the following image, is then displayed.

   ![Attach Template dialog](image)

   - **Name** column:
     - Landscape Template 1: 23 January 2004, 13:25:00
     - New Template 1: 20 February 2004, 09:24:00
     - Format Template 1: 20 February 2004, 09:22:43

   - **Template name** text box:
   - **Text contains** text box:
   - **Last modified** text box (default: any time)

2. Select the template that you want to attach from the **Templates** list box or enter the name in the **Template name** text box.

3. Filter the list of report names in the **Name** list box in one or both of the following ways.
   - To display only those templates that contain that text in their description, enter text in the **Text contains** text box. For example, if you enter **Pay**, only those templates that mention **Pay** in their description are displayed, providing a refined selection list.
   - To display only those templates modified during a specific period, select a last-modified period from the **Last modified** text box. For example, if you select **Last Week**, only those templates modified in the week prior to the current week are displayed. The default value of **any time** means that templates modified in any period are displayed.

4. To further refine the display of templates, perform one of the following actions.
   - To display details relating to the last modified dates of the displayed templates, click the **Display Details** button. (This is the default display.)
   - To display templates as a simple list, click the **Display as List** button.
   - To display the template properties relating to the displayed templates, click the **Display Properties** button.

5. Click the **Attach** button. The selected template is then attached to your report design layout. Alternatively, click the **Cancel** button to abandon your selections.
The frames of the attached template are visible only if you have the Show Template command selected. For details, see "Show/Hide Template Command" under "View Menu", earlier in this chapter.

**Detach Template Command**

Use the Detach Template command from the Report menu to detach a template from your current report design.

1. Select the Detach Template command from the Report menu.
   
   A submenu listing attached templates is then displayed.
   
2. Select the template that you want to detach.
   
   The selected template is then detached from the current report.

**Note** This command is enabled only if one or more templates are attached to the report.

**Template Menu**

Use the Template menu to access the properties and check the usage for your report templates. The Template menu is visible when at least one template open and is the current window in the JADE Report Writer Designer application window.

The commands in the Template menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Displays the Template Properties dialog</td>
</tr>
<tr>
<td>Usage</td>
<td>Displays the usage of the current template</td>
</tr>
</tbody>
</table>

**Properties Command**

Use the Properties command from the Template menu to maintain properties for your report templates.

Set template properties, such as font, alignments, page size, and so on, to reflect the properties of the reports to which your templates will be attached.

**Note** Default properties set for your report override the default settings of the attached template. This may lead to inconsistencies between the appearance of the report (with the attached template) and the template.

**To maintain template Properties**

- Select the Properties command from the Template menu.

  The Report Properties dialog is then displayed. For a template, only the Details, Font, Page and Parameters sheets of this dialog are enabled, with a limited set of options.

  For details about maintaining report properties, see "Setting Report Properties", earlier in this chapter.

**Usage Command**

Use the Usage command from the Template menu to display the usage of the current template.
To display template usage

- Select the Usage command from the Template menu.

The Where Used dialog, shown in the following image, is then displayed.

Reports to which the current template is attached are displayed in the dialog.

Profile Menu

Use the Profile menu to access the dialogs for creating and maintaining your report profiles. The commands in the Profile menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Displays the…</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Profile Properties dialog</td>
</tr>
<tr>
<td>Delete Properties</td>
<td>Profile Properties dialog, with the current profile selected</td>
</tr>
<tr>
<td>Group Properties</td>
<td>Profile Sheet of the Profile Properties dialog</td>
</tr>
<tr>
<td>Sort Order</td>
<td>Group Sheet of the Profile Properties dialog</td>
</tr>
<tr>
<td>Selection Criteria</td>
<td>Selection Criteria Sheet of the Profile Properties dialog</td>
</tr>
</tbody>
</table>

New Command

Use the New command from the Profile menu to create a new profile for your report.
To create a new profile

- Select the New command from the Profile menu.

The Profile Properties dialog is then displayed. All of the settings are blank, to enable you to begin building a new profile.

For details about creating profiles, see "Creating or Maintaining Profiles", earlier in this chapter.

Delete Command

Use the Delete command from the Profile menu to delete a report profile.

To delete a report profile

1. Select the Delete command from the Profile menu.
   The Profile Properties dialog is then displayed. The current profile is selected.
2. In the All Profiles list box, select the profile that you want to delete.
3. Click the Delete button.
   A confirmation dialog is then displayed.
4. Click the Yes button. The selected profile is then deleted.
   Alternatively, click the No button to cancel the deletion.

For details about using profiles, see "Creating or Maintaining Profiles", earlier in this chapter.

Note: You cannot delete a profile if it is the only active profile (that is, there must always be one active profile). If you delete the default profile (specified by the Set as default check box), the first profile in the All Profiles list box is used as the default instead.

Properties Command

Use the Properties command from the Profile menu to display the Profile sheet of the Profile Properties dialog.

To display the Profile Sheet of the Profile Properties dialog

- Select the Properties command from the Profile menu.

The Profile sheet of the Profile Properties dialog is then displayed. For details about modifying profiles, see "Creating or Maintaining Profiles", earlier in this chapter.

Group Properties Command

Use the Group Properties command from the Profile menu to display the Group sheet of the Profile Properties dialog.

To display the Group sheet of the Profile Properties dialog

- Select the Group Properties command from the Profile menu.

The Group sheet of the Profile Properties dialog is then displayed.

For details about creating and modifying groups, see "Creating Groups", earlier in this chapter. For details about modifying profiles, see "Creating or Maintaining Profiles", earlier in this chapter.
Sort Order Command

Use the Sort Order command from the Profile menu to display the Sort Order sheet of the Profile Properties dialog.

To display the Sort Order sheet of the Profile Properties dialog
- Select the Sort Order command from the Profile menu

The Sort Order sheet of the Profile Properties dialog is then displayed.

For details about modifying profiles, see "Creating or Maintaining Profiles", earlier in this chapter.

Selection Criteria Command

Use the Selection Criteria command from the Profile menu to display the Selection Criteria sheet of the Profile Properties dialog.

To display the Selection Criteria sheet of the Properties dialog
- Select the Selection Criteria command from the Profile menu

The Selection Criteria sheet of the Profile Properties dialog is then displayed.

For details about modifying profiles, see "Creating or Maintaining Profiles", earlier in this chapter.

Layout Menu

The Layout menu provides commands that enable you to control the alignment, spacing, and size of selected items on your report design.

The commands in the Layout menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alignment</td>
<td>Displays the subcommands for aligning report items</td>
</tr>
<tr>
<td>Spacing</td>
<td>Displays the subcommands for spacing report items</td>
</tr>
<tr>
<td>Size</td>
<td>Displays the subcommands for sizing report items</td>
</tr>
</tbody>
</table>

Alignment Command

Use the Alignment command from the Layout menu to access the tools that enable you to neatly and logically align your fields with other fields in the report design layout.

To access the alignment tools
- Select the Alignment command from the Layout menu
- Select a layout tool from the toolbar

When you select the Alignment command, a submenu of the available alignment tools is then displayed. The alignment tools are listed in the following table.
<table>
<thead>
<tr>
<th>Layout tool</th>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>![Left Icon]</td>
<td>Aligns to the left edge of the selected master field</td>
</tr>
<tr>
<td>Right</td>
<td>![Right Icon]</td>
<td>Aligns to the right edge of the selected master field</td>
</tr>
<tr>
<td>Top</td>
<td>![Top Icon]</td>
<td>Aligns to the top edge of the selected master field</td>
</tr>
<tr>
<td>Bottom</td>
<td>![Bottom Icon]</td>
<td>Aligns to the bottom edge of the selected master field</td>
</tr>
<tr>
<td>Center Horizontally</td>
<td>![Center Horizontally Icon]</td>
<td>Centers the selected fields horizontally</td>
</tr>
<tr>
<td>Center Vertically</td>
<td>![Center Vertically Icon]</td>
<td>Centers the selected fields vertically</td>
</tr>
</tbody>
</table>

For details about using the alignment tools and the other layout tools, see "Using the Layout Commands" under "Using the Detail Functions", earlier in this chapter.

### Spacing Command

Use the Spacing command from the Layout menu to access the tools that enable you to neatly and logically space your fields across or down the report design layout.

**To access the spacing tools**

- Select the Spacing command from the Layout menu
- Select a spacing tool from the toolbar

When you select the Spacing command, a submenu of the available spacing tools is then displayed. The spacing tools are listed in the following table.

<table>
<thead>
<tr>
<th>Spacing tool</th>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space Evenly Down</td>
<td>![Space Evenly Down Icon]</td>
<td>Spaces fields evenly down the page</td>
</tr>
<tr>
<td>Space Evenly Across</td>
<td>![Space Evenly Across Icon]</td>
<td>Spaces fields evenly across the page</td>
</tr>
<tr>
<td>Spread Down Container</td>
<td>![Spread Down Container Icon]</td>
<td>Spreads fields down the page</td>
</tr>
<tr>
<td>Spread Across Container</td>
<td>![Spread Across Container Icon]</td>
<td>Spreads field across the page</td>
</tr>
<tr>
<td>Vertically Adjacent</td>
<td>![Vertically Adjacent Icon]</td>
<td>Attaches fields vertically</td>
</tr>
<tr>
<td>Horizontally Adjacent</td>
<td>![Horizontally Adjacent Icon]</td>
<td>Attaches fields horizontally</td>
</tr>
</tbody>
</table>

For details about using the spacing tools and the other layout tools, see "Using the Layout Commands" under "Using the Detail Functions", earlier in this chapter.
Size Command

Use the Size command from the Layout menu to access the tools that enable you to standardize the size of your report fields.

To access the sizing tools

- Select the Size command from the Layout menu
- Select a sizing tool from the toolbar

When you select the Sizing command, a submenu of the available sizing tools is displayed. The sizing tools are listed in the following table.

<table>
<thead>
<tr>
<th>Sizing tool</th>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same Width</td>
<td>![icon]</td>
<td>Makes selected fields the same width</td>
</tr>
<tr>
<td>Same Height</td>
<td>![icon]</td>
<td>Makes selected fields the same height</td>
</tr>
<tr>
<td>Same Height and Width</td>
<td>![icon]</td>
<td>Makes selected fields the same height and width</td>
</tr>
</tbody>
</table>

For details about using the sizing tools and the other layout tools, see "Using the Layout Commands" under "Using the Detail Functions", earlier in this chapter.

Window Menu

The Window menu provides standard facilities that enable you to select tiling or cascading of windows. It also displays a list of the currently open windows.

The commands in the Window menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Arranges open windows in an overlapping pattern</td>
</tr>
<tr>
<td>Tile Horizontal</td>
<td>Resizes and arranges windows horizontally without overlap</td>
</tr>
<tr>
<td>Tile Vertical</td>
<td>Resizes and arranges windows vertically without overlap</td>
</tr>
</tbody>
</table>

For details, see "Using the Window Menu", in Chapter 2.

Help Menu

Use the commands in the Help menu to access the online JADE Report Writer User's Guide for help and to display current version information for the JADE Report Writer Designer application. (See also "Using the Help Menu", in Chapter 2.)

The commands in the Help menu are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Displays details about the current version of the JADE Report Writer application</td>
</tr>
</tbody>
</table>
Chapter 5  Printing and Extracting JADE Reports

This chapter covers the following topics.

- Overview
- Previewing Print Output
  - Searching Your Report Preview
- Printing Your Report
  - Using the Print Setup Command
- Extracting Your Report Data
  - Extracting to an HTML File
  - Extracting to a Delimiter-Separated Data File
  - Extracting to a Text File
  - Extracting to an RTF File
  - Extracting to an XML File

Overview

The ways in which you can output your report when you have configured and designed it are listed in the following table and are described later in this chapter.

<table>
<thead>
<tr>
<th>Output</th>
<th>Enables you to...</th>
<th>For details, see...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Preview</td>
<td>Preview your report on screen</td>
<td>Previewing Print Output</td>
</tr>
<tr>
<td>Printed report</td>
<td>Print the report on the selected printer</td>
<td>Printing Your Report</td>
</tr>
<tr>
<td>Extract files</td>
<td>Create output in various other file formats</td>
<td>Extracting Your Report Data</td>
</tr>
</tbody>
</table>

Previewing Print Output

The print preview facility of the JADE Report Writer Designer application enables you to review your report on your screen before you commit it to print.

When previewing print output, you can browse the report page by page and select a view of the page layout in addition to the actual size view.

You can also search to find text in your report preview, in order to check on details of the report output before reporting. For details, see "Searching Your Report Preview", in the following subsection.

The query result set is saved and reused for reporting in preview. This is done to make the preview more efficient, since complex queries can take many minutes to run and previews are often required to check formatting and layout changes only.

Query results are saved for each report profile rather than each report.
The result set is automatically reused unless new database items are required, under the following conditions.

- A new database item is used in the report design
- The profile selection, group, or sort criteria are changed
- The value of a parameter used in a profile selection is changed
- The report query concurrency strategy, resource, or preview limit options are changed
- You select the Refresh Preview command

The following changes do not require a new query from the database.

- Adding, changing, or deleting a parameter (other than changing the value, as above), script, or summary
- Removing a database item from the report design

**To preview a report, perform one of the following actions**

- Select the Refresh Preview command from the File menu.
- Select the Preview tab on your Report Designer window.

A preview of the current report is then displayed, as shown in the following image.

A progress dialog is displayed while the print preview is being built. Click the Cancel button to cancel the print preview. The JADE Report Writer Designer application abandons the print preview if it is in the database reading phase or displays the pages that have been built so far if it is in the printing phase.
The report status is displayed on the toolbar above the preview pane. The first status line displays Saved Query, to indicate that the preview is based on a saved query, or Preview from Database, to indicate that the preview is based on data read from the database. The second status line indicates if any preview limits have been reached or if the preview has been cancelled.

To navigate around your print preview display, perform one of the following actions:
- To view the previous page before the current page, click the Previous Page button.
- To view the next page after the current page, click the Next Page button.
- To view the first page of the report, click the First Page button.
- To view the last page of the report, click the Last Page button.

You can change the size of your report preview display to gain an overview of the layout.

To alter the size of the display page, perform one of the following actions:
- To obtain a view of the whole page, click the Reduce button.
  The button is then displayed with the Expand caption. Click the Expand button to return to the readable display of your print preview.
- With the focus in the print preview window, your cursor becomes a magnifying glass with either a minus sign or a plus sign inside it.
  When the pointer contains the:
  - Minus sign, click in the print preview window to reduce the size of the page view.
  - Plus sign, click in the print preview window to restore the size of the page view.

Note The reduced view enables you to examine your page layout and is not intended to be fully legible. Smaller-sized text appears distorted.

Searching Your Report Preview

Use the Find and Find Next buttons on the report preview pane to search your report for text that you specify. This enables you to check specific details of your report in the preview phase.
To search your report preview

1. Click the Find button.

The Find Text dialog, shown in the following image, is then displayed.

2. Enter the search text you want to find in your report in the Find Text text box.

3. Check the Case sensitive check box to make your search case-sensitive; that is, the capitalization of your search text must find an exact match.

4. Check the Whole words only check box to match your search text against whole words only; that is, only matches with whole words (and not parts of words) are returned.

5. Enter the page on which searching starts in the Starting page number text box. The search proceeds sequentially to the end of your report, beginning on the starting page.

6. Click the Find button to find the first match with your specified search text, beginning on the starting page. The Find Text dialog is closed and matching text is then highlighted in red in your print preview. A message box is displayed if your search text is not found.

   Alternatively, click the Cancel button to abandon your search specifications and close the Find Text dialog.

7. Click the Find Next button to find the next match for your search text.

The next match is then highlighted in red in your print preview. A message box is displayed if no further matches are found.

Printing Your Report

When you have completed your report design and checked it by performing a print preview, you can then print directly from the Report Writer Designer window.

To print the current report, perform one of the following actions

- Select the Print command from the File menu
- Press Ctrl+P
- Click the Print toolbar button

Selecting the Print command from the File menu (or by pressing Ctrl+P) opens the Print Setup dialog, to enable you to check your printer setting before you begin printing. Click the OK button after you have verified the printer settings to begin printing.

Clicking the Print toolbar button immediately begins printing.
The current report is then printed to the current (default) printer.

A progress dialog is displayed while printing. Click the Stop button to stop the printing and retain the printed output produced up to this point. Click the Cancel button to stop the printing and discard the printed output that is produced.

For details about directing print output to an alternative printer or paper size, see "Using the Print Setup Command", later in this chapter. For details about using the print preview facility, see "Previewing Print Output", earlier in this chapter.

Using the Print Setup Command

By default, printing is performed on the default printer using the default paper size and orientation that is set up for your system.

Use the print set-up to change your printer settings.

**Note** The JADE Report Writer Designer application report design layout is displayed sized to the paper type specified for the report. This is the total size of the paper and does not take into account margins that are applied by the printer (which can change from printer to printer and print driver to print driver, since most printers cannot print to the edge of the paper).

The JADE Report Writer Designer application enables you to set up page orientation, size, and margins. These user-defined margins are then added the margins that the printer applies, resulting in the final print output.

To change your printer settings

1. Select the Print Setup command from the File menu.
   
   The common Print Setup dialog is then displayed.

2. Make the selections that you require for advanced documentation and printer connection.

3. Click the OK button. Alternatively, click the Cancel button to abandon your selections.

The Print Setup command uses common dialogs that enable you to specify advanced documentation options and printer connection options. For details, see your Microsoft Windows User’s Guide.

**Note** The print set-up dialogs and the options that these dialogs provide are printer-dependent and cannot be controlled from within JADE.

Extracting Your Report Data

Use the Extract Data command from the File menu to extract your report in other formats.

You can set options associated with each output type by using the Report Properties dialog. For details, see "Using the Output Sheet" under "Setting Report Properties", in Chapter 4.

In addition, you can extract all view, folder, user, system option, report definitions, and template definitions to a single flat file. For details, see "Unloading All Report Writer Data to a Single File", in Chapter 3.
The available output formats are listed in the following table.

<table>
<thead>
<tr>
<th>Output Format</th>
<th>Provides…</th>
<th>For details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML (HyperText Markup Language)</td>
<td>Standard HTML format for displaying the</td>
<td>Extracting to an HTML File report on theWorld Wide Web</td>
</tr>
<tr>
<td>File (Delimiter Separated Data)</td>
<td>Contiguous file with field delimiters</td>
<td>Extracting to a Delimiter-Separated DataFile</td>
</tr>
<tr>
<td>Text (ASCII, optionally paginated)</td>
<td>Standard ASCII text file</td>
<td>Extracting to a Text File</td>
</tr>
<tr>
<td>RTF (Rich Text Format)</td>
<td>Standard RTF format</td>
<td>Extracting to an RTF File</td>
</tr>
<tr>
<td>XML (Extensible Markup Language)</td>
<td>Standard XML format</td>
<td>Extracting to an XML File</td>
</tr>
</tbody>
</table>

To extract your report data

1. Select the Extract Data command from the File menu.

The Report Parameters dialog, shown in the following image, is then displayed.

[Image of Report Parameters dialog]

- **Parameter Name**
  - exchange rate
  - seasonal index
  - performance bonus
  - company

- **Parameter Value**
  - 0.415
  - 1.00
  - 5
  - Erewhon Investments Inc

- **Extract output format**
  - File (Delimiter Separated Data)
  - Text (optionally paginated)
  - RTF (Rich Text Format)
  - HTML (HyperText Markup Language)
  - XML (Extensible Markup Language)

- **Output file name**
  - .htm

- **Use Client File System? (otherwise Jade AppServer File System)**

[Bottom of dialog]

[Options: OK, Cancel]
2. In the Enter Report Parameter Values group box, specify any parameter values used in your report. Enter or select the parameter value for the listed parameter in the **Parameter Value** column.

**Note** You can specify object parameters in the relevant combo box only when the appropriate JADE methods are reimplemented in the schema from which your JADE Report Writer application is run. If objects are not listed for selection, consult your application developer.

In the **Ignore** column, check the check box for the appropriate parameter to specify that the parameter is ignored in selection. This overrides the **User value must be entered** option on the **Param** sheet of the Catalog of Available fields dialog, and the Parameter Value must be entered for `<parameter name>` message box is not displayed when a parameter value is not entered.

Any selection criteria using this parameter are dropped from the query when the report data is extracted. The specified parameter is therefore treated as an **all** action when applied as a selection criterion.

3. In the **Extract output format** group box, select an extract output format by clicking the appropriate option button.

4. In the **Output file Name** text box, enter the name and location of the file to which you want to extract.

If you are unsure of your file name or location, click the **Browse** button. The common File dialog is then displayed, to enable you to select the appropriate file.

5. To specify that the output file path and file name specified in the **Output file name** text box is specified from the perspective of the local (client) workstation, check the **Use Client File System** check box. If you do not check this box, the output file path and file name is treated as specified from the perspective of the application server. By default, the output file uses the file system of the client workstation.

**Note** The application server executes JADE application logic in JADE thin client mode. It communicates with the JADE database on the server node and one or many presentation (thin) clients; that is, local client workstations.

6. Click the **OK** button. Alternatively, click the **Cancel** button to abandon your selections and close the dialog.

Your current report is then extracted to the specified file.

The JADE Report Writer extract formats are described in the following subsections.

- **Extracting to an HTML File**
- **Extracting to a Delimiter-Separated Data File**
- **Extracting to a Text File**
- **Extracting to an RTF File**
- **Extracting to an XML File**

### Extracting to an HTML File

You can extract reports in the HyperText Markup Language (HTML) format.

HTML is the standard markup language for creating Web pages. When you select this extract format, HTML tags are applied to your data and a file is created with the **.htm** extension, enabling you to display it directly on the World Wide Web.
Before you create your HTML output, set options applicable to your HTML output from the Output sheet of the Report Properties dialog, if applicable. The HTML Options group box of the Output sheet is shown in the following image.

By default, HTML options are not selected. For details about setting the HTML options, see "Using the Output Sheet" under "Setting Report Properties", in Chapter 4.

**Extracting to a Delimiter-Separated Data File**

You can extract reports to a delimiter-separated data file in which the data items are separated by a separator character.

You can select the separator character when you set your report options, by using the Output sheet of the Report Properties dialog.

The Delimiter Separated File Options group box of the Output sheet is shown in the following image, in which the default values are displayed.

You can also specify extraction options for the file. You can include report header and footer data and group header and footer data in the output file. You can combine groups and details and specify that numbers and dates be extracted in their printed form. The Extract group box of the Output sheet is shown in the above image, in which the default values are displayed.

For details about setting the delimiter-separated file options, see "Using the Output Sheet" under "Setting Report Properties", in Chapter 4.
Extracting to a Text File

Select the text file extract format if you want your report extracted in simple text form. You can specify the number of lines on each page and the record length by using the Output sheet of the Report Properties dialog.

The following image shows the Text File Options group box of the Output sheet, in which the default values are displayed.

For details about setting the Text File options, see "Using the Output Sheet" under "Setting Report Properties", in Chapter 4.

Extracting to an RTF File

You can extract reports to a rich-text format (RTF) standard file, which encodes formatted text and graphics for easy transfer between:
- Microsoft Disk Operating System (MS-DOS)
- Windows
- OS/2
- Apple Macintosh (MacOS) applications

The RTF format provides a file that has a universal format. There are no options associated with this format.

Extracting to an XML File

You can extract reports to the Extensible Markup Language (XML) format, which is the universal format for structured documents and data on the World Wide Web. When you select this extract format, tags that you specify in your report properties are applied to your data and a file is created with the .xml extension. The XML Options group box of the Output sheet of the Report Properties dialog is shown in the following image.

For details about setting the XML options, see "Using the Output Sheet" under "Setting Report Properties", in Chapter 4.
Chapter 6  Run Time Considerations

This chapter covers the following topics.

- Application Types of Your JADE Reports
- Setting Security for Your JADE Reports
- Dynamically Configuring JADE Reports at Run Time
- Handling Exceptions in JADE Reports
- Font Used by Report Writer Applications

Application Types for Your JADE Reports

Applications that run reports that output to a printer can have an applicationType value of ApplicationType_GUI or ApplicationType_GUI_No_Forms.

Applications that run reports that extract data (as opposed to printing the data) to a file in a format listed in the following table can have an applicationType value of ApplicationType_GUI, ApplicationType_GUI_No_Forms, or ApplicationType_Non_GUI.

<table>
<thead>
<tr>
<th>Output Format</th>
<th>Provides…</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML (HyperText Markup Language)</td>
<td>Standard HTML format for displaying the report on the World Wide Web</td>
</tr>
<tr>
<td>File (Delimiter Separated Data)</td>
<td>Contiguous file with field delimiters</td>
</tr>
<tr>
<td>Text (ASCII, optionally paginated)</td>
<td>Standard ASCII text file</td>
</tr>
<tr>
<td>RTF (Rich Text Format)</td>
<td>Standard RTF format</td>
</tr>
<tr>
<td>XML (Extensible Markup Language)</td>
<td>Standard XML format</td>
</tr>
</tbody>
</table>

Setting Security for Your JADE Reports

You can dynamically define runtime access to the JADE Report Writer applications by implementing the required security rules in a subclass of the JadeReportWriterSecurity class in the schema from which the JADE Report Writer is run.

Using the methods provided by the JadeReportWriterSecurity class, you can set access security to the applications individually and also set access security to various parts of the applications; for example, specific folders, specific reports, and the maintenance of system formats.

By utilizing the folders feature of the JADE Report Writer, you have a ready means of maintaining a security system that ensures that users can access only the reports to which they have been assigned access permission. The canAccessFolder method enables you to assign users to or restrict users from accessing specific folders. Example code is provided later in this chapter.
Using the JadeReportWriterSecurity Class

The `JadeReportWriterSecurity` class provides a superclass for all user `JadeReportWriterSecurity` subclasses. This section provides an overview of the constants and methods provided by the `JadeReportWriterSecurity` class that enable you to apply access security to your JADE Report Writer sessions.

For full details about the `JadeReportWriterSecurity` class, see Chapter 1 of the JADE Encyclopaedia of Classes, Volume 1.

Report folders containing the JADE Report Writer reports can be unsecured so that all users have access to them, or you can dynamically define runtime access to folders by implementing the required security rules in a subclass of the `JadeReportWriterSecurity` class in the schema in which the report is defined.

The constants provided by the `JadeReportWriterSecurity` class are listed in the following table.

<table>
<thead>
<tr>
<th>Class Constant</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FULL_ACCESS</td>
<td>2</td>
<td>Allows full access to the report for definition and use</td>
</tr>
<tr>
<td>NO_ACCESS</td>
<td>0</td>
<td>No access is allowed to the report</td>
</tr>
<tr>
<td>READ_ONLY_ACCESS</td>
<td>1</td>
<td>The report can be accessed and run but the definitions cannot be changed</td>
</tr>
</tbody>
</table>

When you implement security in your JADE Report Writer reports, these values are returned by the methods in your subclass of the `JadeReportWriterSecurity` class, to indicate the type of access that the user has.

The `folderDeleted`, `folderPathChanged`, `reportDeleted`, `reportNameChanged`, and `viewDeleted` methods inform the host system that a folder, report, or view has changed. You can reimplement these methods to automatically create a security access entry for the values specified in the method parameters so that the user can then access and maintain the folder, report, or view.

Methods provided by instances of the `JadeReportWriterSecurity` class are listed in the following table.

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>canAccessConfiguration</td>
<td>Returns the type of access that the specified user has to the Configuration application.</td>
</tr>
<tr>
<td>canAccessDesigner</td>
<td>Returns the type of access that the specified user has to the Designer application.</td>
</tr>
<tr>
<td>canAccessFolder</td>
<td>Returns the type of access that the specified user has to the specified folder in the Configuration application.</td>
</tr>
<tr>
<td>canAccessReport</td>
<td>Returns the type of access that the specified user has to the specified report when reports are listed for selection.</td>
</tr>
<tr>
<td>canAccessView</td>
<td>Returns the type of access that the specified user has to the specified view when reports are listed for selection or extraction.</td>
</tr>
<tr>
<td>canAccessViewClass</td>
<td>Controls visibility of view classes in the JADE Report Writer Designer application.</td>
</tr>
<tr>
<td>canAccessViewFeature</td>
<td>Controls visibility of view features in the JADE Report Writer Designer application.</td>
</tr>
<tr>
<td>canDeleteReport</td>
<td>Controls which reports the user can delete.</td>
</tr>
<tr>
<td>canMaintainFolders</td>
<td>Returns the type of access that the specified user has to folders in the Configuration application.</td>
</tr>
</tbody>
</table>
## Method Description

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>canMaintainSystemOptions</td>
<td>Returns the type of access that the specified user has to system options in the Configuration application.</td>
</tr>
<tr>
<td>canMaintainViews</td>
<td>Returns the type of access that the specified user has to views in the Configuration application.</td>
</tr>
<tr>
<td>folderDeleted</td>
<td>Called when a folder is deleted, with the specified folder path in the same format as that of the <code>newFolderAdded</code> method. Enables synchronization of user security details when a folder is deleted.</td>
</tr>
<tr>
<td>folderPathChanged</td>
<td>Called when a folder path is changed, with the specified folder paths in the same formats as that of the <code>newFolderAdded</code> method. Enables synchronization of user security details when a folder name is changed or the folder is moved to another parent folder.</td>
</tr>
<tr>
<td>isViewFeatureAccessSet</td>
<td>Specifies whether the user can access the view.</td>
</tr>
<tr>
<td>newFolderAdded</td>
<td>Enables the user who created a new folder to access that folder when security is set.</td>
</tr>
<tr>
<td>newReportAdded</td>
<td>Enables the user who created a new report to access that report when security is set.</td>
</tr>
<tr>
<td>newViewAdded</td>
<td>Enables the user who created a new view to access that view when security is set.</td>
</tr>
<tr>
<td>reportDeleted</td>
<td>Called when a report is deleted. Enables synchronization of user security details when a report is deleted.</td>
</tr>
<tr>
<td>reportNameChanged</td>
<td>Called when a report name is changed. Enables synchronization of user security details when a report name is changed.</td>
</tr>
<tr>
<td>viewDeleted</td>
<td>Called when a view is deleted. Enables synchronization of user security details when a view is deleted.</td>
</tr>
<tr>
<td>viewNameChanged</td>
<td>Called when a view name is changed.</td>
</tr>
</tbody>
</table>

## Examples

The following example shows how to control access to a JADE Report Writer application, in this case the JADE Report Writer Configuration application.

```java
  canAccessConfiguration(userName: String): Integer;
  begin
    if userName = "USER1" then
      return FULL_ACCESS;
    elseif userName = "USER2" then
      return READ_ONLY_ACCESS;
    else
      return NO_ACCESS;
    endif;
  end;
```

In the above example, `USER1` has full access to the JADE Report Writer Configuration application, which means that `USER1` can create and change reporting views. `USER2` has read-only access, and every other user is prevented from running the JADE Report Writer Configuration application.
You can use similar code to apply security to the use of folders, as shown in the following example.

```java
canMaintainFolders(userName: String): Integer;
begin
    if userName = "USER1" then
        return FULL_ACCESS;
    elseif userName = "USER2" then
        return READ_ONLY_ACCESS;
    else
        return NO_ACCESS;
    endif;
end;
```

If you want to control access to a named folder, use the `canAccessFolder` method, as shown in the following example.

```java
canAccessFolder(userName: String; folderPath: String): Integer;
begin
    if folderPath = "/Reports/Clients" then
        if userName = "USER1" or userName = "USER2" then
            return FULL_ACCESS;
        else
            return NO_ACCESS;
        endif;
    else
        return FULL_ACCESS;
    endif;
end;
```

In the above example, USER1 and USER2 have full access to the Clients folder. All other users have no access to the Clients folder, but all users have full access to folders other than the Clients folder.

**Dynamically Configuring JADE Reports at Run Time**

The `JadeReportWriterManager` class and the `JadeReportWriterReport` class provide methods that enable JADE developers to dynamically override JADE Report Writer details at run time.

The `JadeReportWriterManager` class provides methods that enable you to run the JADE Report Writer applications, set the security class, add user names, and apply other management functions. In addition, this class provides methods that enable you run a named report, override printer options, override report options, specify parameters, set the profile, and so on. The methods and their descriptions defined in these classes are listed in tables in the following subsections.

- JadeReportWriterManager Class
- JadeReportWriterReport Class

For full details, see Chapter 1 of the *JADE Encyclopaedia of Classes*. See also "Setting Security for Your JADE Reports", earlier in this chapter.

Both primitive and object parameters can optionally have a different value printed when the ignore flag is set for the parameter. (For details, see "Using the Parameters Sheet", in Chapter 4.) To do this, reimplement the `Application` class `jadeReportWriterParamLiteral` method to return the required literal (for example, "<All>").

Parameters with their ignore flag set are reported as this value in the report body. If the method returns null (""), which is the default behavior, the parameter value is still reported. In either case, parameters used in scripts continue to use the parameter value rather than the method value.
JadeReportWriterManager Class

The JadeReportWriterManager class provides a superclass for each JADE Report Writer application. The methods provided by instances of the JadeReportWriterManager class are listed in the following table.

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>createReport</td>
<td>Creates a new, empty report with a specified name, folder, view, and root collection, and with options copied from an existing report (if specified)</td>
</tr>
<tr>
<td>getAllReportNames</td>
<td>Updates the parameter array values with the folder path and report names visible to the current user</td>
</tr>
<tr>
<td>getAllViewNames</td>
<td>Updates the parameter array values with all report views visible to the current user</td>
</tr>
<tr>
<td>getFolderPaths</td>
<td>Gets an array of the full paths of each report folder to which the user has access</td>
</tr>
<tr>
<td>getFoldersInFolderPath</td>
<td>Gets an array of names of all child folders to which the current user has access in the specified folder</td>
</tr>
<tr>
<td>getReport</td>
<td>Returns a transient instance of the JadeReportWriterReport class for the specified report</td>
</tr>
<tr>
<td>getReportsInFolderPath</td>
<td>Gets an array of all report names in the folder to which the user has access</td>
</tr>
<tr>
<td>getViewDetails</td>
<td>Retrieves details of the specified report view</td>
</tr>
<tr>
<td>isReportWriterInstalled</td>
<td>Specifies whether the JadeReportWriterSchema is loaded and available</td>
</tr>
<tr>
<td>setSecurity</td>
<td>Sets the JadeReportWriterSecurity class to the user subclass of JadeReportWriterSecurity</td>
</tr>
<tr>
<td>setSecurityObject</td>
<td>Sets the object to be passed to the Object class jadeReportWriterCheck method during the query phase of the JADE Report Writer process</td>
</tr>
<tr>
<td>setUserName</td>
<td>Sets the user name that is to be used in security checks</td>
</tr>
<tr>
<td>startReportDesignerForReport</td>
<td>Starts the JADE Report Writer Designer application in the same way as the startReportWriterDesigner method but automatically opens a specified report</td>
</tr>
<tr>
<td>startReportWriterConfiguration</td>
<td>Starts the JADE Report Writer Configuration application, passing the current user code and security class</td>
</tr>
<tr>
<td>startReportWriterDesigner</td>
<td>Starts the JADE Report Writer Designer application, passing the current user code and security class</td>
</tr>
</tbody>
</table>

JadeReportWriterReport Class

The JadeReportWriterReport class, in conjunction with the JadeReportWriterManager class and JadeReportWriterSecurity class, provides methods that enable you to dynamically override JADE Report Writer details and programmatically run report definitions at run time.

The constants provided by this class for use in the setOutputDestination and setQueryOptions methods are listed in the following table.

<table>
<thead>
<tr>
<th>Class Constant</th>
<th>Integer Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONCURRENCY_NONE</td>
<td>1</td>
<td>Does no explicit resynchronization or locking</td>
</tr>
</tbody>
</table>
## Class Constants

<table>
<thead>
<tr>
<th>Class Constant</th>
<th>Integer Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONCURRENCY_READ_COMMITTED</td>
<td>3</td>
<td>Resynchronizes every object accessed, share locks collections</td>
</tr>
<tr>
<td>CONCURRENCY_READ_OPTIMISTIC</td>
<td>4</td>
<td>Resynchronizes every object accessed, share locks collections and objects included in the report output</td>
</tr>
<tr>
<td>CONCURRENCY_READ_PESSIMISTIC</td>
<td>5</td>
<td>Share locks all objects accessed during report output</td>
</tr>
<tr>
<td>CSV</td>
<td>3</td>
<td>Comma-Separated Value (CSV) file format</td>
</tr>
<tr>
<td>DELIMITED_FILE</td>
<td>3</td>
<td>Delimited file format (for example, containing commas, semicolons, tabs, or spaces)</td>
</tr>
<tr>
<td>HTML</td>
<td>2</td>
<td>HyperText Markup Language (HTML) file</td>
</tr>
<tr>
<td>PRINTER</td>
<td>0</td>
<td>Output to the default printer of the user</td>
</tr>
<tr>
<td>RESOURCE_LIMIT_NONE</td>
<td>0</td>
<td>Not applicable (that is, ignored), which is the default value</td>
</tr>
<tr>
<td>RESOURCE_LIMIT_READS</td>
<td>1</td>
<td>Maximum number of objects to read</td>
</tr>
<tr>
<td>RESOURCE_LIMIT_RESULTS</td>
<td>2</td>
<td>Maximum number of result objects to add</td>
</tr>
<tr>
<td>RESOURCE_LIMIT_TIME</td>
<td>3</td>
<td>Maximum number of milliseconds the report query runs</td>
</tr>
<tr>
<td>RESOURCE_LIMIT_QUERYOPS</td>
<td>4</td>
<td>Maximum number of query operations</td>
</tr>
<tr>
<td>RTF</td>
<td>4</td>
<td>Rich Text File (RTF) file format for Microsoft Word for Windows</td>
</tr>
<tr>
<td>TEXT</td>
<td>6</td>
<td>Text (or ASCII) file format, and may contain new page characters</td>
</tr>
<tr>
<td>XML</td>
<td>5</td>
<td>Extensible Markup Language (XML) file format</td>
</tr>
</tbody>
</table>

The class constants CSV and DELIMITED_FILE have the same value and are the same, in that in either case you can use commas, semicolons, tabs, or spaces as field delimiters. Traditionally, as the name suggests, csv was applied to files in which only commas could be used as delimiters. Consequently, CSV is retained as a class constant for the JADE Report Writer application, but it actually has the same value as DELIMITED_FILE.

The methods provided by instances of the JadeReportWriterReport class are listed in the following table.

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>getDefaultOutputDestination</td>
<td>Returns an integer value containing JadeReportWriterReport class constants (for example, PRINTER or CSV) representing the default output destination (for example, a printer or extract file) if none is explicitly set.</td>
</tr>
<tr>
<td>getDefaultProfile</td>
<td>Returns a string value containing the name of the default profile.</td>
</tr>
<tr>
<td>getDelimitedFileOptions</td>
<td>Obtains the current values to be used when running the report for extraction to a delimited file.</td>
</tr>
<tr>
<td>getExtraParameterDetails</td>
<td>Obtains whether a value is mandatory and the user prompt value for the specified parameter.</td>
</tr>
<tr>
<td>getFolder</td>
<td>Returns the folder path of the report.</td>
</tr>
<tr>
<td>Method</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>getHtmlOptions</td>
<td>Obtains the current values to be used when running the report for extraction to a HyperText Markup Language (HTML) file.</td>
</tr>
<tr>
<td>getOutputFileTitle</td>
<td>Returns a string value containing the full file title of the default output file.</td>
</tr>
<tr>
<td>getPageOptions</td>
<td>Obtains the current report attributes relating to paper size values to be used when running the report.</td>
</tr>
<tr>
<td>getParameterDetails</td>
<td>Gets the parameter type, length and scale factor, current value, is used, and ignore status. The isUsedInReport parameter is set to true if the parameter is used anywhere.</td>
</tr>
<tr>
<td>getParameters</td>
<td>Obtains the names and values of all individual parameters.</td>
</tr>
<tr>
<td>getParametersForProfile</td>
<td>Populates the string arrays specified in the names and types parameters with the parameter names and types that are used in the profile specified in the profileName parameter.</td>
</tr>
<tr>
<td>getProfileDescription</td>
<td>Returns the description of the specified profile.</td>
</tr>
<tr>
<td>getProfiles</td>
<td>Returns an array of profile names defined in the report.</td>
</tr>
<tr>
<td>getQueryOptions</td>
<td>Returns the locking concurrency and resource limits to be applied at the query phase of the report run.</td>
</tr>
<tr>
<td>getReportDescription</td>
<td>Returns the report description.</td>
</tr>
<tr>
<td>getReportingViewName</td>
<td>Returns the name of the reporting view for the report.</td>
</tr>
<tr>
<td>getRootCollections</td>
<td>Returns the alias and path of each report root collection or join, or both root collections and joins.</td>
</tr>
<tr>
<td>getTextOptions</td>
<td>Obtains the number of lines on pages when running the report for extraction to a text file.</td>
</tr>
<tr>
<td>getUseClientFileSystem</td>
<td>Returns true if the presentation client file system is used or false if the application server file system is used.</td>
</tr>
<tr>
<td>getXmlOptions</td>
<td>Obtains the current values to be used when running the report for extraction to an XML file.</td>
</tr>
<tr>
<td>run</td>
<td>Runs the current report, using the parameter values specified in the appropriate set methods.</td>
</tr>
<tr>
<td>runWithStatus</td>
<td>Runs the current report, using the parameter values specified in the appropriate set methods, displays and refreshes a progress dialog, and returns the status of the report after it has been run, indicating the success of the report run and the page count of a report output to a printer or the record count of a report extracted to file.</td>
</tr>
<tr>
<td>setDelimitedFileOptions</td>
<td>Sets the values to be used when running the report for extraction to a delimited file.</td>
</tr>
<tr>
<td>setEndingNotification</td>
<td>Passes an object that is to be notified when the report finishes.</td>
</tr>
<tr>
<td>setHtmlOptions</td>
<td>Sets the values to be used when running the report for extraction to an HTML file.</td>
</tr>
<tr>
<td>setLocaleDateOptions</td>
<td>Sets date formats to be used at runtime.</td>
</tr>
<tr>
<td>setLocaleNumericOptions</td>
<td>Sets number and currency formats to be used at runtime.</td>
</tr>
<tr>
<td>setLocaleTimeOptions</td>
<td>Sets time formats to be used at runtime.</td>
</tr>
</tbody>
</table>
## Handling Exceptions in JADE Reports

Any exception or error condition arising from a JADE Report Writer application or running a report stops the current action and initiates an exception entry and dump to a Report Writer application log.

An exception does not result in the display of a user dialog.

Exceptions that occur in the JADE Report Designer application usually stop the current action. If an exception occurs while a report is running, the report stops at that point and the exception information is output to a JADE Report Writer log and a detailed stack dump log file. Accessing the appropriate log file is the first step towards determining the cause of the exception.

If the exception arises from a flaw in the report design, you can use the log information to isolate the cause of the problem and then take the appropriate steps to deal with the error.

If the exception arises from the user system against which the report is being run, the application developer can take the usual steps to design and implement an exception handler in the JADE application. For details about handling exceptions in JADE systems, see "Handling Exceptions", in Chapter 3 of the JADE Developer’s Reference.

The JADE initialization file provides the `PassBackException` parameter that enables exceptions trapped by the JADE Report Writer to be passed back to the application exception handler after they are logged. For details, see the `PassBackException` parameter under "JADE Report Writer Section [JadeReportWriter]", in the JADE Initialization File Reference.

The following subsection, "JADE Report Writer Application Logs", describes the JADE Report Writer application logs and dump logs, which contain details about exception errors that occur when running reports.

---

### Method Table

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>setOutputDestination</code></td>
<td>Sets the destination of the report output.</td>
</tr>
<tr>
<td><code>setOutputFileTitle</code></td>
<td>Sets the title of the output file that is created when the report runs.</td>
</tr>
<tr>
<td><code>setPageOptions</code></td>
<td>Sets the <code>Printer</code> class attributes relating to paper size values to be used when running the report.</td>
</tr>
<tr>
<td><code>setParameter</code></td>
<td>Sets the name and value of a parameter to be used when running the report.</td>
</tr>
<tr>
<td><code>setParameterIgnoreInSelection</code></td>
<td>Specifies whether a parameter is to be ignored when selecting parameters for the current run of the report.</td>
</tr>
<tr>
<td><code>setPreviewOptions</code></td>
<td>Sets the <code>Printer</code> class preview attributes to be used when running the report.</td>
</tr>
<tr>
<td><code>setProfile</code></td>
<td>Sets the report profile name to use when running the report.</td>
</tr>
<tr>
<td><code>setQueryOptions</code></td>
<td>Sets the locking concurrency and specified resource limits on the execution of a query when running the report.</td>
</tr>
<tr>
<td><code>setStartEndMethods</code></td>
<td>Sets the names of the application initialize method that is called before the report is run and the finalize method that is called after the report has completed.</td>
</tr>
<tr>
<td><code>setTextOptions</code></td>
<td>Sets the number of lines on pages and the size of each fixed-length record when running the report for extraction to a text file.</td>
</tr>
<tr>
<td><code>setUseClientFileSystem</code></td>
<td>Specifies whether the presentation client file system is used (true) or the application server file system is used (false).</td>
</tr>
<tr>
<td><code>setXmlOptions</code></td>
<td>Sets the values used when running the report for extraction to an XML file.</td>
</tr>
</tbody>
</table>
JADE Report Writer Application Logs

Any exception that occurs in the JADE Report Writer Configuration application, the JADE Report Writer Designer application, or when running a report stops the current action or report process and initiates an exception entry and dump to the following JADE Report Writer application logs.

- `jadereportwriter<n>.log`
- `jrw_dump_yyyyMMdd_HHmmss.log`

If an exception error occurs, the `jrw_dump.log` file is a detailed summary of the exception and the conditions under which it occurred. The `jadereportwriter<n>.log` is a continuous summary of activity in the JADE Report Writer environment, with any errors also detailed.

The JADE Report Writer application logs are described in the following subsections.
- **JADE Report Writer Dump Log**
- **JADE Report Writer Application Log**

**JADE Report Writer Dump Log**

For each exception error, the default exception handler initiates a dump to a `jrw_dump` log file. This dump file is uniquely identified with both the date and time of the file dump in the `yyyyMMdd` (year, month, day) format and the `HHmmss` (hours, minutes, seconds) format.

The log contains a detailed summary of the exception and the conditions under which it occurred, including the current execution location and database path, the exception number and description, the error item and object, the object and method that caused the exception, and the receiver object and method that reported the exception, as well as the call stack history and detailed report context information.

**JADE Report Writer Application Log**

The JADE Report Writer log (`jadereportwriter<n>.log`) is a continuous log of activity in JADE Report Writer applications.

As each log reaches its maximum length, a new log is created and numbered sequentially from the previous log (for example, `jadereportwriter1.log` is followed by `jadereportwriter2.log`, and so on). The default location and maximum length of each log is defined by the `MaxLogFileSize` and `LogDirectory` parameters in the `[JadeLog]` section of the JADE initialization file (usually `jade.ini`, located in the JADE `system` directory).

The JADE Report Writer application log contains entries detailing when the JADE Report Writer Designer application is started and stopped, and when a report is opened, closed, or run. The log also tracks report and reporting view loads, with details of any error that is found as well as exceptions and the `jrw_dump` log file to which these were logged.

When an exception occurs, the error number and identifier are logged to the JADE Report Writer log.

**Font Used by JADE Report Writer Applications**

When the JADE Report Writer configuration or designer application is started from a JADE application, the JADE Report Writer application uses the default font and point size defined for the JADE application by default. This can result in truncation of text on the controls in the JADE Report Writer forms and dialogs.

You can avoid this truncation by using the standard **MS Sans Serif** at **8.25 point** size. To use this standard font, set the `UseAppFont` parameter in the `[JadeReportWriter]` section of the JADE initialization file (usually `jade.ini`, located in the JADE `system` directory) to **false**.
Appendix A  Using JADE Report Writer Scripts

This appendix covers the following topics.

- Overview
  - Return Types and Parameters
  - Script Language Restrictions
- Creating Single Expression Scripts
- Creating Full Scripts
- Resolving Errors in Scripts
- Report Execution
- Summary Fields Based on Script Fields

This appendix assumes that you know how to access and maintain scripts within the JADE Report Writer Designer application. For details, see "Using the Catalog of Available Fields Dialog", in Chapter 4.

Overview

JADE Report Writer scripts enable you to programmatically derive report fields by performing calculations involving one or more database fields, report special fields, or report parameters; for example, applying a variable tax rate to a currency field.

There are two ways of creating scripts, as follows.

- A single expression script is available in which you would typically create a formula; for example, multiplying a currency amount (for example, a salary) by a tax rate to create a tax amount.

  The JADE Report Writer provides a simple step-by-step procedure that enables you to formulate the expression even if you have never written computer code. Even if you have programming experience, the procedure provides easy selection of the fields for use in your expression.

- For complex field derivations or calculations, the JADE Report Writer provides you with a full scripting capability.

  Full scripting enables you to apply JADE-like code directly to your script field.

Whichever way you create a script, your script becomes a pseudo field that you can click and drag from the Catalog of Available Fields dialog to your report layout in the same way that you apply any other field type. You can also use scripts in your report profile sort, selection, and group criteria. For details about inserting field, see "Inserting Report Fields", in Chapter 4.
In the following image, a script field that is derived from a script that calculates a value in US dollars is dragged onto the footer section of the report design from the Catalog of Available Fields.

In this example, the script is a single expression that multiplies the total sales value by an exchange rate to obtain the US dollar amount. If you want to make the field value conditional on another value, you need to code a full script and apply conditional instructions (for example, if, then, and else instructions) as you would when coding JADE methods. In the above example, you might want to print the US dollar conversion only on the end-of-year report, in which case you would make the calculation conditional on a date.

The primitive type methods are available to you when you create scripts are described in this appendix grouped by type; for example, Binary, Date, Character, and so on. In JADE, these are referred to as primitive types. The primitive types documented in Chapter 1 of the JADE Encyclopaedia of Primitive Types are types used to store values, and they can have methods added to them. The primitive types are displayed in the Methods list box of the Add Script Field and Update Script Field dialogs in the JADE Report Writer Designer application, as shown in the following image.

You can open up each category, or type, to display the list of the methods within that category.

The default set of script methods initially available in the Methods list box of the Add Script Field and Update Script Field dialogs of the JADE Report Writer Designer application comprises the most frequently used JADE primitive type methods. More primitive types and many more methods can be added to a report view from the Available Methods list box of the Script Methods sheet of the JADE Report Writer Configuration window.

When a method is added to a view, it becomes available as a script method in reports based on that view in the JADE Report Writer Designer application.

**Note** JADE developers can also add methods to primitive types in JADE schemas and these methods can also be added to a reporting view based on those schemas.
Return Types and Parameters

The majority of primitive type methods listed in this appendix have a return type. As described in "Creating Full Scripts", later in this appendix, the return type is the type of the result value returned to the report script field by the method. For example, the `dayName` method of the `Date` primitive type has a return type of `String`. This means that where the `dayName` method is applied to a value of type `Date`, the returned value is a string, containing the day of the week (such as `Monday`) associated with a specific date.

When there is no return type, the method is one that sets a value of the calling field or executes some other action (for example, saving a file to disk).

JADE is a **strongly typed** language. This means that where a script method returns a value that will be used for the final output of the field, this must be compatible with the return type defined for the script field. A common source of errors in script fields is incompatible types. For an example of this, see the example method in "Using Intermediate Variables", later in this appendix.

In JADE terms, when a method invokes another method (for example, when the `dayName` method is used in a script method to find the day associated with a specific date in order to include it in a customized format), it sends a message or **calls a method**. The method call must follow a specific format (syntax). In JADE, this skeleton structure is known as the signature of the method. As a simplified JADE method, a typical script method has the following syntax.

```
.method-name ([parameters])
```

The **parameters** are a list of parameters for the method. In JADE, a parameter is a value that is passed to another method as part of a method call. These parameters are not to be confused with report parameters, which are used to set up default values that apply throughout a report. A JADE method parameter value is one that affects the operation of the method to which it is passed. For example, the `decimalPlaces` parameter of the `roundedTo` method of the `Decimal` primitive type affects the operation of the method by specifying the number of decimal places to which the returned value is rounded.

Some script methods require parameters. If the script method requires parameters, these are included in the skeleton method call that is inserted into your script code when you select a script method from the **Methods** list box. For example, the `roundedTo` method of the `Decimal` primitive type is displayed in the **Script Code** sheet, as follows.

```
.roundedTo(decimalPlaces: Integer)
```

Parameters are inserted after the method name between parentheses and are separated by semicolons (;). A parameter declaration has the following syntax:

```
parameter-name : type [usage];
```

The type of each parameter specified in a method call must correspond to that defined for the parameters of the method. Parameters must be passed in the exact order specified by the parameter list. To define your parameters in a script method, simply delete the parameters of the method signature and replace them with values of the specified type of your own.

If there are no parameters, the parentheses can be left empty or they can be deleted. Alternatively, you can type the method name and parameters directly into the code.

In the following example, the `roundedTo` method of the `Decimal` primitive type with a parameter defined as the integer 2 is displayed in the **Script Code** sheet, as follows.

```
.roundedTo(2)
```

This method returns a decimal value rounded to two decimal places.
For script methods, the usage value can be constant or io (input-output). If you do not specify a usage, as is the case with most primitive type methods, a default value of constant is assumed. The parameter usages are as follows.

- For constant parameters, the parameter value specified in the method call is passed to the called method. As the name implies, constant parameters cannot be updated or modified in any way within the body of the method.
- For io parameters, the parameter value is passed in both directions, from the caller to the called method when the method begins execution, and from the called method back to the caller when it returns.

An io parameter is one that is updated (changed) by the method call. An io parameter must be defined and passed when the method is called but it may be affected by the operation and changed when it is passed back.

Further usage options are described in the JADE product information library. If you have access to the JADE documentation, see "Parameters", in Chapter 1 of the JADE Developer’s Reference, for details.

**Script Language Restrictions**

The following JADE language features are not allowed in report scripts.

- Transaction control instructions (beginTransaction, commitTransaction, abortTransaction)
- Exception handling instructions (on exception, raise)
- The terminate instruction
- The create and delete instructions
- Accessing methods and properties on non-JADE Report Writer classes
- System variables other than self, app, global, node, process, system, and currentSession
- Any user-defined property reference or method call on the permitted system variables

Using these JADE language features in a JADE Report Writer script results in a compile syntax error, *This is not allowed in report scripts*. For details about compiling scripts and removing errors, see "Resolving Errors in Scripts", later in this appendix.

JADE RootSchema properties and methods of the permitted system variables can be used; for example, app.userName or app.beep.

There are no restrictions on using properties and methods defined in your JADE Report Writer views in the having JADE Report Writer Configuration application.

**Creating Single Expression Scripts**

Single expression scripts enable you to create "one-liner" expressions to derive report fields. With this facility, you create a formula for calculating a field or an expression that manipulates a string field.

A typical use of a single expression script would be to apply a report parameter to a field; for example, a tax rate or an exchange rate. You could also perform string manipulation. For example, you could take full name fields and extract the first characters of the first names in order to print initials, or you could convert a numeric date into day and month names to aid readability.

Creating these simple expressions requires no coding skills. You select the fields that you want to use in your expression and you select the operator that you want to apply to those fields.
To create a simple single expression script, ensure that the **Single Expression** option button is selected as the **Script Type** in the Add Script Field dialog. (This option is selected by default.) For example, if you want to multiply a salary field by a tax rate, the basic procedure is as follows. Select the:

1. Salary field from a provided list of database fields or report fields.
2. Multiplication symbol from a provided list of arithmetic operators.
3. Tax rate field from a provided list of report parameters.

The resulting expression could look like the following.

```plaintext
({Employees::payRoll->salary} * {?taxRate})
```

To create an expression such as this, you do not have to invent any part of it yourself. You select each of the three parts (that is, the field from which you want to derive the result, the multiplication symbol, and the field by which you want to multiply) from lists that are provided on the Add Script Field dialog.

The expression becomes your script field. When you move the script field to a section of your report, the expression is resolved based on current data each time the section is printed.

For examples of creating single expression scripts, see the following subsection, "Single Expression Script Examples".

The following image shows the Add Script Field dialog after a single expression script has been built (this is the first example described in "Single Expression Script Examples"). The script concatenates (joins together) two address fields, with a comma and a space between them, in order to print them as one field.
For single expression scripts, you have limited use of the available commands (displayed in the Commands list box) and available methods (displayed in the Methods list box). However, all commands and methods, as well as fields and return types, are described in the appendixes listed in the following table.

<table>
<thead>
<tr>
<th>Script Elements</th>
<th>For details, see…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Return Types</td>
<td>Chapter 1 of the <em>JADE Encyclopaedia of Primitive Types</em></td>
</tr>
<tr>
<td>Commands</td>
<td>Appendix B, &quot;Script Commands&quot;</td>
</tr>
<tr>
<td>Fields</td>
<td>Appendix C, &quot;Script Fields&quot;</td>
</tr>
<tr>
<td>Methods</td>
<td>Chapter 1 of the <em>JADE Encyclopaedia of Primitive Types</em></td>
</tr>
</tbody>
</table>

When you click the Apply button, the full script code is checked by the JADE compiler, to make sure that it is correct and does not cause any errors when it is run as part of a report.

If your expression is in error, the Errors sheet is displayed on the Add Script Field dialog. The most-common error when creating single expressions is using the wrong return type; for example, you are deriving a numeric field and your return type is String, which is non-numeric.

If you encounter errors in your scripts, see "Resolving Errors in Scripts", later in this appendix.

### Single Expression Script Examples

You can derive report fields with single expression scripts in a great number of ways. Some typical examples are shown in the following subsections.

- Deriving String Fields
- Using Arithmetic Expressions
- Applying the Supplied Methods

### Deriving String Fields

The following example shows how you can derive string fields by using a single expression script.

In this example:

- There are two address fields in the database (displayed as address1 and address2 in the following image) that need to be concatenated (that is, joined together)

- A comma and space are included in the concatenation to improve the readability. This can be achieved with one simple script expression.

For details about the Fields pane, see Appendix C, "Script Fields".
To create a new script

1. Click the New button on the Catalog of Available Fields dialog.

   The Add Script Field dialog is then displayed.

2. Enter a name for your script in the Script Name text box.

   In the example in the following image, the script has been named addresses.

   ![Add Script Field dialog](image)

To select the first field to concatenate

- In the Fields list box, expand the Database Fields folder and double-click the required field, which is the first address field in the example.
The field is then displayed on the **Script Code** sheet, as shown in the following image.

To select the concatenation symbol

- Expand the **String operators** in the **Commands** list box and then double-click the concatenation symbol (\&), as shown in the following image.

**Note** If you know the symbol for concatenation, you can simply type it in rather than select it from the **Commands** list box.
At this stage, you could complete the expression simply by selecting the second address field. However, the address fields are to be separated by a comma and a space in this example.

**To concatenate the comma separator**

- Type in the comma and a following space as a string; that is, between quotation marks, as shown in the following image.

**To concatenate the second string**

1. Select the concatenation symbol again (as described earlier in this section).
2. In the **Fields** list box, double-click the field that you want to concatenate.
In the example, this is the second address field; that is, `address2`.

The expression is now complete, as shown in the following image.

To complete the script, you need to set the return type. In this case, two address fields have been joined so it may also be necessary to extend the length of the result field to accommodate the combined strings.
To set the return type and change the length

1. Click the **Define Return Type** button in the top right corner of the Add Script Field dialog.

   The Define Script Return Type dialog, shown in the following image, is then displayed.

   ![Define Script Return Type dialog]

   - **Script**: addresses
   - **Type**: String
   - **Details**:
     - **Length**: 50
     - **Decimals**: 0

   2. Select the type from the **Type** list box. In this case, the **String** default return type is selected.

   3. Enter a length in the **Length** text box. In this case, the length has been set to 60 to accommodate the combined address fields.

   4. Click the **Apply** button to complete the definition.

   The Define Script Return Type dialog is then closed and the return type is displayed in the **Return Type** list box in the top right of the Add Script Field dialog.

   For more details about return types, particularly for users who are new to scripting concepts, see "Return Types and Parameters", earlier in this appendix.

To complete the script

- Click the **Apply** button on the Add Script Field dialog.

   The new script is then listed on the **Script** sheet of the Catalog of Available Fields dialog.
To include it in your report design, drag it on to the layout, as shown in the following image.

![Drag to layout](image)

The contents of the **Commands** list box, **Fields** list box, and the **Methods** list box of the Add Script Field or Update Script Field dialog are described in:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the *JADE Encyclopaedia of Primitive Types*

### Using Arithmetic Expressions

The following example shows the creation of a single expression script that uses an arithmetic expression to derive a sales price as a percentage of the total sales.

**To create a new script**

1. Click the **New** button on the Catalog of Available Fields dialog. The Add Script Field dialog is then displayed.
2. Enter a name for your script in the **Script Name** text box.
In the following image, the single expression script has been named **percent sales**.

To select the first field in the expression:
- In the **Fields** list box, expand the **Report Fields** folder and then double-click the required field.
The field is then displayed on the **Script Code** sheet, as shown in the following image.

![Add Script Field](image)

In this example, the retail sales price is selected (it is qualified by the **RetailSaleItem** subclass name).

The sales price is to be divided by the total sales value and multiplied by 100 to derive the percent of sales figure. You must first select the division operator.

**To select the arithmetic operator**

- Expand the **Arithmetic operators** folder in the **Commands** list box and then double-click the division operator (/), as shown in the following image.
Note: If you know the symbol for division, simply type it in rather than select it in the **Commands** list box.

To select the divisor:

- In the **Fields** list box, double-click the divisor in the **Summary Fields** folder.
In this example, **total price** is selected, as shown in the following image.

As the formula stands at this point, the result is the price divided by the total price for all sales to this client. To turn this fraction into a percentage, you need to multiply it by **100**.

**To change the result to a percentage**

1. Select the **multiply** operator from the **Arithmetic operators** list in the **Commands** list box.

   Alternatively, you could simply type the symbol for multiplication; that is, the asterisk (*).

2. Type the multiplier, which in this case is the value **100**.
The formula is then complete, as shown in the following image.

As the result is a decimal value rather than a string, the return type must be changed to reflect this. Having completed the expression, select the Return Type (which in this example has been set to Decimal(12:2)), apply the expression, and you are then ready to apply your script field to your report. These procedures are described fully in the previous subsection, "Deriving String Fields".

Another example of applying a simple arithmetic expression to derive a report field is described in "Using the Script Sheet" under "Using the Catalog of Available Fields Dialog", in Chapter 4. In that example, a single expression is developed in which an exchange rate report parameter is applied to a report total value to produce that total in another currency.

The Commands list box, Fields list box, and the Methods list box of the Add Script Field or Update Script Field dialog are described in:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the JADE Encyclopaedia of Primitive Types

### Applying the Supplied Methods

The Methods list box of the Add Script Field dialog contains standard methods that you can apply to your single expression formulas.
These methods are made available to the JADE Report Writer designer at the configuration stage. (For details, see "Selecting Script Methods", in Chapter 3.)

The methods are arranged by type, as shown in the following image in which the Date folder has been opened to display its methods.

The majority of these methods apply only if you are creating full scripts. For details about the available methods, see Chapter 1 of the JADE Encyclopaedia of Primitive Types. This section describes the creation of an expression that derives the month name from a full numeric date, using one of the supplied Date methods.

To select the field to which to apply a method

- Double-click the field in the Fields list box.
In the example, the sales date is selected and displayed on the **Script Code** sheet, as shown in the following image.

To apply a method to the expression

1. Expand the relevant folder in the **Methods** list box.

   In the example shown in the following image, the **Date** folder is opened.

2. Double-click the required method.

   The method is then applied to the field on the **Script Code** sheet.
In the example shown in the following image, the `monthName` method is selected and is automatically applied to the date value, as shown in the following image.

When the resulting script field shown in this example is added to your report, the month name is printed rather than the full numeric date.

For details about the procedures required to apply your script to your report, see "Deriving String Fields", in the previous subsection.

The `Commands` list box, `Fields` list box, and the `Methods` list box of the Add Script Field or Update Script Field dialog are described in:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the *JADE Encyclopaedia of Primitive Types*

If you encounter errors in your scripts, see "Resolving Errors in Scripts", later in this appendix.

### Creating Full Scripts

Use the full script facility in the JADE Report Writer Designer application when a single expression is not sufficient to derive a field.
The most common need for a full script is if your field is derived conditionally. A simple example would be if the field is conditional on a date; for example, you might want to print a derived currency value only at year end.

When you select the full script option, skeleton code is provided in the *Script Code* sheet of the Add Script Field dialog, as shown in the following image.

![Add Script Field dialog](image)

The JADE Report Writer script facility provides a coding structure that is very much like JADE code. However, you do not have to know JADE code or even have previously written any computer programs. The Add Script Field dialog provides all of the tools that you need to enable you to form script code to derive simple and complex fields.

As the above image shows, the result of the execution (running) of this code for your derived field must be returned with a `return` instruction (just before the `end` statement at the end of the skeleton script code). The default return type is `String[100]`, which means your derived field is a string of alpha-numeric characters with a maximum length of 100 characters. You can change the return type by clicking on the Define Return Type button next to the Return Type text box.

All of the commands that you need are described in Appendix B, "Script Commands". The return types are described in Chapter 1 of the *JADE Encyclopaedia of Primitive Types*.

All aspects of the code follow JADE coding rules, except the field names, which you have to select from the Field Catalog folder in the Fields list box at the upper center of the dialog. If you are not familiar with JADE code, you have the same facility to select commands and methods that you have with single expression scripts.
All of the examples in this section are aimed at users who are not familiar with JADE code. You should experiment with single expression scripts before you attempt more complex scripting. For examples of single expression scripts, see "Single Expression Script Examples", earlier in this appendix.

For more details about creating full scripts, see the following subsections, later in this appendix.

- Full Script Examples
- Resolving Errors in Scripts

The scripting language that is available with the JADE Report Writer is based on the JADE programming language. In general, there are few restrictions on the use of any part of the JADE language in your scripts. Some JADE language features, largely those used in transaction control and the creation and deletion of object and non-JADE Report Writer method calls or object property references, are not allowed in report scripts, and using them returns an error (for details, see "Script Language Restrictions", earlier in this appendix).

However, it is not necessary to acquire a complete knowledge of the JADE language where the aim is to have more flexibility in how you derive report fields using the range of fields types and script methods that are available within the JADE Report Writer Designer application.

For reference material to help you create complex scripts, see:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the  *JADE Encyclopaedia of Primitive Types*
- Chapter 1, "JADE Language Reference", of the *JADE Developer's Reference*

### Full Script Examples

The examples in this section do not show how to access the Add Script Field dialog or how to insert your derived field into your report, as these procedures are described fully in "Using the Script Sheet" under "Using the Catalog of Available Fields Dialog", in Chapter 4.

You should also read the single expression examples before writing full scripts. For details about single expression scripts, see "Creating Single Expression Scripts", earlier in this appendix.

Full script examples are described in the following subsections.

- Simple Conditional Scripts
- Using Intermediate Variables

### Simple Conditional Scripts

The following subsections provide examples of simple conditional scripts.

- Example 1 – Using One if Instruction
- Example 2 – Using the if Instruction and its then and else Clauses
- Example 3 – Using Nested if Instructions

#### Example 1 - Using One if Instruction

In this example, sales prices greater than one million dollars are to be highlighted with a message that prompts the user of the report to check and verify that figure.
The expression has the following generic format.

\[
\text{if } \text{<value>} \text{ greater than 1000000 then result := "CHECK THIS ONE".}
\]

When the script field is inserted at the end of the detail line in which the sales value is printed, the warning message is printed only when the value exceeds one million dollars, as shown in the following report extract.

<table>
<thead>
<tr>
<th>Customer</th>
<th>S. Bailey</th>
<th>17 Lake Crescent, Queenstown</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEST</td>
<td>13</td>
<td>Ancient Ruins 7.593.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.24% Thursday, 27 Apr 2000</td>
</tr>
<tr>
<td>PROP</td>
<td>2004</td>
<td>Famed House 3.200.000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>99.49% Wednesday, 17 May 2000</td>
</tr>
<tr>
<td>DEST</td>
<td>34</td>
<td>Beach Getaway 8.993.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.29% Thursday, 03 Aug 2000</td>
</tr>
</tbody>
</table>

Total Sales $3,216,598.00

Percentage of total 33.71

Using the features on the Add Script Field dialog, you can build the correct code for this script simply by pointing and clicking.

To create a new full script

1. Click the New button on the Catalog of Available Fields dialog. The Add Script Field dialog is then displayed.
2. Enter a name for your script in the Script Name text box.
3. Select the Full Script option button.
In the example in the following image, the script has been named alert.

When the Full Script option button is selected, skeleton code is displayed, as shown in the previous image. In this example, the required code is to be inserted between the begin and end statements. The intention is to put the result that is required into the result variable. The result variable is of type String. The name and type of this, or any other variable, is declared after the vars statement and before the begin statement.

When your script field is inserted into your report layout, the JADE Report Writer application prints whatever value is in the result variable.

You could simply insert the value you wanted into the result := line, as follows.

```
result := "*** CHECK THIS ONE ***";
```

In the above example, the string value is assigned to the result variable by using the JADE assignment := operator. However, if you applied this script to your report detail section, the message *** CHECK THIS ONE *** would be printed for every detail line. The expression therefore needs to be qualified with the condition that this message text is applied to the result variable only if the sales price is greater than one million dollars. It requires a conditional instruction; that is, an instruction that tests if certain conditions are met, as shown in the following example.

```
if <sales price> greater than 1000000
```

The if instruction and then clause is used to do this.
To insert a conditional instruction

1. Create a blank line for your conditional instruction before the `result :=` line, as follows.
   a. Click at the start of the `result :=` line.
   b. Press Enter. A new line is then created above the `result :=` line.
   c. Click at the start of the new line, as shown in the following image.

![Image of code with blank line added](image_url)

2. Open the **Commands** folder in the **Commands** list box, as shown in the following image.

![Image of Command list](image_url)

3. Select (double-click) the **if then** command in the Commands folder. The **if** instruction and its **then** and **endif** clauses are then inserted into the **Script Code** sheet, as shown in the following image.

![Image of code with if then endif added](image_url)
The if instruction is always accompanied by a then clause, and all of the instructions conditional on that if instruction must be inserted between the then and endif clauses. The code therefore has the following form.

```
if <sale price> greater than 1000000 then
    result := "CHECK THIS ONE";
endif;
```

In the above example, there are spaces between the elements of the if instruction and then clause that are left blank for the code elements that are added in the next step.

4. Click in the space between the if instruction and the then clause to set your insertion point.

You then select the field to which you want to apply the condition. In this example, the sale price field is the field to which the condition is to be applied and it is one of the report fields.

5. Open up the Report Fields folder in the Fields list box, as shown in the following image.

6. Select (double-click) the Clients::allRetailSales->mySaleItem->RetailSaleItem.price field in the Reports Field folder.

The field is then inserted at the insertion point between the if instruction and then clause, as shown in the following image.

7. Open the Comparison Operators folder in the Commands list box, as shown in the following image.

You then apply the comparison operator, which in this example is the greater than sign.
8. Select (double-click) the greater than operator, as shown in the previous image.

The greater than sign (>) is then inserted into your expression, as shown in the following image.

![Code snippet showing the greater than operator inserted into an expression]

Note: If you know the symbol for the greater than sign, you can simply type it into the expression.

To complete the comparison, enter the comparison value. In this example, the sale price is to be compared with the value one million and the result set if it is greater than one million.

9. Enter (type in) the comparison value after the greater than sign and before the then clause, as shown in the following image.

![Code snippet showing the sale price compared to one million]

At this point, the code will check to see if the sale price is greater than one million. If this is the case, the code assigns the required value to the result. In this example, we want to print a warning message beside sales values that are greater than one million. The required code is as follows.

```java
if <sale price> greater than 1000000 then
    result := "CHECK THIS ONE";
endif;
```

10. Move the result := variable declaration so that it is positioned after the then clause and before the endif clause.

    You can cut and paste it or you can delete it from its current position and type it again.
The result is shown in the following image.

```
vars
result : String;
begin
  if (Clients::allRetailSales->paySaleItem->RetailSaleItem.price) > 1000000
    result := ;
  endif;
return result;
end;
```

Note that the `result :=` variable declaration has been indented. You can use the Tab key to indent the lines of code. It is good practice to indent the code that lies between the `if` instruction and the `endif` clause so that it is obvious which code is conditional. Note also that the `endif` clause is indented to line up with the `if` instruction. This is also good practice.

A literal message must be inserted to complete the script expression.

11. Type the message into the `result :=` line.

Literal values must be entered between quotation marks, as shown in the following image.

```
vars
result : String;
begin
  if (Clients::allRetailSales->paySaleItem->RetailSaleItem.price) > 1000000
    result := "*** CHECK THIS ONE ***";
  endif;
return result;
end;
```

The asterisk characters have been entered to make the message easily visible when it is printed. These asterisks are part of the literal message and have no other meaning.

In this example, you do not have to set the return type, as `String[100]` is the default value and the character string that is created here is less than thirty characters long.

12. Click the **Save** button to check your script for errors. Any errors are displayed on the **Errors** sheet. After you have reviewed any errors, click on the **Script Code** sheet to correct your code. Click the **Save** button to ensure that there are no further errors and repeat this process as required.

**Note** Do not remove the semicolon characters (`;`). Each statement (other than the `begin` statement) must terminate with a semicolon character (`;`). For details about the script language, see "JADE Language Syntax", in Chapter 1 of the *JADE Developer's Reference*.

The script is then complete.
When this script field is applied to your report, sales items priced at greater than one million dollars are highlighted with the alert message, as shown in the following report extract.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Sarah Bailey</th>
<th>17 Lake Crescent Queenstown</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPART</td>
<td>13</td>
<td>Ancient Run</td>
</tr>
<tr>
<td>PROP</td>
<td>2,004</td>
<td>Famed House</td>
</tr>
<tr>
<td>DEPART</td>
<td>34</td>
<td>Beach Getaway</td>
</tr>
<tr>
<td>Total Sales</td>
<td>$3,216,595.00</td>
<td></td>
</tr>
<tr>
<td>Percentage of total</td>
<td>33.71</td>
<td></td>
</tr>
</tbody>
</table>

Drag the completed script field from the Catalog of Available Fields dialog to the required position in your report layout, which is the field farthest right of the detail line in this example, as shown marked with an arrow in the following image.

In this script code, the result field is not set if the conditional instruction is not satisfied; that is, for sales values of one million dollars or less. You do not need to code this, as the JADE Report Writer puts a null value in the result field by default and nothing is printed in your field when the condition is not satisfied.

However, you might want to output a different message if the condition is not satisfied. This is described in Example 2, in the following section, which uses the else clause of the if instruction to provide an alternative action if the original condition is not satisfied.

For reference material to help you create complex scripts, see:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the *JADE Encyclopaedia of Primitive Types*
- Chapter 1 of the *JADE Developer’s Reference*

If you encounter errors in your scripts, see "Resolving Errors in Scripts", later in this appendix.

**Example 2 - Using the if Instruction and its then and else Clauses**

In Example 1 earlier in this appendix, a message is printed if a sales value is greater than one million dollars. For all sales values that are a million dollars or less, no action is taken and the JADE Report Writer applies a default null value to the result.

However, if you want to apply a message that highlights the sales values that are within reasonable limits (that is, not greater than one million dollars), you need to code an else clause for the if instruction.

**To return a result when the if instruction is not satisfied**

1. Perform the steps documented in Example 1, earlier in this appendix, except that you double-click the if then else command in the Commands folder of the Commands list box in step 3.
The if instruction and its then, else, and endif clauses are then inserted, as shown in the following image.

2. Follow steps 4 through 11 of Example 1 to enter the code that sets the result when the sales value is more than one million dollars. Make sure that you insert your code for the if instruction and then clause before the else clause.

   It is also good practice to indent the else clause so that it lines up with the start of the if instruction, as shown in the following image.

3. Enter another result := variable declaration after the else clause.

   Type it or copy and paste it from the previous line, as shown in the following image.
4. Enter your message as a string literal; that is, enter it between quotation marks, as shown in the following image.

5. To check your script for errors, click the Save button as you did in Example 1, earlier in this appendix.

When you apply the script that includes this code to your report, the warning message is printed for sales values of more than one million dollars. For values less than one million dollars (provided by the else clause), an "OK" message is printed, as shown in the following report extract.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Sarah Bailey</th>
<th>17 Lake Crescent, Queenstown</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEST</td>
<td>13</td>
<td>Ancient Run; 7,599.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.24 % Thursday, 27 Apr 2000</td>
</tr>
<tr>
<td></td>
<td>1000000.00</td>
<td>OK</td>
</tr>
<tr>
<td>PROP</td>
<td>2004</td>
<td>Famed House; 3,200,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>99.49 % Wednesday, 17 May 2000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CHECK THIS ONE</td>
</tr>
<tr>
<td>DEST</td>
<td>34</td>
<td>Beach Getaway; 8,999.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.20 % Thursday, 03 Aug 2000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>OK</td>
</tr>
</tbody>
</table>

**Note** Make sure that you have entered a semicolon (;) at the end of your instructions.

See "Resolving Errors in Scripts", later in this appendix, for a description of any errors that you may encounter.

**Example 3 - Using Nested if Instructions**

This example shows how to add another condition for which to test to your script code. This example tests for sales greater than $8000 but prints a warning message only if the sales item is a destination vacation; that is, it has a sales code of DEST.

For details about creating the first if condition, see steps 1 through 9 in Example 1, earlier in this appendix.
The following image shows the first if condition, where the comparison figure is 8000 in the current example.

![Image of script code]

You then apply the second condition.

To add the second condition

1. Click in the line below the current if instruction.
2. Select (double-click) the if then command in the Commands folder of the Commands list box.

Another set of if instruction and its then and endif clauses are then inserted, as shown in the following image.

![Image of script code]

3. Click between the second-level if instruction and the then clause.
4. From the Fields list box, select (double-click) the field on which you are going to test your second-level condition.
In this example, another report field is selected, as shown in the following image.

In this example, this field is to be compared to the "DEST" literal value, which is the sales code prefix for destination vacation sales items. The following image shows the field after it has been selected.

5. Select (double-click) the equals sign (=) from the Comparison operators folder in the Commands list box (or simply type it).

6. Enter the literal value with which you want to compare the sales code prefix, as shown in the following image.

7. Assign your literal message to your result.
Type the `result :=` variable declaration below the second `if` instruction, or cut and paste the line from lower in your code, as shown in the following image.

The script code is then complete, but it is good practice to tidy up your code indentations in order to outline the logic.

8. It is good coding practice to indent the second `if` instruction, as it is executed only if the first `if` condition is satisfied. Similarly, the result line should be indented again, as it is executed only if both `if` conditions are satisfied.

Finally, lining up both `endif` clauses so that they match their respective `if` instructions makes the structure of your code clearer, as shown in the following image.

9. To check your script for errors, click the `Save` button as you did in Example 1, earlier in this appendix.

When this script field is applied to the report, sales items for destination vacations that have a price greater than $8,000 have the warning message displayed, as shown in the following image.
Using Intermediate Variables

When you start a new script and select the Full Script option button on the Add Script Field dialog, the skeleton code that is provided includes a variable declaration for the result variable, as shown in the following image.

```
vars
    result : String;
begin
    result := ;
    return result;
end;
```

In complex scripts, you may need to store an intermediate value that you are going to use to derive the final result. You can declare your own variables for this purpose, as shown in the following image in which a variable named tax is declared.

```
vars
    result : String;
    tax : Decimal[12,2];
begin
    result := ;
    return result;
end;
```

In the following example, it is supposed that a tax was applied to all sales items during the second half of the year, but for some reason it was never applied to destination vacation sales items. For each of these sales items, the 12.5% tax component that should have been applied is printed on the end of the detail line of the sales report.

The conditions for printing the tax component are that the sales item has a code of "DEST" and the sales date is later than June.

One more requirement is that the tax amount is to be printed along with a message that describes what it is; for example:

```
Add 12.5% Tax $1439.55
```

As there can be only one result from a script and the message "Add 12.5% Tax" and the tax amount are different types (string and decimal), the tax amount must be converted to a string so that it can be incorporated into the result. This is very easily done, and demonstrates the use of the methods that are provided on the Add Script Field dialog.

In the following example, the currencyFormat method is used to convert a decimal result into a string in the currency format of the current locale. This Decimal primitive type method must be added to the reporting view the on which report is based in the configuration phase. For details, see "Selecting Script Methods", in Chapter 3.
To create the conditional instructions

- Create two nested if instructions, as described in Example 3 under "Simple Conditional Scripts", earlier in this appendix.

The first instruction tests to see if this is a vacation destination item.

In the second if instruction, only the sales date has been selected at this point, as shown in the following image.

As the sales date is a generic date, you can extract the month portion of the date by applying one of the Date methods listed in the Methods list box of the Add Script Field dialog so that you can determine whether the date is later than June.

To compare the month portion of the sales date

1. In your script code, position the insertion point by clicking at the end of the date field in the second if instruction.

2. Open the Date folder in the Methods list box and then select (double-click) the month method, as shown in the following image.

The month method returns the month portion of the date as an integer (whole number) value.
When you select the method, it is applied to the sales date, as shown in the following image.

```
vars
    result : String;
begin
    if {Clients::allRetailSales->mySaleItem->RetailSaleItem.codePrefix} = "T"
        if {Clients::allRetailSales->date}.month() then
            endif;
        endif;
    result := ;
```

Having obtained the month portion of the sales date, test it to see if it is greater than 6; that is, it is later than June, the sixth month of the year.

3. Select the **greater than** sign (>) from the Comparison operators folder in the **Commands** list box (or you can type it).

4. Enter the value **6**.

The resulting script code is shown in the following image.

```
vars
    result : String;
begin
    if {Clients::allRetailSales->mySaleItem->RetailSaleItem.codePrefix} = "T"
        if {Clients::allRetailSales->date}.month() > 6 then
            endif;
        endif;
    result := ;
```

The result field then needs to be calculated. The result of the calculation needs to be assigned to an intermediate decimal variable, as the tax value is to be part of a message string in the final result.
To create an intermediate variable to contain the tax field

1. In your script code, position the insertion point by clicking below the `result` variable.

2. Open the Variable declarations folder in the `Commands` list box and then double-click the `Decimal variable` command, as shown in the following image.

The variable is then inserted at your caret, as shown in the following image.

3. Enter a meaningful name for the variable in place of the default name represented by the `x` character that has been assigned.

In this example, it is named simply `tax`, as shown in the following image.

You could change the maximum length and the number of decimal places, by overwriting the values within the square brackets. For this example, the default length of 12 and the number of decimal places (2) is adequate.
To assign the result of the tax calculation to the tax variable

1. Within the second if condition, enter the variable and the assignment operator (:=), as shown in the following image.

```
vars
result : String;
tax : Decimal[12,2];
begin
  if (Clients::allRetailSales->mySaleItem->RetailSaleItem.code?prefix) = 'T
    if (Clients::allRetailSales->date).month() > 6 then
      tax :=
    endif;
  endif;
end;
```

If you do not know the assignment symbol (:=), you can select it from the Commands folder in the Commands list box.

2. Select the sales price field from the Field Catalog in the Fields list box.

3. Select (or type in) the multiplication symbol (*).

4. Enter the multiplier. In this example, the multiplier is 0.125 (that is, 12.5%), as shown in the following image.

```
result : String;
tax : Decimal[12,2];
begin
  if (Clients::allRetailSales->mySaleItem->RetailSaleItem.code?prefix) = 'DEST' then
    if (Clients::allRetailSales->date).month() > 6 then
      tax := (Clients::allRetailSales->mySaleItem->RetailSaleItem.price) * 0.125;
    endif;
  endif;
end;
```

For detailed instructions about performing steps 2 through 4, see "Using Arithmetic Expressions" under "Single Expression Script Examples", earlier in this appendix.

At this point in the code, the tax variable contains the sales price multiplied by 12.5% and this value is stored in Decimal primitive type format. It is to be assigned to the result as part of a message string.

To incorporate the numeric tax value into a message string

1. Move the result := ; line to the line after the tax calculation and then click in the space in front of the semicolon character (;) to make the insertion point.
2. Enter the text part of the message within quotation marks, as shown in the following image.

```
vars
result: String;
tax: Decimal[12,2];
begin
  if (Clients::allRetailSales->mySaleItem->RetailSaleItem.codePrefix) = "DEST" then
    if (Clients::allRetailSales->date).month() > 6 then
      tax := (Clients::allRetailSales->mySaleItem->RetailSaleItem.price) * 0.1
      result := "12.5% Tax" + tax;
    end;
  end;
```

Note that a space has been entered at the end of the text string and before the last quotation mark. This produces a space between the text and the tax amount when they are concatenated.

3. Open the String operators folder in the Commands list box and then double-click the concatenation symbol (&).

4. Enter your tax variable, as shown in the following image.

```
vars
result: String;
tax: Decimal[12,2];
begin
  if (Clients::allRetailSales->mySaleItem->RetailSaleItem.codePrefix) = "DEST" then
    if (Clients::allRetailSales->date).month() > 6 then
      tax := (Clients::allRetailSales->mySaleItem->RetailSaleItem.price) * 0.1
      result := "12.5% Tax" + tax;
    end;
  end;
```

This produces an error, as `tax` is a numeric value and the result is specified as having a return type of `String`. However, the `Decimal` primitive type has methods that you can apply to create string versions of the decimal field.

5. Open the `Decimal` folder in the Methods list box and select the `currencyFormat` method.

When this method is applied to the `tax` field, it returns a string version of the field in the currency format specified for the JADE Report Writer Designer session.

**Note** The `currencyFormat` method must be included in the view before you can select it in the JADE Report Writer Designer. For details, see "Selecting Script Methods", in Chapter 3.
6. To check your script for errors, click the Save button as you did in Example 1, earlier in this appendix.

The following image shows a section of a report into which this script field has been inserted into the column at the right.

The third sales item in the previous example is the only one that meets both conditions that were coded into the script, because it is a destination vacation item and it has a sales date that is later than June.

For reference material to help you create complex scripts, see:

- Appendix B, "Script Commands"
- Appendix C, "Script Fields"
- Chapter 1 of the JADE Encyclopaedia of Primitive Types
- Chapter 1 of the JADE Developer’s Reference

If you encounter errors in your scripts, see "Resolving Errors in Scripts", in the following section.

**Resolving Errors in Scripts**

The JADE Report Writer script facility enables you to resolve any code errors on the fly.

When you have created your script and you click the Save button on the Add Script Field dialog, the Errors sheet is automatically displayed if your script code contains one or more errors. Only the first error is displayed on the Errors sheet. Once you have reviewed the error, you can switch back to your code on the Script Code sheet and make any corrections that are required. Any subsequent error is then displayed in turn, as you click the Save button to reapply your modified code.

A typical error is shown in the following image.
You can view your script with line numbers down the left-hand side by right-clicking on the Script Code sheet and selecting the Line Numbers options.

In the previous image, the Incompatible types error is displayed because the result is declared as a decimal while the code is attempting to assign a string. This is probably the most common error you will encounter. In all cases in which the Errors sheet is displayed, perform the following actions to correct errors in your script code.

1. Make sure that you understand what has caused the error. The common errors that you could encounter are described in "Script Errors", later in this section.
2. Click the Script Code tab to display the Script Code sheet again.
3. Correct the code that is in error.
4. Click the Save button on the Add Script Field dialog.

If there are further errors, the Errors sheet is displayed again. Perform steps 1 through 4, until you have resolved all errors.

**Script Errors**

When a script contains one or more errors, the description of the first error is displayed on the Errors sheet after the script is applied. If more errors are present, they are displayed in turn, as each one is resolved.

The script code in which the error was detected and the corresponding line number are also displayed. The highlighted code may be the source of the error or there may be an error earlier in the code, with no inconsistency being detected until the highlighted line.
Always check your code carefully when an error is reported, and if the highlighted line seems correct, check preceding lines for an undetected error.

The following table lists the common or typical script error messages that can be encountered, with an explanation of each. It is not a comprehensive list of errors in JADE code.

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expecting [expression] with</td>
<td>Indicates an incomplete line of script logic.</td>
</tr>
<tr>
<td>Incompatible types</td>
<td>Inconsistent use of JADE types with items; for example, using a non-numeric value (such as a string) with a numeric data item.</td>
</tr>
<tr>
<td>Incompatible operand</td>
<td>Incorrect or incomplete script logic syntax. The input contains a pair of operands that are not compatible for the operation that is being performed; for example, it is invalid to add a Real value to a Date or to compare a Binary with an Integer by using the &lt; operator.</td>
</tr>
<tr>
<td>Unknown identifier</td>
<td>Use of an undefined (undeclared) variable or something that the system attempts to treat as an identifier (that is, a value that has meaning to JADE, such as a constant or method name). This is often the result of a spelling error.</td>
</tr>
<tr>
<td>Unknown type</td>
<td>An incorrect type definition used in the vars statement.</td>
</tr>
<tr>
<td>Expecting then</td>
<td>Missing then clause at the end of an if instruction line.</td>
</tr>
<tr>
<td>Expecting endif</td>
<td>Missing endif clause from an if statement.</td>
</tr>
<tr>
<td>Method does not return a value</td>
<td>The method needs to have a return [value] statement in it.</td>
</tr>
<tr>
<td>String delimiter mismatch</td>
<td>Indicates a string literal value with an opening quote mark (either single or double) but without the same closing quote; for example: string := &quot;hello&quot;</td>
</tr>
<tr>
<td>Invalid statement</td>
<td>Use of incorrect script logic syntax. The following is an example of incorrect script syntax. result := &quot;abc&quot;;</td>
</tr>
<tr>
<td></td>
<td>The following example is the correct script syntax. result := &quot;abc&quot;;</td>
</tr>
<tr>
<td></td>
<td>Note the correct use of the assignment operator.</td>
</tr>
<tr>
<td>Non-numeric operand</td>
<td>Attempting to perform a numeric operation such as * (multiplication) or + (addition) on an item that is not a number.</td>
</tr>
<tr>
<td>Return expression mismatch</td>
<td>The type of the item in the return statement is not the same as the defined return type of the script.</td>
</tr>
<tr>
<td>This is not allowed in report scripts</td>
<td>Use of a JADE language feature that is not allowed in report scripts (for details, see &quot;Script Language Restrictions&quot;, earlier in this appendix).</td>
</tr>
</tbody>
</table>

**Report Execution**

Scripts are always evaluated in the Report Generator phase, not in the Query Processor phase. When a report variable is used in more than one script, the order in which the scripts are executed is important.

There are up to three phases in the execution of a report. Within each phase, scripts are evaluated in ascending order of name unless there is a dependency between them that changes this.
The first process, the pre-process occurs when the Report Generator phase first starts, before any data from the Query Processor phase has been read. The pre-process covers scripts which do not access any data items. These scripts are evaluated once at the start.

The second process, called the reading phase occurs when the data for the report is read from the Query Processor phase. Scripts that are used selection, group, or sort criteria and those themselves summarized are evaluated at the reading phase.

The third process, the printing phase occurs when the data is printed. If both the reading phase and printing phase are present, the printing phase is a second reading of the data from the query engine, otherwise the reading phase and printing phase are combined. For example, with scripts A and B evaluated at pre-process time, C and D in the reading phase and E and F at print time, and three sets of data items (effectively three detail lines) present, data1 through data3, the overall order of script evaluation is:

1.  A
2.  B
3.  C (data1)
4.  D (data1)
5.  C (data2)
6.  D (data2)
7.  C (data3)
8.  D (data3)
9.  E (data1)
10. F (data1)
11. E (data2)
12. F (data2)
13. E (data3)
14. F (data3)

### Changing Execution Times for a Script

The Evaluation Time options on the Add Scripts dialog enables you to override when the script is evaluated. This enables flexibility when using report variables, however, it is not restricted to report variable usage.

To select the evaluation time for the script, select one of the following option buttons as the Evaluation Time:

- Default
- Before Read of the Query Processor results
- Reading of the Query Processor results
- Printing

The default value is Default, which means the report writer works it out (according to what the script uses).
Summary Fields Based on Script Fields

When a summary field is based on a database field, the summary is evaluated based on the values of the database field in the detail section. If the detail section does not include the database field, the summary field is evaluated as if it were included. The situation is less clear if the summary field is based on a script field.

The value of a summary field based on a script field depends on the sections of the report that include the script field. If the script field is included only in a header or footer section, the script field values in that section are summarized; otherwise, the script field is evaluated for each detail section, and those values are summarized.
Appendix B  Script Commands

This appendix describes the commands that are available from the Commands list box of the Add Script Field and Update Script Field dialogs.

Script commands are described in the following subsections.

- Overview
- Arithmetic Operators
- Comparison Operators
- String Operators
- Commands
- Variable Declarations

Overview

The Commands list box of the Add Script Field and Update Script Field dialogs, shown in the following image, contains the commands, operators, and declarations that enable you to create script code. For single expression scripts, only the Arithmetic operators and String operators are displayed.

The commands provided by the script facility are a subset of the JADE language. If you are proficient in writing JADE code, you can utilize more commands than those that are available in the script facility. However, this appendix describes only those commands that are provided through the Commands list box.

If you intend to utilize more of the JADE language features than those that are available in the script facility and you have access to the JADE product information library, Chapter 1 of the JADE Developer’s Reference provides details to assist you.

You can open each folder in the Commands list box to display the list of the operators, commands, or declarations within. The commands are listed in the following table.

<table>
<thead>
<tr>
<th>Commands</th>
<th>Displayed for…</th>
<th>Enables you to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic Operators</td>
<td>All script types</td>
<td>Apply arithmetic in your scripts</td>
</tr>
<tr>
<td>String Operators</td>
<td>All script types</td>
<td>Manipulate character strings</td>
</tr>
<tr>
<td>Commands</td>
<td>Full scripts only</td>
<td>Use some language commands</td>
</tr>
<tr>
<td>Comparison Operators</td>
<td>Full scripts only</td>
<td>Compare fields</td>
</tr>
<tr>
<td>Variable Declarations</td>
<td>Full scripts only</td>
<td>Declare the types of your variables</td>
</tr>
</tbody>
</table>
Arithmetic Operators

The arithmetic operators are provided to enable you to apply arithmetic in your script code.

The arithmetic operators are displayed when you open the Arithmetic operators folder in the Commands list box of the Add Script Field or Update Script Field dialogs, as shown in the following image.

The arithmetic operators are described in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
<th>When selected, provides…</th>
</tr>
</thead>
<tbody>
<tr>
<td>x + y</td>
<td>Add</td>
<td>The addition symbol (+).</td>
</tr>
<tr>
<td>x - y</td>
<td>Subtract</td>
<td>The subtraction symbol (-).</td>
</tr>
<tr>
<td>x * y</td>
<td>Multiply</td>
<td>The multiplication symbol (*).</td>
</tr>
<tr>
<td>x / y</td>
<td>Divide</td>
<td>The division symbol (/). This provides Real division (for example, 7 / 3 = 2.33333333333333).</td>
</tr>
<tr>
<td>x div y</td>
<td>Integer division (with truncation)</td>
<td>Integer division (division with truncation; for example, 7 div 3 = 2).</td>
</tr>
<tr>
<td>x mod y</td>
<td>Modulus (remainder after integer division)</td>
<td>Modulus (remainder after integer division; for example, 7 mod 3 = 1).</td>
</tr>
</tbody>
</table>

Order of Precedence

Arithmetic operations follow the universally accepted order of precedence, which is as follows.

1. Operations inside parentheses are performed first; for example:
   
   \[(x + y) * 3\]
   
   In this example, \(x\) is added to \(y\) and then the result is multiplied by 3.

2. Multiply and divide operations are performed next; for example:
   
   \[x * y / z + 3\]
   
   In this example, \(x\) is multiplied by \(y\) and the result is then divided by \(z\) (following the left-to-right rule) and then 3 is added to the result.

3. Finally, addition and subtraction operations are performed.

Operations are performed left-to-right when they otherwise have equal precedence; for example:

\[x * y / z\]

In this example, \(x\) is multiplied by \(y\) and then the result is divided by \(z\).
Order of Precedence Example

The following example demonstrates all of the precedence rules in one formula.

\[
\text{result} := (a + b) / c + (x - y) \times z;
\]

The left-to-right rule dictates that the \((a + b) / c\) expression is performed before the \((x - y) \times z\) expression. Within each of these expressions, the operations in parentheses are performed first, followed by the divide and multiply operations.

Having resolved the \((a + b) / c\) expression and the \((x - y) \times z\) expression, the addition is then performed. The importance of the parentheses to the precedence is shown in the following table in which the same values have been substituted in the expressions \((a + b) / c\) and \(a + b / c\), producing completely different results.

<table>
<thead>
<tr>
<th>Expression</th>
<th>With Values Substituted</th>
<th>Interim Result</th>
<th>Final Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>((a + b) / c)</td>
<td>((3 + 8) / 2)</td>
<td>(11 / 2)</td>
<td>(5.5)</td>
</tr>
<tr>
<td>(a + b / c)</td>
<td>(3 + 8 / 2)</td>
<td>(3 + 4)</td>
<td>(7)</td>
</tr>
</tbody>
</table>

String Operators

The string operators are provided to enable you to manipulate strings in your scripts. The string operators are displayed when you open the String operators folder in the Commands list box of the Add Script Field or Update Script Field dialogs, as shown in the following image.

The string operators are listed in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Purpose</th>
<th>Enables you to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>Concatenation</td>
<td>Combine strings sequentially</td>
</tr>
<tr>
<td>[n]</td>
<td>&quot;n&quot;th character</td>
<td>Access a specified character within the string</td>
</tr>
<tr>
<td>[n:length]</td>
<td>&quot;n&quot; for length</td>
<td>Access a piece of the string from a specified position and for a specified length</td>
</tr>
<tr>
<td>[n:end]</td>
<td>&quot;n&quot; to end</td>
<td>Access a piece of the string from a specified position and to the end of the string</td>
</tr>
</tbody>
</table>

String Operators Examples

The following example demonstrates the use of the concatenation character (\&). In this example, the result is a string that combines the two lines of address separated by a comma (, ) and one space.

\[
\text{result} := \{\text{Clients::address1}\} \& " \, " \& \{\text{Clients::address2}\};
\]

The following example demonstrates the use of the [n] operator and the concatenation character (\&). In this example, the result is a string that consists of the first character of the first name and the entire second name, separated by a comma (, ) and one space.

\[
\text{result} := \{\text{Clients::name1}\}[1] \& " \, " \& \{\text{Clients::name2}\};
\]
The following example demonstrates the use of the \([n:length]\) operator. In this example, the result is a string containing the third and fourth characters of the code prefix.

\[
\text{result} := \{\text{Clients::allRetailSales->codePrefix}\}[3:2];
\]

The following example demonstrates the use of the \([n:end]\) operator. In this example, the result is a string containing all of the characters from the second character of the code prefix to the end of the code prefix, inclusive.

\[
\text{result} := \{\text{Clients::allRetailSales->codePrefix}\}[2:end];
\]

**Commands**

Commands enable you to code simple statements in your scripts. The commands are displayed when you open the Commands folder in the Commands list box of the Add Script Field or Update Script Field dialogs, as shown in the following image.

Commands are available only for full scripts.

The commands are listed in the following table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Purpose</th>
<th>Enables you to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>if then</td>
<td>Purpose</td>
<td>Create conditional instructions that execute action if the condition is true.</td>
</tr>
<tr>
<td>if then else</td>
<td>Purpose</td>
<td>Create conditional instructions that execute actions if the condition is true or another set of actions if the condition is false.</td>
</tr>
<tr>
<td>:=</td>
<td>Assignment</td>
<td>Assign a value to a variable; for example, result := {\text{Clients::address1}}.</td>
</tr>
<tr>
<td>///</td>
<td>Comment</td>
<td>Include comment lines in your scripts.</td>
</tr>
</tbody>
</table>

**Commands Examples**

Examples of using the commands are shown in the following code fragments.

The following example demonstrates the use of the \(\text{if}\) instruction and its \(\text{then}\) clause. In this example, a warning message is placed against sales items that are priced more than $8,000.

\[
\text{if } \{\text{Clients::allRetailSales->mySaleItem->price}\} > 8000 \text{ then}
\text{result} := "*** CHECK THIS ONE ***";
\text{endif};
\]

The following example demonstrates the use of the \(\text{if}\) instruction and its \(\text{then}\) and \(\text{else}\) clauses. In this example, a warning message is placed against sales items that are priced more than $8,000 and the message \(\text{OK}\) is placed against any other record.

\[
\text{if } \{\text{Clients::allRetailSales->mySaleItem->price}\} > 8000 \text{ then}
\text{result} := "*** CHECK THIS ONE ***";
\text{else}
\text{result} := "OK";
\text{endif};
\]
The following example uses the previous code, but with explanatory comments included to demonstrate the use of comment lines in scripts. Comments do not in any way affect the execution of the script.

```java
if (Clients::allRetailSales->mySaleItem->price) > 8000 then
    result := "*** CHECK THIS ONE ***";
else
    result := "*** OK ***";
endif;
```

For step-by-step instructions about writing conditional scripts, see "Creating Full Scripts", in Appendix A.

### Comparison Operators

Comparison operators are provided to enable you to build comparison statements in your scripts. The comparison operators are displayed when you open the Comparison operators folder in the Commands list box of the Add Script Field or Update Script Field dialogs, as shown in the following image.

Comparison operators are available only for full scripts. The comparison operators are listed in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
<th>When selected, provides…</th>
</tr>
</thead>
<tbody>
<tr>
<td>x = y</td>
<td>Equals</td>
<td>The equals symbol (=)</td>
</tr>
<tr>
<td>x &lt; y</td>
<td>Less than</td>
<td>The less than symbol (&lt;)</td>
</tr>
<tr>
<td>x &lt;= y</td>
<td>Less than or equal to</td>
<td>The less than or equal to symbol (&lt;=)</td>
</tr>
<tr>
<td>x &gt; y</td>
<td>Greater than</td>
<td>The greater than symbol (&gt;)</td>
</tr>
<tr>
<td>x &gt;= y</td>
<td>Greater than or equal to</td>
<td>The greater than or equal to symbol (&gt;=)</td>
</tr>
<tr>
<td>x &lt;&gt; y</td>
<td>Not equal to</td>
<td>The not equal to symbol (&lt;&gt; )</td>
</tr>
<tr>
<td>and</td>
<td>Logical and</td>
<td>The and operator</td>
</tr>
<tr>
<td>or</td>
<td>Logical or</td>
<td>The or operator</td>
</tr>
<tr>
<td>not</td>
<td>Logical not</td>
<td>The not operator</td>
</tr>
</tbody>
</table>
Comparison Operator Examples

The code fragments in the following example show the use of comparison operators.

```plaintext
if (Clients::name) = "Jarvis" then  // equals
    result := "Check this client";
endif;

if (Clients::allRetailSales->price} < 10 then  // less than
    result := "Too cheap";
endif;

if (Clients::allRetailSales->price} <= 10 then  // less than or equal to
    result := "Too cheap";
endif;

if (Clients::allRetailSales->price} > 100 then  // greater than
    result := "Too expensive";
endif;

if (Clients::allRetailSales->price} >= 100 then  // greater than or equal to
    result := "Too expensive";
endif;

if (Clients::name) <> "Jarvis" then  // not equal to
    result := "OK";
endif;

if (Clients::name) = "Jarvis"  
    and (Clients::allRetailSales->price} > 8000 then  // and
    result := "Check this client";
endif;

if (Clients::name) = "Jarvis" or (Clients::name} = "Granville" then  // or
    result := "Check these clients";
endif;
```

The result of the comparison operations is a Boolean logical value; that is, one of the values true or false. If you simply require to print the Boolean value in your detail line, you do not need to use the if instruction, as shown in the following example.

```plaintext
vars
    result : Boolean;
begin
    return (Clients::name) = "Jarvis";
end;
```

In this example, the return value is set to the Boolean result of the comparison; that is, for clients named Jarvis, this script returns the value true. It returns the value false for all other names.

Variable Declarations

Variable declarations are provided to enable you declare the types of any intermediate variables that you use in your scripts.
You are provided with a default variable declaration for the result field of your script, as follows.

```plaintext
define vars
    result : String;
begin
    ...  // do some processing here
enddefine
```

However, if your script performs complex arithmetic or you want a string result from an arithmetic calculation, you often need to declare a variable to hold an intermediate value, as follows.

```plaintext
define vars
    result : String;
    tax    : Decimal[12,2];
begin
    ...  // do some processing here
enddefine
```

The variable declarations are displayed when you open the Variable declarations folder in the Commands list box of the Add Script Field or Update Script Field dialogs, as shown in the following image.

![Variable Declarations](image)

The variable declaration (primitive) types are described in Chapter 1 of the JADE Encyclopaedia of Primitive Types.
Appendix C  Script Fields

This appendix describes the Fields list box of the Add Script Field, Update Script Field, and the Format Script dialogs.

The field categories are described in the following subsections.

- Overview
- Report Fields
- Parameter Fields
- Script Fields
- Summary Fields
- Database Fields
- Method Fields
- Report Variables
- Special Fields
- Format Properties
- Format Constants

Overview

The Fields list box of the Add Script Field, Update Script Field, and Format Script dialogs contains a list of the fields that you can insert into your scripts. The fields, which are grouped by category, are listed in the following table.

<table>
<thead>
<tr>
<th>Field Category</th>
<th>Provides…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Fields</td>
<td>The database fields that you have inserted into your report design.</td>
</tr>
<tr>
<td>Parameter Fields</td>
<td>The parameter fields you have created in your report design.</td>
</tr>
<tr>
<td>Script Fields</td>
<td>The script fields you have previously created in your report design.</td>
</tr>
<tr>
<td>Summary Fields</td>
<td>The summary fields you have created in your report design.</td>
</tr>
<tr>
<td>Database Fields</td>
<td>The database fields as defined in the view used by your report design.</td>
</tr>
<tr>
<td>Method Fields</td>
<td>The method fields you have created in your report design.</td>
</tr>
<tr>
<td>Report Variables</td>
<td>The report variables you have created in your report design.</td>
</tr>
<tr>
<td>Special Fields</td>
<td>Standard content fields used in your report design.</td>
</tr>
<tr>
<td>Format Properties</td>
<td>The properties for the field. This field is only displayed on the Format Scripts dialog.</td>
</tr>
<tr>
<td>Format Constants</td>
<td>The constants for the field. This field is only displayed on the Format Scripts dialog.</td>
</tr>
</tbody>
</table>
Report Fields

The following image shows the Report Fields category expanded to show the fields that have been included in the report example used in this guide. The sales price has been selected and is subsequently displayed in the Script Code sheet.

Report Fields and Database fields are designated by the brace symbols (that is, the { and } symbols, sometimes know as curly brackets) that enclose them, as shown in the example.

\{Clients::allRetailSales->mySaleItem->RetailSaleItem.price\}

The arrows (\(\rightarrow\)) indicate the path to the price field, which is accessed from the Clients root collection through the references allRetailSales and mySaleItem.

Notes The path includes the name of the RetailSaleItem subclass in the notation RetailSaleItem.price to specify the price feature of the RetailSaleItem subclass of SaleItem.

The result would be the same if you had selected the field from the Database Field folder. If the field you want is a report field, however, it is more convenient to select it from the Report Fields folder.

Parameter Fields

The following image shows the Parameter Fields category expanded to show the fields that have been included in the report example used elsewhere in this guide. The exchangeRate parameter has been selected and is subsequently displayed in the Script Code sheet.

Notes The path includes the name of the RetailSaleItem subclass in the notation RetailSaleItem.exchangeRate to specify the exchangeRate feature of the RetailSaleItem subclass of SaleItem.
Parameter fields are designated by the question mark (?) prefix and the brace symbols (that is, the { and } symbols, sometimes known as curly brackets) that enclose them, as shown in the example.

```{?performance bonus}
```

For details about creating and using parameter fields, see "Using the Param Sheet", under "Using the Catalog of Available Fields Dialog", in Chapter 4.

**Script Fields**

You can use scripts that have been created previously in a new script. The previously created script is calculated or resolved as part of your script code.

In the following image, the Script Fields category has been expanded and shows some example script fields that have been used elsewhere in this guide. The inUSD script has been selected and is subsequently displayed in the Script Code sheet.

In this example, the US dollar value is required to be printed as part of a string.

There is no need to perform the exchange rate calculation in the current script, as it is performed by the inUSD script and the result is converted to a character string in the current script by applying the `currencyFormat` method.

Script fields are designated by the at sign (@) prefix and the brace symbols (that is, the { and } symbols, sometimes known as curly brackets) that enclose them, as shown in the example.

```{@addresses}
```

For details about creating script fields, see "Using the Script Sheet" under "Using the Catalog of Available Fields Dialog", in Chapter 4.
Summary Fields

In the following image, the Summary Fields category has been expanded and shows some example summary fields that have been used elsewhere in this guide. The grand total summary field has been selected and is subsequently displayed in the Script Code sheet.

Summary fields are designated by the exclamation mark (!) prefix and the brace symbols (that is, the { and } symbols, sometimes know as curly brackets) that enclose them, as shown in the example.

{!grand total}

For details about creating summary fields, see "Using the Summary Sheet" under "Using the Catalog of Available Fields Dialog", in Chapter 4.

Method Fields

You can use method fields as named calls to a specified method with specified parameters in your scripts. Method parameters are literal or report parameter values only (that is, they cannot be database features) that have been created previously. In the following image, the Method Fields category has been expanded and shows an example method field that has been used elsewhere in this guide. The price method field has been selected and is subsequently displayed in the Script Code sheet.

Method fields are designated by the pound or hash sign (#) prefix and the brace symbols (that is, the { and } symbols, sometimes know as curly brackets) that enclose them, as shown in the example.

#{price}
For details about creating method fields, see "Using the Methods Sheet" under "Using the Catalog of Available Fields Dialog", in Chapter 4.

Database Fields

The following image shows the Database Fields category expanded. Database fields for address lines have been selected.

![Database Fields Diagram]

Database fields and Report Fields are designated by the brace symbols (that is, the { and } symbols, sometimes know as curly brackets) that enclose them, as shown in the example.

\{Clients::address3\}

**Note**  If the field that you want to insert in your script has been included in your report design, it is more convenient to select it from the Report Fields folder. For details, see "Report Fields", earlier in this appendix.

For details about creating reporting views, see Chapter 3. For details about inserting a database field, see "Inserting a Database Field" under "Using the Detail Functions", in Chapter 4.

Report Variables

The following image shows the Report Variables category expanded to show the fields that have been included in the report example used elsewhere in this guide. The var1 variable has been selected and is subsequently displayed in the Script Code sheet.

![Report Variables Diagram]

Report variables are designated by the dollar sign ($) prefix and the brace symbols (that is, the { and } symbols, sometimes known as curly brackets) that enclose them, as shown in the example.
For details about creating and using report variables, see "Using the Variables Sheet", under "Using the Catalog of Available Fields Dialog", in Chapter 4.

**Special Fields**

The following image shows the Special Fields category expanded to show the special fields used in your report. The **Report Date** special field has been selected and is subsequently displayed on the **Script Code** sheet.

Special fields are designated by the tilde symbol (~) prefix and the brace symbols (that is, the { and } symbols, sometimes know as curly brackets) that enclose them, as shown in the example.

```
{~Report Date}
```

The fields **Group Field Name** and **Group Field Alias** are special cases. If there are no groups defined in the report, these fields return **null**.

If the script field is evaluated in a group section, these fields return the appropriate (current) group name or alias for the group; otherwise, when evaluated in a section that is not a group section, these fields return the group name or alias for the lowest-level group in the report, this being the last group processed.

For details about using special fields in your reports, see "Inserting a Special Field" under "Inserting Report Fields", in Chapter 4.

**Format Properties**

The Format Properties category is displayed on the Format Scripts dialog. The Format Properties category of the **Fields** list box list each property of the current field which can be used in the script. The include layout properties (for example, **alignment**, **borderStyle**, and **visible**), font properties (for example, **fontName**, and **fontSize**), and format properties (for example, **showAsCurrency**, and **thousandSeparator**).

The properties displayed on the Format Properties category of the **Fields** list box depend on the field from which the format script dialog is accessed; for example, numeric format properties are shown only for a numeric field. The following subsection identifies the properties.
Section Format Scripts

The following table lists the properties in the Format Properties category of the **Fields** list box on the Format Script dialog for a report section format script. The table displays the property shown in the Format Properties category, the related field on the Section Properties dialog, and the values that can be entered. Setting the section value in the format script overrides the selection made on the Section Properties dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td>visible</td>
<td>Visible in the Report</td>
<td>True or False.</td>
</tr>
<tr>
<td>printAtBottomOfPage</td>
<td>Print at the bottom of the Page</td>
<td>True or False.</td>
</tr>
<tr>
<td>startNewPageBefore</td>
<td>New Page BEFORE printing</td>
<td>True or False.</td>
</tr>
<tr>
<td>startNewPageAfter</td>
<td>New Page AFTER printing</td>
<td>True or False.</td>
</tr>
<tr>
<td>restartPageNumberAfter</td>
<td>Restart Page Number after printing</td>
<td>True or False.</td>
</tr>
<tr>
<td>suppressIfNoData</td>
<td>Suppress Printing if No Data</td>
<td>True or False.</td>
</tr>
<tr>
<td>skipPageHeaderFirstPage</td>
<td>Skip Page Header on first Page</td>
<td>True or False.</td>
</tr>
<tr>
<td>combineFollowingSections</td>
<td>Combine with the Following</td>
<td>True or False.</td>
</tr>
<tr>
<td>fixedHeight</td>
<td>Fixed height when printing</td>
<td>A positive number.</td>
</tr>
<tr>
<td>height</td>
<td>Height</td>
<td></td>
</tr>
<tr>
<td>backColor</td>
<td>Color</td>
<td>The number for the color, or select the color from the <strong>Format Constants</strong> category. For more details, see &quot;Format Constants&quot;, later in this chapter.</td>
</tr>
</tbody>
</table>

For more details about how section properties affect your report, see steps 2 through 17 under "Changing the Section Properties using the Properties Command", in Chapter 4.

**Note**  The properties displayed in the Format Properties category of the **Fields** list box depend on the field from which the format script dialog is accessed.

Field Format Scripts

The following table lists the properties in the Format Properties category of the **Fields** list box on the Format Script dialog for a field format script. The table displays the properties shown in the Format Properties category, the related fields on the Field Properties dialog, and the values that can be entered. Setting the property value in the format script overrides the value for the field set on the Field Properties dialog for the selected field.

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Common Tab Properties</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>fieldTitle</td>
<td>Title</td>
<td>A title for the field.</td>
</tr>
<tr>
<td>visible</td>
<td>Visible</td>
<td>True or False.</td>
</tr>
<tr>
<td>autoSize</td>
<td>Auto Size</td>
<td>True or False.</td>
</tr>
<tr>
<td>suppressDuplicates</td>
<td>Suppress Duplicate Values</td>
<td>True or False.</td>
</tr>
<tr>
<td>Property</td>
<td>Section Properties Dialog Field</td>
<td>Enter…</td>
</tr>
<tr>
<td>----------------</td>
<td>---------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>borderStyle</td>
<td>Border Style</td>
<td>The number for the border style, or select the border style from the Format Constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
<tr>
<td>alignment</td>
<td>Alignment</td>
<td>The number for the alignment style, or select the alignment style from the Format Constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
<tr>
<td>backColor</td>
<td>Background Color</td>
<td>The number for the color, or select the color from the Format Constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
</tbody>
</table>

**Font Tab Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td>fontName</td>
<td>Font</td>
<td>A character string, length of 31 or less.</td>
</tr>
<tr>
<td>fontSize</td>
<td>Size</td>
<td>A number, minimum of 6, maximum of 72.</td>
</tr>
<tr>
<td>fontBold</td>
<td>&quot;B&quot; button</td>
<td>True or False.</td>
</tr>
<tr>
<td>fontItalic</td>
<td>&quot;I&quot; button</td>
<td>True or False.</td>
</tr>
<tr>
<td>fontUnderline</td>
<td>&quot;U&quot; button</td>
<td>True or False.</td>
</tr>
<tr>
<td>fontColor</td>
<td>Color</td>
<td>The number for the color, or select the color from the Format Constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
</tbody>
</table>

**Picture Tab Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td>pictureStretch</td>
<td>Picture Stretch</td>
<td>The number for the stretch constant, or select the stretch constant from the Stretch constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
</tbody>
</table>

**Number Tab Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td>showAsCurrency</td>
<td>Show as Number/Currency</td>
<td>False for number, or True for currency.</td>
</tr>
<tr>
<td>positiveFormat</td>
<td>Positive</td>
<td>A number, or select the Positive Format from the Positive Format constants category. Used only if showAsCurrency is True. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
<tr>
<td>negativeFormat</td>
<td>Negative</td>
<td>A number, or Negative Format select the Negative Format from the constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
<tr>
<td>currencySymbol</td>
<td>Currency Symbol</td>
<td>A character string length 5 or less; used only if showAsCurrency is True.</td>
</tr>
<tr>
<td>thousandsSeparator</td>
<td>1000’s Separator</td>
<td>A character string length 3 or less.</td>
</tr>
<tr>
<td>Property</td>
<td>Section Properties Dialog Field</td>
<td>Enter…</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>decimalSeparator</td>
<td>Decimal Separator</td>
<td>A character string length 3 or less.</td>
</tr>
<tr>
<td>decimals</td>
<td>Decimals</td>
<td>A number, value in the range 0 through 18, inclusive.</td>
</tr>
<tr>
<td>decimalHasLeadingZero</td>
<td>Show Leading Zero for Decimals</td>
<td>True or False.</td>
</tr>
<tr>
<td>suppressIfZero</td>
<td>Suppress If Zero</td>
<td>True or False. Used only if showAsCurrency is false.</td>
</tr>
<tr>
<td>Date Tab Properties</td>
<td></td>
<td></td>
</tr>
<tr>
<td>useShortDate</td>
<td>Use Short Date</td>
<td>True, to use short date. Alternatively, enter False, to use long date.</td>
</tr>
<tr>
<td>dateOrder</td>
<td>Order</td>
<td>A number; see Date constants, in the following table.</td>
</tr>
<tr>
<td>showFullDayName</td>
<td>Day Name</td>
<td>True or False. Used only if useShortDate is False.</td>
</tr>
<tr>
<td>dayHasLeadingZero</td>
<td>Day</td>
<td>True or False. Used only if useShortDate is False.</td>
</tr>
<tr>
<td>dateSeparator</td>
<td>Separator</td>
<td>A character string length 3 or less, when useShortDate is True.</td>
</tr>
<tr>
<td>daySeparator</td>
<td>Day Separator</td>
<td>A character string length 3 or less; used only if useShortDate is False.</td>
</tr>
<tr>
<td>monthFormat</td>
<td>Month</td>
<td>A number for the month, or select the month from the Month Constants category. For details, see &quot;Format Constants&quot;, in the following section.</td>
</tr>
<tr>
<td>yearIncludesCentury</td>
<td>Year</td>
<td>True or False.</td>
</tr>
<tr>
<td>dateSeparator</td>
<td>Date Separator</td>
<td>A character string length 3 or less. Used only when useShortDate is True.</td>
</tr>
<tr>
<td>Time Tab Properties</td>
<td></td>
<td></td>
</tr>
<tr>
<td>twelveHourClock</td>
<td>12 Hour Clock</td>
<td>True to use 12-hour clock settings. Alternatively, enter False, to use 24-hour clock settings.</td>
</tr>
<tr>
<td>showSeconds</td>
<td>Show Seconds</td>
<td>True or False.</td>
</tr>
<tr>
<td>timeMarkerAsSuffix</td>
<td>Show Time Marker as Suffix</td>
<td>True or False.</td>
</tr>
<tr>
<td>hourHasLeadingZero</td>
<td>Show Leading Zero For Hours &lt; 10</td>
<td>True or False.</td>
</tr>
<tr>
<td>timeSeparator</td>
<td>Separator</td>
<td>A character string length 3 or less.</td>
</tr>
<tr>
<td>amMarker</td>
<td>Marker 00:00 - 11:59</td>
<td>A character string length 30 or less. Used only if twelveHour clock is True.</td>
</tr>
<tr>
<td>pmMarker</td>
<td>Marker 12:00 - 23:59</td>
<td>A character string length 30 or less. Used only if twelveHour clock is True.</td>
</tr>
<tr>
<td>timeMarker</td>
<td>Marker</td>
<td>A character string length 30 or less. Used only if twelveHour clock is False.</td>
</tr>
</tbody>
</table>
Boolean Tab Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Section Properties Dialog Field</th>
<th>Enter…</th>
</tr>
</thead>
<tbody>
<tr>
<td>trueValue</td>
<td>Display when value is TRUE</td>
<td>Character string, length 100 or less.</td>
</tr>
<tr>
<td>falseValue</td>
<td>Display when value is FALSE</td>
<td>Character string, length 100 or less.</td>
</tr>
</tbody>
</table>

**Note** The properties displayed in the Format Properties category of the Fields list box depend on the field from which the format script dialog is accessed.

### Format Constants

The Format Constants category is displayed on the Format Scripts dialog. The Format Constants category of the Fields list box list valid values for the matching property; for example, the `borderStyle` property can be set to one of the `BorderStyle` constant values of `BorderNone`, or `BorderSingle`, and the `alignment` property can be set to one of the `Alignment` constant values of `AlignmentCenter`, `AlignmentLeft`, or `AlignmentRight`. The following table lists the constants in the Format Constants category of the Fields list box.

<table>
<thead>
<tr>
<th>Constant Heading and Names</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colors</td>
<td>For <code>backColor</code> and <code>fontColor</code> properties</td>
</tr>
<tr>
<td>Black</td>
<td>0</td>
</tr>
<tr>
<td>Blue</td>
<td>16711680</td>
</tr>
<tr>
<td>DarkBlue</td>
<td>12582912</td>
</tr>
<tr>
<td>DarkGray</td>
<td>4210752</td>
</tr>
<tr>
<td>Gray</td>
<td>12632256</td>
</tr>
<tr>
<td>Green</td>
<td>32768</td>
</tr>
<tr>
<td>LightGreen</td>
<td>65280</td>
</tr>
<tr>
<td>LightYellow</td>
<td>8454143</td>
</tr>
<tr>
<td>Mauve</td>
<td>16711935</td>
</tr>
<tr>
<td>Purple</td>
<td>12583104</td>
</tr>
<tr>
<td>Red</td>
<td>255</td>
</tr>
<tr>
<td>White</td>
<td>16777215</td>
</tr>
<tr>
<td>Yellow</td>
<td>65535</td>
</tr>
<tr>
<td>None</td>
<td>-1 (for <code>backColor</code> only, to set no color at all; that is, transparent)</td>
</tr>
</tbody>
</table>

**Alignment**

- `AlignmentLeft` 0
- `AlignmentRight` 3
- `AlignmentCenter` 6

**BorderStyle**
### Constant Heading and Names

<table>
<thead>
<tr>
<th>Constant Heading and Names</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderNone</td>
<td>0</td>
</tr>
<tr>
<td>BorderSingle</td>
<td>1</td>
</tr>
</tbody>
</table>

### Date Order

<table>
<thead>
<tr>
<th>Date Order</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>MonthDayYear</td>
<td>0</td>
</tr>
<tr>
<td>DayMonthYear</td>
<td>1</td>
</tr>
<tr>
<td>YearMonthDay</td>
<td>2</td>
</tr>
</tbody>
</table>

### Month Format

<table>
<thead>
<tr>
<th>Month Format</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>MonthFullName</td>
<td>1</td>
</tr>
<tr>
<td>MonthNumber</td>
<td>4</td>
</tr>
<tr>
<td>MonthNumberLeadingZero</td>
<td>3</td>
</tr>
<tr>
<td>MonthShortName</td>
<td>2</td>
</tr>
</tbody>
</table>

### Negative Format

<table>
<thead>
<tr>
<th>Negative Format</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>NegNumberInBrackets</td>
<td>0</td>
</tr>
<tr>
<td>NegNumberLeadingSign</td>
<td>1</td>
</tr>
<tr>
<td>NegNumberLeadingSignSpace</td>
<td>2</td>
</tr>
<tr>
<td>NegNumberTrailingSign</td>
<td>3</td>
</tr>
<tr>
<td>NegNumberTrailingSignSpace</td>
<td>4</td>
</tr>
<tr>
<td>NegCurrLeadingSymbolBrackets</td>
<td>0</td>
</tr>
<tr>
<td>NegCurrLeadingSignSymbol</td>
<td>1</td>
</tr>
<tr>
<td>NegCurrLeadingSymbolSign</td>
<td>2</td>
</tr>
<tr>
<td>NegCurrLeadSymbolTrailingSign</td>
<td>3</td>
</tr>
<tr>
<td>NegCurrTrailingSymbolBrackets</td>
<td>4</td>
</tr>
<tr>
<td>NegCurrLeadSignTrailingSymbol</td>
<td>5</td>
</tr>
<tr>
<td>NegCurrTrailingSymbol</td>
<td>6</td>
</tr>
<tr>
<td>NegCurrTrailingSymbolSign</td>
<td>7</td>
</tr>
<tr>
<td>NegCurrLeadSignTrailSpSymbol</td>
<td>8</td>
</tr>
<tr>
<td>NegCurrLeadingSignSymbolSp</td>
<td>9</td>
</tr>
<tr>
<td>NegCurrTrailingSpSymbolSign</td>
<td>10</td>
</tr>
<tr>
<td>NegCurrLeadSymbolSpTrailSign</td>
<td>11</td>
</tr>
<tr>
<td>NegCurrLeadSymbolSpSign</td>
<td>12</td>
</tr>
<tr>
<td>NegCurrTrailingSpSymbolSign</td>
<td>13</td>
</tr>
<tr>
<td>NegCurrLeadingSymbolSpBrackets</td>
<td>14</td>
</tr>
</tbody>
</table>
### Constant Heading and Names

<table>
<thead>
<tr>
<th>Constant Heading and Names</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>NegCurrTrailSpSymbolBrackets</td>
<td>15</td>
</tr>
</tbody>
</table>

### Positive Format

<table>
<thead>
<tr>
<th>Positive Format</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>PosCurLeadingSymbol</td>
<td>0</td>
</tr>
<tr>
<td>PosCurrTrailingSymbol</td>
<td>1</td>
</tr>
<tr>
<td>PosCurrLeadingSymbolSpace</td>
<td>2</td>
</tr>
<tr>
<td>PosCurrTrailingSpaceSymbol</td>
<td>3</td>
</tr>
</tbody>
</table>

### Output Type

<table>
<thead>
<tr>
<th>Output Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>OutputCSV</td>
<td>3</td>
</tr>
<tr>
<td>OutputHtml</td>
<td>2</td>
</tr>
<tr>
<td>OutputRtf</td>
<td>4</td>
</tr>
<tr>
<td>OutputPrinter</td>
<td>0</td>
</tr>
<tr>
<td>OutputText</td>
<td>6</td>
</tr>
<tr>
<td>OutputXml</td>
<td>5</td>
</tr>
</tbody>
</table>

### Picture Stretch

<table>
<thead>
<tr>
<th>Picture Stretch</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>StretchNone</td>
<td>0</td>
</tr>
<tr>
<td>StretchToControl</td>
<td>1</td>
</tr>
<tr>
<td>StretchControlTo</td>
<td>2</td>
</tr>
<tr>
<td>StretchProportional</td>
<td>3</td>
</tr>
<tr>
<td>StretchPictureProportional</td>
<td>4</td>
</tr>
<tr>
<td>StretchCenterPicture</td>
<td>5</td>
</tr>
</tbody>
</table>

Although the **fontColor** and **backColor** values are not restricted to the colors listed in this table, they are the common ones.